TIBCO WebFOCUS®

InfoAssist User's Manual

Release 8207 and higher
February 2022
DN4501749.0321
# Contents

## 1. Introducing InfoAssist ........................................................ 15

- InfoAssist Highlights ............................................................. 15
- Accessing InfoAssist .................................................................. 16
  - Accessing InfoAssist From the WebFOCUS Start Page ................ 16
  - Accessing InfoAssist From TIBCO WebFOCUS® App Studio ........ 17
- Additional InfoAssist Types ..................................................... 17
  - InfoAssist Basic ...................................................................... 17
    - Accessing InfoAssist Basic .................................................. 19
  - InfoMini ................................................................................ 19

## 2. Navigating the InfoAssist Interface ....................................... 21

- InfoAssist Application Window .................................................. 22
- Application Main Menu .............................................................. 23
  - Accessing InfoAssist Options ................................................... 27
    - Getting Started ...................................................................... 27
    - Help ....................................................................................... 28
  - Changing InfoAssist User Preferences ....................................... 28
    - View ....................................................................................... 29
    - Layout .................................................................................... 29
    - Format ................................................................................... 29
    - Environment and Styling ......................................................... 30
    - Changing Global Preferences .................................................. 31
  - Quick Access Toolbar ................................................................ 31
  - Ribbon ..................................................................................... 34
    - Working With the Ribbon ....................................................... 34
  - Home Tab ................................................................................ 36
  - Insert Tab ................................................................................ 37
  - Format Tab ............................................................................... 37
  - Data Tab .................................................................................. 39
  - Slicers Tab ............................................................................... 39
  - Layout Tab ............................................................................... 40
  - View Tab .................................................................................. 41
  - Field Tab .................................................................................. 42
3. Creating and Customizing Reports ............................................. 79
   Creating Reports ................................................................. 79
   Choosing a Report Output ..................................................... 81
   Using Procedure Settings .................................................... 82
   Creating Thumbnails for Use With the WebFOCUS Start Page ......... 87
   Styling Reports ................................................................. 90
   Changing a Field Format ...................................................... 100
   Using Custom Reporting Features ......................................... 104
   Creating Customized Report Outputs .................................... 111

4. Creating and Customizing Charts ............................................. 119
   Visualizing Your Data With Charts ....................................... 120
   Using Insight to Analyze Dynamic Charts ............................... 120
   Working With Charts in Insight .......................................... 123
   Searching for Fields ......................................................... 128
   Changing Summary Operators for the Field ............................ 128
Filtering in Insight .............................................................. 130
Types of Filters ................................................................. 131
Adding a Filter ................................................................. 134
Removing a Filter ............................................................. 135
Using the Options Toolbar .................................................. 135
Using Insight in Phone Mode ............................................. 140
    User Options in Phone Mode ........................................ 141
        Filtering ............................................................. 141
        General Usability ................................................ 142
Selecting a Chart Type ........................................................ 142
    Bar Charts ................................................................ 142
        Bar Chart Types ................................................ 144
    Pie Charts ................................................................ 144
        Pie Chart Types ................................................ 145
    Line Charts ................................................................ 146
        Line Chart Types ............................................... 147
    Area Charts .............................................................. 148
        Area Chart Types ............................................... 149
    Scatter Charts .......................................................... 150
    Multi-Axis Charts ...................................................... 151
    XY Plot Charts ........................................................ 151
        XY Plot Chart Types ........................................... 152
    3D Charts ................................................................ 153
        3D Chart Types ................................................ 153
    Stock Charts ............................................................. 154
        Stock Chart Types ............................................... 155
    Special Charts .......................................................... 155
    HTML5 Charts ........................................................... 156
    Combination Charts ..................................................... 156
Maps ............................................................................. 157
Creating Charts ............................................................... 158
    Chart Outputs .......................................................... 162
Binning ........................................................................... 163
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binning Values in a Histogram</td>
<td>167</td>
</tr>
<tr>
<td>Accessing Chart Formatting Tools</td>
<td>170</td>
</tr>
<tr>
<td>Using Live Preview</td>
<td>170</td>
</tr>
<tr>
<td>Formatting a Series</td>
<td>172</td>
</tr>
<tr>
<td>Associated Dialog Boxes</td>
<td>172</td>
</tr>
<tr>
<td>Format Series Dialog Box</td>
<td>172</td>
</tr>
<tr>
<td>Edit Title Dialog Box</td>
<td>175</td>
</tr>
<tr>
<td>Traffic Light Condition Dialog Box</td>
<td>175</td>
</tr>
<tr>
<td>Series Elements Shortcut Menu</td>
<td>177</td>
</tr>
<tr>
<td>Using Series Properties</td>
<td>180</td>
</tr>
<tr>
<td>Enhancing Series Using the Series Tab</td>
<td>181</td>
</tr>
<tr>
<td>Formatting Charts Using the Series Tab</td>
<td>182</td>
</tr>
<tr>
<td>Formatting Data Labels</td>
<td>190</td>
</tr>
<tr>
<td>Associated Dialog Boxes</td>
<td>190</td>
</tr>
<tr>
<td>Format Labels Dialog Box</td>
<td>191</td>
</tr>
<tr>
<td>Style Dialog Box</td>
<td>197</td>
</tr>
<tr>
<td>Line Style Dialog Box</td>
<td>198</td>
</tr>
<tr>
<td>Data Labels Elements Shortcut Menu</td>
<td>198</td>
</tr>
<tr>
<td>Using Data Labels Properties</td>
<td>198</td>
</tr>
<tr>
<td>Formatting a Legend</td>
<td>200</td>
</tr>
<tr>
<td>Format Legend Dialog Box</td>
<td>200</td>
</tr>
<tr>
<td>Legend Elements Shortcut Menu</td>
<td>202</td>
</tr>
<tr>
<td>Using Legend Properties</td>
<td>203</td>
</tr>
<tr>
<td>Formatting Gridlines</td>
<td>205</td>
</tr>
<tr>
<td>Format Grid Lines Dialog Box</td>
<td>206</td>
</tr>
<tr>
<td>Gridline Elements Shortcut Menu</td>
<td>208</td>
</tr>
<tr>
<td>Using Gridline Properties</td>
<td>209</td>
</tr>
<tr>
<td>Formatting Axis Labels</td>
<td>215</td>
</tr>
<tr>
<td>Format Axis Dialog Box</td>
<td>215</td>
</tr>
<tr>
<td>Secondary Axes Options</td>
<td>220</td>
</tr>
<tr>
<td>Axis Elements Shortcut Menu</td>
<td>220</td>
</tr>
<tr>
<td>Using Axis Properties</td>
<td>222</td>
</tr>
<tr>
<td>Formatting a Frame and a Background</td>
<td>225</td>
</tr>
</tbody>
</table>
5. Creating and Customizing Documents ........................................ 253
   Accessing Document Mode .......................................................... 253
   Building a Document ................................................................ 256
      Inserting Reports From Multiple Data Sources. ......................... 256
      Inserting a New Report. ............................................................. 257
      Inserting a New Chart. .............................................................. 258
      Inserting an Existing Report. ...................................................... 259
      Creating a Document From a Single Report. ............................ 259
      Inserting Text and Images. ......................................................... 260
      Editing Components in a Document. ........................................... 260
      Building Infographics in InfoAssist ........................................... 268
   Components Supported. .............................................................. 269

6. Creating and Customizing Visualizations ................................. 271
   Creating a Visual ................................................................... 271
      Changing the Visual Type. ......................................................... 273
   Selecting a Visual .................................................................. 273
      Grids. ................................................................................. 277
      Bar Charts. ........................................................................ 278
      Line Charts. ....................................................................... 281
      Area Charts. ....................................................................... 283
      Pie Charts. ........................................................................ 285
      Ring Pie Charts. ................................................................. 287
      Scatter Charts. .................................................................... 289
8. Styling Reports, Charts, and Visualizations ........................................ 367
   Customizing Reports ................................................................. 367
   Using the Report Style Dialog Box .............................................. 370
   Using the Color Dialog Box ......................................................... 371
   Accessing Reporting Options in the Report Group .......................... 372
   Enabling Report Features ............................................................ 374
   Enabling Chart Features .............................................................. 375
   Labeling Charts ........................................................................ 377
   Using Interactive Options ............................................................ 377
   Customizing Page Setup .............................................................. 379

9. Creating Maps to Illustrate Trends .................................................. 381
   A Brief History of Mapping ............................................................ 382
   InfoAssist and Esri Integration ....................................................... 383
      Configuring an Esri On Premise Environment ............................. 386
      Creating and Customizing Maps in InfoAssist ............................ 388
   Customizing the List of Geographic Roles ...................................... 406
   Customizing the List of Basemap Definitions .................................. 416
      Adding a Custom Basemap ......................................................... 416
   Enabling Additional Territories in a Leaflet Map .............................. 420
      Default Territories .................................................................. 422

10. Manipulating Data ................................................................. 425
    Missing Data in a Chart ............................................................... 425
    Adding and Switching Data Sources .............................................. 426
    Setting the Source of Your Data .................................................. 427
    Creating Virtual Fields in TIBCO WebFOCUS ................................. 427
       Selecting a Temporary Field .................................................... 428
       Detail (DEFINE) ...................................................................... 428
       Summary (COMPUTE) .............................................................. 429
       Using Field Titles in a Define or Compute ................................ 430
       Resizing the Text Area of a Define or Compute ......................... 433
       Creating Temporary Fields Independent of a Master File ............. 435
Enabling the Display of Missing Values for a DEFINE or COMPUTE ......................... 435
RStat Scoring Routines in InfoAssist ........................................................................ 436
Using the RStat Scoring Routines in InfoAssist .................................................... 436
  Step 1: Creating the Report or Chart .............................................................. 437
  Step 2: Creating the Virtual Field: Define or Compute ................................... 437
  Step 3: Handling Missing Values ................................................................... 438
Joining and Blending Data ..................................................................................... 439
  Joins ........................................................................................................ 440
  Blending Data ............................................................................................. 441
Using Filters to Customize the Display of Data .................................................... 442
  Including or Excluding a Filter ................................................................ 452
  Using the Prompt Functionality to Select Field Information at Run Time ........ 452
Output Formats .................................................................................................. 453
  HTML5 ..................................................................................................... 455
  Enabling Additional Output Types .................................................................. 455
  User Selection .............................................................................................. 456

11. Creating HOLD Files .................................................................................... 459
  Valuable Applications of HOLD Files ........................................................... 459
  Storing HOLD Files ..................................................................................... 459
  Output Formats for Reports and Charts ........................................................ 460
  Creating HOLD Files .................................................................................. 460
    TIBCO FOCUS Format Index Fields ............................................................ 467
  Creating a Subquery Filter Using a HOLD File ............................................... 468

12. Creating Multi-Page Documents .................................................................... 469
  Creating Multi-Page Documents ................................................................... 469
  Creating a Multi-page In-Document Analytics Dashboard ............................... 471
  Navigating the Page Menu ............................................................................ 472
  Using the Cache Option ............................................................................... 474
  Enabling Cache Through InfoAssist .............................................................. 474

13. Creating Interactive Content ........................................................................ 475
  Overview of In-Document Analytics .............................................................. 475
  Enabling In-Document Analytics in InfoAssist .............................................. 483
15. Building InfoMini Applications ................................................................. 551

Understanding InfoMini Applications .......................................................... 551
Using the InfoMini Button ........................................................................... 552
   Understanding the InfoMini Layout .......................................................... 553
   Interactive Mode ....................................................................................... 553
   Edit Mode .................................................................................................. 553
Ribbon ........................................................................................................... 554
   Home Tab .................................................................................................. 554
   Insert Tab .................................................................................................. 554
   Format Tab ................................................................................................ 554
   Data Tab .................................................................................................... 555
   Slicers Tab ............................................................................................... 555
   Layout Tab ................................................................................................ 556
   Field Tab ................................................................................................... 556
   Series Tab .................................................................................................. 556

Creating an InfoMini Application ................................................................ 556

A. Ribbon Command Reference ...................................................................... 559

Ribbon Commands for Reports ...................................................................... 559
   Home Tab .................................................................................................. 559
   Format Tab ................................................................................................ 561
   Data Tab .................................................................................................... 564
   Slicers Tab ............................................................................................... 565
   Layout Tab ................................................................................................ 566
   View Tab ................................................................................................... 567
   Field Tab .................................................................................................. 569

Ribbon Commands for Charts ...................................................................... 574
   Home Tab .................................................................................................. 574
   Format Tab ................................................................................................ 576
   Data Tab .................................................................................................... 581
Introducing InfoAssist

InfoAssist provides business users with the most advanced, yet simple to use, ad hoc reporting features needed to create intricate reports and perform insightful analysis.

InfoAssist provides a robust, user-friendly solution that helps companies overcome traditional ad hoc reporting challenges.

InfoAssist is available in the following versions:

- **InfoAssist.** Complete version of this powerful report-generation tool.
- **InfoAssist Basic.** Limited version of InfoAssist provided to existing Report and Graph Assist customers.
- **InfoMini.** Applications built from an InfoAssist report that contain a subset of InfoAssist functionality at run time.

In this chapter:

- InfoAssist Highlights
- Accessing InfoAssist
- Additional InfoAssist Types

InfoAssist Highlights

InfoAssist is the web-based ad hoc reporting tool in TIBCO WebFOCUS®.

With InfoAssist, you can quickly and easily:

- Generate highly complex reports, charts, visualizations, and documents from any enterprise information source without IT intervention.
- Complete tasks, such as building a report, with minimal clicks.
- Create useful and dynamic visualizations, giving you greater insight into your data.
- Create maps to illustrate trends and identify patterns in your data.
- Convert reports to charts, or charts to reports, in a single click.
- Analyze multiple reports and charts simultaneously, using advanced tiling options to view data from multiple perspectives.
Browse enterprise-information sources, including multi-dimensional sources.

Output data in a variety of formats, including HTML, HTML5 (charts only), HTML Analytic Document, PDF, PDF Analytic Document, Excel®, and PowerPoint®.

InfoAssist is a Rich Internet Application (RIA) that uses AJAX (Asynchronous JavaScript and XML) technology. It delivers its cutting-edge functionality using a familiar Microsoft Windows® ribbon interface. This highly intuitive environment shields users from the underlying technical complexities associated with ad hoc reporting features, while providing access to all the functionality needed to address mission-critical information requirements.

This powerful ad hoc reporting tool enables rapid and efficient design and deployment of reports and charts. It uses an interactive and fully-customizable WYSIWYG (What You See Is What You Get) development environment. Users receive instant feedback throughout the development process to ensure that reports and charts are properly built.

**Note:** If you manually edit a report created with InfoAssist, do not delete or modify the internal comments located at the top of the procedure. Modifying these comments, or any content of the procedure, could produce unpredictable results when you open the report with InfoAssist. Additionally, WebFOCUS® syntax that you add using the text editor may be modified when the file is reopened in InfoAssist, and comments may be removed. In general, we do not recommend that you manually edit a procedure.

## Accessing InfoAssist

You can quickly access each of the versions of InfoAssist using the information provided in the following sections. InfoAssist is available from the WebFOCUS start page and TIBCO WebFOCUS® App Studio.

### Accessing InfoAssist From the WebFOCUS Start Page

After you have signed into WebFOCUS, you can access InfoAssist by working with existing content, or creating new files.

**Procedure:** How to Access InfoAssist From the WebFOCUS Start Page

1. Sign in to WebFOCUS.
2. From the WebFOCUS start page, click the InfoAssist tab.
3. On the actions bar, click Chart, Visualization, Report, or Document.
   
   **Note:** You may need to click More in order to display all available options.
4. From the Open dialog box, select a Master File as your data source.
5. Click Open.
InfoAssist opens in the mode that you selected.

**Note:** You can also launch the modes of InfoAssist from the Legacy Home Page, which is accessible from the User menu at the top-right of the WebFOCUS start page. Once you access the Legacy Home Page, you can right-click any folder to launch an InfoAssist mode.

**Accessing InfoAssist From TIBCO WebFOCUS® App Studio**

In WebFOCUS® App Studio, the Chart canvas utilizes the InfoAssist graphical user interface (GUI) to create or edit charts. For more information, see the App Studio Online Help.

**Additional InfoAssist Types**

This section describes additional InfoAssist types.

**InfoAssist Basic**

InfoAssist Basic is a modern web-based facility that provides comparable functionality to legacy reporting tools. InfoAssist Basic contains many of the features of InfoAssist, while still allowing you to create and edit reports and charts as you would with a legacy tool.

InfoAssist Basic is an advanced, yet simple to use, ad hoc reporting tool that offers dynamic features for creating intricate reports and performing insightful analysis.

Using InfoAssist Basic, you can create a customized report, organize report output with sorting, change a column heading and format, add a page heading and footing, enhance the appearance of the report, create a matrix report, and validate and test your work.

InfoAssist Basic does not include the following capabilities found in InfoAssist:

- General Features
  - Creating dashboards and documents
  - Live Preview
  - Publishing
  - InfoMini
  - Slicers
  - Cube Browser
  - Chart to Report conversion
Additional Info Assist Types

- Home tab
  - Format group

- Format tab
  - Destination group
  - Reference Lines
  - Annotations
  - Format Horizontal Grid Lines - Color Bands tab and Frames tab
  - Format Vertical Grid Lines - Color Bands tab and Frames tab
  - Gauges
  - Map chart type in the Chart Types group
  - Format Vertical Axis - Frames tab
  - Format Horizontal Axis - Frames tab
  - Format Legend - Fill tab, Border Styles tab, and Shadow tab

- Field tab
  - Sorting

- Series tab
  - Data Position
  - Trendlines
  - Equation
  - Smooth Line
  - Marker Shape
  - Pie Expand
  - Pie Hide

- Output Types
  - PowerPoint
Accessing InfoAssist Basic

To access InfoAssist Basic, type valid credentials in the WebFOCUS Sign In page and click Sign In. InfoAssist Basic has a unique license code that distinguishes it from the complete version of InfoAssist.

InfoMini

You have the option to activate InfoMini when you create a report. When you run a report with InfoMini activated, an InfoMini application is launched. An InfoMini application contains a subset of the functionality available to a full InfoAssist report. You can limit or expand the functionality that is available to the user at run time when you build the report.

An InfoMini application opens in its own browser window if it is running from InfoAssist.
Additional InfoAssist Types
Navigating the InfoAssist Interface

InfoAssist provides an intelligent, flexible layout for creating reports, charts, documents, and visualizations.

The application window provides intuitive menus and toolbars, a versatile ribbon that provides access to specialized groups for different functional areas of report design, a taskbar for selecting output, and a status bar for directing output.

The application window also provides a resources area for selecting and sorting data, and a multi-faceted results area that can display report design, a preview of report output, or actual report output.

In this chapter:

- InfoAssist Application Window
- Application Main Menu
- Quick Access Toolbar
- Ribbon
- Home Tab
- Insert Tab
- Format Tab
- Data Tab
- Slicers Tab
- Layout Tab
- View Tab
- Field Tab
- Series Tab
- Understanding the Resources Panel
- Understanding the Canvas
- Using the Navigation Taskbar
- Using the Status Bar
InfoAssist Application Window

The components of the InfoAssist Application window are shown in the following image.

The main interface components are explained as follows:

1. **Application button.** Provides access to the Application menu of procedure-related commands.

2. **Quick Access Toolbar.** Displays frequently-used commands, such as New, Open, Save, Undo, Redo, View code, Run, and Preview, in a toolbar that remains visible. For more information, see *Quick Access Toolbar* on page 31.

3. **Ribbon.** Displays the commands you need to create reports, charts, visualizations, and documents. It also displays the Help menu. For details, see *Ribbon* on page 34.

4. **Help.** Provides access to the online technical content for InfoAssist in a new browser window.

5. **Resources panel.** Displays the Data pane, Query pane, and Filter pane.

6. **Canvas.** Displays the results of your report. In Live Preview mode, the canvas displays a preview of the file as it is developed.

   Depending on the type of file that you are developing, the canvas may display differently. For example, when creating a document, the canvas includes rulers around the development area. This is to assist you in placing the components on to the document.
7. **Navigation taskbar.** Displays groups and icons that provide different views and quick access to all interactive content. For details, see *Using the Navigation Taskbar* on page 77.

8. **Status bar.** Provides an output format button that you click to see the selected format and an output target button that you click to view the selected option for displaying new output windows or tabs. For more information, see *Using the Status Bar* on page 78.

### Application Main Menu

In the upper-left corner of the InfoAssist interface, click the hamburger menu button 📚 to open the Application main menu.

You can run the following commands from the Application main menu:

- **New.** Opens the InfoAssist splash screen, where you can create a new report, chart, document, or visualization. The exact functionality of the New command depends on your current InfoAssist session.

  If you open a Reporting Object through InfoAssist, and then click New, a new report is generated from the Reporting Object. You are prompted to choose the type of report you want to create from the Reporting Object.

  When you open a new session of InfoAssist and then click New, a new report is created. You are prompted to choose a data source.

- **Open.** Opens an existing report, chart, document, or visualization.

- **Save.** Saves a report, chart, document, or visualization.

- **Save As.** Saves a report, chart, document, or visualization with a new name.

  **Note:** When saving a read-only, non-writable procedure (.fex) in the Save As dialog box, the first writable folder will be selected, by default.

- **Run.** Runs a report, chart, document, or visualization.

- **Run Deferred.** Submits a report, chart, document, or visualization for processing in the background while you continue to work on other tasks.

- **Close.** Closes the currently interactive report, chart, document, or visualization.
Recent Items. Displays recent reports, charts, documents, or visualizations, and those items that have been pinned to the menu. The Recent Items area of the InfoAssist Application main menu is shown in the following image.

Pinned reports, charts, documents, or visualizations are represented by a blue pin icon. Pinned items appear at the top of the list in alphabetical order.

Recent reports, charts, documents, and visualizations are represented by a sideways blue pin icon. Recent items appear below the separator bar in the order in which they were created, with the most recently created item at the top.

You can pin important reports, charts, documents, and visualizations to the top of the Recent Reports section of the Application main menu for quick and easy access. To promote a recent report to pinned report, click the sideways blue pin icon. The icon turns upright and the report is moved to the pinned report area of the Recent Items window, where it stays until it is unpinned.

To demote a pinned report, click the blue pin icon. The icon turns sideways and the report is moved below the separator bar.
A shortcut menu is available when right-clicking a recent item, as shown in the following image.

The options in the menu are:

- **Open.** Opens the selected report, chart, document, or visualization.

- **Pin to list.** Pins or unpins a recent report, chart, document, or visualization to the pinned reports list above the separator bar.

- **Remove from list.** Unpins a pinned report, chart, document, or visualization from the pinned reports list.

- **Clear unpinned list.** Clears all unpinned reports, charts, documents, or visualization from the Recent Items list.

- **Options.** Opens the Options dialog box to customize your user preferences. For more information, see *Changing InfoAssist User Preferences* on page 28.

- **Exit.** Exits the application.
**Reference:** Open Dialog Box

The Open dialog box displays when you launch InfoAssist. It also displays when you join and blend data. You can use this dialog box to do the following:

- Select data sources for creating reports, charts, visualizations, and documents.
- Select data sources for joining and blending data.
- Configure data adapters for connecting to an existing database and creating synonyms.
- Upload user data.

The Open dialog box is shown in the following image.

![Open Dialog Box Image]

The Open dialog box contains the following options:

**Connect to Data**

Opens the Metadata tool, where you can configure a Data Adapter to connect to an existing database and create synonyms.

**Upload Data**

Opens the Upload tool, where you can upload user data from a machine to which you have access. This data can be used with WebFOCUS reporting.

**Open**

Opens the selected Master File.
Accessing InfoAssist Options

On the InfoAssist application window, click the Application button to open the InfoAssist Application main menu of procedure-related commands. When you click New, a splash screen that contains all available options opens, as shown in the following image.

The available options are grouped into Getting Started and Help.

**Note:** When you launch InfoAssist, this splash screen indicates that the application is InfoAssist Basic and displays the available options.

**Getting Started**

The following Getting Started options are available:

- **Build a Report.** Opens the Open dialog box, where you can select a data source for your report.

- **Build a Chart.** Opens the Open dialog box, where you can select a data source for your chart.

- **Build a Document.** Opens the Open dialog box, where you can select a data source for your document.

- **Build a Visualization.** Opens the Open dialog box, where you can select a data source for your visualization.
Open Existing Item. Opens the Open dialog box, where you can select an existing item.

Change Default Options. Opens the Options window, where you can change the default settings to reflect your preferences.

Close Application. Closes and exits the application.

Help

The Help options provide help for the new user. The following Help options are available when you open InfoAssist.

InfoAssist Help. Opens the online documentation window for InfoAssist.

Online Forum. Opens the Focal Point website in a new browser window.

Changing InfoAssist User Preferences

You can change the default user preferences to customize the way that InfoAssist behaves when you create reports and generate output. The application theme, which is inherited from the BI Portal, customizes the InfoAssist interface, including all menus and dialog boxes.

You can style your reports by selecting a document theme independent from the interface. On the InfoAssist Application main menu, click Options.

The Options dialog box, as shown in the following image, opens to provide you with a user-friendly interface for customizing the InfoAssist application.

Note: If you make changes to the default selections in the Options dialog box, changes will take effect the next time InfoAssist launches.

If any of the options are unavailable, contact your administrator for assistance.
You can also select a document styling theme through the ribbon. On the Home tab, in the Report group, click Theme. For more information, see Home Tab on page 36.

View

The View area provides settings for establishing the design view in which you will work, the type of data you will use when you preview your output, the limit you need to set on your record input, how your data and query panels will look, and the output target that you will use.

- **Design View.** Values are Live Preview and Query. Select Live Preview to activate the Preview Method drop-down menu. The default value is Live Preview.

- **Preview Method.** Values are Preview with Source Data and Preview with Sample Data. This menu becomes active when you select Live Preview from the Design View drop-down menu. The default value is Preview with Source Data.

- **Record Limit.** Values are All records, 1, 10, 50, 500, or you can type a numeric value directly in the menu. The default value is 500.

- **Data Panel.** Values are Logical, List, and Structured. The default value is Logical.

- **Query Panel.** Values are 2x2 (2 columns by 2 rows), 1x4 (1 column by 4 rows), and Tree. The default value is Tree.

- **Output Target.** Values are Single Tab, New Tab, Single Window, and New Window. The default value is Single Tab.

Layout

The Layout area provides settings for printing reports and charts.

- **Page Size.** Values are A4, A3, A5, Letter, Tabloid, and Legal. The default value is Letter.

- **Orientation.** Values are Portrait and Landscape. The default value is Portrait.

Format

The Format area provides settings for the output types for reports, charts, and documents.

- **Report output type.** Values are HTML, PDF, PowerPoint (pptx), Excel (xlsx), Excel (xlsx Formula), Excel, Excel (Formula), Excel(csv), and HTML Analytic Document. The default value is HTML.

- **Chart output type.** Values are HTML, HTML5, PDF, PowerPoint (pptx), Excel (xlsx), Excel, and HTML Analytic Document. The default value is HTML5.
Document output type. Values are HTML, PDF, PowerPoint (pptx), Excel (xlsx), Excel (xlsx Formula), Excel, Excel (Formula), and HTML Analytic Document. The default value is HTML Analytic Document.

Environment and Styling

The Environment and Styling area provides settings for styling reports and charts through the specification of a Document Theme. Click the Browse button to open the Templates - Browse predefined template files dialog box, in which you can search for an existing WebFOCUS StyleSheet. The default StyleSheet is Warm.sty, but you can select from the other themes that are available (Dark.sty or Flat.sty).

Note: StyleSheets are stored in the following directory of your WebFOCUS installation:

drive:\ibi\WebFOCUS82\IBI_HTML\ibi_themes

In addition, you can access a repository of additional themes by accessing the Legacy Templates, under Libraries, as shown in the following image.

The theme that you select determines the coloring and hues that display within InfoAssist. The default templates in the Templates section apply to all languages, whereas some of those in the Legacy Templates sections are specific to just one language (for example, EN=English).
Note: If you switch themes when working in Report mode, all custom styling is removed from the procedure.

- **Accordion.** Values for this option are: Autofit and Legacy. The enhanced Accordion report format is built to autofit and be adaptive within windows and portal page containers. The legacy Accordion report opens in a tree structure independent of the window or container. The default value is Autofit.

- **Freeze.** The Freeze option allows you to define a scroll area within the data of your report. It locks column headings in place, as well as headings and footings, enabling you to scroll through the data within the container. The scroll area is defined to automatically fit within the size of the container where the report is run.

### Changing Global Preferences

You can change global preferences for InfoAssist through the Administration Console found on the WebFOCUS start page. For more information, see the *TIBCO WebFOCUS® Security and Administration* manual.

Note: If Microsoft PowerPoint 2000 and Microsoft PowerPoint 2007 are enabled in Global Preferences, the default selection for PowerPoint on the InfoAssist Home tab is PowerPoint, as opposed to PowerPoint (pptx).

### Quick Access Toolbar

The Quick Access Toolbar provides access to the most commonly used functions. It is located to the right of the Application main menu button and is always visible no matter which options are selected.

- **Create a new report, chart, document, or visualization.** Opens the InfoAssist splash screen, where you can create a new report, chart, document, or visualization.

- **Open existing item.** Opens the Open dialog box, where you can select an existing item.

- **Save.** Saves a report, chart, document, or visualization.

- **Undo and Redo.** The Undo icon undoes your last action. The Redo icon repeats your last action.

  The Undo icon is enabled (blue) when there is an action to undo. Otherwise, the icon is unavailable (gray). The Redo icon is enabled (blue) when there is an action to redo. Otherwise, the icon is unavailable (gray).
For example, if you add a database field to a report, the Undo icon turns blue. You can now click the Undo icon to remove the database field from the report. The Undo icon turns gray, and the Redo icon turns blue. To restore the field to the report, click the blue Redo icon.

You can also press Ctrl+Z to undo an action, or Ctrl+Y to redo an action.

You can undo and redo up to 25 actions per session. InfoAssist maintains the undo and redo list of actions even when you switch between reports.

When a dialog box is open in the application window, you cannot use the Undo and Redo icons. However, when you click OK and close the dialog box, the icons become available for use. With a single click of Undo, you can undo all the actions that you performed in the dialog box, and you can reinstate them with a single click of Redo.

- **View code.** View the underlying code for the report.
- **Procedure Settings.** Click the Procedure Settings button to specify and control items for inclusion in a procedure. The Procedure Settings dialog box presents various SET commands which are useful when you need to tailor your report, chart, or document presentation or content to meet your individual needs. For more information, see *Using Procedure Settings* on page 82.

- **Create Thumbnail.** In InfoAssist, you can create and store thumbnail images for use in the Business Intelligence Portal. Thumbnail images allow you to see a snapshot of a report or chart without opening the file. In InfoAssist, you can create a thumbnail image by clicking on the Create Thumbnail icon, which is located on the Quick Access toolbar.
You can create thumbnail images when working in Report and Chart mode in InfoAssist. These images are smaller renditions (220x160px) of your actual report or chart as it displays in Live Preview. Once you create the thumbnail and save the report or chart, you can access the thumbnail image from the file list on the Workspaces area of the WebFOCUS start page, as shown in the following image.

Note: Thumbnail images are stored as part of the procedure when it is saved in the repository. For more information, see How to Create a Thumbnail Image of a Report or Chart on page 87.

- **Run.** Click the Run button to run a report, chart, document, or visualization immediately. Click the down arrow to open the Run menu, which contains the following additional options:
  - **Preview.** Runs the report, chart, document, or visualization in the selected format with the limited number of records as set in the Design group on the Home tab.
  - **Run with Default Parameter Values.** Runs a report or chart using the default parameter values. If you have parameters defined, the default value is the first data field defined for the parameter. If you do not have parameters defined, the report or chart will run, regardless.
  - **SQL Trace.** Returns the SQL commands for the request.
SQL Preview Trace. Returns the SQL commands for the Live Preview run.

Ribbon

The ribbon is a rectangular area of distinct groups of buttons that spans the top of the InfoAssist application window.

The ribbon, with the Home tab selected, is shown in the following image.

The ribbon is contextual and changes depending on the type of file that you are developing. For example, in Chart mode, the ribbon is made up of nine tabs, whereas when working in Visualization mode, the ribbon consists of five tabs. Each tab contains a subset of InfoAssist functionality organized in logically-related groups of controls and commands graphically represented by distinctive icons.

Working With the Ribbon

The ribbon contains two types of arrow-based buttons. The first type of button opens a menu when you click it. The Orientation button is an example of this type of button. Clicking the Orientation button opens a menu of options, as shown in the following image.
The second type of button is a split button. Clicking the left side of the split button performs a default action. Clicking the down arrow, on the right side of the button, opens a menu of options. The Header & Footer button is an example of a split button. It is shown in the following image.

![Header & Footer button](image)

Clicking the Header & Footer button on the left opens the Header & Footer dialog box. Clicking the down arrow on the right opens a menu of options.

Some options open dialog boxes of additional commands and option lists.

The ribbon displays all controls and commands using different sized icons and groups, depending on the size of the monitor and application window.

In the following example, the Features group is fully expanded and all its icons are visible.

![Features group expanded](image)

When you reduce the size of the application window, some groups are collapsed into single icons as determined by the amount of available space.

The following image shows the Features group, from the Format tab, collapsed into a single icon.

![Features group collapsed](image)

When a group is collapsed into a single icon, the individual icons are removed from view, but are still available. Clicking a collapsed group icon restores the group to its normal full size and displays all of the individual icons.
When expanding a collapsed group, the ribbon collapses a neighboring group to make enough room to expand the selected group.

When an icon, button, or option in a menu or dialog box appears dimmed, that functionality is not available for that report as it currently exists. Some functionality is available for reports only, charts only, visualizations only, or documents only.

In some situations, selecting one or more options makes other options incompatible with the previously selected ones. As a result, the incompatible options are dimmed and unavailable for selection. InfoAssist automatically makes incompatible options unavailable as you create and modify a report.

**Note:** If you do not have access to a particular option, contact your administrator.

### Home Tab

The Home tab contains the most commonly used commands and options, which you can use when developing reports, charts, documents, or visualizations. The following list highlights the features on the Home tab for each mode.

- For reports, the Format, Design, Filter, and Report groups offer options for changing the output format of your report, as well as styling it.
- For charts, the Format Design, Filter, and Report groups enable you to change the theme or your chart or add a header and footer.
- For documents, options are enabled in the Format and Design groups only. Available options for documents include changing the data source for the document and changing the output format.
- For visualizations, the Clipboard, Data, Visual, and Storyboard groups enable you to perform some of the more basic functions, such as copy and paste. You also use the Home tab to change your visual type.

The Home tab is shown in the following image. The options and groups on the Home tab change, depending on what mode of InfoAssist you are in.

### Related Information for Reports, Charts, and Documents:

- View on page 29
Creating Customized Report Outputs on page 111

Styling Reports, Charts, and Visualizations on page 367

Using Filters to Customize the Display of Data on page 442

Related Information for Visualizations:

Interacting With Visualizations on page 299

Using Storyboards on page 337

Manipulating Data on page 425

Joins on page 440

Insert Tab

The Insert tab contains options to add reports, charts, existing reports, text, images, and form controls () to a canvas in Document mode.

It is shown in the following image.

Note: The Insert tab is only available in Document mode.

Related Information for Documents:

Creating and Customizing Documents on page 253

Accessing Document Mode on page 253

Building a Document on page 256

Format Tab

The Format tab provides options for formatting your report, chart, document, or visualization. Depending on the mode you are using, you can perform tasks such as selecting a chart type, enabling Auto Linking, or adding navigational aspects to a report.
The following list highlights the features on the Format tab for each mode.

- For reports, the Format tab provides access to the Destination, Navigation, Features, Run with, and Auto Linking groups. These options enable you to perform many functions related to reports, including Auto Drill or any other report navigation feature.

- For charts, the Format tab provides access to the Destination, Chart Types, Features, Labels, Interactive, Run with, and Auto Linking groups. These options enable you to perform a variety of charting tasks, including changing the chart type and adding interactive options.

- For documents, the Format tab enables you to change to Report or Chart mode. You can also access InfoMini.

- For visualizations, the Format tab provides access to the Report, Features, Labels, and Interactive groups. These options enable you to format your visualization. Also included are grid commands, as well as various features and label commands.

The Format tab is shown in the following image. The options and groups on the Format tab change, depending on what mode of InfoAssist you are in.

**Related Information for Reports, Charts, and Documents:**

- *Styling Reports* on page 90
- *Formatting a Series* on page 172
- *Formatting Data Labels* on page 190
- *Formatting a Legend* on page 200
- *How to Style and Customize a Report* on page 265
- *How to Style and Customize a Chart* on page 266
- *Using Auto Drill* on page 345
- *Using the Auto Linking Feature to Link Content* on page 349

**Related Information for Visualizations:**

- *Interacting With Visualizations* on page 299
Data Tab

The Data tab contains data manipulation and data display options. For example, you can access Join functionality and work with Defines and Computes. The Data tab is available in the Report, Chart, and Document mode. It is not available in Visualization mode.

The following list highlights the features on the Data tab for each available mode.

- For reports, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with reports, you can join data sources or create Defines and Computes. You can also filter data.

- For charts, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with charts, these options enable you to join data sources, create a Define or Compute, and filter data.

- For documents, the Data tab provides access to the Calculation, Join, Filter, Display, and Data Source groups. When working with a document, you can create a define or join data sources. You can also add or switch data sources.

The Data tab is shown in the following image.

Related Information for Reports, Charts, and Documents:

- Creating Virtual Fields in TIBCO WebFOCUS on page 427
- Joins on page 440
- Using Filters to Customize the Display of Data on page 442

Slicers Tab

The Slicers tab provides the ability to create and edit slicers. Slicers are dynamic filters that you can use with reports, charts, and documents.

Note: The Slicers tab is unavailable in Visualization mode.
The features on the Slicers tab are the same for reports, charts, and documents. You can perform the following functions with the slicer functionality:

- Add slicers to your report, chart, or document to create dynamic filters
- Set a record limit for the display of your data
- Create groups of slicers to filter your data
- Add fields to existing slicers
- Clear slicers to clear all selected values from existing slicers

The Slicers tab is shown in the following image.

Related Information for Reports, Charts, and Documents:

- **Using Slicers** on page 539
- **Filtering With Slicers** on page 542
- **Edit Slicers Dialog Box** on page 547

**Note:** The slicer capabilities are only available in the full version of InfoAssist. They are not available in InfoAssist Basic.

**Layout Tab**

The Layout tab provides access to page display and layout options. These include page orientation and AutoFit, which is a feature that limits the width of columns in a report to be no wider than the largest value in each column.

The Layout tab is available in Report, Chart, and Document mode.

**Note:** The Layout tab is unavailable in Visualization mode.
The following list highlights the features on the Layout tab for each available mode.

- For reports, the Layout tab provides access to the Page Setup and Report groups. These options allow you to change the size or orientation of your report. You can also add page numbers.

- For charts, the Layout tab provides access to the Page Setup and Size & Arrange groups. These options allow you to change the orientation or size of your chart. You can also set a height and width for your chart, and enable the AutoFit functionality.

The Layout tab is shown in the following image. The options and groups on the Layout tab change, depending on what mode of InfoAssist you are in.

Related Information for Reports, Charts, and Documents:

- Customizing Reports on page 367
- Customizing Page Setup on page 379

View Tab

The View tab provides access to reporting options, including design and display options. Some of the options on the View tab control how information is displayed, whether it be in structured view or list view. The View tab is available in all modes of InfoAssist.

The following list highlights the features on the View tab for each mode.

- For reports, the View tab provides access to the Design, Show/Hide, Data Panel, Query panel, Output Window and Report groups. When creating your report, you can change the way your data displays or switch to another mode, such as document.

- For charts, the View tab provides access to the Design, Show/Hide, Data Panel, Query panel, Output Window and Report groups. When creating your chart, you can change the output location for the chart or switch to another report or chart.

- For documents, the View tab provides access to the Design, Show/Hide, Data Panel, Query panel, Output Window and Report groups. When working with your document, you may want to change the display of data in the Data pane or Query pane.
For visualizations, the View tab provides access to the Show/Hide, Data Panel, and Report groups. When creating your visualization, you can use these options to show or hide the resources panel. You can also change the display of your data to either logical, list or structured.

The View tab is shown in the following image. The options and groups on the View tab change, depending on what mode of InfoAssist you are in.

Related Information for Reports, Charts, and Documents:
- Using the Query Pane and Filter Pane on the Canvas on page 75

Field Tab

The Field tab is enabled in the ribbon when you select a data source field. The options available in the Field tab are specific to the data type that is selected. The options available for numeric fields are different from the options available for non-numeric and date fields. The Field tab provides access to the Filter, Sort, Break, Style, Format, Display, and Links groups.

The following list highlights the features on the Field tab for each mode.

- For reports, the Field tab provides options for filtering and styling your report. It also provides you with access to the Traffic Lights and Within functionality, making your reports more robust and customized.

- For charts, the Field tab enables you to hide a particular field or group values in your chart. You can also use the filter options to limit the display of information in your chart.

- For documents, the Field tab provides options for filtering, as well as Traffic Light functionality. You can also hide fields and add aggregations.

- For visualizations, the Field tab provides options for filtering and sorting, as well as access to the Multi Drill feature. You can also hide fields and add aggregations.

The Field tab is shown in the following image.
Series Tab

The Series tab provides access to chart options through the Select, Style, Properties, Line, and Pie groups. The Series tab is available in Document, Chart, and Visualization mode. It is not available in Report mode.

The following list highlights the features on the Series tab for each available mode.

- For charts, the Series tab enables you to add such features as a trendline or data labels to your chart. If multiple series are specified, you can select a series and specify options specific to that series.

- For documents, the Series tab displays once you have specified fields within your document or embedded chart. You can use the options on the Series tab to add markers, smoothlines, or trendlines to your data.

- For visualizations, the Series tab enables you to switch between series, style the selected series, or add any other property or line features, as required.

The Series tab is shown in the following image.

Related Information for Reports, Charts, and Documents:

- How to Apply Traffic Light Conditional Styling to a Report (By Constant) on page 96
- How to Apply Traffic Light Conditional Styling to a Report (By Field) on page 97
- Changing a Field Format on page 100
- How to Access the Within Functionality on page 109

Related Information for Visualizations:

- Working With Filters at Run Time on page 340

- Formatting a Series on page 172
- Formatting Data Labels on page 190
Understanding the Resources Panel

The Resources panel is comprised of the Data pane, the Filter pane, and the Query pane. It is located on the left side of the InfoAssist interface and is visible by default. You can customize how the Resources panel displays by using the options on the Home tab and View tab. For example, on the View tab, in the Design group, click Query to display only the Query and Filter panes.
The following image shows the default view of the Resources panel, which displays the Data pane next to the Query and Filter panes when you create a chart.

The Data pane, which contains all the fields from the selected data sources, is always displayed.

You can manually adjust the size of the Resources panel. To do so, move the mouse pointer over the border. When the pointer changes to a two-way arrow, drag the border.
Reference: Field Image List

In the Resources panel, each field has an image associated with it. The following table displays each image and describes what it represents.

Note: This list of icons changes based on the type of database that is in use.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Blob Icon]</td>
<td>Blob</td>
</tr>
<tr>
<td>![Calculated Date Field Icon]</td>
<td>Calculated Date Field</td>
</tr>
<tr>
<td>![Calculated Numeric Field Icon]</td>
<td>Calculated Numeric Field</td>
</tr>
<tr>
<td>![Calculated Other Field Icon]</td>
<td>Calculated Other Field</td>
</tr>
<tr>
<td>![Calculated Text Field Icon]</td>
<td>Calculated Text Field</td>
</tr>
<tr>
<td>![Cube Property Icon]</td>
<td>Cube Property</td>
</tr>
<tr>
<td>![Date or Date and Time Field Icon]</td>
<td>Date or Date and Time Field</td>
</tr>
<tr>
<td>![Dimension Field (Standalone or Drillable) Icon]</td>
<td>Dimension Field (Standalone or Drillable)</td>
</tr>
<tr>
<td>![Dimension Field (Drillable, Second-level) Icon]</td>
<td>Dimension Field (Drillable, Second-level)</td>
</tr>
<tr>
<td>![Dimension Field (Drillable, Third-level) Icon]</td>
<td>Dimension Field (Drillable, Third-level)</td>
</tr>
<tr>
<td>![Geographic Role Dimension Field (Standalone or Drillable) Icon]</td>
<td>Geographic Role Dimension Field (Standalone or Drillable)</td>
</tr>
<tr>
<td>![Geographic Role Dimension Field (Drillable, Second-level) Icon]</td>
<td>Geographic Role Dimension Field (Drillable, Second-level)</td>
</tr>
<tr>
<td>![Geographic Role Dimension Field (Drillable, Third-level) Icon]</td>
<td>Geographic Role Dimension Field (Drillable, Third-level)</td>
</tr>
</tbody>
</table>

Note: There are 17 dimension field levels. Level 0 is specific to certain databases.

Note: There are 17 geographic role dimension field levels. Level 0 is specific to certain databases.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>🍔</td>
<td>Funnel (filter)</td>
</tr>
<tr>
<td>🌍</td>
<td>Geolocation</td>
</tr>
<tr>
<td>📊</td>
<td>Index Field</td>
</tr>
<tr>
<td>⚖</td>
<td>Key Field</td>
</tr>
<tr>
<td>🕵️</td>
<td>Measure</td>
</tr>
<tr>
<td>⬆️</td>
<td>Numeric Field</td>
</tr>
<tr>
<td>📜</td>
<td>Text or Alpha Field</td>
</tr>
</tbody>
</table>

**Reference:** Filter Pane

The Filter pane displays all filters that have been created for the selected report. For more information on filtering, see *Field Tab* on page 42 and *Data Tab* on page 39.

**Note:** The Filter pane displays all created filters, both active (included) and inactive (excluded).

**Using the Data Pane**

The Data pane contains the data fields that are used to construct reports, charts, or visualizations. The default structure of data in the Data pane displays your data by field type, for example, measure field or dimension field. You can explore this structure using the sample retail database that is included with InfoAssist. The structure of this sample database, which is a cube database, includes measure groups, measure fields, dimension hierarchies, dimension fields, and attributes.

The data fields that display in the Data pane may vary. Depending on the underlying structure of your metadata, these fields may be organized and presented differently. For example, you may have just measures and dimensions, or you may have fields that represent multiple drill levels. You can also have any combination of these field types.
The structure of your metadata dictates the order of the fields, as well as the hierarchy that they employ. InfoAssist displays this hierarchy based on the structure defined for the master file that you choose. For more information on the specific field types, see Field Image List on page 46.

If you are using a Business View (BV) data source, which is built based on a pre-determined targeted hierarchy or structure, the view of your Data pane will be set to Structured, by default. When using a BV data source, Logical view is disabled. These options are available on the View tab, in the Data Panel group.

**Note:** When you open a BV data source, you will have access to common components, such as measures, dimensions, and filters, but values will not be displayed.

When navigating folders and content in the Data pane, you can double-click a folder to expand or collapse its contents. This applies to folders based on the hierarchy of your data source. It does not apply to fields that have additional fields within them.

**Note:** You can also use the arrow adjacent to the folder name to expand and collapse folders.

The Expand Data Source Tree check box in the Administration Console controls the initial view of the fields in the Data pane. For example, if you are working with a data source that has numerous fields and you wish to collapse the list to limit their view, contact your administrator to clear this check box. All items in the Data pane will collapse into their highest categorical level.

The fields in the database structure are displayed in Logical view, by default. You can use the commands in the View tab to change how your data fields are organized in the Data pane. These commands display the data fields in a Logical, List, or Structured view. All three views provide options for displaying each data source field as a Title, Description, Field, or Alias. The List view also includes options to show the Alias, Format, and Reference of each field.

Field list search functionality is also available in the Data pane, which you can use to search for specific fields within a tree or list. When conducting a search in the Tree view, the search functionality searches only the attribute that is displayed.

When searching in List view, all attributes are searched at once.

**Note:** There are additional options on which you can search, including Name, Title, Alias, Format, Segment, Filename, Description, and Reference.

As you enter search criteria, InfoAssist begins the search process. When you enter just a few letters, the list of records that is returned is typically long. As your search criteria gets more specific, the list of returned fields narrows.
If you are conducting a search that you wish to cancel, click the X icon in the field list search tool to abort the search.

**Note:** The X icon displays only when you have search criteria specified in the Search fields box. The following is an example of the default Logical view, displaying the Title of each field.

![Data Pane Example](image)

**Using the Data Pane to Add Fields to a Report**

There are several ways that you can add data source fields to a report. You can drag, double-click, or right-click data source fields in the Data pane to add them to a Query field container or the Filter pane. You can also replace an existing field in the Query pane by dragging the new field from the Data pane so that it is over the data field in the Query pane. You can also drag fields from other field containers in the Query pane over a field in a different field container. A dotted line displays, indicating that this new field will replace the existing field. Release your mouse to confirm placement of the new data field.

**Note:** When you drag a field from the Data pane to the Query pane, Filter pane, or canvas, a tooltip displays to indicate the name of the field.
When rearranging fields in the Query pane, a solid line is used to indicate placement. A solid line is also used when you are dragging a data field from the Data pane into the Query pane in between existing fields or into an empty field container. You can also use the solid line to drop a field onto a field container directly, which places that data field into that specific field container.

After you add data source fields to a Query field container, you can change the order of the fields by dragging and dropping one field above or below another field.

**Drag.** This method provides the most control. You can drag data source fields from the Data pane to the appropriate Query field container or Filter pane.

For a larger work area in which to drop data source fields in the appropriate Query field container, make sure that Query Design view is selected, and then, on the View tab, in the **Query Panel** group, click **Areas 2x2** or **Areas 1x4**.

You can select Query Design view on the **Home** tab, in the **Design** group, by clicking **Query** or on the **View** tab, in the **Design** group by clicking **Query**. That selection expands the Query and Filter panes.

**Multi-Select.** You can multi-select data source fields that you want to add to a report in Live Preview, Query Design view, and Document mode. To select multiple data source fields to add to a report, click the appropriate fields while holding the Ctrl key on the keyboard. You can drag fields onto the canvas, or add them to the Query field container.

**Double-Click.** To automatically add a field to the appropriate Query field container in the Query pane, you can double-click a data source field in the Data pane.

- When you double-click a measure field in the Data pane, it is automatically added to the Sum Query field container.

- When you double-click a dimension field in the Data pane, it is added to the By (Row Label) Query field container for a report, or to the X-axis Query field container for a chart.

You cannot automatically add a field to the Across (Column Label) Query field container for a report, or to the Legend (Series) and Multi-graph Query field containers for a chart.

**Right-Click.** You can right-click a field in the Data pane to add it to the Filter area or a Query field container in the Query pane. For reports, the available shortcut menu options are as follows:

- **Across.** For dimension fields.

- **Add to Query.** Opens a menu of available Query field containers, to which you can add your data.
- **Create Group.** Allows you to create a group of elements based on the field data type that you select.

- **Include as Category Axis.** For dimension fields.

- **Include as Coordinated.** Only available in Document mode.

- **Include as Legends Series.** For dimension fields.

- **Filter.** For all types of fields.

- **Slicers.** For all types of fields.

- **Sort.** Adds the field to the Sort field container. This is for all types of fields.

- **Sum.** For measure fields.

- **Create Bins.** Allows you to create a bin for the selected measure. Bins are used with the Binning functionality. For more information, see *Binning* on page 163.

A measure is a numeric value, such as Gross Profit or Cost of Goods Sold, that you may want to aggregate. All numeric values that can be summed are measures. Numeric fields that cannot be summed, such as product number and miles per gallon, are not treated as measures. Instead, they may be used in the same way as dimension fields to analyze measures. It is up to you to understand your data and determine whether each numeric field can be summed. Related measures can be organized into measure groups. For example, Gross Profit and Cost of Goods Sold can be part of a Sales measure group.

A dimension is a way to categorize data. You can use a dimension to analyze and compare measures. Generally, any field that is not a measure, usually an alphanumeric field such as product, is a dimension. Dimensions can be organized into hierarchies to define the relationships between the fields in the hierarchies. For example, a Geography hierarchy can contain the Continent, Country, State, and City dimensions. You can also define dimension fields that are not part of a dimension hierarchy.

**Enforcing Paths to Disable Unavailable Fields**

The Enforce Paths feature controls access to fields in the metadata tree based on their relationship to other fields within your data source. With each field that you add to the field containers in the Query pane, Enforce Paths will update the available fields and only allow for the selection of fields in related fact tables. Fields in unrelated fact tables will become inaccessible.

As of Release 8.2 Version 04, Enforce Paths is available to all InfoAssist users. It is disabled, by default. This default can be changed for your site in the InfoAssist Properties section of the Administration Console.
Enforcing Paths can be enabled for any individual procedure by clicking the *Enforce Paths* button (the silo container) to the left of the Data title in the Resources panel. This container is shown in the following image.

![Data - wf_retail-lite](image)

You can disable this feature for any procedure by toggling this Enforce Paths button.

A synonym can describe a single path or multiple paths. When Enforce Paths is enabled, if a field cannot be accessed as part of the retrieval path of fields that have already been selected, it will be greyed out and unavailable for selection. The following example shows a data source without and with Enforce Paths enabled, respectively.

In WFRetail, the shipping information is not directly related to the sales information so they cannot be used together in a single request.

With Enforce Paths disabled, as shown in the following image, InfoAssist will allow you to add a Shipping Date field and the Sales Revenue field to the field containers but the request will not produce valid results because the fact tables have no direct link.
With Enforce Paths Disabled

With Enforce Paths enabled, as shown in the following image, once the Shipping Date field is added to the field container, the sales related measures become unavailable so that the invalid request cannot be built.
With Enforce Paths Enabled

Using the Query Pane and Filter Pane

The Query and Filter panes appear to the right of the Data pane, except when you select Query Design view, which expands the size of the Query and Filter panes. There are different Query field containers for reports and charts.

**Note:** If you have more than one item in either Sum, By, or Across Query field containers (for reports) or Measure (Sum) or X-axis Query field containers (for charts), you can drag them up or down in the Query pane to rearrange the order in which they display in your report or chart. When you drag fields to rearrange them, an indicator line displays, providing guidance as to where the field will be placed. The color of this line is determined by the theme. Once you have performed the rearrangement, the Live Preview refreshes based on the newly indicated order.
Reports. For all reports, the Query field containers in the Query pane include Sum, By, and Across.

- Use the Sum $\Sigma$ field container to aggregate or display numeric measure fields. Its context menu provides options to Sum (default), Print, Count, or List the fields in the report.

- Use the By Query field container to vertically sort dimension fields to produce row labels in the report output. Dimension fields are normally non-numeric or date fields.

- Use the Across Query field container to horizontally sort dimension fields to produce column labels in the report output.

Charts. For most charts, the Query field containers in the Query pane include Measure (Sum), X Axis, Legend (Series), Multi-graph and Coordinated. More complex charts that require additional dimension fields have alternative Query field containers.

- **Measure (Sum).** Use this Query field container to aggregate or display numeric measure field values.

- **Location.** Use this Query field container to display a location field. This Query field container displays for maps only.

- **X Axis.** Use this Query field container to sort dimension fields in the chart output.

- **Legend (Series).** Use this Query field container to display dimension fields as color-coded values (lines, bars, areas, scatter plots) that match the color-coded dimension values displayed in the legend below the chart. Legend (Series) provides functionality that is similar to an Across field in a report.

- **Multi-graph.** Use this Query field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph Query field container is not plotted on the chart, but each unique sort field value is listed for every chart.

- **Coordinated.** Use this Query field container to collectively sort and collate by a common sort group (for documents only).

For pie charts, the Query field containers in the Query pane include Measure (Sum), Slices, Category, Multi-graph, and Coordinated.

- **Measure (Sum).** Use this Query field container to aggregate or display numeric measure field values in the pie.
Pie slices. Use this Query field container to display dimension fields as color-coded pie slices that match the color-coded dimension values displayed in the legend below the chart. The Pie slices Query field container is equivalent to the Legend (Series) Query field container used for other chart types.

Multi-graph. Use this Query field container to create outermost sort fields and to serve as a page break for working with multiple charts. The sort field added to this Multi-graph Query field container is not plotted on the chart, but each unique sort field value is listed for every chart.

Category. Use this Query field container to sort dimension fields in the chart output. Category is equivalent to the X-axis Query field container used for other chart types.

Coordinated. Use this Query field container to collectively sort and collate by a common sort group (for documents only).

Using Field Containers

Field containers are used to hold fields that you select based on the function that you want it to perform. For example, in Chart and Visualization mode, you can add a field to the Color field container, which will color your data based on the selected field.

For reports, the available field containers are different than those presented for charts and visualizations. This section reviews all of the field containers, providing you with a reference point when working with field containers.

Field Containers for Reports

The following field containers display when creating reports.

Across

Enables you to display column headings across the top of the report for the measure or dimension that is placed in this field container.

By

Enables you to specify sort fields for your report.

Note: You can rearrange the display order of your By sorts by dragging them into the desired order in the Query pane.

Sum

Displays numeric totals for numeric (measure) fields that are added to this field container.
Field Containers for Charts and Visualizations

The following field containers display when creating charts and visualizations.

**Animate**

Enables you to animate time progression using a slider control. As you move the control along the slider bar, an animation effect results. The slider control has a Play button that allows you to play and pause the animation. When you click Play, the Pause option is activated, enabling you to pause the progression and analyze your data. Slider controls are limited to one sort field and should be time or sequence related, such as month or year. This field container displays for many different chart types.

**By**

Use this field container to differentiate data types in a field that contains multiple categorical values. For example, when creating a gauge chart, the field that you specify in this field container becomes a By field, by which all values are displayed as a separate chart.

**Category**

Enables you to display data categorically in a chart. This field container displays for Tag Cloud charts, which are available in the Other charts category.

**Category Axis**

Use this field container to specify a field that contains categorical data. These categories display on the categorical portion of a 3D bar chart. The other axis, Series Axis, is plotted against the categorical data.

**Close**

Enables you to specify a numeric field to indicate the closing value of a stock. Other required values include: Open, High, and Low. This field container displays for Stock charts, which are available in the Other charts category.

**Color**

Enables the application of different colors based on the underlying data set for the field in this field container. When you place a numeric field in the Color field container, the legend displays as a heat scale. When you place an alphanumerical or a date field (non-measure) in the Color field container, the legend displays as colored markers. To change how the legend displays, right-click the Color field container and click Color BY.
**Columns**

Enables you to specify a field to display column data in a matrix chart in a visual. The use of measure fields is supported. Column data is displayed at the top of the visual, along the X axis. This field container is available for charts and visualizations.

**Detail**

Use this field container to add detail to your visual by adding a data field to it. For example, if you add Sale,Quarter to the Detail field container in your Scatter plot, the points on the plot are quadrupled, one for each quarter. In addition, the field that you specify in the Detail field container also displays on the hover menu for each point in the plot.

**Geolocation**

Enables you to specify a Geolocation field for use in a map.

*Note:* Geolocation fields are listed in the Data pane with a Geolocation icon 🌍.

**Grouping**

Enables you to specify a field by which to present your data in categories or groups. For example, this data field controls how a treemap is grouped.

**High**

Enables you to specify a numeric field to indicate the high value of a stock. Other required values include: Open, Low, and Close. This field container displays for Stock charts, which are available in the Other charts category.

**Horizontal Axis**

Displays the data for the selected along the X axis. This field container is available for charts and visualizations.

*Note:* You can specify up to three fields on the horizontal axis.

**Latitude**

Enables you to specify a geolocation field that contains latitudinal data. This field container displays for Leaflet bubble maps.

**Longitude**

Enables you to specify a geolocation field that contains longitudinal data. This field container displays for Leaflet bubble maps.
Legend (Series)

Enables you to add a field to specify for the legend of the chart. This field container displays for a number of charts that are available in the Other chart category.

Low

Enables you to specify a numeric field to indicate the low value of a stock. Other required values include: Open, High, and Close. This field container displays for Stock charts, which are available in the Other charts category.

Lower Limit

Enables you to specify a numeric (measure) field by which to establish a lower limit. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

Lower quartile

Enables you to specify a numeric (measure) field by which to establish a lower quartile. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

Measure

Use this field container to specify a measure that will serve as the basis for a pie chart. The Measure metric is used with the Color field container for pie charts to create sections based on your field selections. It is also used with Gauge charts.

Measure (Sum)

Enables you to specify a numeric (measure field) by which to sum data. This field container displays for a number of charts that are available in the Other chart category.

Median

Enables you to specify a numeric (measure) field by which to establish an median. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

Multi-graph

Enables the creation of multiple graphs based on the field that you place in this field container. This field container displays for many different chart types, including Spectral Heatmaps, which are available from the Other dialog box.

Open

Enables you to specify a numeric field to indicate the opening value of a stock. Other required values include: High, Low, and Close. This field container displays for Stock charts, which are available in the Other charts category.
**Rows**

Enables you to specify a field to display row data in a matrix chart in a visual. The use of measure fields is supported. Row data is displayed on the left side of the visual, along the Y axis. This field container is available for charts and visualizations.

**Series Axis**

Use this field container to specify a series to plot against the data presented on the Categorical Axis. This field container displays for 3D bar charts.

**Size**

Controls the size of markers or other data points.

**Size (Sum)**

Enables you to specify a numeric (measure) field, which will control the size of the data presented in a chart. This field container displays for Tag Cloud charts, which are available in the Other charts category.

**Slices**

Enables you to specify a field whose data values will dictate the size of the slices in a chart. This field container is available for Funnel charts, which are available in the Other chart category.

**Tooltip**

When you place a field in this field container, InfoAssist enables you to view additional information in the tooltip for a chart or visual.

**Upper limit**

Enables you to specify a numeric (measure) field by which to establish an upper limit. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

**Upper quartile**

Enables you to specify a numeric (measure) field by which to establish an upper quartile. This field container displays for Vertical Box Plot charts, which are available in the Other chart category.

**Vertical Axis**

Displays the data for the selected field along the Y axis. This field container is available for charts and visualizations.
X Axis

Enables the specification of a field on the X Axis of certain chart types. For example, XY Polar. This field container displays for a number of charts that are available in the Other chart category.

Y1 Measure (Sum)

Enables you to specify a measure (numeric) field for the Y Axis in a Pareto and certain line charts, which can be accessed from the Other chart category.

Y2 Measure

Use this field container to indicate a measure to serve as the basis for second Y axis. This field is used in various line charts, which can be accessed from the Other chart category.

Adding Parameters for Data Selection at Run Time

You can add new parameters to your report or chart to create parameter options for selection at run time. This enables you to dynamically select and review different scenarios with your data, offering you on-demand, dynamic report or chart creation at run time.

When you add a parameter, it becomes a field container into which you can add one or more measures and dimensions. You create a new parameter by right-clicking on a field container in the Query pane and clicking New Parameter. This creates a numbered parameter (for example, Parameter 1). In cases where you have multiple parameters defined, the numbering is applied sequentially.

Once you add a parameter, you can define the parameter prompt by right-clicking the Parameter-n field container and clicking Parameter Prompt, where n is the number of the parameter that was added. The new parameter prompt will display in the Query pane and at run time. This allows you to easily identify the parameters while categorizing the data fields that you want each to contain. For example, if you add a number of Sales-related fields to a parameter, you can rename the parameter with a title of Sales to encapsulate the data fields that you selected. Parameters should be renamed before you run the report or chart so that they are easy to identify.

In order to populate parameters in your report or chart, data fields must be placed in the parameter field container. You can do this by selecting fields from the Data pane and dragging them into the relevant parameter field containers that you create.

Note: Double-clicking the data fields in the Data pane places the data field in the default field containers in the Query pane, not the parameter field container. For example, in a report, if you double-click Discount, the data field is placed in the Sum container (outside of the parameter field container that you created). You can always drag a data field into a parameter container from another field container in the Query pane if you wish to consider it a parameter.
You can also reorder the data fields that you have placed in a given parameter field container by dragging them into the order that you wish to display them at run time.

Parameters can be specified in any field container, with the exception of Multi-graph. Once you have defined your parameters and selected the relevant data fields, run the report or chart. Using the drop-down lists for each parameter, you can select different options from the parameter lists to view the data in your report or chart dynamically. To load different scenarios, select the values and then click Run.

The following image shows the Query pane with a number of parameters and data fields specified.

**Procedure:** How to Add a Parameter

1. Create a new report or chart or open an existing one.
2. Add a new parameter by right-clicking a field container and clicking **New Parameter**, as shown in the following image.

![Image of parameter creation](image)

A new parameter field container is added.

3. Add the data fields that you would like to display in a parameter list at run time to the new parameter field container.

4. Optionally, rename the parameter by right-clicking the parameter and clicking **Parameter Prompt**.

   This is not required, but it does help in differentiating the various numbered parameters that display, depending on how many you define.

   **Note:** When defining parameter prompt, you can include a space in any position in the prompt string. The first character cannot be a single quotation mark (') and the following characters cannot be used within the parameter prompt: & . ; ( )

5. Optionally, add one or more additional parameters, and relevant data fields, into the field containers for which you would like to select data values at run time.

6. On the Quick Access toolbar, click **Run**.

   You can use the Parameter drop-down lists that display at run-time to create different views of your data, as shown in the following image.

![Parameter drop-down lists](image)
**Note:** You can optionally run your report or chart using the default parameters without making a selection. Click the down arrow on the Run button in the Quick Access toolbar and select *Run with Default Parameter Values*.

The following navigational icons display at run time:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Close Filter Panel" /></td>
<td><strong>Close Filter Panel.</strong> Click this option to collapse the filter panel, displaying more of the report or chart in the right pane.</td>
</tr>
<tr>
<td><img src="image" alt="Reset Filter Values" /></td>
<td><strong>Reset filter values.</strong> Click this option to reset the filter values to their default values, as indicated when the parameter was initially set up.</td>
</tr>
<tr>
<td><img src="image" alt="Run with Filter Values" /></td>
<td><strong>Run with filter values.</strong> Click this option to run the report or chart based on your selections.</td>
</tr>
<tr>
<td><img src="image" alt="Show Filter Panel" /></td>
<td><strong>Show filter panel.</strong> Click this option to show the filter panel when viewing a report or chart. When viewing the filter panel, you can close it by clicking <em>Close Filter panel</em>.</td>
</tr>
</tbody>
</table>

**Using Shortcut Menu Options in the Query Pane**

In the Query pane, you can right-click any field and select from a list of available options that are displayed in the menu that appears. The options that you can select vary, depending on the type of Query field container in which the field is located and the type of report that you are creating.
You can also rename the content type in the Query pane. You can right-click the component and click Rename to change the title, as shown in the following image.

![Query](image)

This allows you to customize the title in the Query pane. In addition, when working in Excel format, the name that you provide is used as the worksheet name in the workbook that is generated at run-time.

**Note:**
- If you are working with a report or chart in HTML format, you can also access Sum, Print, List, and Count aggregations from the shortcut menu on the report or chart component.
- When working with an -INCLUDE component in Document mode, you can change the Title text of the included .fex or component. However, this only affects prompts. The title text of an included .fex will not be shown as a tab title in the related Excel document.

**Related Information:**
- [Using Field Containers](#) on page 56
- [Right-Click Field Options in the Query and Filter Panes](#) on page 65

**Reference:** [Right-Click Field Options in the Query and Filter Panes](#)

The following table lists and describes all the right-click field options available in the Query and Filter panes for a selected field.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td># of Columns</td>
<td>Opens the Number of Columns dialog box, where you can indicate the number of columns in which you wish to display multiple graphs. This is only available for the Multi-graph field container.</td>
</tr>
<tr>
<td>Aggregation Functions</td>
<td>Provides a menu for selecting options to assign an aggregation type value to a selected numeric or dimension (non-numeric) field in a report or chart.</td>
</tr>
<tr>
<td>Break</td>
<td>Provides a menu of options to enable page breaks and subtotals, and resetting page numbers. This option is available for any measure or dimension field used in a report.</td>
</tr>
<tr>
<td>Color BY</td>
<td>Changes the Color field container to Color BY. The field container also changes to Color BY when you place a field into the Color field container. You can disable Color BY, which changes a dimension field into a measure field. This option is only available for charts and visualizations.</td>
</tr>
<tr>
<td>Create Group</td>
<td>Allows you to create a group of elements based on the field data type that you select. Once you define a new group, a higher-level field is created that contains the selected elements. This option is available for dimension fields of non-numeric format or attribute. For more information, see <em>How to Create a Dynamic Group</em> on page 70.</td>
</tr>
<tr>
<td>Change Title</td>
<td>Opens the Edit Title dialog box, where you can change the title of the selected field by typing the new title in the Enter Title field. This option is available for all fields. Note: When changing the title of a column heading, you can place a comma between words in the Enter Title field to create a multi-line header.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Data Bars</td>
<td>Provides a menu for enabling the data bar representation functionality. Selecting <strong>On</strong> adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values. This option is available for fields within the Sum field container in a report.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected field. This option is available for all fields in every field container.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> In the Query and Filter panes, you can select and delete multiple data fields at one time. Using the CTRL key, select two or more data fields, right-mouse click, and then click <strong>Delete</strong>.</td>
</tr>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can create multiple drilldown links on a data field to external procedures or websites. This option is available for any measure or dimension field in a report or chart.</td>
</tr>
<tr>
<td>Edit Format</td>
<td>Opens the Field Format Options dialog box, where you can edit the field type and display options. This option is available for fields within the Sum field container in a report, as well as measure fields in a chart or visualization.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Any changes to the format of a field will be reflected in the tooltip for charts at run time, as well as for visualizations at design and run time.</td>
</tr>
<tr>
<td>Filter Values</td>
<td>Opens the Filter dialog box for creating WHERE statements, which enable you to select only the data that you want and to exclude all unwanted data. This option is available for all fields, except for a field in the Multi-graph field container.</td>
</tr>
<tr>
<td>Geographic Role</td>
<td>Opens the Location Type dialog box, from which you can make a location selection.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> This option is only available when working with Leaflet maps.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Multi-Y split</td>
<td>Allows you to display individual charts for each measure field where multiple measures are specified. Located on the Vertical Axis, this option is available for charts and visualizations.</td>
</tr>
<tr>
<td>New Parameter</td>
<td>Allows you to add new parameters to your report or chart, which creates parameter options for selection at run time. You can create a new parameter in a report or chart in any field container.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> When working with charts, a new parameter can only be added for charts that use the new attribute syntax.</td>
</tr>
<tr>
<td>Missing</td>
<td>Allows you to show or hide fields with no value. This option is available for fields in the Sum and By field containers in reports. For charts, the option appears but is disabled.</td>
</tr>
<tr>
<td>Sort</td>
<td>Provides access to the Sort, Rank, and Limit menus. The Sort menu allows you to sort your data either in ascending or descending order. The Limit menu allows you to specify the number of unique values displayed for a sort group that has been added. The Rank menu allows you to insert a rank column immediately to the left if a Sort By field is selected and adds a rank column to the left of the Sort By field if a Measure field is selected. Ranking a Measure field results in two copies of the field, the original Measure field and the Sort By field that is created during ranking. This option is available for any measure or dimension field used in a report or chart.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box, where you can edit and style your footers. This option is available for fields within the By field container in a report.</td>
</tr>
<tr>
<td>Sub Header</td>
<td>Opens the Sub Header &amp; Sub Footer dialog box, where you can edit and style your headers. This option is available for fields within the By field container in a report.</td>
</tr>
<tr>
<td>Suppress Empty Group</td>
<td>Suppresses any part of your chart that is empty. You can deselect this option, which is enabled, by default. This option is available on the Horizontal axis in both Chart and Visualization mode.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Sort by Total Value</td>
<td>Enables you to sort the output in a chart or visualization using the values from the y-axis (Horizontal axis) of a stacked bar chart. While this feature was implemented specifically for Stacked Bar charts, it also applies to regular bar charts, as well as line and area charts. This enables you to view your data as ranked, or sorted, from highest value to lowest value. Accordingly, this option sorts the output by the bar (or other) with the highest total. This option is set to Off by default, but you can select Ascending or Descending to sort your data. This option is available on the Horizontal axis in both Chart and Visualization mode. <strong>Note:</strong> If you rotate your chart horizontally, the Sort By Total Value menu option displays on the Vertical Axis. For more information, see <em>How to Sort a Chart by Total Value</em> on page 247.</td>
</tr>
<tr>
<td>Traffic Light Conditions</td>
<td>Opens the Traffic Light Condition dialog box, where you can add new conditional styling or modify existing conditional styling by applying traffic light (and other) colors to a selected field in the report output when the field meets specified criteria. This option is available for both measure and dimension fields in reports and measure fields in charts.</td>
</tr>
<tr>
<td>Visibility</td>
<td>Provides a menu for controlling the visibility of the selected field. Clicking <em>Hide</em> removes the selected field from the report output. Clicking <em>Show</em> (default) displays the selected field in the report output. This option is available for all fields, except for the Multi-graph field container or parameters.</td>
</tr>
</tbody>
</table>

All of the shortcut menu options that are available in the Query and Filter panes are also available in the Field tab. For more information, see *Field Tab* on page 42.
Dynamic Grouping

Dynamic grouping allows you to create groups of elements based on the field data type that you select. For example, in the wf_retail_lite database, there are a number of brands of televisions. Using the dynamic grouping functionality, you can create groups based on the popularity of a particular brand. The first group might include top sellers such as LG and Sony. The second group might contain the remaining brands (Panasonic, GPX, Supersonic, Tivax, and Audiovox). This would allow you to group top sellers into one group, and the remaining brands into another group.

**Note:** The Create Group option is only available for dimension fields of non-numeric format or attribute.

You can also specify multiple, unique groupings in the same session. For example, you might want to group the data to indicate groups or products, or specific regions.

**Note:** If you want to exclude a specific data element from your analysis, you can use the filter functionality.

The grouping that you specify is applied and this new group then replaces the original field that you selected in the Query pane. The name that you specify when creating the group is reflected in the Query pane.

The process of dynamic grouping creates a Define field, which can then be used in other reports or charts in the same session. Dynamic grouping also supports Auto Drill, enabling you to drill through the hierarchy of your data just like any other data field. For more information, see *Using Auto Drill* on page 345.

**Note:**

- You can edit the group once it has been created by right-clicking on the higher-level field and clicking *Edit Group*.
- When working with Reporting Objects, Dynamic Grouping is not supported.

**Procedure:** How to Create a Dynamic Group

1. From the Data pane, add one or more data fields to your report or chart.
   
   **Note:** You can use the dynamic grouping functionality on non-numeric dimension fields only.

2. In the Query pane, right-click the data field for which you want to apply dynamic grouping.
   
   **Note:** The Create Group option is also available in the Data pane shortcut menu.

3. Click *Create Group*.

   The Create a Group dialog box displays.
4. In the Field text box, optionally type a name for the new group.

   **Note**: The fully qualified field name is displayed in the Field Origin text field. This field is enabled and has a read-only attribute. The display of the fully qualified field name is particularly useful when renaming or editing a group, as it identifies the data source followed by the hierarchical location of the field within a data set. For example, WF_RETAIL_LITE.WF_RETAIL_PRODUCT.BRAND.

5. Select the data values that you want to group. Use CTRL + click to select more than one value, as shown in the following image.

![Image of Create a Group dialog box](image)

6. Click **Group**.

   **Note**: To ungroup values, click a group and then click **Ungroup**.
7. Optionally, create additional groups, as shown in the following image.

8. Click OK.

Your grouped data will display in the Data pane when your report, chart, or visualization refreshes, as shown in the following image.
Understanding the Canvas

The canvas displays a preview of the report being created or modified on the canvas when you are in the default Live Preview. To select Live Preview, go to Home tab, and in the Design group, click Live Preview, or on the View tab, in the Design group, click Live Preview. The canvas is always fully maximized and cannot be minimized, cascaded, or tiled. However, a blank canvas opens when there is no report.

The canvas displays either live data or sample data.

To display live data, on the Home tab, in the Design group, click Data from Source (default).

When you select Data from Source, a live preview of the report being built, with records from your data source, is refreshed on the canvas as you add, remove, and style fields in the report.

When you use live data, you can set the number of records that display in your content by selecting a value from the Records menu. Displaying more records gives a more complete view of your data at design time, but may result in slower performance.

**Note:** Prior to Release 8207, when creating content using an Oracle Database 12c data source, design time record limits were applied prior to aggregation. In Release 8207 and higher, the record limit when using Oracle Database 12c is applied after aggregation.

To display sample data, on the Home tab, in the Design group, click Use Sample Data.

When you select Use Sample Data, the canvas displays sample data based on the field type, with the same formatting and styling used to display live data.

When you execute a report, the canvas displays the Output window. If the Output is minimized, or if there is no report to preview, the canvas is blank. To change the canvas view, you can select Query Design view or Live Preview from the Design group of the View tab or Home tab.
The following image shows the canvas, which displays a chart preview when you first launch InfoAssist to create a chart. The Resources panel appears to the left of the canvas.

When working with a report in Live Preview, you can rearrange the columns of the report by dragging them to the left or right, depending on your display preference. If the column is numeric, you are presented with the option to Drop as Sum or Drop as Sort, as shown in the following image.

**Note:** If you select *Drop as Sort*, the values are listed individually and they are sorted. If you select *Drop as Sum*, the values are summed for that particular row. The default is Drop as Sum.

When placing the column in a new location, an indicator bar displays, indicating the location of placement for the moved column. This allows you to see where the column will be placed before you actually perform the operation.
**Note:** Column sort order can also be rearranged by dragging the fields in the Query field containers of the Query pane to reorder them. For more information, see *Using the Query Pane and Filter Pane* on page 54.

If you create a filter, then the filter appears in the Filter pane.

**Using the Query Pane and Filter Pane on the Canvas**

If you click *Query* on the *Home* tab, in the *Design* group, the Query and Filter panes expand in to the canvas.

This provides a larger area for displaying the Query and Filter panes. This feature is useful when you are designing a report with multiple filters or numerous fields.

Depending on whether you are creating a report or a chart, the Query pane displays selected data source fields using different types of Query field containers.

**Related Information:**

- *Using Filters to Customize the Display of Data* on page 442
- *Using Field Containers* on page 56

**Understanding Output Options**

When you run a report, the output appears, either in a tab on the canvas, or in a new browser window. You can create and display output in several different ways, depending on the following options. You can select these options on the *View* tab, in the *Output Window* group:

- Cascade
- Tile Horizontally
- Tile Vertically
- Single Tab
- New Tab
- Single Window
- New Window
- Switch Output

Output window and tab options are also available in the status bar, and output window display options are also available in the Navigation taskbar.
Note: When you run a report, tab focus is not on the output window and pressing the Tab key
does not move the selection. To move the Tab focus out of the output window, press F6.

Reference: Output Target Options

The following are output target options that you can select.

- **Single Tab.** When you click Single Tab and run a report, a new output window is created on
  the canvas, a report instance is created, and an output tab is placed on the Navigation
taskbar. As you modify a report, the same output window is refreshed each time the report
is run. This option, which is the default, is ideal when you are working with just one report.

- **New Tab.** When you click New Tab, each time you run a report, a new output window is
  created on the canvas. A new report instance is also created and preserved by the addition
  of a new output tab on the Navigation taskbar. Each output tab maintains the output of the
  report that generated the corresponding output window. Selecting an output tab on the
  Navigation taskbar loads the associated output instance into the output window.

- **Single Window.** When you click Single Window and run a report, a new browser window is
  opened and populated with the report output. As you modify the report, the same browser
  window is refreshed each time the report is run. If the browser window is closed and the
  report is run, a new browser window is opened again and is refreshed for each subsequent
  run. The output is not displayed on the canvas, and an output tab is not added to the
  Navigation taskbar.

- **New Window.** When you click New Window, each time you run a report, a new browser
  window is opened and populated with the report output. The output is not displayed on the
  canvas, and an output tab is not added to the Navigation Taskbar.

Reference: Output View Options

The following are output view options (Arrange) that you can select.

- **Cascade.** When you click Cascade, if multiple output windows exist, they are cascaded
diagonally across the canvas. This option does not affect open browser windows when you
  select New Window or Single Window.

- **Tile Horizontally.** When you click Tile Horizontally, if multiple output windows exist, they are
tiled horizontally, one above another, across the canvas. This option does not affect open
browser windows when you select New Window or Single Window.

- **Tile Vertically.** When you click Tile Vertically, if multiple output windows exist, they are tiled
vertically, side by side, across the canvas. This option does not affect open browser
windows when you select New Window or Single Window.
Switch Output. When you click Switch Output, a drop-down menu opens, where you can select any active report to view the output. The selected report is loaded into the output window or browser window, depending on the selected output window or tab option.

Reference: Output Format Options

The Output window can display report output in the following formats: HTML, HTML5, HTML Analytic Document, PDF, and PDF Analytic Document.

Note: Excel and PowerPoint formats open in their native programs in a window external to InfoAssist.

Using the Navigation Taskbar

The Navigation taskbar provides quick access to all active output windows and to the report design that generated the output. You can return to the last report that you edited in the Query pane by clicking Display Design View on the taskbar. The Navigation taskbar is always visible. It is located near the bottom of the application window, just above the status bar.

Each of the active output windows displays a tab on the Navigation taskbar. Selecting the tab displays that output window on the canvas. If you save a report with a unique name each time you modify it, when the report is executed and a new output window is generated, the unique name appears as a tab on the taskbar. If you continue to modify and execute a report without saving it with a unique name, a number in parentheses is appended to the original, saved report name to differentiate it among the multiple output windows.

The ability to select report output from the Navigation taskbar depends on the output window option selected from the status bar or from the Output Window group of the View tab. For more information, see Using the Status Bar on page 78, or Understanding Output Options on page 75.

Each report tab on the Navigation taskbar has a shortcut menu with the following options:

- Restore
- Minimize
- Maximize
- Close
- Auto Resize
Restore, Minimize, Maximize, and Close are standard options available in any browser window or software application. Minimize, Maximize (if the window is not maximized), or Restore (if the window is maximized), and Close can also be found in the top-right corner of the output window.

The Auto Resize option enables automatic resizing of an output window as needed when you add or remove fields.

The Window Options menu at the far left of the Navigation taskbar provides options for displaying all active output windows on the canvas. The display options that you can select are Cascade, Tile Horizontally, Tile Vertically, Restore All, Minimize All, Maximize All, or Close All. The name of each active output window appears at the bottom of the menu.

The Window Options menu options are directly linked to the options available in the Output Window group of the View tab.

Using the Status Bar

The status bar displays the status of the last selected action, a reports button that shows the number of open reports, an output format button that shows the selected format, as well as a list of the available formats, and an output target button that shows the selected option for displaying new output windows or tabs.

The status bar is shown in the following image.

![Status Bar](image)

When you click the reports button, a menu opens, with options for selecting any of the open reports. Each report is listed by name and an icon which represents the report type (report, chart, visualization, document). The report you select becomes active.

When you click the output format button, a menu opens, with options for selecting a different output format. For a complete list of options, see Understanding Output Options on page 75.

When you click the output target button, a menu opens, with options for Single Tab (default), New Tab, Single Window, and New Window. For more information, see Understanding Output Options on page 75.
Creating and Customizing Reports

You can apply styling to specific areas of a report to customize its appearance and functionality. You can also use the many optional reporting features to add custom functionality and output formats to reports.

In this chapter:

- Creating Reports
- Styling Reports
- Changing a Field Format
- Using Custom Reporting Features
- Creating Customized Report Outputs

Creating Reports

You can use the following procedures to create a basic report in the WebFOCUS start page and InfoAssist.

Procedure: How to Create a Report

After you have signed in to WebFOCUS, you can work with an existing folder, or create a new folder in the WebFOCUS start page to store your reports.

1. Open InfoAssist in Report mode.
2. Drag fields onto the canvas or into the Query pane to begin building your report.
A basic report is shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>511,667</td>
<td>$129,608,338.53</td>
</tr>
<tr>
<td>Camcorder</td>
<td>455,244</td>
<td>$154,465,702.24</td>
</tr>
<tr>
<td>Computers</td>
<td>351,777</td>
<td>$103,316,482.12</td>
</tr>
<tr>
<td>Media Player</td>
<td>771,934</td>
<td>$246,073,059.36</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>1,114,332</td>
<td>$291,294,933.52</td>
</tr>
<tr>
<td>Televisions</td>
<td>105,188</td>
<td>$78,381,132.81</td>
</tr>
<tr>
<td>Video Production</td>
<td>199,749</td>
<td>$58,053,276.62</td>
</tr>
</tbody>
</table>

**Procedure: How to Create a Report From the Application Main Menu**

1. In the upper-left corner of the InfoAssist interface, click the IA button to open the Application Main Menu.
2. From the Application Main Menu, click New.
   The InfoAssist splash screen opens.
3. On the InfoAssist splash screen, select *Build a Report*.
   The Open dialog box opens.
4. From the Open dialog box, select the data source that you want to use, and click Open.
   The data source that you selected appears in the Data pane of the Resources panel.
5. Drag fields onto the canvas or into the Query pane to begin building your report.

**Procedure: How to Create a Report From the Quick Access Toolbar**

1. On the Quick Access Toolbar, click the New icon.
   The InfoAssist splash screen opens.
2. On the InfoAssist splash screen, select *Build a Report*.
   The Open dialog box opens.
3. From the Open dialog box, select the data source that you want to use, and click Open.
   The data source that you selected appears in the Data pane of the Resources panel.
4. Drag fields onto the canvas or into the Query pane to begin building your report.
Procedure: How to Create a Report From an Existing Chart

1. Open the chart that contains the data that you want to present in a report.
   
   The data is presented as a report.

   Note: When creating a report, the SUM or PRINT field containers can support the addition of up to 99 fields. If you add a one-hundredth field, it will automatically replace the last field on the list.

Choosing a Report Output

The following output types are available for reports:

- HTML
- HTML Analytic Document
- PDF
- PDF Analytic Document
- Excel
- PowerPoint
- Visual Discovery AE (only available with a Visual Discovery Analyst Edition license)

Note: When you create a report in Document mode, you have access to Excel only.

When you create a report in Live Preview or Query Design view, you have access to the following Excel output types:

- Excel (xlsx). Outputs the report in Excel 2007 (and higher) format.
- Excel. Outputs the report in Excel format.
- Excel Formula (xlsx). Outputs the report, using Excel formulas that calculate and display the results of any type of summed information, such as column totals, row totals, and subtotals. This format is for Excel 2007 (and higher).
- Excel Formula. Outputs the report, using native Excel formulas for totals and computed values.

Note: Additional output types can be enabled in the WebFOCUS Administration Console, including Excel Pivot.
Using Procedure Settings

Procedure Settings, also known as SET commands, enable you to specify and control items for inclusion in a procedure. If you want to include a Procedure Setting in a procedure (.fex), select the relevant check box to include that setting in the procedure (.fex). Procedure Settings are available in Report, Chart, and Document mode.

You can access Procedure Settings from the Quick Access toolbar. When you click Procedure Settings, the Procedure Settings dialog box displays, allowing you to select the options to apply to your procedure, as shown in the following image.

![Procedure Settings Dialog Box](image)

Options include:

- **Collation Sequence (COLLATION)**. Establishes a binary or case-insensitive collation sequence. Options include Code Page (default), Binary, Case-Sensitive, and Case-Insensitive. This value will not be written into the procedure (.fex), by default. Therefore, you must select the check box to prompt this action.

- **Summary Lines (SUMMARY LINES)**. Allows you to combine fields with and without prefix operators on summary lines in one request. Options include New (default value), Old, and Explicit. This value will not be written into the procedure (.fex), by default. Therefore, you must select the check box to prompt this action.

- **Missing Value (NODATA)**. Specifies the missing data characters to be printed in a report. This is a text box with a default value of period ( . ). Common entries include N/A or NONE. In addition, this field has a limit of six characters. This value will not be written into the procedure (.fex), by default. Therefore, you must select the check box to prompt this action.
Note: You can use amper (&) variables in the Missing Data field to allow the entry of values at run-time. In general, valid values include any string or amper (&) variable, which will print automatically. You can use &xx to activate autoprompt. For example, you can use &NONE to specify a value at run-time. In Live Preview, this value is set to _FOC_NULL or as many characters that will fit in the width as defined by the existing values in a column. Global variables (&&x) should not be entered as they do not activate autoprompt. Mixing strings with amper (&) variable can result in Focus error messages. For example, &&&N& or &nn&.

- **In-Document Analytics.** Allows you to select between the Designer Style and Legacy formats when working with In-Document Analytics.

- **Decimal Notation (CDN).** Ensures the correct display of currency for the target language. Radio buttons include On and Off (default value).

- **HTML Encode (HTMLENCODE).** Controls whether HTML tags are encoded when these tags are stored within the actual data or when they are created using a DEFINE or COMPUTE command. Radio buttons include On (default value) and Off. This option is selected for inclusion in the procedure (.fex), by default (the check box is selected), as it is not a default setting of the Reporting Server.

- **Empty Report (EMPTY REPORT).** Controls the output generated when a TABLE request retrieves zero records. Radio buttons include On (default value) and Off. When set to On, an empty report (column headings with no content) is generated. When set to Off, no report is generated. This option is selected for inclusion in the procedure (.fex), by default (the check box is selected), as it is not a default setting of the Reporting Server.

Note: In Report mode, all settings apply. In Chart mode, only Collation Sequence (COLLATION), Decimal Notation (CDN), and Empty Report (EMPTYREPORT) settings are applicable. In Document mode, Procedure Settings apply to the whole document. These settings are currently unavailable in Visualization mode.
Procedure: How to Create a Procedure Using the Missing Value Option

1. Create a report with a dimension, a measure, and an across sort field that shows missing values, as shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Subcategory</th>
<th>Month</th>
<th>3</th>
<th>Revenue Per Sq. Ft.</th>
<th>4</th>
<th>Revenue Per Sq. Ft.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>Charger</td>
<td>1,973</td>
<td>6,204</td>
<td>$63.53</td>
<td>1,747</td>
<td>5,650</td>
</tr>
<tr>
<td></td>
<td>Headphones</td>
<td>4,245</td>
<td>13,463</td>
<td>$11,00.01</td>
<td>3,843</td>
<td>12,178</td>
</tr>
<tr>
<td></td>
<td>Universal Remote Controls</td>
<td>3,340</td>
<td>10,839</td>
<td>$790.19</td>
<td>2,585</td>
<td>9,581</td>
</tr>
<tr>
<td>Camcorder</td>
<td>Handheld</td>
<td>4,575</td>
<td>14,636</td>
<td>$648.54</td>
<td>4,256</td>
<td>13,490</td>
</tr>
<tr>
<td></td>
<td>Professional</td>
<td>242</td>
<td>755</td>
<td>$622.19</td>
<td>216</td>
<td>746</td>
</tr>
<tr>
<td></td>
<td>Standard</td>
<td>3,610</td>
<td>11,263</td>
<td>$1,499.08</td>
<td>3,291</td>
<td>10,071</td>
</tr>
<tr>
<td>Computers</td>
<td>Smartphone</td>
<td>3,822</td>
<td>11,413</td>
<td>$734.68</td>
<td>3,173</td>
<td>10,081</td>
</tr>
<tr>
<td></td>
<td>Tablet</td>
<td>3,102</td>
<td>8,134</td>
<td>$619.59</td>
<td>3,368</td>
<td>8,858</td>
</tr>
<tr>
<td>Media Player</td>
<td>Blu Ray</td>
<td>12,842</td>
<td>40,797</td>
<td>$3,762.71</td>
<td>11,421</td>
<td>38,130</td>
</tr>
<tr>
<td></td>
<td>DVD Players</td>
<td></td>
<td></td>
<td>$1,114.09</td>
<td>1,314</td>
<td>3,696</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>Streaming</td>
<td>1,304</td>
<td>4,187</td>
<td>$11,140.01</td>
<td>1,211</td>
<td>3,696</td>
</tr>
<tr>
<td></td>
<td>Home Theater Systems</td>
<td>7,485</td>
<td>23,315</td>
<td>$1,300.07</td>
<td>6,599</td>
<td>21,120</td>
</tr>
<tr>
<td></td>
<td>Receivers</td>
<td>2,767</td>
<td>8,730</td>
<td>$857.80</td>
<td>2,477</td>
<td>8,685</td>
</tr>
<tr>
<td></td>
<td>Speaker Kits</td>
<td>4,542</td>
<td>14,332</td>
<td>$1,491.64</td>
<td>4,029</td>
<td>13,117</td>
</tr>
<tr>
<td></td>
<td>iPod Docking Station</td>
<td>5,863</td>
<td>18,348</td>
<td>$859.48</td>
<td>5,147</td>
<td>18,636</td>
</tr>
<tr>
<td>Televisions</td>
<td>Flat Panel TV</td>
<td>1,709</td>
<td>5,427</td>
<td>$1,166.59</td>
<td>1,561</td>
<td>4,862</td>
</tr>
<tr>
<td>Video Production</td>
<td>Video Editing</td>
<td>3,744</td>
<td>11,881</td>
<td>$920.19</td>
<td>3,317</td>
<td>10,774</td>
</tr>
</tbody>
</table>

Note: The highlighted area indicates the default ( . ) for missing values.

2. On the Quick Access toolbar, click Procedure Settings.

3. Click the Missing Value check box.

4. In the Missing Value text box, enter the characters to be used to represent missing values in your report. For example, NONE.

Note: By default, this is set to ( . ). However, common examples include N/A or NONE.

5. Click OK.
Fields with missing values are indicated by the word NONE, in this case, as that is what was specified. This value is shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Subcategory</th>
<th>Month</th>
<th>Shipment Unit(s)</th>
<th>Sale Unit(s)</th>
<th>Revenue Per Sq. Ft.</th>
<th>Revenue Per Sq. Ft.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>Charger</td>
<td>1,973</td>
<td>8,204</td>
<td>843.63</td>
<td>1,747</td>
<td>5,650</td>
</tr>
<tr>
<td></td>
<td>Headphones</td>
<td>4,245</td>
<td>13,463</td>
<td>$1,150.61</td>
<td>3,843</td>
<td>12,178</td>
</tr>
<tr>
<td></td>
<td>Universal Remote Controls</td>
<td>3,340</td>
<td>10,639</td>
<td>$769.19</td>
<td>2,985</td>
<td>9,581</td>
</tr>
<tr>
<td>Camcorder</td>
<td>Handheld</td>
<td>4,575</td>
<td>14,636</td>
<td>$848.54</td>
<td>4,256</td>
<td>13,490</td>
</tr>
<tr>
<td></td>
<td>Professional</td>
<td>242</td>
<td>756</td>
<td>$882.19</td>
<td>216</td>
<td>748</td>
</tr>
<tr>
<td></td>
<td>Standard</td>
<td>3,610</td>
<td>11,283</td>
<td>$1,049.08</td>
<td>3,291</td>
<td>10,409</td>
</tr>
<tr>
<td>Computers</td>
<td>Smartphone</td>
<td>3,622</td>
<td>11,413</td>
<td>$734.86</td>
<td>3,178</td>
<td>10,281</td>
</tr>
<tr>
<td></td>
<td>Tablet</td>
<td>3,102</td>
<td>8,134</td>
<td>$819.59</td>
<td>3,368</td>
<td>8,858</td>
</tr>
<tr>
<td>Media Player</td>
<td>Blu Ray</td>
<td>12,623</td>
<td>40,707</td>
<td>$3,762.71</td>
<td>11,421</td>
<td>36,130</td>
</tr>
<tr>
<td></td>
<td>DVD Players</td>
<td>NONE</td>
<td>NONE</td>
<td>NONE</td>
<td>NONE</td>
<td>NONE</td>
</tr>
<tr>
<td></td>
<td>Streaming</td>
<td>1,364</td>
<td>4,167</td>
<td>$111.40</td>
<td>1,314</td>
<td>3,996</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>Home Theater Systems</td>
<td>7,465</td>
<td>23,315</td>
<td>$1,300.07</td>
<td>6,699</td>
<td>21,120</td>
</tr>
<tr>
<td></td>
<td>Receivers</td>
<td>2,767</td>
<td>8,730</td>
<td>$857.80</td>
<td>2,477</td>
<td>8,080</td>
</tr>
<tr>
<td></td>
<td>Speaker Kits</td>
<td>4,542</td>
<td>14,332</td>
<td>$1,881.64</td>
<td>4,602</td>
<td>13,117</td>
</tr>
<tr>
<td></td>
<td>iPod Docking Station</td>
<td>5,883</td>
<td>18,348</td>
<td>$893.40</td>
<td>5,147</td>
<td>16,836</td>
</tr>
<tr>
<td>Televisions</td>
<td>Flat Panel TV</td>
<td>1,709</td>
<td>5,427</td>
<td>$1,165.90</td>
<td>1,551</td>
<td>4,892</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>3,744</td>
<td>11,881</td>
<td>$920.18</td>
<td>3,317</td>
<td>10,774</td>
</tr>
</tbody>
</table>

6. Save the procedure.

**Procedure:** How to Create a Procedure Using the Empty Report Option

1. Create a report with one or more measures and two dimensions.
2. Add a filter to create an empty report by filtering on a value that does not exist in the dimension that you select.

**Note:** The addition of a filter condition causes your report to have no records, and the default behavior (EMPTYREPORT=ON) displays the heading and column titles.
3. On the Quick Access toolbar, click Procedure Settings.


   **Note:** This option is selected, by default. Notice that Empty Report can be set to On or Off. When enabled and set to On, the shell of the report (headings and titles) will be displayed. If the setting is turned off, the environment default will be used.

5. Click OK.

   When the Empty Report check box is cleared, no report is generated, as shown in the following image.
6. Save the procedure.

Creating Thumbnails for Use With the WebFOCUS Start Page

In InfoAssist, you can create and store thumbnail images for use in the WebFOCUS start page. Thumbnail images allow you to see a snapshot of a report or chart without opening the file. In InfoAssist, you can create a thumbnail image by clicking on the Create Thumbnail icon, which is located on the Quick Access toolbar.

You can create thumbnail images when working in Report and Chart mode in InfoAssist. These images are smaller renditions (220x160px) of your actual report or chart as it displays in Live Preview. Once you create the thumbnail and save the report or chart, you can access the thumbnail image from the file list on the WebFOCUS start page, as shown in the following image.

![Thumbnail Images](image)

**Note:** Thumbnail images are stored as part of the procedure when it is saved in the repository.

**Procedure:** How to Create a Thumbnail Image of a Report or Chart

1. Open InfoAssist in Report or Chart mode.
2. Create a report or chart.
3. On the Quick Access Toolbar, click *Create Thumbnail*, as shown outlined in blue in the following image.
The Create Thumbnail dialog box displays, as shown in the following image.

4. On the Create Thumbnail dialog box, click OK.

5. On the Message dialog box, a message displays stating that the Thumbnail has been created. Click OK.

6. On the Quick Access Toolbar, click Save to save the chart or report along with the thumbnail. The thumbnail is stored with the procedure.

**Procedure:** How to View the Properties of a Thumbnail from the WebFOCUS Start Page

1. Create a report or chart that contains a thumbnail.

2. Save the procedure.

3. In the Items list on the Workspaces area of the WebFOCUS start page, locate the procedure.
   The image that displays is the thumbnail that was saved with the procedure.

4. Right-click the procedure and select Properties to view additional thumbnail options.

5. Click the Advanced tab.
The thumbnail displays in the Explorer/Portal Properties section of the panel, as shown in the following image.
You can apply custom styling to specific areas of a report. When creating a report, you can perform the following styling customization.

- Global styling for the entire report. For more information, see How to Apply Styling to an Entire Report on page 90.

- Style data and column titles. For more information, see How to Perform Field-Level Styling in a Report on page 91.

- Style headings and footings. For more information, see How to Style Headings and Footings in a Report on page 94.

- Style the rows of data with alternating colors. For more information, see How to Style Rows of Data With Alternating Colors in a Report on page 95.

- Apply traffic light conditional styling to data. For more information, see How to Apply Traffic Light Conditional Styling to a Report (By Constant) on page 96 and How to Apply Traffic Light Conditional Styling to a Report (By Field) on page 97.

- Increase or decrease the amount of space inserted between rows and columns. For more information, see How to Use Cell Padding in a Report on page 99.

Procedure: How to Apply Styling to an Entire Report

1. Create a report, or open an existing report.
   
   The Report Style dialog box opens.
3. Select any of the following styling options that are available in the Style group.
   - **Font.** Opens a drop-down list, which you can use to change the font.
   - **Font size.** Opens a drop-down list, which you can use to change the font size value.
   - **Bold.** Applies bold font formatting to the selected text.
   - **Italic.** Applies italic font formatting to the selected text.
   - **Underline.** Underlines the selected text.
   - **Justify Left.** Aligns the text to the left of the canvas.
   - **Justify Center.** Aligns the text to the center of the canvas.
- **Justify Right.** Aligns the text to the right of the canvas.
- **Font Color.** Opens the Color dialog box, where you can select the font color.
- **Background Color.** Opens the Color dialog box, where you can select the background color for the report.
  
  **Note:** If you have chosen to specify a color, you must click OK to return to the Report Style dialog box.
- **Currency Symbol.** Opens a drop-down menu, from which you can choose a currency symbol. Options are US dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel.
- **Reset to Quick Styles from Template.** Resets all settings to the default settings from the template.
  
  **Note:** Reset only works while the Report Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

**Preview.** Displays the text as you have formatted it.

4. Click OK. The report is styled accordingly.

**Procedure:** How to Perform Field-Level Styling in a Report

You can style data, column titles, or both, in the report output for the selected data source field.

1. Create a report.
2. In the Query pane, select a data source field.
   
   The Field tab appears on the ribbon.
3. In the Style group, click one of the following:

   - **Data Style.** Styles only the data for the selected data source field.
   - **Title Style.** Styles only the column title for the selected data source field.
   - **Data + Title.** Styles both the data and the column title for the selected data source field.
4. Select any of the following styling options that are available in the Style group.

   - **Font.** Opens a drop-down list, which you can use to change the font.
   - **Font size.** Opens a drop-down list, which you can use to change the font size value.
Font Color. Opens the Color dialog box, where you can select the font color.

Reset styling to default style. Resets any styling changes to the default style.

Bold. Applies bold font formatting to the selected text.

Italic. Applies italic font formatting to the selected text.

Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

Background Color. Click the button to open the Color dialog box, where you can select the background color for the report.

Note: When working with font or background colors, you must click OK on the Color dialog box to return to the Report Style dialog box.

5. Click OK. The report is styled accordingly.

Procedure: How to Add Headings and Footings to a Report

You can make a report more meaningful by adding headings and footings. Headings and footings supply context and key information about a report, such as its purpose and audience. Headings and footings also provide structure, helping you navigate to the detail sought. They enhance visual appeal.

In this procedure, you will add and style a report heading and page heading. The procedure uses sample values, but you can supply values that apply to your own reports.

Headings and footings are available in Query Design view, Live Preview, and Document mode.

1. Create a report.
2. On the Home tab, in the Report group, click the Header & Footer button.
   The Header & Footer dialog box opens.
3. Click the tab for the heading or footing element that you want to add.
   For a report, you can add a report heading, page heading, page footing, or report footing. By default, the Report Header tab is selected. In this procedure, accept the default.
4. Click inside the design area of the dialog box, and type the text for the heading.
   For example, the text for a sample report heading might be Quantity Sold by Product.
5. Using the styling ribbon, apply styling to the report heading text.
   For example, click HELVETICA from the Font drop-down list. From the Font size drop-down list, click 12.
   The sample report heading with the selected styling values is shown in the following image.

6. Click Apply to save the changes you have made so far, without closing the dialog box.

7. To add a page heading, click the Page Header tab.
   In this procedure, you are going to add one of the supplied quick text options.

8. Click the last icon (Insert preformatted text content for headers/footers) on the right of the styling ribbon, and click Confidential in the list.

9. Change the font and font size. For example, change the font to HELVETICA and the size to 10.
   You can add your own text before or after the supplied text, for example, For Regional Managers Only.

10. Click OK to save the report heading and page heading and close the Header & Footer dialog box.
The report heading and page heading that you added and styled are shown in Live Preview in the following image.

Quantity Sold by Product

Confidential
For Regional Managers Only

<table>
<thead>
<tr>
<th>Product</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>511,667</td>
</tr>
<tr>
<td>Camcorder</td>
<td>455,244</td>
</tr>
<tr>
<td>Computers</td>
<td>351,777</td>
</tr>
<tr>
<td>Media Player</td>
<td>771,934</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>1,114,332</td>
</tr>
<tr>
<td>Televsions</td>
<td>105,188</td>
</tr>
<tr>
<td>Video Production</td>
<td>199,749</td>
</tr>
</tbody>
</table>

11. To make changes to either the report or page heading, right-click the heading and click Edit. You can also double-click on the header to open the Header & Footer dialog box.

Procedure: How to Style Headings and Footings in a Report

You can style headings and footings in the report output for the selected heading or footing field.

1. Create a report.
2. With the report opened in Live Preview, select the heading or footing text that you want to style.

The Header & Footer dialog box opens.

4. Select any of the following styling options that are available in the Style dialog box.
   - **Font.** Opens a drop-down list, which you can use to change the font.
   - **Font size.** Opens a drop-down list, which you can use to change the font size value.
   - **Bold.** Applies bold font formatting to the selected text.
   - **Italic.** Applies italic font formatting to the selected text.
Underline. Underlines the selected text.

Justify Left. Aligns the text to the left of the canvas.

Justify Center. Aligns the text to the center of the canvas.

Justify Right. Aligns the text to the right of the canvas.

Font Color. Opens the Color dialog box, where you can select the font color.

Background Color. Opens the Color dialog box, where you can select the background color for the report.

Reset to Quick Styles from Template. Resets all settings to the default settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

5. Click OK. The report is styled accordingly.

Procedure: How to Style Rows of Data With Alternating Colors in a Report

You can style rows of data in a report with alternating colors.

1. Create a report.

2. Open the report in Live Preview.


   The Color dialog box opens.

4. Select a color.

5. Click OK.
The selected color provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report, as shown in the following image of Banded report output.

![Banded report output](image)

**Procedure:** How to Apply Traffic Light Conditional Styling to a Report (By Constant)

You can apply traffic light conditional styling to data for a selected measure field. By default the report displays the values that satisfy the first condition in green, and the values that satisfy the second condition in red.

1. Open a report in Live Preview.
2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** Select a field on the report, and then on the Field tab, in the Display group, click Traffic Lights.
   - **Shortcut Menu:** Right-click a field on the report, point to More, and then click Traffic Light Conditions.

   The Traffic Light Condition dialog box opens.
3. From the Relational Operators drop-down menu below the field name, click a relational operator. For example, Equal to.
4. In the field to the right of the Relational Operators drop-down menu, click the down arrow for the Type drop-down menu.

   The Type menu opens.
5. In the Type drop-down list, click Constant.
6. Enter a value in the Value field.
or

a. From the Get Values drop-down menu, select one of the following values: All, First, Last, Minimum, Maximum, or From File. The value that you select appears in the Get Values field.

b. Select the value in the Get Values field. The value that you selected appears in the Value field.

7. Click OK.

The value that you selected appears in the field to the right of the Relational Operators drop-down menu.

8. Click the Style button.

The Style menu opens.

9. From the Style menu, click the Font Color or Background Color button.

The Color dialog box opens.

10. Select a color.

11. Click OK.

The color appears in the Preview box.

12. Click Apply to apply the colors to the report.

13. Click the Drill Down button.

The Drill Down dialog box opens.

14. In the Drill Down dialog box, use the radio buttons to specify the action you wish to perform. For example, drill down to a report or webpage, create an auto link target, or refresh a BI portal.

15. Click OK to close the dialog box.

16. In the Traffic Light Condition dialog box, click the New button to set traffic light conditions for additional fields.

**Procedure:** How to Apply Traffic Light Conditional Styling to a Report (By Field)

You can apply traffic light conditional styling to data for a selected measure field. By default, the report displays the values that satisfy the first condition in green, and the values that satisfy the second condition in red.

1. Open a report in Live Preview.
2. Open the Traffic Light Condition dialog box in one of the following ways:

   - **Ribbon:** Select a field on the report, and then on the *Field* tab, in the *Display* group, click *Traffic Lights*.

   - **Shortcut Menu:** Right-click a field on the report, point to *More*, and then click *Traffic Light Conditions*.

   The Traffic Light Condition dialog box opens.

3. From the drop-down menu below the field name, select a relational operator. For example, Equal to.

4. In the field to the right of the Relational Operators drop-down menu, click the arrow for the Type drop-down menu.

   The Type dialog box opens.

5. In the Type drop-down list, select *Field*.

   The Type dialog box displays a list of the data fields that you can choose from.

6. Select a data field from the list.

7. Click *OK*.

   The field that you selected appears in the field to the right of the Relational Operators drop-down menu.

8. Click the Style button.

   The Style menu opens.

9. From the Style menu, click the *Color* button.

   The Color dialog box opens.

10. Select a color.

    The color appears in the Preview box.

11. Click *OK*.

12. Click the *Drill Down* button.

    The Drill Down dialog opens.

13. In the Drill Down dialog, specify each of the following:

    - Drill down to a report or a webpage
    - URL of the webpage
    - An alternate comment
Parameters that you want to use (Name, Value)

14. Click OK.
15. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Use Cell Padding in a Report

You can customize the amount of space inserted between rows and columns in a report.

1. Open a report in Live Preview.
2. On the Layout tab, in the Report group, click Cell Padding, and then click Custom.
   The Cell Padding dialog box opens.
3. Type the cell padding values that you want in the Top, Bottom, Left, and Right fields.
4. Click OK.
   The report reflects the cell padding that you set.
The following image shows a report with custom cell padding.

**Quantity Sold by Product**

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>511,667</td>
</tr>
<tr>
<td>Camcorder</td>
<td>455,244</td>
</tr>
<tr>
<td>Computers</td>
<td>351,777</td>
</tr>
<tr>
<td>Media Player</td>
<td>771,934</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>1,114,332</td>
</tr>
<tr>
<td>Televisions</td>
<td>105,188</td>
</tr>
<tr>
<td>Video Production</td>
<td>199,749</td>
</tr>
</tbody>
</table>

**Changing a Field Format**

You can change the format of any field except a Sort field. You can change the format of measure fields, as well as any calculated fields. For more information, see *Binning* on page 163.

You can access the Field Format Options dialog box from the following locations:

- Define and Compute dialog boxes.
- Edit Format option when you right-click a measure in the Query pane (all modes), right-click a column in a chart, or a measure column in a report.
- Format group on the Field tab.
The Field Format Options dialog box enables you to choose from a variety of Field types. Display options are enabled based on the Field type you select. For example, the default Field type selection is Decimal. The first Display option, Currency Symbol, provides the following list of currency symbol options:

- None
- Floating Currency
- Non-floating Currency
- Fixed Euro symbol
- Floating Euro symbol
- Euro symbol on the right
- Fixed pound sterling sign
- Floating pound sterling sign
- Fixed Japanese yen symbol
- Floating Japanese yen symbol
- Fixed dollar sign
The default value for Currency Symbol is set to None, unless the Field Format dialog box was invoked when changing the format of a field that already contains a currency symbol from the Master File. Accordingly, the currency symbol will default to that which is defined in the Master File.

Charts work with floating currency symbols to allow the placement of the currency symbol to work within the different elements of the chart. In a chart, any fixed currency designations will automatically be presented with a floating currency symbol. Floating and fixed currency formats are supported for Reports only.

When working with charts, the axis label formats are defined separately from the field format. To set the format of the axis label, use the option in the Labels group on the Format tab. Click Axes, point to Vertical Axis, and click More Vertical Axis Options. In the Format Vertical Axis dialog box, click Labels, open the Format Labels drop-down menu, and select a currency format.

The following procedures show how to change a field format from the Field Format Options dialog box. For more information on how to use the Format group options, see Field Tab on page 42.

Procedure: How to Assign an Alphanumeric Format

1. With a report open in Live Preview, right-click a virtual field or column measure field, and select Edit Format.
   The Field Format Options dialog box opens.

2. From the Field type list, select Alphanumeric.

3. To assign a different length, specify a number between 1 and 4095 in the Total length field. The default value is 20.

4. Click OK to close the Field Format Options dialog box and return to the canvas.
   The new format appears in the previously selected column.

Procedure: How to Assign a Numeric Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and click Edit Format.
   The Field Format Options dialog box opens.
2. From the Field type list, click one of the following options:

- Floating Point (default length 7.2)
- Integer (default length 5)
- Decimal (default length 12.2)
- Packed (default length 12.2)

If the selected field matches the selected format type, its current length appears in the Field Length field. Otherwise, the default length appears in the Field Length field. The Decimals field shows the numbers of decimal places for Floating Point, Decimal, and Packed.

- To assign a different length, specify it in the Field Length field for format types as follows: 1-9 for Floating Point, 1-11 for Integer, 1-20 for Decimal, and 1-33 for Packed.

- To assign a different number of decimal places for Floating Point, Decimal, or Packed, specify the number in the Decimals field.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

The new format appears in the previously selected column.

**Procedure:** How to Assign a Date Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select Edit Format.

   The Field Format Options dialog box opens.

2. To assign a different date display format, select a date format from the Display options list.

   The default date display format is MDY.

3. Optionally, select a separator for the date format.

4. Click OK to close the Field Format Options dialog box and return to the canvas.

   The new format appears in the previously selected column.

**Procedure:** How to Assign a Date-Time Format

1. With a report open in Live Preview, right-click a virtual or column measure field, and select Edit Format.

   The Field Format Options dialog box opens.
2. To assign a different date-time format, select the date format you want to use from the Date Format list. Expand Year First, Month First, or Day First to see the available options.

3. Select a time format (if applicable) from the Time Format list.

   If you select the Time Only check box then you can only set a time format. Expand Hour First, Minute First, or Seconds First to see the available options.

   **Note:** These expansion options are only visible when you select Time Only.

4. Optionally select a separator for the date format.

   The default is /, but you can select . (period), - (hyphen), (space) or None.

5. Click the Use AM/PM check box if you are indicating a time format.

   The format of the time selection displays in the text box at the bottom of the dialog box. A preview displays in the Sample text box in the left pane, showing you the exact format of your time-based selection.

6. Click OK to close the Field Format Options dialog box and return to the canvas.

   The new format appears in the previously selected column.

**Procedure:** How to Add a Percent Sign to a Numeric Field

You can add a percent sign to the end of a numeric value (Decimal, Integer, Packed, and Floating Point formats). This numeric display option includes a percent sign along with the numeric data, but does not calculate the percent.

1. With a report open in Live Preview, right-click a virtual or column measure field, and select Edit Format.

   The Field Format Options dialog box opens.

2. From the Field type list, click a numeric value format (Floating point, Integer, Decimal, or Packed), and then select the Percent (%) check box.

3. Click OK to close the Field Format Options dialog box and return to the canvas.

   The new format appears in the previously selected column.

**Using Custom Reporting Features**

You can use the following custom features when creating reports.

- **Rank.** Inserts a ranking column for dimension and measure fields in a report. For more information, see How to Rank Fields in a Report on page 106.

- **Limit.** Limits the number of unique variables in a column. For more information, see How to Limit the Values of a Column in a Report on page 107.
3. Creating and Customizing Reports

- **Page Breaks.** Starts a new page in the output when the primary sort field changes. For more information, see *How to Add Page and Line Breaks to a Report* on page 107.

- **Line Breaks.** Inserts a line in the report output when the primary sort field changes. For more information, see *How to Add Page and Line Breaks to a Report* on page 107.

- **Subtotal.** Inserts subtotals in the output for all numeric fields when the primary sort field changes. For more information, see *How to Add Subtotals to a Report* on page 107.

- **Column Totals.** Inserts a grand total row at the bottom of the report to sum numeric data in each column. For more information, see *How to Add Column Totals to a Report* on page 108.

- **Row Totals.** Inserts a grand total column to the right side of the report to sum numeric data in each row. For more information, see *How to Add Row Totals to a Report* on page 108.

- **Sub Header.** Adds a subheading just below the column titles in the report output when the primary sort field changes. For more information, see *How to Add Subheadings and Subfootings to a Report* on page 108.

- **Sub Footer.** Adds a subfooting at the end of the data on each page of the report output when the primary sort field changes. For more information, see *How to Add Subheadings and Subfootings to a Report* on page 108.

- **Pop-up Titles.** Adds pop-up titles to report output when the mouse pointer hovers over a column title. For more information, see *How to Add Pop-Up Titles to a Report* on page 108.

- **Data Bars.** Adds data visualization bars to numeric data. For more information, see *How to Add Data Visualization Bars to a Report* on page 109.

- **Aggregation.** Displays numeric measure data or non-numeric dimension data using aggregation options other than the default of Sum for measures or Count for non-numeric measures. For more information, see *How to Display Numeric Measure Data Using Aggregation Options in a Report* on page 109 or *How to Display Aggregations on Dimension (Non-Numeric) Data* on page 186.

- **Repeat Sort Values.** Displays all repeated sort values instead of blanks after the first instance of a new sort value appears in the report. The default behavior is to display blanks after the first instance of a new sort value. For more information, see *How to Display Repeated Sort Values in a Report* on page 110.
Recompute. Recalculates the result of a Compute command. Recompute is similar to Subtotal in that it recalculates only at the specified sort break. For more information, see How to Recalculate the Result of a Compute Command on page 111.

Procedure: How to Rank Fields in a Report

You can add rank columns to the dimension and measure fields in a report by clicking the Rank button. You access the Rank button, on the Field tab, in the Sort group.

- Adding a rank column to a dimension field inserts a rank column immediately to the left of the field.

- Adding a rank column to a measure field creates a copy of the column as a dimension field and adds a rank column to the left of the new dimension field.

Note: The rank option can also be accessed by right-clicking a dimension or measure field and accessing the Rank option through the shortcut menu by clicking Sort and then Rank.

1. With a report open, in the Query pane, select a dimension or a measure field.

   The Field tab appears on the ribbon.

2. In the Sort group, click Rank.

   A rank column appears, as shown in the following image.

<table>
<thead>
<tr>
<th>RANK</th>
<th>Product Category</th>
<th>Gross Profit</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Accessories</td>
<td>$39,854,440.53</td>
<td>511,667.00%</td>
</tr>
<tr>
<td>2</td>
<td>Camcorder</td>
<td>$49,598,845.24</td>
<td>455,244.00%</td>
</tr>
<tr>
<td>3</td>
<td>Computers</td>
<td>$33,508,818.12</td>
<td>351,777.00%</td>
</tr>
<tr>
<td>4</td>
<td>Media Player</td>
<td>$55,832,578.36</td>
<td>771,934.00%</td>
</tr>
<tr>
<td>5</td>
<td>Stereo Systems</td>
<td>$86,181,070.52</td>
<td>1,114,332.00%</td>
</tr>
<tr>
<td>6</td>
<td>Televisions</td>
<td>$16,830,023.81</td>
<td>105,188.00%</td>
</tr>
<tr>
<td>7</td>
<td>Video Production</td>
<td>$17,947,619.62</td>
<td>199,749.00%</td>
</tr>
</tbody>
</table>

Note: The rank column can now be edited and formatted like any other column, with the following exceptions:

- The only formatting that can be applied is Traffic Light Conditions.

- It cannot be hidden.
You cannot insert breaks or a filter on the RANK column.

No column can be moved in between the rank column and the column it is ranking.

**Procedure:** How to Limit the Values of a Column in a Report

You can limit the number of unique values that appear in a column through the Limit menu. First, you must select a column, then the Limit menu becomes available on the **Field** tab, in the **Sort** group.

**Note:** You can also access the Limit option by right-clicking a column, pointing to Sort, and then selecting **Limit**.

1. With a report open, in the Query pane, select a dimension or measure field.
   
   The Field tab appears on the ribbon.

2. In the Sort group, enter a value in the Limit field, or select a value from the list. The number of unique values that appear in the column is now limited to the value that you set.

**Procedure:** How to Add Page and Line Breaks to a Report

You can add page breaks and line breaks to report output for the primary sort field.

1. With a report open, in the Query pane, select a dimension (sort) field.
   
   The Field tab appears on the ribbon.

2. From the Break group, click **Page Break** or **Line Break**.

**Procedure:** How to Add Subtotals to a Report

1. With a report open, in the Query pane, select a dimension (sort) field.
   
   The Field tab appears on the ribbon.

2. From the Break group, click **Subtotal**.

   If you select Page Break, a new page is created every time the value of the primary sort field changes. Each page includes a new set of column titles.

   If you select Line Break, a new divider line is inserted in the report output every time the value of the primary sort field changes.
Clicking Subtotal turns Subtotal on for all fields as a RECOMPUTE and inserts a line of descriptive text (*Subtotal **FIELD Value**). Clicking the down arrow launches a menu of options. From this menu, you can choose between Simple and Recomputed. Selecting More Options opens a dialog box from which you can choose which fields to subtotal, as well as what type of aggregation to do for those fields. You can also change the Subtotal text.

**Procedure:** How to Add Column Totals to a Report

On the Home tab, in the Report group, click Column Totals.

Clicking Column Totals adds a grand total row at the bottom of the report that sums numeric data in each column. Clicking the down arrow launches a menu of options. From this menu, you can choose between Simple and Recomputed. Selecting More Options opens a dialog box from which you can choose which fields to total, as well as what type of aggregation to do for those fields. You can also change the Current Total text.

**Procedure:** How to Add Row Totals to a Report

On the Home tab, in the Report group, click Row Totals.

Clicking Row Totals adds a grand TOTAL column to the right side of the report that sums numeric data in each row.

**Procedure:** How to Add Subheadings and Subfootings to a Report

You can add subheadings and subfootings to report output for the sort field.

1. With a report open, in the Query pane, select a dimension (sort) field.
   
   The Field tab appears on the ribbon.

2. From the Break group, click Sub Header or Sub Footer.

   The Sub Header & Sub Footer dialog box opens.

3. In the Sub Header & Sub Footer dialog box, type and style the text, and click OK.

   Subheadings appear just below the column titles in the report output every time the value of the primary sort field changes. Subfootings appear at the end of the data on each page of the report output every time the value of the primary sort field changes.

**Procedure:** How to Add Pop-Up Titles to a Report

On the Format tab, in the Features group, click Title Popup.
Clicking Title Popup displays a pop-up title when the mouse pointer hovers over any column title in the report, at run-time.

**Procedure: How to Add Data Visualization Bars to a Report**

You can add data visualization bars to the report output for a selected numeric data source field.

1. With a report open, in the Query pane, select a measure field.
   
   The Field tab appears on the ribbon.

2. In the Display group, click *Data Bars*.

   A data visualization column appears to the right of the selected numeric data source field to display values in each row. The column uses horizontal bars that extend from left to right and vary in length, depending on the corresponding data values.

**Procedure: How to Display Numeric Measure Data Using Aggregation Options in a Report**

You can display numeric measure data using a variety of aggregation type values other than the default of Sum.

1. With a report open, in the Query pane, select a measure field.
   
   The Field tab appears on the ribbon.

2. Access the Aggregation Functions menu by doing one of the following:

   - From the Display group, click *Aggregation*.
   
   or

   - Right-click the selected measure field, point to *More*, then *Aggregation Functions*, and choose one of the options. For example, First Value.

   If you change the Measure Query field container from Sum to Print, Count, or List, it overrides all assigned aggregation type values.

**Procedure: How to Access the Within Functionality**

You can use the Within functionality to apply specific aggregation tasks at different report levels.

1. With a report open, in the Query pane, select a numeric measure field.

   The Field tab appears on the ribbon.
2. On the Field tab, in the Display group, click Within.

Note: Depending on how your data is set up, you can apply the Within phrase on a By or Across field.

Optionally, you can access the Within functionality from the shortcut menus on the column level. You can also access these menus when you right-click a measure field in the Query pane.

3. On the Within menu, click the down arrow to select the Within phrase for the By or Across field.

4. Select a By field from the list of available fields.

The report automatically generates based on your selection.

Procedure: How to Display Repeated Sort Values in a Report

Run this procedure when the output format, Excel, for example, does not sort properly.

On the Format tab, in the Features group, click Repeat Sort Value.
When you click *Repeat Sort Value*, all repeated sort values appear in the report output. This option overrides the default behavior, which displays blanks after the first instance of each new sort value that appears in the report.

**Procedure: How to Recalculate the Result of a Compute Command**

For more information on the compute command, see *Creating Virtual Fields in TIBCO WebFOCUS* on page 427.

1. With a report open, in the Query pane, select a By (sort) field.
   - The Field tab appears on the ribbon.

2. You can recalculate the result of a Compute command in one of the following ways:
   - **Ribbon:** On the *Field* tab, in the *Break* group, open the Subtotal menu. On the menu, click *Recomputed*.
   - **Shortcut Menu:** Right-click a sort field, point to *Break*, then *Subtotal*, and then click *Recomputed*.

**Creating Customized Report Outputs**

You can create customized report outputs in InfoAssist. The standard output formats, which are found in the Format group on the Home tab, include: HTML, HTML Analytic Document, PDF, PDF Analytic Document, Excel, and PowerPoint. For charts, HTML5 is the default output format. For reports, you can also create the following custom report output formats from the Navigation group on the Format tab, including: Table, Table of Contents, Freeze, Pages on Demand, and OLAP.

- **Table.** Generates standard browser output. This is the default.
- **Table of Contents.** Generates output by displaying a table of contents icon in the upper-left corner where report output typically appears. Clicking *Table of Contents* opens a menu that enables you to select (view) individual values of the first Sort By (By) field, one value at a time.

  You can also select options to view the entire report or remove the table of contents. For more information, see *How to Create Table of Contents Reports* on page 112.

**Note:**

- The Table of Contents option is activated only when HTML, HTML Analytic Document, Excel, or PowerPoint output format is selected.
- You cannot use the Table of Contents option with the Accordion feature. For more information, see *How to Create Accordion Reports* on page 117.
Pages On Demand. Provides access to two distinct features depending upon the output type that you have selected.

HTML. If you select this output type, and click Pages On Demand, then the report opens in the WebFOCUS Viewer.

The WebFOCUS Viewer saves the bulk of your report to your web server and delivers one page of report output at a time, decreasing the amount of time that you wait for the report to process.

The bulk of your report remains on the web server until you request it or close the WebFOCUS Viewer.

The WebFOCUS Viewer menu bar, at the bottom of the Viewer, contains options for navigating through the pages. For more information on these options, see How to Create Pages On Demand Reports on page 115.

OLAP. To view output with OLAP functionality. For more information, see How to Create OLAP Reports on page 116.

Note: This functionality is disabled by default. It can be enabled in the WebFOCUS Administration Console. Contact your administrator for assistance.

Procedure: How to Create Table of Contents Reports

Note: You cannot use the Table of Contents with the Accordion feature.

1. Create a report.

2. On the Format tab, in the Navigation group, click Table of Contents.

When you run the report, a table of contents button appears in the top-left corner of the report output, as shown in the following image.

![Table of Contents](image)

3. Double-click the button to display the Table of Contents menu. The Table of Contents menu enables you to select and view individual values of the first sort (By) field, one value at a time.
Drag the Table of Contents menu in any direction to view the report output, which appears behind the menu by default.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Subcategory</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>Charger</td>
<td>105,257</td>
</tr>
<tr>
<td></td>
<td>Headphones</td>
<td>228,349</td>
</tr>
<tr>
<td></td>
<td>Universal Remote Controls</td>
<td>178,061</td>
</tr>
</tbody>
</table>

Select a sort field to view values for that field.
In the following example, clicking Stereo Systems displays the corresponding report output.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Subcategory</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stereo Systems</td>
<td>Boom Box</td>
<td>9,370</td>
</tr>
<tr>
<td></td>
<td>Home Theater Systems</td>
<td>399,092</td>
</tr>
<tr>
<td></td>
<td>Receivers</td>
<td>150,568</td>
</tr>
<tr>
<td></td>
<td>Speaker Kits</td>
<td>244,199</td>
</tr>
<tr>
<td></td>
<td>iPod Docking Station</td>
<td>311,103</td>
</tr>
</tbody>
</table>

You can also select options to view the entire report or remove the table of contents.

**Procedure:**  How to Freeze Column Titles in Reports

On the Format tab, in the Navigation group, click Freeze.

Column titles freeze (remain in view) when you scroll through pages of the report output.

**Note:** You must run the report in order to see the frozen column titles.
The following image shows the scroll bar that appears when you freeze column titles.

<table>
<thead>
<tr>
<th>Store Business Region</th>
<th>Product Category</th>
<th>Quantity Sold</th>
<th>Revenue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subtotal: EMEA</td>
<td></td>
<td>1,404,540</td>
<td>$422,745,677.92</td>
</tr>
<tr>
<td>North America</td>
<td>Accessories</td>
<td>293,461</td>
<td>$74,326,669.37</td>
</tr>
<tr>
<td></td>
<td>Camcorder</td>
<td>259,953</td>
<td>$88,243,858.49</td>
</tr>
<tr>
<td></td>
<td>Computers</td>
<td>214,049</td>
<td>$64,415,033.70</td>
</tr>
<tr>
<td></td>
<td>Media Player</td>
<td>435,684</td>
<td>$139,282,702.54</td>
</tr>
<tr>
<td></td>
<td>Stereo Systems</td>
<td>636,612</td>
<td>$166,530,524.29</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>56,161</td>
<td>$43,837,977.12</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>114,260</td>
<td>$33,280,088.15</td>
</tr>
<tr>
<td>Subtotal: North America</td>
<td></td>
<td>2,010,180</td>
<td>$609,916,853.66</td>
</tr>
<tr>
<td>Oceania</td>
<td>Accessories</td>
<td>592</td>
<td>$153,375.30</td>
</tr>
<tr>
<td></td>
<td>Camcorder</td>
<td>554</td>
<td>$155,222.60</td>
</tr>
<tr>
<td></td>
<td>Computers</td>
<td>526</td>
<td>$168,481.59</td>
</tr>
<tr>
<td></td>
<td>Media Player</td>
<td>984</td>
<td>$304,677.82</td>
</tr>
<tr>
<td></td>
<td>Stereo Systems</td>
<td>1,265</td>
<td>$330,054.74</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>94</td>
<td>$81,026.50</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>227</td>
<td>$60,468.74</td>
</tr>
<tr>
<td>Subtotal: Oceania</td>
<td></td>
<td>4,242</td>
<td>$1,260,307.29</td>
</tr>
</tbody>
</table>

**Procedure:** How to Create Pages On Demand Reports

This procedure describes using the Pages On Demand feature to create an HTML report.

1. Create a report.
   
   The default output is HTML.


3. Run the report.
   
   The report opens in the WebFOCUS Viewer.

4. Navigate through the report using the navigation options available on the WebFOCUS Viewer menu bar. For example, Go to the first page.
**Procedure:** How to Create OLAP Reports

1. On the **Format** tab, in the **Navigation** group, click the **OLAP Analysis** button, which enables the OLAP Analysis functionality.

2. On the **OLAP Analysis** button, click the down arrow.

   The OLAP Analysis menu displays. It contains the following options:

   - **OLAP panel accessible.** Select this option to access the OLAP panel in the output of the report at run-time. You can access the OLAP panel by clicking on one of the categories that displays at the top of the report.

   - **OLAP panel not accessible.** Select this option to only display sorting options in the column titles. The OCP (OLAP ribbon) cannot be accessed from the title options.

   - **Dimension filtering enabled.** Select this option to display dimension filters at the top of the report. You customize the filter placement within the Navigation dialog box. You access the dialog box by clicking **More options**.

   - **Dimensions grouped in tabs.** Select this option to group dimension filters in tabs based on hierarchy within statements in the metadata.

   - **More options.** Select this option to open the OLAP Analysis dialog box.

   In addition to the options discussed previously, the OLAP Analysis dialog box allows the following additional configuration and customization options for OLAP output:

   - **No OLAP.** Select this option to disable OLAP Analysis.

   - **OLAP panel is accessible.** Select this option to make the OLAP panel accessible. This option is selected by default.

   - **OLAP panel is not accessible.** Select this option to make the OLAP panel inaccessible.

   - **Hide access to the OLAP Panel.** Select this option to hide access to the OLAP panel.

   - **Dimension filtering enabled.** This option provides a secondary positioning option allowing placement of the filters on the Top (default) or Bottom of the report.

     **Note:** If the Dimension filtering enabled option is cleared at any time, the position option resets to Top.

   - **Auto drill options.** The auto drill options are:

     - **Dimensions.** Select this option to automatically drill down on dimensions in both reports and graphs.
Dimensions and Measures. (Default). Select this option to automatically drill down on dimensions in both reports and graphs and on measure fields in reports.

None. Select this option to disable automatic drill downs.

3. Select an option.

Selecting an option from the OLAP options group, such as OLAP panel accessible, generates output that invokes OLAP processing. The OLAP button displays below the report. When clicked, the OLAP Control Panel is launched.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Discount</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computers</td>
<td>$4,808,910.10</td>
<td>351,777</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>$13,530,873.57</td>
<td>1,114,332</td>
</tr>
<tr>
<td>Televisions</td>
<td>$3,635,693.38</td>
<td>105,188</td>
</tr>
<tr>
<td>Video Production</td>
<td>$2,695,890.76</td>
<td>199,749</td>
</tr>
</tbody>
</table>

Procedure: How to Create Accordion Reports

Note: You cannot use the Table of Contents in conjunction with the Accordion feature.

1. Create a report.
The following image shows a report before the accordion option is applied.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Store Region</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Media Player</td>
<td>EMEA</td>
<td>314,737</td>
</tr>
<tr>
<td></td>
<td>North America</td>
<td>435,684</td>
</tr>
<tr>
<td></td>
<td>Oceania</td>
<td>984</td>
</tr>
<tr>
<td></td>
<td>South America</td>
<td>20,529</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>EMEA</td>
<td>447,733</td>
</tr>
<tr>
<td></td>
<td>North America</td>
<td>636,612</td>
</tr>
<tr>
<td></td>
<td>Oceania</td>
<td>1,265</td>
</tr>
<tr>
<td></td>
<td>South America</td>
<td>28,722</td>
</tr>
<tr>
<td>Televisions</td>
<td>EMEA</td>
<td>45,714</td>
</tr>
<tr>
<td></td>
<td>North America</td>
<td>56,161</td>
</tr>
<tr>
<td></td>
<td>Oceania</td>
<td>94</td>
</tr>
<tr>
<td></td>
<td>South America</td>
<td>3,219</td>
</tr>
</tbody>
</table>

2. On the Format tab, in the Features group, click Accordion and then click Run.

Plus signs indicate that there are expandable views of data for each vertical sort field.

You can manually expand your view to expose the data.

**Procedure:** How to Implement Stack Measures

1. Create a report with at least two measure fields.
2. On the Format tab, in the Features group, click Stack Measures.

All measure fields in the report are stacked. For more information on Stacked Measures, see the Stacking Columns topic in the Creating Reports With TIBCO WebFOCUS® Language manual.
Chapter 4

Creating and Customizing Charts

InfoAssist enables you to easily create different types of simple and complex charts. You can select from a variety of chart types and output formats, and add custom features to a chart.

You can also create a chart from any existing report.

In this chapter:

- Visualizing Your Data With Charts
- Using Insight to Analyze Dynamic Charts
- Selecting a Chart Type
- Creating Charts
- Binning
- Accessing Chart Formatting Tools
- Formatting a Series

- Formatting Data Labels
- Formatting a Legend
- Formatting Gridlines
- Formatting Axis Labels
- Formatting a Frame and a Background
- Formatting a Gauge Chart
- Formatting Page Headings and Page Footings
- Using Additional Formatting Features
Visualizing Your Data With Charts

A chart often conveys meaning more clearly and effectively than data displayed in tabular form. A chart enables you to visually communicate quantitative information. On a chart, you can give data a shape and form, and reveal patterns and relationships among many data values. A chart can highlight anomalies that require further investigation. These are some things to consider when deciding between a report and a chart for your data.

### Using Insight to Analyze Dynamic Charts

In InfoAssist, you now have access to a number of visualization tools: Chart mode, Visualization mode, and Insight. Each tool offers different options for you as you visualize your data.

Insight is a new visualization tool that allows for the interactive selection of measures and dimensions, so you can create dynamic charts that refresh as you make changes. This feature is available in HTML5 Chart mode only.

With Insight, you can build a chart that shows the data fields that you choose in real-time. It even rebuilds as you select additional fields or specify filters.

Similar to Visualization mode in InfoAssist, you can make quick decisions regarding your data with Insight. Using logical menus and simple filtering, you can build charts interactively to suit your needs. As you select additional fields and create filters, your chart refreshes instantly, letting you see the results of your data choices as you use the tool.
In Visualization mode, you can create and work with multiple charts in a single visualization. All charts in the visual are linked to the same data source. You can use the filter prompts to narrow the data that displays.

Insight lets you build filters, as needed, to customize the data that displays. You can add and remove fields, at any time and in any pattern, to enhance your chart. You can take advantage of the customization options that are available to you right from the toolbar.

With Insight, the chart type determines the field containers that display. For example, if you are working with a pie chart, you can specify values for the following field containers: Measure, Rows, Columns, Color, and Size. In many cases, these field containers mirror the field containers that display when working with InfoAssist.

Available fields are organized into applicable Dimension and Measure categories. You can use the plus sign (+) to add additional fields to your chart. For example, if you want to create a bar chart that plots Gross Profit, Revenue, and MSRP for each Product Category, click the plus sign to add fields using the drop-down field selector. Once you choose the fields that you want to include, you can rearrange them by dragging and dropping them into the order that you prefer.

The resulting bar chart displays, as shown in the following image.
You can use the navigational arrows in the interactive header to move between the available field containers in your chart. The following image highlights these arrows, which shift the focus of these field containers to the right or left.

All charts support a field container for Color, which adds contrast to your chart. Some charts also support the Size field container, which binds a measure to the size of the markers rendered on the chart.

Once you have added fields to the relevant field containers, you can use the Sort arrows adjacent to each field to sort the data in ascending or descending order. This helps identify trends and priorities within your data. You can only sort one field at a time. Ascending order sorts your data from the smallest value to the greatest value, while descending order sorts your data from the greatest value to the smallest value, as shown in the following image.

When you select a sort order for a field, the field arrow changes color, appearing bolder than the unsorted fields. In the image below, a sort order was selected for MSRP, so the field arrow appears black.
You can specify measures and dimensions for your chart in InfoAssist before using Insight. This pre-loads the Insight user interface (UI) with those selections. Optionally, you can use Insight without selecting any fields. In this case, the field selection options are broad, meaning that all fields will be presented. An example of an empty canvas is shown in the following image.

---

**Procedure:** How to Enable Insight From InfoAssist

1. Open InfoAssist in Chart mode.

2. On the Format tab, in the Run with group, click the Insight icon.

3. On the Quick Access toolbar, click Run.

   The Insight interface opens, and you can begin building your chart.

**Working With Charts in Insight**

With Insight, you can choose individual fields for the field containers that you add. Whether you added fields into the Query pane before running Insight or you added fields to the existing field containers (or field containers that you add), creating a chart in Insight is streamlined to allow you to easily create a dynamic chart in real time. It also provides you with the flexibility of interactive comparison as you change your data selections rapidly and adjust the options for display.
You can use the default vertical bar chart or you can specify a different chart type using the Chart Picker in the Options toolbar.

In addition, you can re-order the display of field containers in your chart. This allows you to change the placement of a particular field, giving you control over where the data for this component displays in your chart.

**Procedure:** How to Create a Basic Bar Chart Using Insight

1. Click the plus icon under the Vertical Axis field container.
2. Choose a measure field from the drop-down list.
3. Click the plus icon under the Group field container.
4. Choose a dimension field from the drop-down list.

Your bar chart displays, as shown in the following image.

![Bar Chart Example](image)

**Procedure:** How to Change the Chart Type in Insight

1. On the Options toolbar, click Chart Picker.
The table of chart selections opens, as shown in the following image.

2. Select a chart type.

Your chart refreshes with the new chart type, and the Insight interface refreshes to display all of the field containers that are relevant to the current chart type.

Procedure: How to Delete a Field From a Field Container

1. Add one or more fields to your chart.
2. Hover over the field that you want to delete and click X, as shown in the following image.

The chart refreshes to reflect your selections.

Procedure: How to Reorder the Display of Field Containers

1. Add multiple fields to your chart, as shown in the following image.
2. In the Vertical Axis grouping, drag the second field container into the first position. The placement of the field is shown by a dark blue vertical bar, as shown in the following image.

The following image shows the newly ordered fields.

![Diagram showing the newly ordered fields.](image-url)
Searching for Fields

You can locate fields for your field containers using the search option. On the toolbar, click the plus sign. In the search field, start typing the field that you want to locate. You can type in whole words or partial words. The search identifies all fields that contain any instance of the characters that you specify, as shown in the following image.

![Search example](image)

Changing Summary Operators for the Field

When working with measure fields, you can change the summary operators for the field from Summary (default) to Average, Maximum, or Minimum. You can also change a Count field to Count Distinct, using a similar menu selection.
When you make a selection, the axis of the relevant measure updates in the chart, as shown in the following image.

Options for changing the Summary field are shown in the following image.
Filtering in Insight

To enable filtering, click the Show Filter icon , which is located in the Options section of the toolbar. This opens the filter shelf that renders above the field container shelf, as shown in the following image.

![Filter shelf image]

Use the filter shelf to build your filter. The filter shelf must be visible in order to add or modify a filter. In addition, filters that were created in a procedure (.fex) or InfoAssist session prior to launching Insight are applied, but do not show in Insight.
**Note:** As of Release 8.2 Version 03, query variables in Insight are available and functional on the Filter shelf. Typically, query variables display in the Data pane, above the measure fields. The filter values display as True or False, rather than one and zero. In addition, you can only select one value, as shown in the following image.

### Accessories

<table>
<thead>
<tr>
<th>All</th>
</tr>
</thead>
</table>

- Select all
- Clear

<table>
<thead>
<tr>
<th>True</th>
</tr>
</thead>
</table>
- False

### Types of Filters

There are different types of filters in Insight. For example, if you are filtering with a date field, you can use a built in calendar to select a date range, as shown in the following image.
If you are filtering on a numeric value, such as a measure value, you can filter on values that are specific to a field. In this scenario, when you define the filter, a slider control opens. You can adjust the range of values that you want to include, using the slider control options, as shown in the following image.

![Image of slider control for Cost of Goods]

You can also filter on dimension values. You can select one or more values by simply clicking on multiple values. A check mark appears, indicating the values selected, as shown in the following image.

![Image of checkmarks for Product Subcategory]
You can select all values for the dimension, select one or more, or clear all selected values, as shown in the following image.
Adding a Filter

You add a filter when you want to limit the display of your data, or drill down to focus on specific data values. For example, you may want to just display data for Camcorder and Televisions, rather than all Product Categories. You can do this by adding a filter for the Camcorder and Televisions, as shown in the following image.

![Image of a chart with filters applied]

**Procedure: How to Add a Filter in Insight**

1. In the Options toolbar, click *Show Filter*.
   
The filter shelf opens.
2. Click the Show Filter icon.
3. From the drop-down list that opens, select the field on which to filter.
4. Click the identified field in the filter shelf to specify a value for the filter.
   
   A list displays, showing the values that you can select.
5. Click on the filter shelf to save your filtered items.
   
   Your chart refreshes.
Removing a Filter

To remove a filter, hover over it and click on the X, as shown in the following image.

![Removing a Filter](image)

The chart refreshes and displays your data without any filter.

Using the Options Toolbar

The Options toolbar is located in the upper-right corner of the Insight interface. These options control your interactions with your data, including options such as pivoting and filtering. You can also change your chart type using the Chart Picker option.

Reference: Options Toolbar Icons

The following section describes the icons that display on the Options toolbar.

- **Reset**
  Returns the chart to its original state. Any filters, measures, dimensions that are added in the current Insight session are reverted. The chart type is reverted, as well.

- **Swap Axis**
  Swaps the x and y axis, placing the contents of the x axis on the y axis. You can click Swap Axis again to change the chart back to its original orientation.
Save
Saves the current Insight chart as a unique entry in the repository. When you click Save, you are presented with a list of folders. Navigation is limited to where you can save content. The default folder is your My Content folder. You can save the same Insight chart multiple times. Insight uses the same title and file name. You will then be prompted to overwrite the file.

Chart Picker
Provides options for selecting different chart types, including:

- **Horizontal Bar.** Offers the capability of ranking data in descending order. This chart type can also be used when x-axis labels are too long to fit legibly side-by-side. The following field containers are available for this chart type: Horizontal Axis, Group, and Color.

- **Vertical Bar.** Shows different measures per dimension component using different identifying colors. The following field containers are available for this chart type: Vertical Axis, Group, and Color.

- **Vertical Stacked Bar.** Stacks values per dimension component using differentiating colors. The following field containers are available for this chart type: Vertical Axis, Group, and Color.

- **Pie.** Presents values as part of a whole using colors to separate the segments. Pie charts emphasize where your data fits in relation to the larger whole. The following field containers are available for this chart type: Rows, Columns, Measure, Color, and Size.

- **Vertical Line.** Creates a line chart which is representative of the data. Line charts are useful for showing trends in numerical data. The following field containers are available for this chart type: Vertical Axis, Group, and Color.
Area. Creates an area chart which is similar to a line chart except the area between the data line and the zero line (or axis) is usually filled with color. The following field containers are available for this chart type: Vertical Axis, Group, and Color.

Scatter. Plots data using variable scales on both axes. The following field containers are available for this chart type: Rows, Columns, Vertical Axis, Horizontal Axis, Size, Detail, and Color.

Note: When working with Insight Scatter or Bubble Charts, the "Show Datalabels" ability is tied to the Size bucket. Therefore, you will only see datalabels if there is a measure in the Size field container.

Circle. Plots differing values in rows, enabling you to draw inferences as to how the values overlap. The following field containers are available for this chart type: Rows, Columns, Vertical Axis, Horizontal Axis, Size, Detail, and Color.

Treemap. Displays large amounts of hierarchically structured data. This chart type uses sections to represent an aspect of the selected measure. The following field containers are available for this chart type: Grouping, Size, and Color.

Histogram. Analyzes the distribution of a measure while assigning it to field containers based on the values you specify for the bins that are created. The default bin count is 10. The following field containers are available for this chart type: Rows, Columns, and Measure.

Table. Presents data in tabular form, allowing you to compare various intersections in your data. The following field containers are available for this chart type: Rows, Columns, and Measure.

Matrix. Analyzes one or two measures against a crosstab of two categorical dimensions. The following field containers are available for this chart type: Rows, Columns, Size, and Color.
Point Map. Uses symbols of different sizes to represent data associated with different areas or locations within the map. The following field containers are available for this chart type: Layer, Size, and Color.

Choropleth Map. Visualizes location-based data, trends, and distributions across a geographic area. These maps are geographically-based heat maps. The following field containers are available for this chart type: Layer and Color.

Note: The orientation of this chart icon changes if you swap an axis. In addition, the image that displays for the chart type changes, based on your selection.

Show Filter
Defines filters for your data. Select this icon, and using the filter shelf that opens above the field container shelf, click the Show Filter icon to define a filter. For more information, see Filtering on page 141.

Note: To select one or more non-consecutive values, select each field. The selected values will display with a check mark to indicate that they have been selected.

More Options
Opens the following additional options:

- Export Data. Exports the underlying data of the current chart to an Excel file in LOCAL file storage. You will be alerted when the file appears in the bottom left corner, similar to any other file that you download.

- Export Image. Generates an image of the current chart, which is saved in PNG format to LOCAL file storage using the current width and height of the browser window.

- Series Layout. The bar, line, and area charts in Insight support several different sub-graph types (aka Layout). The supported graph types include: horizontal bar, vertical bar, vertical stacked bar, line, and area charts. For bar, line, and area charts, the Series Layout Options are as follows:

  - Horizontal Bar: Stacked, Absolute, Percent, Side-by-Side
  - Vertical Bar: Stacked, Absolute, Percent, Side-by-Side
  - Vertical Stacked Bar: Stacked, Absolute, Percent, Side-by-Side
  - Line: Stacked, Absolute, Percent
Vertical Stacked Area: Stacked, Absolute, Percent

Y-Axis Log Scale. Adjusts the log scale on the y axis. This option is always unchecked, by default. The following chart types are supported:

- Horizontal Bar
- Vertical Bar
- Vertical Stacked Bar
- Line
- Area charts
- Scatter charts
- Bubble
- Circle
- Histogram

X-Axis Log Scale. Adjusts the log scale on the x axis. This option is always not selected, by default. The following chart types are supported:

- Scatter
- Bubble

Change Bin Size. Changes the size of the bin (numeric value only). This option is only available for histograms. Clearing the text box switches it back to automatic bin size generation.

Show Data Label. Turns numeric Data labels on/off on all charts, except Grids. The default for this setting is always Off except for Treemaps.

Show Totals. Turns the Summary Row Total on Data Grid on or off. The default for this setting is always False.

Marker Shape. Changes the marker shape used in the matrix marker chart. Options include: Circle, Square, or Fill.
Using Insight in Phone Mode

Phone mode, which is available in Insight, allows you to take advantage of the features of Insight on your phone. The interactive heading that is available in Insight on a tablet or desktop is replaced by a static heading that displays the field names in the chart, in blue text. These become summary fields that allow you to see what fields are included in the chart.

Insight is mobile aware and mobile friendly. Full functionality is available on tablet devices and other high-resolution touch displays. On smaller devices, such as an iPhone, Insight enters a special phone mode which has a useful, but more limited, set of options and features that are tuned for the small screen real-estate of the device. In this mode, you can add or modify filters to narrow your data as needed. You can also hover over data points to see the underlying data.

Measures are shown first. The first measure displays with a summation attribute (for example, Sum or Avg) and then displays of and then the name of the measure, as shown in the following image.

In the above image, area one is the static heading. Area two marks the filtering side option button. Lastly, area three shows the body of the chart.
Numeric measures are displayed after the measures in the order of Y-Axis and then X-axis. If you define fields in your Grouping field container, they display after the collective measures and are preceded by the word *by*. If you have created a matrix marker chart, the relevant field containers for these display next. They also use the word *by*, as do any Detail field containers that are populated in the chart. If your chart specifies a field for color, Phone mode precedes the display of this item with *color by*. Lastly, if you have populated the Size field container, this displays last and is introduced by *size by*.

**User Options in Phone Mode**

You have a number of options in Phone mode, including robust filtering and hover capabilities.

**Filtering**

In Phone mode, you can filter just like in regular desktop mode. The primary difference is that the filter shelf stacks the available filters in a vertical row, as shown in the following image.

![Filter Shelf Example](image)

You click the filter icon to bring up the filter shelf and then you click the X to close it. If you have defined filters, closing the filter shelf merely collapses it. The filters that you defined remain intact. To remove a filter, hover over it and click the X in the upper-right corner.
General Usability

Phone mode allows you to view your chart and filter it to refine it based on your own unique scenario.

You can hover over a data bar a segment of a chart to obtain additional, detailed information from the underlying data. The tooltips that display are based on your data selections.

You can also show and hide the legend using the right arrow above the legend. When you collapse the legend, you can see more of your chart.

The opportunities for dynamic charting are vast with Insight. Using dynamic menus, filtering options, and search features, you can quickly and effectively create charts that communicate your data.

Selecting a Chart Type

InfoAssist provides a complete chart library of both basic and advanced charts. You can choose from a wide variety of charts to best represent the data that you want to display.

It is important that you choose a chart that is appropriate for your data. When working with chart types in the Other category, which is available in the Chart Types group on the Format tab in Chart mode, you can quickly access a description for each chart, simply by hovering over the chart type with your mouse in the Select a chart dialog box. This facilitates quick identification of the relevant chart type, making it easy to create the right type of chart based on your data.

Note:

- To change the chart type of a migrated chart procedure that contains bar, line, or area charts, click the Type button on the Series tab, instead of the Format tab.

- As of Release 8.2 Version 02, the new chart attribute syntax has been applied to the following chart types: Dual Bar and Line, Tag Cloud, Streamgraph, Mekko, Funnel, and Pyramid. In InfoAssist, specific field containers display for each chart type. For more information on the underlying syntax used to create each chart type, see the Creating HTML5 Charts With TIBCO WebFOCUS® Language manual. For information on the field containers for charts, see Field Containers for Charts and Visualizations on page 57.

Bar Charts

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or variable measure fields that appear along the axis). The length of a bar corresponds to a value or amount. You can clearly compare data series (fields) by the relative heights of the bars. Use a bar chart to display the distribution of numerical data. You can create horizontal and vertical bar charts.
Note:

- If you are working with a large dataset, you can enable the display of a scroll bar under your chart, allowing you to easily scroll through your data from left to right. If you want to enable, disable or re-enable scroll bars, click the Format tab and then click Interactive Options. In the Interactive Options dialog box, select the Auto Enable X-Axis Scrolling check box.

- When working with stacked bar charts in either Chart or Visualization mode, borders can be enabled to show each series or measure in the chart. When enabled, the borders outline each measure in a stacked bar chart. This allows you to differentiate between the measures when they are displayed using the same color on a riser.

You can specify a border for all series in the Style dialog box, which is accessible from the Series tab.

**When to use:** Use a bar chart when individual values are important. For example, a basic vertical bar chart can compare the individual products sold to the total amount in sales for each product. A retailer would find it important to know which pieces of inventory are selling and how much revenue each item is generating for the company.

The following image is an example of a bar chart showing gross profit and quantity sold by product category.
A horizontal bar chart becomes useful when you want to emphasize a ranking relationship in descending order, or the X-axis labels are too long to fit legibly side-by-side. For example, a basic horizontal bar chart can rank in descending order which products are generating the most revenue for the retailer.

**Bar Chart Types**

The following table lists the available bar chart types.

<table>
<thead>
<tr>
<th>Available Bar Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Clustered Bar</td>
</tr>
<tr>
<td>Vertical Stacked Bar</td>
</tr>
<tr>
<td>Vertical Dual-Axis Clustered Bar</td>
</tr>
<tr>
<td>Vertical Dual-Axis Stacked Bar</td>
</tr>
<tr>
<td>Vertical Bi-Polar Clustered Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Bar</td>
</tr>
<tr>
<td>Vertical Histogram</td>
</tr>
<tr>
<td>Vertical Waterfall</td>
</tr>
<tr>
<td>Vertical Multi-3Y Bar (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Multi-4Y Bar (Not in HTML5)</td>
</tr>
</tbody>
</table>

**Pie Charts**

A pie chart is a circular chart that represents parts of a whole. A pie chart emphasizes where your data fits, in relation to a larger whole. Pie charts work best when the data consists of several large segments. As a best practice, limit your pie chart to five measure fields. Too many measure fields can divide a pie into many thin components that could become difficult to see. Use color on individual segments to create visual contrast.
In addition, you can add one or more measures to the Measure field container. Each measure will be used to create a separate, unique pie chart, to which you can add a measure or dimension to the Color field container to add color to your chart.

**Note:**

- When working with pie charts, you can add one measure field to the Color field container. This adds the measure as a By field, and determines how the pie chart is colored. Depending on your measure data, this may result in a large number of pie segments.

- You cannot plot negative data on a pie chart.

**When to use:** Use a pie chart when you have several large segments of data that you want to display as a whole.

For example, the following image is a pie chart showing the product revenue by sale quarter.

**Pie Chart Types**

The following table lists the available pie chart types.
**Available Pie Chart Types**

<table>
<thead>
<tr>
<th>Multi Pie</th>
<th>Multi Ring Pie</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi Proportional Pie (Not in HTML5)</td>
<td>Multi Proportional Ring Pie (Not in HTML5)</td>
</tr>
<tr>
<td>Single Pie</td>
<td>Single Ring Pie</td>
</tr>
<tr>
<td>Pie-Bar (Not in HTML5)</td>
<td>Ring Pie-Bar (Not in HTML5)</td>
</tr>
</tbody>
</table>

**Line Charts**

Line charts are useful for emphasizing the movement or trend of numerical data over time. They allow you to trace the evolution of a data point by working backwards or interpolating. Highs and lows, rapid or slow movement, or a tendency towards stability are all types of trends well suited to a line chart.

You can also plot line charts with two or more scales to present a comparison of the same value, or set of values, in different time periods.

**Note:** If you are working with a large dataset, you can enable the display of a scroll bar under your chart, allowing you to easily scroll through your data from left to right. If you want to enable, disable or re-enable scroll bars, click the Format tab and then click **Interactive Options**. In the Interactive Options dialog box, select the **Auto Enable X-Axis Scrolling** check box.

**When to use:** Use a line chart when you want to trend data over time. For example, monthly changes in employment figures, or yearly sales of an item in your inventory.
For example, the following image is a line chart that traces product revenue over a four-year period.

Radar charts are essentially analogous to line charts, except that the scale wraps around. Radar charts compare two or more data sets. They work well with data that is cyclical, such as the months of a year. A radar line chart is available in the line chart category, and a radar area chart is available in the area chart category. You can use axes or polygons to represent values in a star or spider configuration.

**Line Chart Types**

The following table lists the available line chart types.

<table>
<thead>
<tr>
<th>Available Line Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Absolute Line</td>
</tr>
<tr>
<td>Horizontal Absolute Line</td>
</tr>
<tr>
<td>Vertical Stacked Line</td>
</tr>
<tr>
<td>Horizontal Stacked Line</td>
</tr>
<tr>
<td>Vertical Dual-Axis Absolute Line</td>
</tr>
<tr>
<td>Horizontal Dual-Axis Absolute Line</td>
</tr>
</tbody>
</table>
## Available Line Chart Types

<table>
<thead>
<tr>
<th>Vertical Dual-Axis Stacked Line</th>
<th>Horizontal Dual-Axis Stacked Line</th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Bi-Polar Absolute Line (Not in HTML5)</td>
<td>Horizontal Bi-Polar Absolute Line (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Line (Not in HTML5)</td>
<td>Horizontal Bi-Polar Stacked Line (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Line</td>
<td>Horizontal Percent Line</td>
</tr>
<tr>
<td>Radar Line</td>
<td></td>
</tr>
</tbody>
</table>

## Area Charts

Area charts are similar to line charts except that the area between the data line and zero line (or axis) is usually filled with color. Area charts allow you to stack data on top of each other. Stacking allows you to highlight the relationship between data series, showing how some data series approach a second series.

**Note:** If you are working with a large dataset, you can enable the display of a scroll bar under your chart, allowing you to easily scroll through your data from left to right. If you want to enable, disable or re-enable scroll bars, click the Format tab and then click *Interactive Options*. In the Interactive Options dialog box, select the *Auto Enable X-Axis Scrolling* check box.
**When to Use:** Use an area chart when you want to distinguish the data more dramatically by highlighting volume with color. For example, the following image is a stacked area chart depicting the gross profit, revenue, and quantities sold for products over a three-year time period.

![](image.png)

**Area Chart Types**

The following table lists the available area chart types.

<table>
<thead>
<tr>
<th>Available Area Chart Types</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Vertical Absolute Area</td>
<td>Horizontal Absolute Area</td>
</tr>
<tr>
<td>Vertical Stacked Area</td>
<td>Horizontal Stacked Area</td>
</tr>
<tr>
<td>Vertical Bi-Polar Absolute Area (Not in HTML5)</td>
<td>Horizontal Bi-Polar Absolute Area (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Bi-Polar Stacked Area (Not in HTML5)</td>
<td>Horizontal Bi-Polar Stacked Area (Not in HTML5)</td>
</tr>
<tr>
<td>Vertical Percent Area</td>
<td>Horizontal Percent Area</td>
</tr>
</tbody>
</table>
Scatter Charts

Scatter charts enable you to plot data using variable scales on both axes. When you use a scatter chart, the data is plotted with a hollow marker, so that you can visualize the density of individual data values around particular points, or discern patterns in the data. A numeric X axis, or sort field, always yields a scatter chart, by default, however you can optionally specify a non-measure (dimension) field on either the vertical or horizontal axis. You can also specify a non-measure field on both axes, which results in a vertical display of your dimension data.

If your chart reveals clouds of points, there is a strong relationship between X and Y values. If data points are scattered, there is a weak relationship, or no relationship.

**When to use:** Use a scatter chart when you want to determine patterns in your data.

The following image is a scatter chart that shows gross profit and MSRP data for product categories.
Multi-Axis Charts

Bar, line, and area chart types have multi-axis options, such as dual-axis charts and multi-Y charts, where you can compare one X-axis value to several Y-axis measure fields.

InfoAssist allows you to assign each individual series to the Y1 through Y5 axis. For more information, see *How to Create a Dual-Axis Chart* on page 161.

**When to use:** Use a multi-axis chart when you want to plot values on an additional axis, or multiple axes, to compare multiple sets of data that are on different scales.

For example, the following image is a dual-axis bar chart that shows the revenue and MSRP by store type over a four-year time period.

![Dual-axis bar chart](image)

XY Plot Charts

An XY plot chart depicts the relationships among the numeric values in several data series. It plots two groups of numbers, where for every X value, there is a corresponding Y value. This results in a single point of XY coordinate.
When to use: Use XY plot charts when you have two sets of numbers to compare and want to perform trend analysis.

- **Scatter.** Scatter charts show a relationship between X and Y values. They compare two sets of numbers at once, possibly revealing patterns and trends.

  You can plot data using variable scales on both axes. When you use a scatter chart, the data is plotted with a basic line pattern so that you can visualize the density of individual data values around particular points, or discern patterns in the data. A numeric X axis, or sort field, always yields a scatter chart by default.

  If your chart reveals clouds of points, there is a strong relationship between X and Y values. If data points are scattered, there is a weak or no relationship.

  Scatter charts share many of the characteristics of basic line charts. Scatter charts and line charts are distinguishable from one another only by virtue of their X-axis format. Line charts can appear without connecting lines, making them look like scatter charts, and scatter charts can appear with connecting lines, making them look like line charts.

- **Polar.** A polar chart is a circular chart. Data is displayed on a polar chart in terms of values and angles. Polar charts share characteristics with scatter charts. Only one column field is allowed, in the following order: X (degree) for the column field, and Y (distance from the center) for the Across or By field.

- **Bubble.** A bubble chart is a chart in which the data points are represented by bubbles. Bubble charts can have two column fields representing X and Y data values, or have three column fields representing X, Y, and Z data values, in that order. The third variable (Z) represents size. The size of each bubble is used to show the relative importance of the data.

  **Note:** You can specify a non-measure (dimension) data field on the horizontal or vertical axis, or both.

### XY Plot Chart Types

The following table lists the available XY plot chart types.

<table>
<thead>
<tr>
<th>Available XY Plot Chart Types</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>XY Scatter</td>
<td>XY Polar</td>
</tr>
<tr>
<td>Bubble</td>
<td></td>
</tr>
</tbody>
</table>
3D Charts

A 3D chart uses three axes, X, Y, and Z to display data from two or more data sets so that trends are most apparent.

**When to use:** Use a 3D bar chart when you want to look at the general shape of the data, but add visual depth to a chart presentation. A 3D chart would not be a good choice for presenting exact values, since it is difficult to determine values in a 3D chart.

**Note:** When working with charts in HTML5 format, the 3D Effect option is not supported.

The following image is a 3D chart that shows the revenue for products categories over a four-year time period.

![3D Chart Example](image)

### 3D Chart Types

The following table lists the available 3D chart types.

<table>
<thead>
<tr>
<th>Available 3D Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>3D Bar</td>
</tr>
<tr>
<td>3D Octagon (Not in HTML5)</td>
</tr>
<tr>
<td>3D Floating Cubes (Not in HTML5)</td>
</tr>
<tr>
<td>3D Pyramid (Not in HTML5)</td>
</tr>
<tr>
<td>3D Cylinder (Not in HTML5)</td>
</tr>
<tr>
<td>3D Floating Pyramids (Not in HTML5)</td>
</tr>
</tbody>
</table>
Available 3D Chart Types

| 3D Connected Series Area          | 3D Connected Series Ribbon          |
| 3D Connected Group Area           | 3D Connected Group Ribbon           |
| 3D Cone (Not in HTML5)            | 3D Sphere (Not in HTML5)            |
| 3D Surface                        | 3D Surface with Sides (Not in HTML5) |
| 3D Smooth Surface (Not in HTML5)  | 3D Smooth Surface with Sides (Not in HTML5) |
| 3D Honeycomb Surface (Not in HTML5)|                                        |

Stock Charts

Stock charts track the trend of a particular stock. They show the trading volume of the stock, its opening and closing values, and its high and low values over a specific time period. The data is represented by sets of bars or lines.
Stock Chart Types

The following table lists the available stock chart types.

<table>
<thead>
<tr>
<th>Available Stock Chart Types</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stock Hi-Lo (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo with Volume (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo Open-Close (Not in HTML5)</td>
</tr>
<tr>
<td>Stock Hi-Lo Open-Close with Volume (Not in HTML5)</td>
</tr>
<tr>
<td>Open-Hi-Lo-Close Candle Stock</td>
</tr>
<tr>
<td>Open-Hi-Lo-Close Candle Stock with Volume (Not in HTML5)</td>
</tr>
</tbody>
</table>

Special Charts

Special charts include a variety of additional chart types.

- **Gauge.** A gauge chart indicates the current position of a single data value within a given spectrum. This chart has a circular shape.

- **Gauge Thermometer.** A gauge thermometer chart indicates the current position of a single data value within a given scale. This chart has the shape of a thermometer. It is not available in HTML5.

- **Pareto.** A Pareto chart uses the X axis to show group members, and the Y axis to show the percent of the total of all groups that each group represents. This chart highlights the differences between groups of data.

- **Vertical Box Plot.** A vertical box plot is oriented vertically, and shows the distribution of data through five-number summaries: Upper limit, Upper Quartile, Median, Lower Quartile, and Lower Limit. This chart can be represented with or without outliers, also known as whiskers.

- **Horizontal Box Plot.** A horizontal box plot is oriented horizontally, and shows the distribution of data through five-number summaries: Upper limit, Upper Quartile, Median, Lower Quartile, and Lower Limit. This chart can be represented with or without outliers, also known as whiskers.

- **Funnel.** A funnel chart is essentially a pie chart, displaying only one group of data at a time, from the first series to the last series at the bottom of the funnel.

- **Pyramid.** A pyramid chart is essentially a pie chart, displaying only one group of data at a time, from the first series to the last series at the top of the pyramid.
Spectral Map. A spectral map contains a row or column matrix of markers that are displayed in different colors, according to the data values.

HTML5 Charts

The following HTML5 charts are available:

Parabox. Parabox charts are used to visualize and analyze multivariate data. In a typical scenario, hundreds of possible outcomes can be compared by filtering along any dimension.

Mekko Chart. Mekko charts compare two related variables by percent of total and magnitude. They are popular in business and marketing.

Streamgraph. Streamgraph charts are typically used to illustrate how data has changed over time. They resemble a stacked area chart. However, the x-axis is not fixed. Streamgraphs are commonly used to illustrate trends in the Social Media arena.

Tag Cloud. Tag Cloud charts display the most prominent terms in a visual representation for text data. They are noted for their quick display of relevant information, allowing you to make quick decisions and narrow your search for terminology. Tag Cloud charts are typically used to depict keywords on websites or to visualize free form text.

Treemap. Treemap charts are used to display large amounts of hierarchically structured data. In a sectioned format, each rectangle represents an aspect of the selected measure. When a second measure is indicated, color coding is applied, emphasizing the unique sections of the treemap.

Grid. Grids present data in tabular form. For example, in Chart mode, you can use the Grid chart type to create a table that summarizes your data. This option is also available in Visualization mode.

Combination Charts

A combination chart displays multiple series using two or more different types of data graphics from a bar, line, or an area chart. Combining these charts improves clarity in the presentation of your data, and highlights the relationship between various data sets on one graph. This combination chart is referred to as a mixed, composite, or overlay graph.
When to use: For example, a retailer might want to combine a vertical bar chart that shows revenue and discount with an area chart that shows cost of goods.

Maps

InfoAssist maps use Geographic Information System (GIS) capabilities to convert data values into maps that can be used for visualizing patterns or trends. This allows you to display your underlying data regionally. More specifically, data that is bound to a geo-location, such as State, Country, and ZIP Code, can be viewed as symbol layers integrated into a powerful map viewer.

InfoAssist maps also utilize the robust mapping capabilities of Esri, a mapping engine that enables the display of layered maps with extensive detail and topography.

The mapping functionality supports a variety of popular formats, such as bubble markers and heat-filled polygons (also known as choropleths). These map formats are described below.

- **Choropleth.** A geographically-based heat map. It is useful for visualizing location-based data, trends, and distributions across a geographic area.

- **Proportional Symbol (Bubble).** A technique that uses symbols of different sizes to represent data associated with different areas or locations within the map.
**When to use:** The mapping functionality enables business users to make informed decisions. They can also visualize patterns, trends, and relationships related to the location information in their data.

For information on maps, see *Creating Maps to Illustrate Trends* on page 381.

**Creating Charts**

On the *Format* tab, the *Chart Types* group provides buttons for each of the five most commonly-used chart types. These include Bar (default), Pie, Line, Area, and Scatter. You also have access to Esri Choropleth and Proportional Symbol maps. A button labeled Other gives you access to the complete chart library of advanced charts, including Lightweight (Leaflet) maps. For more information, see *Creating and Customizing Maps in InfoAssist* on page 388.

The Chart Types group is shown in the following image.

![Chart Types](image)

**Note:** For more information on how to invoke the version of InfoAssist that you are using, please see *Introducing InfoAssist* on page 15.

When switching between chart formats that use a different syntax, you are prompted with a message that allows you to proceed with the change, or cancel your request. This message is shown in the following image.

![Chart Attributes Modified](image)

On the Chart Attributes Modified dialog box, you can click Yes to accept the changes or click No to save the changes to a different file and preserve the originating procedure (.fex).
**Procedure:**  How to Create a Basic Chart

You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want to create. Bar chart is the default.

   The chart appears on the canvas.

2. Populate the chart with your data in one of the following ways:
   - Drag the dimension fields and measure fields onto the chart.
   - Drag the dimension fields and measure fields into the appropriate Query field containers in the Query pane.

**Procedure:**  How to Create an Advanced Chart

You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click Other.

   The Select a chart dialog box opens. The chart types, depicted by icons, display on the left side of the dialog box.

2. To display the name of a chart type, hover over the chart type with the mouse.

   From top to bottom, the chart type categories are Bar, Line, Area, Pie, XY Plots, 3D, Stock, Special, HTML5, Map, and HTML5 Extension.

   **Note:**

   - For streamgraphs, which are in the HTML5 category, the tooltip has been enhanced to display specific information, by data point, depending on the underlying data source.

   - HTML5 Extensions are chart types developed outside of WebFOCUS and made available to InfoAssist. They display when they are set up according to the Adding Your Own Chart Types to the Chart Library chapter in the Creating HTML5 Charts With TIBCO WebFOCUS® Language manual.

3. In the left pane, click a chart type.

   All supported variations of the chart type appear as thumbnail images in the dialog box.

4. Click an image to display a detailed description of that chart type.
If you are not familiar with a chart type, be sure to read the description carefully before finalizing your selection. Some chart types require a certain number of data values, or a certain type of data values. If your data does not satisfy the requirements, the chart will not accurately represent the data.

In the following image, the Pie chart type is selected. To the right, the dialog box displays thumbnail images of the chart variations that are supported. Once a selection is made, a description for that chart appears underneath.

You can also hover over an image with your mouse to display the chart type name.

5. In the Select a chart dialog box, click OK to finalize your selection and close the dialog box.
6. Populate the chart with your data in one of the following ways:
   - Drag the dimension fields and measure fields onto the chart.
   - Drag the dimension fields and measure fields into the appropriate Query field containers in the Query pane.

**Procedure: How to Create a Combination Chart**

You can run this procedure in Query Design view or Live Preview.

1. On the **Format** tab, in the **Chart Types** group, click the button of the chart that you want to create. Bar chart is the default.
   The chart appears on the canvas.

2. Populate the chart with your data in one of the following ways:
   - Drag the dimension fields and measure fields onto the chart.
   - Drag the dimension fields and measure fields into the appropriate Query field containers in the Query pane.

3. Change a series type in one of the following ways:
   - **Ribbon:** On the **Series** tab, in the **Select** group, select the series that you want to display in a different chart type. Then, in the Properties group, from the Type drop-down menu, select the chart type.

   - **Shortcut Menu:** On the canvas, right-click the series that you want to display in a different chart type, point to **Series Type**, and click the chart type.
     The series appears in the new chart type.

**Procedure: How to Create a Dual-Axis Chart**

When you create a dual-axis chart, you assign one data series to the Y1 axis and another data series to the Y2 axis.

**Note:** This applies to charts in HTML format. If you are creating a dual-axis chart in HTML5 format, the field containers are labeled Vertical Axis 1 and Vertical Axis 2. If your chart is horizontal, the field containers are labeled Horizontal 1 and Horizontal 2.

1. Create a chart.

2. On the **Format** tab, in the **Chart Types** group, click **Other**.
   The Select a chart dialog box opens.
3. Select a dual-axis chart, such as dual-axis bar, and then click OK.
4. Drag one field onto the Y1 field, and then drag another field onto the Y2 field.

**Procedure: How to Create a Multi-Axis Chart**

When you create a multi-axis chart, you assign one data series to the Y1 axis and another data series to the Y2, Y3, Y4, and Y5 axes (as needed).

**Note:** This procedure is specific to HTML format.

1. Create a chart.
2. On the **Format** tab, in the **Chart Types** group, click **Other**.
   
   The Select a chart dialog box opens.
3. Select a multi-axis chart, and then click **OK**.
4. Drag fields into the Y1, Y2, Y3, Y4, and Y5 fields, as needed.

**Chart Outputs**

You can create charts using one of the following output formats:

- HTML
- HTML5 (default)
- HTML Analytic Document
- PDF
- PDF Analytic Document
- Excel
- PowerPoint

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript engine. Charts with this output format utilize the very latest capabilities of the HTML5 Web standard, including animation, high-quality vector output, and attractive alpha-channel and gradient effects.

**Note:** Not every chart type can be output in every format listed here. To make sure that the chart that you are creating can be output in the format that you want, please see the topic for that particular chart type.
Binning

Binning is a powerful tool for analyzing your data using ranges that you define.

Binning enables you to determine the frequency of values across the entire range of values. It is used for analyzing a frequency distribution. With binning, you can create discrete buckets of continuous data that control how groups of your data display. In addition, binning gives you the ability to review trends and spot outliers.

For example, you can review the range of expenses incurred by households. In the following example, these ranges are represented by bins that are grouped by $1000. In this case, you can see that the largest number of households had the smallest expense (16) while the trend declines as the bin size gets larger. With binning, you can see the frequency of how often values in a range appear across the different groupings, as shown in the following image.

In InfoAssist, bins are automatically created for Histograms. You can change the size of your bins to meet the requirements of your data. For example, if your data has very large values (for example, in billions) you might want to create larger bins. You can also create bins manually in Vertical bar charts and reports.

**Note:** When creating a bin, the format of the bin and the value set for the Width of Bins must be compatible. If the Width of Bins is a large decimal value, define the field format to match the format of the field being converted so that the bins can be successfully generated with the appropriate numeric precision.

Binning is available for the different output types, including reports, charts, and visualizations, depending on how you choose to display and analyze your data.

**Procedure:** How to Use Binning in a Vertical Bar Chart

1. Open InfoAssist in Chart mode.
2. In the Query pane, right-click the chart component and change Sum to Count, as shown in the following image.

3. Add a measure, such as Households, to the Vertical Axis field container.
4. From the Data Pane, right-click the same measure and click Create Bins.
5. In the Create Bins dialog box, accept the default bin value and click OK.
6. From the Data pane, drag the bin into the Horizontal Axis field container. The chart displays showing the bins along the x-axis, as shown in the following image.

7. Save the chart. You can edit the bin size to meet your requirements for grouping and display.

**Procedure:** **How to Edit an Existing Bin**

1. Open a report, chart, or visualization that contains a bin.
2. From the Dimensions group, in the Data pane, right-click the existing bin and click Edit Bins.
The Edit Bins dialog box opens, as shown in the following image.

![Edit Bins dialog box]

**Note:** If you are working with a report, chart, or visualization where the bin is specified and therefore displays in the Query pane, the position of the Edit Bins field in the shortcut menu appears in a different location.

3. Optionally, change the name of the field for the bin, and click **Format** to edit the formatting that you want to change (for example, currency).

4. In the **Width of Bins** field, specify a value that meets your display requirements.

5. Click **OK**.

**Procedure: How to Create Bins for Reporting**

You can create bins in reports, which lets you view the detail behind a chart or histogram. You can optionally switch between report and chart as you perform your analysis. This allows you to review the actual values that fall into each bin.

1. Create a report.

2. In the Query pane, on the Report component, change **Sum** to **Print**, as shown in the following image.

![Query pane]

3. Right-click the measure on which to bin, and click **Create Bins**.

4. In the Create Bins dialog box, set the width of the bins and change any formatting options (for example, currency).

5. Click **OK**.

6. In the Data pane, double-click the bin to add it to your report.
The report displays showing the bin assignments per value, as shown in the following image.
7. Optionally, you can change the Print and By field assignments to view the Households values by bin, as shown in the following image.

**Binning Values in a Histogram**

Histograms graphically represent the distribution of numeric data. They facilitate the identification and discovery of the underlying frequency distribution within a set of continuous data. You can use histograms to identify trends and illustrate categorizations, or groupings, also known as bins. For more information, see *Binning* on page 163.

Histograms use bins to group data. Bins allow you to establish a range of values for your data. For example, you can review how the bins are designated when you consider the age of everyone in your company. In the first table, you can review the bins (using the default value of 10) and counts for each bin.

<table>
<thead>
<tr>
<th>AGE</th>
<th>COUNT</th>
</tr>
</thead>
<tbody>
<tr>
<td>0-9</td>
<td>0</td>
</tr>
<tr>
<td>10-19</td>
<td>5</td>
</tr>
</tbody>
</table>
In the second table, you can review the same data for the bins (with a bin width of 15) and counts for each bin. Notice that as the bin size gets larger, more employees fall into these different ranges.

<table>
<thead>
<tr>
<th>AGE</th>
<th>COUNT</th>
</tr>
</thead>
<tbody>
<tr>
<td>20-29</td>
<td>26</td>
</tr>
<tr>
<td>30-39</td>
<td>351</td>
</tr>
<tr>
<td>40-49</td>
<td>460</td>
</tr>
<tr>
<td>50-59</td>
<td>310</td>
</tr>
<tr>
<td>60-69</td>
<td>285</td>
</tr>
<tr>
<td>70-79</td>
<td>22</td>
</tr>
<tr>
<td>80-89</td>
<td>3</td>
</tr>
<tr>
<td>Total</td>
<td>1462</td>
</tr>
</tbody>
</table>

When you create a histogram in either Chart or Visualization mode, a bin is created automatically for the measure you select. When working with bins, you can change the width of the bin by editing it. In the Query or Data pane, right-click a bin field and click *Edit Bins* to change the value that dictates the width or format of the contents of the bin.
The bin value is designated as a dimension field, since it is a limited field with a discrete set of possible values that was created from a field with an unlimited, continuous range of values. The measure displays as a count (.CNT) field and the related bin is created in the Query pane. It is also placed in the Data Pane for future use.

**Procedure:** How to Create a Histogram with Automatic Binning in Chart Mode

1. Open InfoAssist in Chart mode.
2. On the **Format** tab in the **Chart Types** group, click **Other**.
3. In the Bar group of charts, click **Vertical Histogram**.
4. Click **OK**.
5. From the Data pane, drag a measure into the Measure field container in the Query pane. A histogram is automatically created using the measure you selected along with a generated bin, as shown in the following image.

![](image.png)

**Note:** This process produces the same results as if you had created the histogram manually, however it automatically converts the measure to a count (.CNT) field. It also creates the bin for you, placing it on the x-axis, accordingly.

**Procedure:** How to Create a Histogram with Automatic Binning in Visualization Mode

1. Open InfoAssist in Visualization mode.
2. On the **Home** tab, in the **Visual** group, click **Change**.
3. In the Select a Visual dialog box, click **Histogram**.
4. From the Data pane, drag a measure into the Measure field container in the Query pane.
A histogram is automatically created using the measure you selected along with a generated bin, as shown in the following image.

You can optionally edit the bin to change its width or format. For information on building a histogram manually, in Chart mode, see *Binning* on page 163.

**Accessing Chart Formatting Tools**

Your presentation of data on a chart is successful when it communicates to your audience the message that you intend. InfoAssist helps you meet the needs of your audience and convey your message by providing numerous chart features. For example, you can adjust the appearance of a chart, add layers of information, or customize the labels that identify the data on the chart.

**Using Live Preview**

In Live Preview, the canvas on the right of the window provides a preview of the report or chart content that you can interact with. Live Preview enables you to see your changes as you make them. You can access more detail by running your report or chart.
In the following image, the legend displays on the right side of the canvas.

In Live Preview, when you select a graph element (for example, legend, axis label, title), the bounding area is highlighted with a solid line.

Once you select a chart element, you can access all available design options on the ribbon, or you can right-click an element to open a shortcut menu of frequently-used design options. Once you have selected your design option from the ribbon or the menu, InfoAssist instantly applies it to the chart element, so that you see the result immediately.

Shortcut menus are enabled for charts that are generated with either sample data, or live data from your data source.

**Note:** Shortcut menus are not available in InfoAssist Basic.

The following sections describe the chart elements and the ribbon options that you can work with to design your charts in Live Preview.

**Related Information:**

- Using Shortcut Menu Options in the Query Pane on page 64
- Using Field Containers on page 56
Formatting a Series

A series is a measure field that is included in a chart. You can format a series in a variety of ways. For example, you can change the color of a series, add a trendline to a series, or change the appearance of markers on a series.

You can access the full set of formatting options on the Series tab and Field tab. For more information, see Series Tab on page 43 and Field Tab on page 42.

You can also access a subset of frequently-used options by right-clicking a series element on a chart to open a menu of those options.

Tip: The options that you see on the menu depend on the type of chart that you are creating. For example, the Series Type option would not appear on the menu for a pie chart, but it would appear for a bar, line, and area chart.

Associated Dialog Boxes

Whether you access series options from the ribbon or the shortcut menu, you are presented with a dialog box of options. The following dialog boxes are commonly used for formatting a series:

- Format Series
- Edit Title
- Traffic Light Condition

For Instructions on how to open these dialog boxes, see the procedures in Using Series Properties on page 180.

Format Series Dialog Box

The Format Series dialog box contains options to format the fill and border of each series on a chart. To access this dialog box, on the Series tab, in the Style group, click Style.

The Format Series dialog box contains the following tabs:

- Fill
- Border
- Effect (for HTML5 charts only)

Use the Fill tab to modify the color of a chart series.
The Fill tab is shown in the following image.

The Fill tab contains the following options:

- **No fill.** Select this option to remove the color from the series.

- **Solid fill.** Select this option to display the Color and Transparency options.
  
  - **Color.** Click this icon to open the Color dialog box, where you can select a color for the series.
  
  - **Transparency.** Move the slider to make the bands opaque (0%) or transparent (100%). The default is 0%.

- **Gradient fill.** Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the *stop* or *pin* elements.
  
  - **Direction.** Select from this drop-down menu to set the direction of the gradient fill. For example, Gradient right or Gradient left.

Use the Border tab to specify a border for a chart series.
The Border tab is shown in the following image.

The Border tab contains the following options:

- **Show Border Color.** Select this option to show a border color around each series.

- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border.

Use the Effect tab to specify styling and shadowing options for HTML5 charts.
The Effect tab is shown in the following image.

![Effect tab image](image)

**Note:** This tab only displays when working with HTML5 charts.

The Effect tab contains the following options:

- **Riser Style.** Use this drop-down menu to select a riser style. Options include: None, Bevel, Cylinder, Darken, Inverted Darken, Lighten, and Inverted Lighten.

- **Show Shadow.** Select this option to set a shadow.

**Edit Title Dialog Box**

To edit the title of a series, right-click a series on the canvas, and click *Change Title*. The Edit Title dialog box contains a text field in which you can type the title for a series on a chart. Click *OK* and the title appears on the chart.

If you have specified an amper (&) variable in your title while working in Live Preview, _FOC_NULL displays to indicate that an amper variable that has not been evaluated. It indicates that the value will be evaluated at run time.

**Traffic Light Condition Dialog Box**

The Traffic Light Condition dialog box contains fields for adding new conditional styling or modifying existing conditional styling by applying a traffic light color to the selected field.
The Traffic Light Condition dialog box is shown in the following image.

The Traffic Light Condition dialog box contains the following fields:

- **Relational Operators.** Select from this drop-down menu to set the relational operator. For example, Equal to.

- **Type/Value.** Click this unlabeled field to open a dialog box that contains the following fields:
  - **Type.** Opens a drop-down menu of the following values Constant and Field. Select *Constant* to enter a constant value. Select *Field* to open a visual display of the fields in your data source.
  - **Value:** Enables you to specify a value based on the Type that you select.
    - **Note:** If you are creating a Traffic Light condition on a full date field, the Value field will have a calendar icon adjacent to it. You can use this icon to select a date using a calendar control.
  - **Get Values.** Select a value option from this drop-down list. For example, All or First.

The Traffic Light Condition dialog box contains the following buttons:

- **Selected Condition.** Click this icon to select a condition to work on.

- **New.** Creates a new rule.
- **Delete.** Deletes a rule.

- **Color.** Opens the Color dialog box.

- **Drill Down.** Opens the Drill Down dialog box, where you can drill down to a webpage or a URL using Multi Drill functionality. Specify the following:
  - URL of the webpage or location of the report
  - An alternate comment
  - Target (New Window, Same Window, a value that you enter)
  - Parameters that you want to use (Name, Value)

  **Note:** In InfoAssist, when the output destination is set to Single Tab or New Tab, the drilldown target cannot be displayed in the Same Window so a new window will be generated. When the report is run outside of InfoAssist the Same Window setting will be respected.

### Series Elements Shortcut Menu

When you right-click a series, a menu of options opens. The menu contains options that are available on the Field and Series tabs.

The menu options are described in the following table. The table provides links to the sections of this document in which those options are also discussed.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Values</td>
<td>Enables you to create or modify a WHERE statement, using the Filter dialog box. With a WHERE statement, you select only the data that you want to display, and exclude unwanted data. For information on filtering your data, see <a href="#">Data Tab</a> on page 39 and <a href="#">Field Tab</a> on page 42.</td>
</tr>
<tr>
<td>Sort</td>
<td>Enables you to sort the series in either ascending or descending order.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Visibility</td>
<td>Controls the display of the selected series (field) on a chart. The value Hide suppresses the display of the series, and the default value Show displays the series. For instructions, see <em>How to Hide a Field in a Series</em> on page 185.</td>
</tr>
<tr>
<td>Change Title</td>
<td>Enables you to edit the title of the selected series. In the Edit Title dialog box, type the new title in the Enter Title field, and click OK. For instructions, see <em>How to Change the Title of a Series</em> on page 189.</td>
</tr>
<tr>
<td>Edit Format</td>
<td>Enables you to change the format of a field. This includes field type, display options, field length, and the specification of applicable decimal points. For more information, see <em>Changing a Field Format</em> on page 100. Note: Any changes to the format of a field will be reflected in the tooltip for charts at run time, as well as for visualizations at design and run time.</td>
</tr>
<tr>
<td>Series Type</td>
<td>Changes the chart type of the selected series to bar, line, or area. The option None (default) returns the series to the chart type that was in effect before you changed it. This option applies to bar, line, and area chart types only. For instructions, see <em>How to Change the Type of a Series</em> on page 181.</td>
</tr>
<tr>
<td>Series Color</td>
<td>Enables you to specify the color of the selected series, using the Color dialog box. For more information, see <em>Using the Color Dialog Box</em> on page 371.</td>
</tr>
<tr>
<td>More Style Options</td>
<td>Opens the Format Series dialog box. For more information, see <em>Format Series Dialog Box</em> on page 172.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Data Labels</td>
<td>Controls the display of data labels (values) on the selected series. The default value Hide suppresses the display of labels, and the value Show displays labels. This option does not apply to the gauge chart type. For instructions, see <em>How to Show and Hide Data Labels</em> on page 199.</td>
</tr>
<tr>
<td>Color Mode</td>
<td>Controls how color is applied to a series (measure field) on a chart. The possible settings are By Series (default) and By Group. For example, assume that there is only one series on a sample bar chart. The By Series setting applies the same color to all the bars in the series. The By Group setting applies a different color to each bar. For instructions, see <em>How to Control the Color Mode</em> on page 190.</td>
</tr>
<tr>
<td>Add Trendline</td>
<td>Draws a line on a chart to indicate a statistical trend. This option does not apply to the pie, funnel, 3D, gauge, or stock chart type. For an example of a chart with a trendline, see <em>How to Add a Trendline</em> on page 181.</td>
</tr>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can configure a hyperlink or a drill-down procedure for the selected field. Clicking that field in the report output, at run-time, redirects you to the URL you specified or executes the indicated procedure.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| More   | Contains the Aggregation Functions, Traffic Light Conditions, and Missing options.  
Aggregation Functions assign an aggregation value to a numeric measure field in a report. For instructions, see *How to Display Aggregations on Measure Data* on page 186.  
Traffic Light Conditions enables you to specify the color of numeric measure fields in the output, depending on conditions that you set. You can use the Traffic Light Condition dialog box to specify the conditions and colors.  
For instructions, see *How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)* on page 187 and *How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)* on page 188.  
The Missing option allows you to show or hide fields with no value. |
| Delete | Removes the selected series from the report and updates the Live Preview accordingly. |

**Using Series Properties**

The following sections contain procedures for customizing a series.

**Procedure:**  
*How to Select a Series*

1. Create a chart.
2. On the Series tab, in the Select group drop-down menu, select the Series that you want to customize.  
The Series appears in the drop-down menu field.

**Procedure:**  
*How to Format the Fill and Border of a Series*

1. Create a chart.
2. Open the Format Series dialog box in one of the following ways:
   - **Ribbon:** On the Series tab, in the Style group, click Style.
Shortcut Menu: Right-click a series on the chart, and click More Style Options.

The Format Series dialog box opens.

3. Use the fill and border options to format the series.

For more information, see Format Series Dialog Box on page 172.

4. Click OK to close the dialog box.

The Format Series dialog box closes. The series fill and border are formatted accordingly.

5. Click Run to generate the report.

Enhancing Series Using the Series Tab

The Properties group contains commands for enhancing charts, such as changing the type or adding a trendline, for the selected series.

Procedure: How to Change the Type of a Series

1. Create a bar, line, or area chart.

2. Access the list of series types in one of the following ways:

   - Ribbon: On the Series tab, in the Properties group, open the Type drop-down menu.

   - Shortcut Menu: Right-click a series on the chart, and point to Series Type.

3. Select the type that you want the series to become.

   The chart contains the new series type.

Procedure: How to Add a Trendline

A trendline is a line that is drawn over the plot area of a chart or visual to show the pattern of data points. The pattern reveals a statistical trend. In particular, the slope of the trendline, which is calculated by subtracting and dividing two different x, y coordinate values, is a value that indicates the rate at which the y value of a line rise or falls as the x value increases. Once the slope of your chart or visual is determined, you can further extrapolate your results and gain further insight into your data.

Note: The mathematical equation for the selected trendline option is only available in Chart mode. It is not available in Visualization mode.

1. Create a chart or visual.

2. Access the menu of trendline types in one of the following ways:

   - Ribbon: On the Series tab, in the Properties group, open the Trendline drop-down menu.
Shortcut Menu: Right-click a series on the chart or visual, and point to Add Trendline.

3. Select the type of trendline that you want to display.

The trendline appears on the canvas.

4. Optionally, to display the mathematical equation for the selected trendline option, on the Series tab, in the Properties group, click Equation.

The following image shows a trendline that appears with the Linear option.

Formatting Charts Using the Series Tab

The Series tab contains options for formatting charts.

Procedure: How to Apply Smooth Line Effect to a Line Chart

1. Create a line chart.
2. Select a series on the line chart.

The Smooth Line effect is applied to the series.

Procedure: How to Hide a Series Line Between Markers

Lines appear between markers by default.
To hide a series line between a marker:
1. Create a line chart.
2. Select a series on the line chart.
3. On the Series tab, in the Series group drop-down menu, select the series that you want to hide.
4. In the Line Group, click Connect Lines.
   - The series line between the markers disappears.
   - To make the series line reappear, click Connect Lines again.

Procedure: How to Change the Appearance of a Marker

Markers are used to display points of data on a line chart. They are also used in the legend to identify the data that is on the chart. The different marker shapes distinguish one series from another.

1. Create a line chart.
2. Select a series on the line chart.
3. On the Series tab, in the Line group, click Marker to open a drop-down menu of options.
4. From the Marker drop-down menu, select the marker shape. For example, Diamond or Hourglass.
   - The markers are formatted.
The following image shows a triangle marker for gross profit data and a star marker for revenue data.

**Procedure: How to Expand Pie Slices**

1. Create a pie chart.
2. On the Series tab, in the Select group, from the drop-down menu, select one of the following:
   - **All Series** expands all slices out from the center of the pie.
   - A specific series expands that particular slice out from the center of the pie.
3. In the Pie group, click **Expand**.
   The pie expands accordingly.

**Procedure: How to Hide a Pie Slice**

1. Create a pie chart.
2. On the Series tab, in the Select group, from the drop-down menu, select the series that you want to hide. Then, in the Pie group, click **Hide**.
   The slice is hidden.
**Procedure:** How to Filter Values in a Series

1. Create a chart.
2. Select a series on the chart.
3. Open the Filter dialog box in one of the following ways:
   - **Ribbon:** On the Field tab, in the Filter group, click Filter.
   - **Shortcut Menu:** Right-click a series, and click Filter Values.

   The Filter dialog box opens.
4. Select values for values and prompts.
5. Click OK to close the dialog box.

   The series values are filtered.

**Procedure:** How to Sort the Fields in a Series

1. Create a chart.
2. Select a series.
3. Sort the series in one of the following ways:
   - **Ribbon:** On the Field tab, in the Sort group, click Up to sort the series values from smallest to largest, or click Down to sort the series values from largest to smallest.
   - **Shortcut Menu:** Right-click a series on the chart, and point to Sort, and then Sort again. Click Ascending to sort the series values from smallest to largest, or click Descending to sort the series values from largest to smallest. Select Limit to open a list of values to display for a sort group.

   The chart appears with the series sorted accordingly.

**Procedure:** How to Hide a Field in a Series

1. Create a chart.
2. Hide a field in a series in one of the following ways:
   - Select the field in the Query pane.
   - Right-click the field in the chart.

   **Ribbon:** Select the field in the Query pane or by right-clicking it in the chart. On the Field tab, in the Display group, click Hide Field. Click Hide Field again to make the series reappear.
Shortcut Menu: Right-click a series in the Query pane, or in the chart, point to Visibility, and then click Hide. Right-click the same series, point to Visibility, and then click Show to make the series reappear.

The field is hidden.

Procedure: How to Display Aggregations on Measure Data

You can display numeric measure data using a variety of aggregation values.

For more information, see Missing Data in a Chart on page 425.

1. Create a chart.
2. Open the list of Aggregation options in one of the following ways:

   Ribbon: On the Field tab, in the Display group, click Aggregation.

   Shortcut Menu: Right-click a series, point to More, and then Aggregation Functions.

3. Select an aggregation function.

   The aggregation function is applied to the series.

   Note: If you change the Measure (Sum) Query field container in the Query pane from Sum to Print, Count, or List, the change overrides all assigned aggregation values.

Procedure: How to Display Aggregations on Dimension (Non-Numeric) Data

You can use various aggregations when working with dimension (non-numeric) fields in a chart, including Count, Count Distinct, and Percent of Count. The Count aggregation counts the number of occurrences of a field. Count Distinct counts the number of distinct values within a field. Percent of Count computes a field percentage, based on the number of instances found. When a dimension (non-numeric) field is placed in the Vertical Axis field container, it is converted to a Count field. You can subsequently change the aggregation to Count Distinct or Percent of Count.

1. Create a chart.
2. Convert a dimension (non-numeric) field into a Count field by placing it in the Vertical Axis field container.
3. Select the series on which to perform an aggregation.
4. Open the list of Aggregation options in one of the following ways:

   Ribbon: On the Field tab, in the Display group, click Aggregation.

   Shortcut Menu: Right-click a series, point to More, and then click Aggregation Functions.
5. Select an aggregation function.
   The aggregation is applied to the series.

**Procedure:**  How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)

1. Create a chart.
2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** In the Query pane, select a field, and then on the **Field** tab, in the **Display** group, click Traffic Lights.
   - **Shortcut Menu:** Right-click a series on the chart, point to More, and then click Traffic Light Conditions.

   The Traffic Light Condition dialog box opens. For more information, see Traffic Light Condition Dialog Box on page 175.
3. From the Relational Operators drop-down menu below the field name, select a relational operator. For example, Equal to.
4. In the field to the right of the Relational Operators drop-down menu, click the down arrow for the Type drop-down menu.

   The Type dialog box opens.
5. In the Type dialog box, select Constant.
6. Enter a value in the Value field, or
   a. From the Get Values drop-down menu, select one of the following values All, First, Last, Minimum, Maximum, From File. The value that you select appears in the Get Values field.
   b. Select the value in the Get Values field. The value that you selected appears in the Value field.
7. Click OK.

   The value that you selected appears in the field to the right of the operator drop-down menu.
8. Click the Color button.

   The Color dialog box opens.
9. Select a color.
10. Click OK.

   The color appears in the Preview box.
11. Click the Drill Down button.
   The Drill Down dialog box opens.

12. In the Drill Down dialog box, specify each of the following:
   - Drill down to a report or a webpage
   - URL of the webpage
   - An alternate comment
   - Target (New Window, Same Window)
   - Parameters that you want to use (Name, Value)

13. Click OK to close the dialog box.

14. Click the New button to set traffic light conditions for additional fields.

**Procedure:** How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)

1. Create a chart.

2. Open the Traffic Light Condition dialog box in one of the following ways:
   - **Ribbon:** In the Query pane, select a field, and then on the Field tab, in the Display group, click Traffic Lights.
   - **Shortcut Menu:** Right-click a series on your chart, point to More, and then click Traffic Light Conditions.

   The Traffic Light Condition dialog box opens. For more information, see Traffic Light Condition Dialog Box on page 175.

3. From the Relational Operators drop-down menu below the field name, select a relational operator. For example, Greater than.

4. In the field to the right of the operator drop-down menu, click the arrow for the Type drop-down menu.
   The Type dialog box opens.

5. In the Type dialog box, select Field.

   The Type dialog box displays the Dimensions, Measures, and Properties of your data. You can display the data in the following ways:
   - View fields in business order. Select from the following options: Title, Description, Name, or Alias.
View fields in a sortable grid. Select from the following options: Name, Title, Alias, Format, Segment, Filename, Description, or Reference.

View the hierarchical structure of the data. Select from the following options: Title, Description, Name, or Alias.

6. Select a field.
7. Click OK.
   The field that you selected appears in the field to the right of the operator drop-down menu.
8. Click the Color button.
   The Color dialog box opens.
9. Select a color.
   The color appears in the Preview box.
10. Click OK.
11. Click the Drill Down button.
   The Drill Down dialog box opens.
12. In the Drill Down dialog box, specify a value for each of the following:
   - Drill down to a report or a webpage
   - URL of the webpage
   - An alternate comment
   - Target (New Window, Same Window)
   - Parameters that you want to use (Name, Value)
13. Click OK to close the dialog box.
14. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Change the Title of a Series
1. Create a chart.
2. Open the Edit Title dialog box in one of the following ways:
   - Shortcut Menu: Right-click a series on the chart, and click Change Title.
   - Query Pane: Right-click a series, and click Change Title.
   The Edit Title dialog box opens.
3. In the Enter Title field, type the new name for the series.

4. Click OK to close the dialog box.

   The series has a new title.

**Procedure: How to Control the Color Mode**

When you create a single-series chart, all series groups appear in the same color. To use a different color for each group, set the color mode to *By Group*.

1. Create a chart.

2. Right-click a series on the chart, point to *Color Mode*, and then click *By Group*.
   
   A different color is applied to each group in the series. To return to the default display of the series in one color, right-click the series, point to *Color Mode*, and then click *By Series*.

3. Click *Run* to generate the report.

**Procedure: How to Delete a Series**

1. Create a chart.

2. Right-click a series on the chart, and click *Delete*.

   The series is deleted.

**Formatting Data Labels**

Data labels highlight important data points on a chart. They identify exact numbers. You can customize data labels in a variety of ways to make them stand out more clearly on the chart. For example, you can change the position, angle, color, or size of data labels.

**Associated Dialog Boxes**

Whether you access data label options from the ribbon or the shortcut menu, you are presented with a dialog box of options. The following dialog boxes are commonly used for formatting data labels:

- Format Labels
- Style
- Line Style

For instructions on how to open these dialog boxes, see the procedures in *Using Data Labels Properties* on page 198.
Format Labels Dialog Box

The Format Labels dialog box contains options for editing data labels. The Format Labels dialog box offers different options depending on the chart type that you are using. Bar, line, and area charts share the same tabs.

The Format Labels dialog box contains the following tabs:

- General Options
- Advanced
- Pie Title (for pie charts only)
- Pie Labels (for pie charts only)
- Funnel Labels (for funnel and pyramid charts)

General Options Tab

Use the General Options tab to add data labels to a chart and set their position, angle, and radius.

The General Options tab is shown in the following image.

![General Options Tab Image]

The General Options tab contains the following options:

- **Show Data Labels.** Select this option to show data labels on a chart. Clear this option to suppress data labels.
Position. Select an option from this drop-down menu to determine where the data label will be positioned. The options are:

- Above
- Below top edge
- Center
- Base
- Center back

Format Labels. Select from this drop-down menu of preset formats that can be applied to the labels. Some of the options include Use Pattern, Currency General, and Date Full.

Custom Format. Enter a standard number format pattern for the data label. This option is only available when you select the Use Pattern option from the Format Labels drop-down menu.

The following table describes the characters that you can use in a custom format.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Is a digit.</td>
</tr>
<tr>
<td>0 (zero)</td>
<td>Shows as absent.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Is a placeholder for decimal separator.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Is a placeholder for grouping separator.</td>
</tr>
<tr>
<td>; (semicolon)</td>
<td>Separates formats.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Is the default negative prefix.</td>
</tr>
<tr>
<td>% (percent)</td>
<td>Divides by 100 and shows as a percentage.</td>
</tr>
<tr>
<td>x</td>
<td>Determines that any other characters can be used in the prefix or suffix.</td>
</tr>
<tr>
<td>‘ (apostrophe)</td>
<td>Is used to quote special characters in a prefix or suffix.</td>
</tr>
</tbody>
</table>

Style Labels. Click this icon to open the Style dialog box, where you can style text. For more information, see Style Dialog Box on page 197.
Show Cumulative Sums. Select this option to have the data text labels show cumulative sums. Clear this option to have data text labels show individual sums. This option is available for stacked charts.

Show Stacked Total. Select this option to display stacked totals. Data position should be set to Center to display a stacked total. This option is available for stacked charts.

Advanced Tab

Use the Advanced tab to modify additional data labels properties.

The Advanced tab is shown in the following image.

![Advanced Tab Image]

The Advanced tab contains the following options:

Show Zero Labels. Select this option to display zero values in a chart. Clear this option to display all data values except zero.

Apply color to negative data labels. Select this option to style negative data labels separately from positive data labels.

Color. Click this icon to open the Color dialog box, where you can select a color for the negative number.

Pie Labels Tab

Use the Pie Labels tab to customize your pie data labels.
The Pie Labels tab is shown in the following image.

The Pie Labels tab contains the following options:

- **Label Position.** Select from this drop-down menu an option to control the display of feeler lines and labels on a pie chart.

- **Label Display.** Select from this drop-down menu an option to control the format of labels displayed next to feelers on a pie chart.

- **Format Labels.** Select from this drop-down menu of preset formats that can be applied to labels.

- **Custom Format.** Select this option to use a custom format from a list of preset formats. See the following table for a list and description of the characters that you can use in a custom format.

- **Style Labels.** Click this button to open the Style dialog box, where you can style text.

**Ring Label.** These options appear on the tab for a ring pie chart.

- **Show Ring Label.** Select this option to control the display of the total label on a pie ring chart.

- **Format Labels.** Select from this drop-down menu of preset formats that can be applied to labels.
Custom Format. Enter a standard number format pattern for the data label. This option is only available when you select the Use Pattern option from the Format Labels drop-down menu.

Style Labels. Click this button to open the Style dialog box, where you can style text.

Feeler Line. Provides options to style the feeler lines for pie chart labels.

Line Style. Click this button to open the Line Style dialog box, where you can edit the color, weight, and style of the feeler line.

Pie Title Tab

Use the Pie Title tab to create and style a pie title.

The Pie Title tab is shown in the following image.

The Pie Title tab contains the following options:

Show Pie Title. Clear this option to suppress a pie title. Select this option to display a pie title. This is the default option.

Style Title. Click this icon to open the Style dialog box, where you can style pie title text.

Funnel Labels Tab

Use the Funnel Labels tab to customize the labels on a funnel or a pyramid chart.
The Funnel Labels tab contains the following options:

- **Label Position.** Select an option from this drop-down menu to control the display of feeler lines and labels on a funnel chart.

- **Format Labels.** Select from this drop-down menu of preset formats that can be applied to labels.

- **Custom Format.** Select this option to use a custom format. See the table in the previous section for a list and description of the characters that you can use in a custom format.

- **Style Labels.** Click this button to open the Style dialog box, where you can style text.

- **Style Value.** Opens the Style dialog box, where you can style the value.

**Feeler Line**

- **Show Feeler Lines.** (Default) Clear this option to suppress feeler lines. Select this option to display feeler lines.

- **Line Style.** Click this button to open the Line Style dialog box, where you can edit the color, weight, and style of the feeler line.
**Note:** While some style options, such as Show Pie Title and Show Feeler Lines, are enabled by default, a stylesheet applied to the chart may contain different settings that will override these default settings.

**Style Dialog Box**

The Style dialog box contains options to style the data labels.

The Style dialog box is shown in the following image.

![Report Style dialog box](image)

The Style dialog box contains the following options:

- **Font.** Use the drop-down menu to change the font.
- **Font size.** Use the drop-down menu to change the numeric value for the font size.
- **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
- **Text alignment.** Click the appropriate button (left, center, right) to align the selected text.
- **Font color.** Click the button to open the Color dialog box, where you can select the font color.

- **Reset to Quick Styles from Template.** Click the button to reset all settings to the default settings from the template.

**Note:** Reset only works while the Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the *Undo* command on the Quick Access Toolbar.
Line Style Dialog Box

The Line Style dialog box contains options to style lines on a chart.

The Line Style dialog box is shown in the following image.

![Line Style Dialog Box](image)

The Line Style dialog box contains the following options:

- **Color.** Click this button to open the Color dialog box, where you can select the color for the line.
- **Weight.** Click this button to open a drop-down menu of line weight options.
- **Style.** Click this button to open a drop-down menu of line style options.
- **Reset.** Click this button to reset the line to the default options.

Data Labels Elements Shortcut Menu

When you right-click a data label on a bar, line, or area chart, a menu of the following options opens:

- **Data Labels.** Point to this option to toggle between Show and Hide.
- **More Label Options.** Click this option to open the Format Labels dialog box.

The shortcut menu contains options that are available on the Series tab.

Using Data Labels Properties

The following sections contain procedures for customizing data labels.
**Procedure:** How to Show and Hide Data Labels

1. Create a chart.
2. You can access the option to show data labels in one of the following ways:

   - **Ribbon:** On the Series tab, in the Properties group, click Data Labels, and from the drop-down menu, click More Data Label Options. The Format Labels dialog box opens. On the General Options tab, select the Show Data Labels check box, and click OK to close the dialog box. You can use this dialog box to format and style the data labels. For more information, see Format Labels Dialog Box on page 191. To hide data labels, clear this option.

   - **Shortcut Menu:** Right-click a series on the chart, point to Data Labels, and then click Show. To hide data labels, right-click a series on the chart, point to Data Labels, and then click Hide.

The data labels appear, and are formatted and styled accordingly.

The following image shows a chart with data labels.

![Chart with data labels](image)

**Procedure:** How to Change the Position of Data Labels

2. On the menu, select the position for the data labels.
The data labels are positioned accordingly.

**Formatting a Legend**

A legend contains information that is necessary to accurately interpret the data on a chart. By default, a chart displays either a vertical axis title if there is a single measure field, or a legend if there are multiple measure fields.

**Format Legend Dialog Box**

Whether you access legend options from the ribbon or the shortcut menu, you are presented with the Format Legend dialog box of options. For instructions on how to open this dialog box, see *Using Legend Properties* on page 203.

The Format Legend dialog box contains options for formatting a legend on a chart or visualization. It contains the following tabs:

- Legend Options
- Markers & Labels
- Fill
- Border Styles

**Note:** The Fill, Border Style, and Shadows tab are not available in InfoAssist Basic.

For instructions on how to open this dialog box, see the procedures in *Using Legend Properties* on page 203.

Use the Legend Options tab to customize the appearance of a legend on a chart or visualization.

The Legend Options tab is shown in the following image.
The Legend Options tab contains the following options.

- **Show Legend.** When selected, a legend displays on a chart or visualization. Clear this option to suppress a legend on a chart or visualization.

- **Legend Position.** Opens a drop-down menu of options to position the legend. For example, top or left.

- **Reverse Legend Order.** Specifies that the legend be drawn in reverse order. Clear this option to specify that the legend be drawn in normal order.

- **Docking State.** This option dictates how the legend is docked. It is set to Expanded by default, but you can set it to Collapsed, which will show that the legend is available (using the grey arrow). This option saves real estate in your chart by collapsing the categorical text labels in the legend while preserving the legend label colors. This is particularly useful when items in your legend have long labels and you wish to truncate them for the purposes of display. If you set this option to None, the ability to expand or collapse the legend is removed and the grey arrow no longer displays.
Enable Scrolling. Select this check box to enable scrolling in your legend. This is particularly useful when you have numerous entries in your legend. This check box is selected by default. To disable scrolling in your legend, clear the Enable Scrolling check box. All legend options display in columns, and a scroll bar does not display.

Show Title. Select this check box to display the legend title.

Use the Markers & Labels tab to customize the appearance of markers and labels on legends. The Markers & Labels tab contains the following options:

Style Labels. Opens the Style dialog box, where you can style text.

Marker Position. Opens a drop-down menu of options to set the position of text relative to the legend marker. For example, Left of Text or Above Text.

Use the Fill tab to modify the color of the legend area. For more information, see Format Series Dialog Box on page 172.

Use the Border Styles tab to place a border around a legend. For more information, see Format Series Dialog Box on page 172.

The Border Styles tab contains the following options:

Show Border. Select this option to place a border around a legend.

Color. With the Show Border option selected, you can click this button to open the Color dialog box, where you can select a color for the border.

Legend Elements Shortcut Menu

When you right-click a legend on a chart, a menu of options opens. The menu contains options that are available on the Format tab.

The shortcut menu options are described in the following table. The table provides links to the sections of this document in which those options are also discussed.
<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Show legend</td>
<td>Controls the display of the legend. InfoAssist displays the legend by default. When you clear this option, InfoAssist suppresses the legend. For instructions, see <em>Using Legend Properties</em> on page 203. The background shortcut menu has an option to restore the legend after it has been suppressed.</td>
</tr>
<tr>
<td>Legend Position</td>
<td>Controls the placement of the legend on the chart. For instructions see, <em>Using Legend Properties</em> on page 203.</td>
</tr>
<tr>
<td>Legend Area Color</td>
<td>Enables you to specify the color of the legend background area using the Color dialog box.</td>
</tr>
<tr>
<td></td>
<td>This option is available only when you right-click the area around the legend. For instructions see, <em>Using Legend Properties</em> on page 203.</td>
</tr>
<tr>
<td>Legend Border Color</td>
<td>Enables you to specify the color of the border around the legend background area using the Color dialog box.</td>
</tr>
<tr>
<td></td>
<td>This option is available only when you right-click the area around the legend. For instructions see, <em>Using Legend Properties</em> on page 203.</td>
</tr>
<tr>
<td>More Legend Options</td>
<td>Opens the Format Legend dialog box.</td>
</tr>
</tbody>
</table>

**Using Legend Properties**

The following sections contain procedures for customizing legends. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

**Procedure:** How to Hide a Legend

1. Create a chart with multiple measure fields.
2. Clear the *Show legend* option in one of the following ways:
   - **Ribbon:** On the *Format* tab, in the *Labels* group, click *Legend*, then click *Show legend* to clear the option.
   - **Shortcut Menu:** Right-click the legend, and clear the *Show legend* option.
Procedure: How to Position a Legend
1. Create a chart with multiple measure fields.
2. Open the menu of label position options in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, click Legend, then point to Legend Position.
   - **Shortcut Menu:** Right-click the legend, and point to Legend Position.
3. Select a position for the legend. For example, Auto or Right.

Procedure: How to Specify the Color of a Legend Border
1. Create a chart with multiple measure fields.
2. Open the Format Legends dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, click Legend, then click More Legend Options.
   - **Shortcut Menu:** Right-click the legend, and click More Legend Options.
   The Format Legend dialog box opens. For more information, see Format Legend Dialog Box on page 200.
3. On the Border Styles tab, select the option to Show Border.
4. Click the Color icon to open the Color dialog box, where you can specify the color of the legend border.
5. Click OK to close the Color dialog box.
6. Click OK to close the Format Legend dialog box.
   The legend border is formatted accordingly.
Formatting Gridlines

Gridlines are used on a chart as a reference to help you understand the quantities and values of your data and decode information on the axis. There are four types of gridlines that you can display and edit on your chart. They are:

- **Horizontal major gridlines**
- **Horizontal minor gridlines**
- **Vertical major gridlines**
- **Vertical minor gridlines**

Major gridlines enhance the display of values, while minor gridlines supplement major gridlines. If a plot point falls in between major gridlines, you can use minor gridlines for more precise interpretation of the data.

- **Vertical gridlines in a vertical chart run on the X axis.**
- **Horizontal gridlines in a vertical chart run on the Y axis.**
- **Horizontal major gridlines enhance the display of values, compared to the Y-axis scale alone. They are enabled by default on many charts. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.**
Horizontal minor gridlines are disabled by default. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

Vertical major gridlines enhance the display of values, compared to the X-axis scale alone. They are enabled by default. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

Vertical minor gridlines are disabled by default. They apply only to scatter and bubble chart types, where the X axis is numeric. They do not apply to the pie, 3D, gauge, spectral map, or funnel chart type.

**Note:** The orientation of a chart determines the available gridline options.

**Format Grid Lines Dialog Box**

You can format horizontal and vertical gridlines, color bands, and frames on a chart using the options in the Format Grid Lines dialog box. For instructions on how to open this dialog box, see the procedures in *Using Gridline Properties* on page 209.

Color bands come in a pair, with each band uniquely colored. They appear in a continually repeating pattern behind a series on a chart. The contrast of colors is designed to make the chart easier to read.

Alternate formatting can be used to apply different colors to sections, called regions, of an axis.

The Format Grid Lines dialog box contains the following tabs:

- **Major Grid Lines**
- **Minor Grid Lines**
- **Color Bands**
- **Frames**

**Note:** The Color Bands and the Frames options are not available in InfoAssist Basic.

Use the Major Grid Lines tab to format the major gridlines on the chart.

The Major Grid Lines tab contains the following options:

- **Show Grid Lines.** Select this option to display major gridlines on a chart if minor gridlines are the default for the chart.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.
- **Show Ticks.** Select this check box to enable or disable the tick mark functionality.

- **Tick Style.** Select from this drop-down menu of tick styles (Inside, Outside, Spanning).

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

Use the Minor Grid Lines tab to format the minor gridlines on your chart.

The Minor Grid Lines tab contains the following options:

- **Show Grid Lines.** Select this option to display minor gridlines on a chart. By default, this option is enabled.

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

- **Grid count.** Set the number of minor gridlines that will appear between major gridlines.

- **Show Ticks.** Select this check box to enable or disable the tick mark functionality.

- **Tick Style.** Select from this drop-down menu of tick styles (Inside, Outside, Spanning).

- **Line Style.** Click this icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

Use the Color Bands tab to format the color bands on your chart.

The Color Bands tab contains the following options:

- **Band 1.** Select this option to add Band 1 to a chart.

  - **Color.** Click this icon to open the Color dialog box, where you can edit the color of Band 1.

  - **Transparency.** Move the slider to make Band 1 opaque (0%) or transparent (100%). The default is 0%.

  - **%.** Enter or select the percentage of the transparency of Band 1.

- **Band 2.** Select this option to add Band 2 to a chart.

  - **Color.** Click this icon to open the Color dialog box, where you can edit the color of Band 2.

  - **Transparency.** Move the slider to make the Band 2 opaque (0%) or transparent (100%). The default is 0%.
Enter or select the percentage of the transparency of Band 2.

Use the Frames tab to enable or disable frame regions, and to set the location and style of the frame text.

The Frames tab contains the following options:

- **Show Frame Regions.** Select this option to show a frame region. Clear this option to suppress a frame region.

- **Region.** Select from this drop-down list, the region that you want to format.

- **Add.** Click this button to add a region.

- **Remove.** Click this button to remove a region.

- **Location.** Enter the location of the region.

- **Color.** Click this icon to open the Color dialog box, where you can edit the color of the frame.

- **Border Color.** Click this icon to open the Color dialog box, where you can edit the color of the frame border.

- **Text.** Enter the text that you want to appear on the frame.

- **Style Text.** Click this icon to style the frame text.

For instructions on how to open this dialog box, see the procedures in *Using Gridline Properties* on page 209.

**Gridline Elements Shortcut Menu**

When you right-click a gridline on a chart, a menu of options opens. The options for the gridline elements are described in the following table.
Using Gridline Properties

The following sections contain procedures for customizing gridlines.

**Procedure:** How to Display Horizontal Major Gridlines

If your chart does not display gridlines by default, use this procedure to generate gridlines.

1. Create a chart.
2. On the Format tab, in the Features group, open the Grid drop-down menu, point to Horizontal Gridlines, and then click Major Gridlines.

   Horizontal major gridlines are added to the chart.

**Procedure:** How to Display Horizontal Minor Gridlines

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. On the Grid drop-down menu, point to Horizontal Gridlines, and then click Minor Gridlines.

   - **Shortcut Menu:** Right-click the gridlines on the chart, and click More Grid Lines Options. The Format Horizontal Grid Lines dialog box opens. On the Minor Grid Lines tab, select Show Grid Lines.
Horizontal minor gridlines are added to the chart.

**Procedure:** How to Display Vertical Major Gridlines

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:
   - **Ribbon:** On the *Format* tab, in the *Features* group, open the *Grid* drop-down menu. On the Grid drop-down menu, point to *Vertical Gridlines*, and then click *Major Gridlines*.
   - **Shortcut Menu:** Right-click the gridlines on the chart, and click *More Grid Lines Options*. The Format Vertical Grid Lines dialog box opens. On the Major Grid Lines tab, select *Show Grid Lines*.

   Vertical major gridlines are added to the chart.

**Procedure:** How to Display Vertical Minor Gridlines

1. Create a chart.
2. Access the option to show gridlines in one of the following ways:
   - **Ribbon:** On the *Format* tab, in the *Features* group, open the *Grid* drop-down menu. On the Grid drop-down menu, point to *Vertical Gridlines*, and then click *Minor Gridlines*.
   - **Shortcut Menu:** Right-click the gridlines on the chart, and click *More Grid Lines Options*. The Format Vertical Grid Lines dialog box opens. On the Minor Grid Lines tab, select *Show Grid Lines*.

   Vertical minor gridlines are added to the chart.

**Procedure:** How to Set the Color, Weight, and Style of a Gridline

1. Open the Format Grid Lines dialog box in one of the following ways:
   - **Ribbon:** On the *Format* tab, in the *Features* group, open the Grid drop-down menu, point to the gridline type that you want to format, and click *More Grid Lines Options*.
   - **Shortcut Menu:** Right-click a gridline, and click *More Grid Lines Options*.

   The Format Grid Lines dialog box opens.
2. Click the Line Style icon.
   - The Line Style dialog box opens.
3. Set the color, weight, and style of the gridline.
4. Click **OK** to close the Line Style dialog box.

5. Click **OK** again to close the Format Grid Lines dialog box.

   The gridline is formatted accordingly.

   The following image shows a line chart with styling applied to the gridlines.

   ![Line Chart with Gridlines](image)

**Procedure: How to Set Ticks**

Ticks are short lines which are perpendicular to a gridline. They are used to tick off specific increments along the gridline.

1. Create a chart with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:
   
   - **Ribbon:** On the **Format** tab, in the **Features** group, open the Grid drop-down menu, point to the gridline type that you want to format, and click **More Grid Lines Options**.
   
   - **Shortcut Menu:** Right-click a gridline, and click **More Grid Lines Options**.

   The Format Grid Lines dialog box opens.

3. From the Tick Style drop-down menu, select a tick style option. The options are:
   
   - **Inside**
Outside
Spanning

4. Click the Line Style icon to open the Line Style dialog box, where you can edit the color, weight, and style of the gridline.

5. Click OK to close the Line Style dialog box.

6. Click OK again to close the Format Grid Lines dialog box.

The tick marks are formatted accordingly.

The following image shows a chart with tick marks spanning both the vertical axis and horizontal axis.

Procedure: How to Set Color Bands

1. Create a chart with gridlines.

2. Open the Format Grid Lines dialog box in one of the following ways:

   ❑ **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu, point to gridlines that you want to format, and click More Grid Lines Options.

   ❑ **Shortcut Menu:** Right-click a gridline, and click More Grid Lines Options.

The Format Grid Lines dialog box opens.
3. On the Color Bands tab, click the Color icon to open the Color dialog box, where you can set the color of the color bands.

4. Use the transparency slider, or the percentage box, to type or select the percentage of the transparency that you want to apply to the color.

5. Click OK to close the Color dialog box.

6. Click OK again to close the Format Grid Lines dialog box.

The following image shows a chart with color bands along the horizontal gridline.

**Procedure:** How to Delete a Gridline

1. Create a chart with gridlines.

2. Select a gridline.

3. Delete the gridline in one of the following ways:

   - **Ribbon:** On the Format tab, in the Features group, open the Grid drop-down menu. From the menu, point to the gridline that you want to format, and click More Grid Lines to open the Format Grid Lines dialog box. On the tab for the gridline that you want to delete, clear the Show Grid Lines option, and click OK.

   - **Shortcut Menu:** Right-click the gridline, and from the menu, select Delete.
The gridline is deleted from the chart.

**Procedure:** How to Add Frames to Regions on a Chart
1. Create a chart.
2. On the Format tab, in the Features group, click Grid.
3. On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and then click More Grid Lines Options.
   The Format Grid Lines dialog box opens.
4. On the Frames tab, select the Show Frame Regions check box.
5. Click Apply.
   Colored frames are added to the chart, using the default styling options. Optionally, you may use the color and border color options to change these.

The following image shows a bar chart with colored frames around each region.
Formatting Axis Labels

Vertical and horizontal axes are based on the orientation of the graph. For example, in a vertical graph, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis. In a horizontal graph, the horizontal axis refers to the Y axis and the vertical axis refers to the X axis. This is important to consider, since options could change depending on the orientation of the graph.

A chart can contain the following types of axis labels:

- Horizontal axis labels represent the X axis. They do not apply to pie, funnel, or gauge charts.

- Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric scale, usually located on the left side of a vertical chart.

- Secondary horizontal and vertical labels can only be used when dual axes charts are selected.

Format Axis Dialog Box

Whether you access axis options from the ribbon, or the shortcut menu, you are presented with the Format Axis dialog box of options for formatting for both vertical and horizontal axes. The Format Axis dialog box contains the following tabs:

- General (for horizontal axes)
- Scale (for vertical axes)
- Title
- Labels
- Advanced

Reference: Format Vertical Axis Dialog Box

You use the Format Vertical Axis dialog box to specify formatting options for the vertical axis in your chart.

Use the Scale tab to modify scale properties.
The Scale tab is shown in the following image.

![Scale tab](image)

The Scale tab contains the following options:

- **Automatic Minimum.** Supplies the minimum value on the Y-axis scale automatically. To use manual scaling, clear this option. You can then set the minimum value by entering a number into the Value text box.
  - **Value.** Type the minimum value in this text box if you have not selected Automatic Minimum.

- **Automatic Maximum.** Supplies the maximum value on the Y-axis scale automatically. To use manual scaling, clear this option. You can then set the maximum value by entering a number into the Value text box.
  - **Value.** Type the maximum value in this text box if you have not selected Automatic Maximum.

- **Automatic Grid Step.** Calculates the number of major grid steps automatically. To use manual scaling, clear this option. You can then set the value by typing the number into the Value text box.
  - **Value.** Type the value in this text box if you have not selected Automatic Grid Step.

- **Logarithmic Scale.** Controls whether or not the Y-axis scale progresses logarithmically instead of linearly. This option is disabled by default. When selected, the logarithmic base is set to 10.0.
Include zero on scale. Controls whether or not a zero (0) value appears on the scale. This option is enabled by default.

Use the Title tab to show or hide the axis title, and create and style the title for the axis.

The Title tab contains the following options:

Show title. Select this check box to show the axis title (default) or clear the check box to hide the axis title.

Text. Type a title for the axis in the Text field.

Style text. Opens the Style dialog box, where you can style the text.

Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

Show Labels. Displays labels next to the axis. This is enabled by default. Clear this option to suppress labels.

Axis side. Contains a list of position options for the labels on the axis. The options are Left (default), Right, or Both.

Style labels. Opens the Style dialog box, where you can style text.

Format Labels. Contains a list of preset formats that can be applied to the labels.

Custom Format. Allows you to use a custom format. This option is activated when Use Pattern /100 and Use Pattern are selected as the format labels.

The Format Labels drop-down menu provides a list of preset formats that you can apply to labels. When you select a custom format, it must be defined using a custom format pattern. See the following table for a list and description of the characters that you can use in a custom format.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Is a digit.</td>
</tr>
<tr>
<td>0 (zero)</td>
<td>Shows as absent.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Is a placeholder for a decimal separator.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Is a placeholder for a grouping separator.</td>
</tr>
</tbody>
</table>
### Formatting Axis Labels

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>; (semicolon)</td>
<td>Separates formats.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Is the default negative prefix.</td>
</tr>
<tr>
<td>% (percent)</td>
<td>Divides by 100 and shows as a percentage.</td>
</tr>
<tr>
<td>x</td>
<td>Determines that any other characters can be used in the prefix or suffix.</td>
</tr>
<tr>
<td>‘ (apostrophe)</td>
<td>Is used to quote special characters in a prefix or suffix.</td>
</tr>
</tbody>
</table>

Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

- **Exclude Minimum Label.** Excludes the label with the lowest axis value from the chart.
- **Exclude Maximum Label.** Excludes the label with the highest axis value from the chart.
- **Descending Axis.** Draws the axis in descending order.
- **Show axis line.** Controls the display of the axis baseline.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the axis line.
- **Show zero line.** Controls the display of the zero line.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the zero line.
- **Custom Baseline.** Controls the display of the custom baseline.
  - **Value.** Type a value for the custom baseline.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the custom baseline.

For instructions on how to open this dialog box, see the procedures in *Using Axis Properties* on page 222.

**Reference:** Format Horizontal Axis Dialog Box

You use the Format Horizontal Axis dialog box to specify formatting options for the horizontal axis in your chart.

218
The General tab contains the Show axis line check box, which controls the display of the axis line. When this check box is selected, you can style the axis line.

The General tab is shown in the following image.

The General tab contains the following options:

- **Show axis line.** Enables the display of the axis line.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the axis line.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:

- **Text.** Type a title for the axis in the Text field.
- **Style.** Opens the Style dialog box, where you can style the text.

Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- **Show Labels.** Displays labels next to the axis. This is enabled by default. Clear this option to suppress labels.
  - **Axis side.** Contains a list of position options for the labels on the axis. The options are Left (default), Right, or Both.
  - **Style labels.** Opens the Style dialog box, where you can style text.
  - **Stagger Labels.** Sets the labels to appear staggered.
Concatenate Labels. Concatenates the labels in your chart. This is enabled by default. Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

- **Exclude Minimum Label.** Excludes the label with the lowest axis value from the chart.
- **Exclude Maximum Label.** Excludes the label with the highest axis value from the chart.
- **Reverse Groups.** Reverses the order of the display of the groups on the horizontal axis.

For instructions on how to open this dialog box, see the procedures in *Using Axis Properties* on page 222.

Secondary Axes Options

Formatting options are available for secondary axes in dual-axis charts. For example, in a vertical dual-axis chart, the secondary vertical axis refers to the Y2 axis.

The Format Secondary Axis dialog box contains the following tabs for both vertical and horizontal axes:

- **General.** For more information, see the Scale tab options in *Format Axis Dialog Box* on page 215.
- **Title.** For more information, see the equivalent tab in *Format Axis Dialog Box* on page 215.
- **Labels.** For more information, see the equivalent tab in *Format Axis Dialog Box* on page 215.
- **Advanced.** For more information, see the equivalent tab in *Format Axis Dialog Box* on page 215.

Axis Elements Shortcut Menu

When you right-click an axis label or title in a chart in Live Preview, a menu of options opens. The options for the right-click axis label elements are described in the following table.
<table>
<thead>
<tr>
<th><strong>Element</strong></th>
<th><strong>Option</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Axis Title</strong></td>
<td>Delete</td>
<td>Deletes the axis title from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td></td>
<td>Change Title</td>
<td>Enables you to change the axis title.</td>
</tr>
<tr>
<td></td>
<td>Style Title</td>
<td>Enables you to apply styling to the axis title, using the Style dialog box. For more information, see <em>Style Dialog Box</em> on page 197.</td>
</tr>
<tr>
<td><strong>Horizontal Labels</strong></td>
<td>Delete</td>
<td>Deletes labels from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td></td>
<td>Stagger</td>
<td>Controls the positioning of the labels. The On value positions the labels in a zigzag pattern. The Off default value positions the labels in a straight row.</td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotates the labels a specified number of degrees.</td>
</tr>
<tr>
<td></td>
<td>Style Labels</td>
<td>Enables you to apply styling to the labels, using the Style dialog box. For more information, see <em>Style Dialog Box</em> on page 197.</td>
</tr>
<tr>
<td></td>
<td>More Axis Options</td>
<td>Opens the Format Axis dialog box. For more information, see <em>Formatting Axis Labels</em> on page 215.</td>
</tr>
<tr>
<td><strong>Vertical Labels</strong></td>
<td>Delete</td>
<td>Deletes labels from the chart and updates the Live Preview accordingly.</td>
</tr>
<tr>
<td></td>
<td>Rotate</td>
<td>Rotates the labels a specified number of degrees.</td>
</tr>
<tr>
<td></td>
<td>Format Labels</td>
<td>Formats the labels according to the value that you specify.</td>
</tr>
<tr>
<td></td>
<td>Style Labels</td>
<td>Enables you to apply styling to the labels, using the Style dialog box. For more information, see <em>Style Dialog Box</em> on page 197.</td>
</tr>
<tr>
<td></td>
<td>More Axis Options</td>
<td>Opens the Format Axis dialog box. For more information, see <em>Formatting Axis Labels</em> on page 215.</td>
</tr>
</tbody>
</table>
Using Axis Properties

The following sections contain procedures for customizing an axis. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

Procedure: How to Delete Axis Labels

1. Create a chart.
2. You can delete axis labels in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and clear the Show Labels option.
   - **Shortcut Menu:** Right-click an axis label on the chart, and click Delete.

The axis labels are deleted from the chart.

Procedure: How to Stagger Axis Labels

**Note:** You can only apply a staggered effect to horizontal axis labels.

1. Create a chart with at least one axis label on display.
2. Access the Stagger option in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to Horizontal Axis, and click Stagger Labels.
   - **Shortcut Menu:** Right-click an axis label on the chart, point to Stagger and select On.

The axis labels are staggered.

Procedure: How to Rotate Axis Labels

1. Create a chart with axis labels.
2. Access the Rotate option in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, point to Rotate Labels, and then click the degree to which you want to rotate the axis labels.
   - **Shortcut Menu:** Right-click an axis label on the chart, point to Rotate, and then click the degree to which you want to rotate the axis labels.

The axis labels are rotated.
Procedure: How to Format Axis Labels
1. Create a chart with an axis label.
2. Access the list of axis label options in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and click More Axis Options to open the Format Axis dialog box. Open the Labels tab, and from the Labels option drop-down menu, select the formatting option that you want.
   - **Shortcut Menu:** Right-click an axis label, point to Format Labels, and click the formatting option that you want.

   The axis labels are formatted accordingly.

Procedure: How to Manually Set the Scale of an Axis
1. Create a chart.
2. Open the Format Axis dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and click More Axis Options.
   - **Shortcut Menu:** Right-click an axis value on the chart, and click More Axis Options.

   The Format Axis dialog box opens.
3. On the Scale tab, clear the Automatic Minimum option and enter your own minimum value in the Value text box.
4. Clear the Automatic Maximum option, and enter your own maximum value in the Value text box.
5. Clear the Automatic Grid Step option, and enter your own grid step value in the Value text box.
6. Optionally, you can select the Logarithmic Scale option. You can also clear the Include zero on scale option if you do not want zero to appear on the axis.
7. Click OK to close the dialog box.

   The axis scale is set accordingly.

Procedure: How to Add an Axis Title
1. Create a chart with an axis label.
2. Open the Format Axis dialog box in one of the following ways:

- **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and click More Axis Options.

- **Shortcut Menu:** Right-click an axis label, and click More Axis Options.

The Format Axis dialog box opens.

3. On the Title tab, type the axis title in the Text field.

4. Click the Style text icon to open the Style dialog box, where you can style the text.

The axis title is styled accordingly.

**Note:** Right-click the axis title to delete, change, or style the axis title.

**Procedure:** How to Set Advanced Axis Properties

1. Create a chart with an axis label.

2. Open the Format Axis dialog box in one of the following ways:

- **Ribbon:** On the Format tab, in the Labels group, open the Axes drop-down menu, point to the axis that you are working with, and click More Axis Options.

- **Shortcut Menu:** Right-click an axis label, and click More Axis Options.

The Format Axis dialog box opens.

3. On the Advanced tab, set the following options:

- Exclude Minimum Label

- Exclude Maximum Label

- Descending Axis

- Show axis line

- Show zero line

- Custom Baseline (Value)

You can edit the color, weight, and style of all the lines that you set in the Line Style dialog box.

4. Click OK.

The axis advanced options are set accordingly.
Formatting a Frame and a Background

The frame of a chart is the area that contains the plot points. It is also the area in which horizontal and vertical gridlines are drawn.

The background of a chart is the area around the frame.

You can adjust the appearance of the frame and background to achieve different visual effects for your charts. For example, you can change the appearance of the chart frame line, or you can change the color of the background of your chart, as shown in the following image.

Frame & Background Dialog Box

Whether you access frame and background options from the ribbon, or the shortcut menu, you are presented with the Frame & Background dialog box of options for formatting the frame and background of a chart. The Frame & Background dialog contains the following tabs:

- Frame
- Frame Edge
- Background
The Frame & Background dialog box and pertinent tabs are discussed in this section for the following types of charts:

- 2D Charts and 2D Charts with 3D Effects (Frame and Frame Edge tabs)
- Pie Charts (Frame and Frame Edge tabs)
- 3D Charts (Left Wall, Right Wall, Floor, and Advanced tabs)

**Note:** The options in the Frame tab vary based on the chart type selected.

Use the Frame tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts.

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

- **Depth Angle.** Enter the angle from the front of the chart to the back where the chart risers and frames are drawn. You can set the depth angle from zero to 180 degrees, but it must be used along with Depth Radius.
  
  The depth angle in 3D charts can only be changed when using the HTML, PDF, PowerPoint, and Excel output formats.

- **Depth Radius.** Enter how far out the extruded frame will be extended. Small values, such as zero, produce very narrow charts. Large values, the maximum being 100, produce thicker charts.

**Fill**

- **No fill.** (Default). Select this option to keep the legend colorless.

- **Solid fill.** Select this option to display the Color and Transparency options.
  
  - **Color.** Click this icon to open the Color dialog box, where you can select a color for a frame.
  
  - **Transparency.** Move the slider to make the frame opaque (0%) or transparent (100%). The default is 0%.

- **Gradient fill.** Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.
  
  - **Direction.** Select from this drop-down menu to set the direction of the gradient fill. For example, Gradient right or Gradient left.
Gradient style

- **Color Pattern.** Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.

- **First Color.** Click this icon to open the Color dialog box, where you can select a color for the first color.

- **Second Color.** Click this icon to open the Color dialog box, where you can select a color for the second color.

Shadow

- **Show Shadow.** Select this option to set a shadow.

Use the Frame Edge tab for 2D charts and 2D charts with 3D effects to set a frame depth angle and depth radius, select a fill for a frame, and set a shadow for a frame for these types of charts.

The Frame Edge tab for 2D charts and 2D charts with 3D effects contains the following options:

- **Automatically Shade Frame Edge.** Select this option to automatically shade the frame edge. Clear this option to enable the Side Frame and Bottom Frame options.

Side Frame

- **Show Color.** Select this option to show the color of the side frame.

- **Color.** Click this icon to open the Color dialog box, where you can select a color for the side frame.

- **Show Border Color.** Select this option to show the color of the border of the side frame.

  The border color only displays when using the HTML, PDF, PowerPoint, and Excel output formats.

- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the side frame.

Bottom Frame

- **Show Color.** Select this option to show the color of the bottom frame.

- **Color.** Click this icon to open the Color dialog box, where you can select a color for the bottom frame.
Show Border Color. Select this option to show the color of the bottom frame.

The border color only displays when using the HTML, PDF, PowerPoint, and Excel output formats.

Border Color. Click this icon to open the Color dialog box, where you can select a color for the border of the bottom frame.

Use the Frame tab for pie charts to set pie depth and tilt, select a fill and color for a pie frame, and set a shadow for the frame.

Note: This is only available for pie charts in HTML format.

The Frame tab is shown in the following image.

The Frame tab for pie charts contains the following options:

Pie Depth. Set the depth of the edge of a pie chart. You can select a value from zero to 100 to set the thickness of an edge.

Pie Tilt. Set the tilt of the pie chart. The smaller the value you add, the flatter the pie chart appears. The larger the value you add, more of the pie edge appears.

Fill

No fill. (Default). Results in no color added to the edge of the pie.
Solid fill. Select this option to display the Color and Transparency options.

- **Color.** Click this icon to open the Color dialog box, where you can select a color for the frame.

- **Transparency.** Move the slider to make the fill opaque (0%) or transparent (100%). The default is 0%.

Gradient fill. Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.

- **Direction.** Select from this drop-down menu to set the direction of the gradient fill. For example, Gradient right or Gradient left.

Gradient Style

- **Color Pattern.** Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.

- **First Color.** Click this icon to open the Color dialog box, where you can select a color for the first color.

- **Second Color.** Click this icon to open the Color dialog box, where you can select a color for the second color.

Shadow

- **Show Shadow.** Select this option to set a shadow around the frame.

Use the Frame Edge tab for pie charts to set the edge of a pie frame.

The Frame Edge tab for pie charts contains the following options:

- **Automatically Shade Frame Edge.** Select this option to automatically shade the frame edge. Clear this option to enable the Side Frame and Bottom Frame options.

- **Show Color.** Select this option to show the color of the side frame.

- **Color.** Click this icon to open the Color dialog box, where you can select a color for side frame.

- **Show Border Color.** Select this option to show the color of the border of the side frame.
Formatting a Frame and a Background

- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the side frame.

**Bottom Frame**

- **Show Color.** Select this option to show the color of the bottom frame.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the bottom frame.
- **Show Border Color.** Select this option to show the color of the bottom frame.
- **Border Color.** Click this icon to open the Color dialog box, where you can select a color for the border of the bottom frame.

Use Wall and Floor tabs to set the walls and floor of a 3D chart.

The Left Wall tab is shown in the following image:

These Wall and Floor tabs contain the following options:

- **Show Wall** or **Show Floor.** Select this option to show the wall or floor (depending on the tab) of the 3D chart.
- **Wall Thickness.** Specify the thickness of the wall or floor.
- **Cube Size.** Specify the cube size of the wall or floor.
- **Color.** Click this icon to open the Color dialog box, where you can select a color for the wall or floor.
Border Color. Click this icon to open the Color dialog box, where you can select a color for the border of the wall or floor.

Show Wall (Left Wall). Select this option to show the left wall.

Show Wall (Right Wall). Select this option to show the right wall.

Show Floor. Select this option to show the floor.

Use the Advanced tab for 3D charts to modify additional properties for 3D frames.

The Advanced tab contains the following options:

Viewing Angles. Select from a drop-down menu of viewing angles for three-dimensional charts. For example, Standard or Group View.

Isometric Projection. Select this option to ignore perspective distortion in a project graph cube from an isometric view.

Proportional Cube. Select this option to define the axis size proportional to the number of series or groups.

Automatic shading of walls. Select this option to shade chart walls.

Automatically Shade Frame Edge. Select this option to automatically shade the frame edge.

3D Zoom Factor. Enter a value in the text box to set the global scaling factor for zooming in and out in a 3D chart. Smaller values zoom out and produce a smaller display of the chart within a frame. Larger values zoom in and produce a larger display of the chart within a frame.

Pan Horizontally. Enter a value in the text box to pan a 3D chart in the horizontal direction. Smaller values move the frame of the chart to the left. Larger values move the frame of the chart to the right.

Pan Vertically. Enter a value in the text box to pan a 3D chart in the vertical direction. Smaller values move the frame of the chart upward. Larger values move the frame of the chart downward.

Use the Background tab to set and customize a border for a chart.

The Background tab contains the following options:

Show Border Color. Select this option to show the color of the border.

Border Color. Click this icon to open the Color dialog box, where you can select a color for the border.
Solid fill. Select this option to display the Color and Transparency options.

- Color. Click this icon to open the Color dialog box, where you can select a color for the frame.

- Transparency. Move the slider to make the background opaque (0%) or transparent (100%). The default is 0%.

Gradient fill. Select this option to display the direction of the gradient, the color pattern of the gradient, and the degrees of transparency for the two colors that make up the gradient. A gradient is a smooth color transition or blending of one color to another. The number of colors to use in a gradient is defined by the stop or pin elements.

- Direction. Select from this drop-down menu to set the direction of the gradient fill. For example, Gradient right or Radial.

Gradient Style

- Color Pattern. Select the color pattern for the data series. The color pattern option on the left is an AB wash that uses two colors in the pattern color1 - color2, for example, red-green. The color pattern option on the right is an ABA wash that uses two colors in the pattern color1 - color2 - color1, for example, red-green-red.

- First Color. Click this icon to open the Color dialog box, where you can select a color for the first color.

- Second Color. Click this icon to open the Color dialog box, where you can select a color for the second color.

For instructions on how to open this dialog box, see the procedures in Using Frame and Background Properties on page 233.

Frame and Background Shortcut Menu

When you right-click a chart background, a menu of options opens. The options for the background and frame elements are described in the following table.
<table>
<thead>
<tr>
<th>Element</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Background</td>
<td>Background Color</td>
<td>Enables you to specify the color of the background, using the Color dialog box. For instructions, <em>How to Change the Color of the Background</em> on page 234.</td>
</tr>
<tr>
<td></td>
<td>Show legend</td>
<td>Controls the display of the legend on the background. When selected, it displays the legend. When cleared, it suppresses the display of the legend.</td>
</tr>
<tr>
<td></td>
<td>More Frame and Background Options</td>
<td>Opens the Frame &amp; Background dialog box. For more information, see <em>Frame &amp; Background Dialog Box</em> on page 225.</td>
</tr>
<tr>
<td>Frame</td>
<td>Frame Color</td>
<td>Enables you to specify the color of the frame, using the Color dialog box. For more information, see <em>Using the Color Dialog Box</em> on page 371.</td>
</tr>
<tr>
<td></td>
<td>Show 3D</td>
<td>Controls the depth of the frame. The value On renders the frame in 3D depth. The value Off renders the frame in one dimension.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>For instructions, see <em>How to Set 3D Depth on a Bar Chart</em> on page 246.</td>
</tr>
<tr>
<td></td>
<td>More Frame &amp; Background Options</td>
<td>Opens the Frame &amp; Background dialog box. For more information, see <em>Frame &amp; Background Dialog Box</em> on page 225.</td>
</tr>
</tbody>
</table>

**Using Frame and Background Properties**

The following sections contain procedures for customizing frame and background properties. The options for the following procedures are found in the Features group of the Format tab.
Procedure: How to Change the Color of the Frame

The default color of the frame in a chart is determined by the Document Theme selected in the Options dialog box. For more information, see Changing InfoAssist User Preferences on page 28.

This procedure describes how to change the color of the frame.

1. Create a chart.
2. Access the Frame & Background dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Frame & Background.
   - **Shortcut Menu:** Right-click the chart, and click More Frame & Background Options.

   The Frame & Background dialog box opens.

3. On the Frame tab, in the Fill section, click Solid fill, and then click the Color icon.

   The Color dialog box opens. Select a new color for the frame. For more information on the Color dialog box, see Using the Color Dialog Box on page 371. You can also set the depth angle and depth radius for the frame, as well as set a shadow for the frame.

4. Click OK.

   The chart displays the new frame color.

Procedure: How to Change the Color of the Background

The default color of the background of a chart is determined by the Document Theme selected in the Options dialog box. For more information, see Changing InfoAssist User Preferences on page 28.

1. Create a chart.
2. Open the Frame & Background dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Frame & Background.
   - **Shortcut Menu:** Right-click the background of the chart, and click More Frame & Background Options.

   The Frame & Background dialog box opens.

3. On the Background tab, in the Background Fill section, click the Color icon.

   The Color dialog box opens. Select a new color for the background. For more information on the Color dialog box, see Using the Color Dialog Box on page 371.

4. Click OK.
The chart displays the new background color.

**Formatting a Gauge Chart**

A gauge chart is a circular chart that indicates the current position of a single data value within a given spectrum.

A gauge chart is shown in the following image.

![Gauge Chart Image]

You can change the appearance of a gauge chart by using the gauge chart options found on the Format Gauge dialog box. To access the Format Gauge dialog box, on the Format tab, in the Features group, click Gauges.

**Format Gauge Dialog Box**

Whether you access gauge options from the ribbon, or the shortcut menu, you are presented with the Format Gauge dialog box of options for formatting a gauge chart. Such options include setting and styling a title for the gauge chart, setting tick marks, enabling and styling color bands, as well as setting advanced options, such as the gauge start and stop angle.

The Format Gauge dialog box contains the following tabs:

- General Options
Axis Scale & Labels

Tick Marks

Bands

Advanced

Use the General Options tab to set general gauge options.

The General Options tab contains the following options:

- **Gauges per row.** Enter or select how many gauges appear on each row. The default setting displays two gauge charts. A maximum of 32 gauge charts can appear on each row.
  
  **Note:** The number of charts displayed per row can differ, based on the output format selected. For example, HTML format will display two charts per row, and HTML5 will display four.

**Gauge Title**

- **Show title.** (Default) Displays a gauge title appear for each gauge. Clear this option to suppress the title.

- **Position.** Select a position for the gauge title. Above is the default value.

- **Style.** Click this icon to open the Style dialog box, where you can style text.

**Gauge value**

- **Show value.** (Default) Clear this option to suppress the gauge value.

- **Style.** Click this icon to open the Style dialog box, where you can style text.

- **Format Value.** Contains a list of preset formats that can be applied.

- **Custom Format.** Allows you to use a custom format. This option is activated when Use Pattern /100 and Use Pattern are selected as the format labels.

Use the Axis Scale & Labels tab to set the axis scale and label properties for the gauge needle.

The Axis Scale & Labels tab contains the following options:

**Scale**

- **Automatic Minimum.** (Default) Sets the engine to automatically supply the minimum value on the scale. Clear this option to manually set the minimum value by entering a number into the Value text box.
- **Value.** Enter the minimum value in this text box if you have not selected Automatic Minimum.

- **Automatic Maximum.** (Default) Sets the engine to automatically supply the maximum value on the scale. Clear this option to manually set the maximum value by entering a number into the Value text box.

- **Value.** Enter the maximum value in this text box if you have not selected Automatic Maximum.

**Labels**

- **Show Labels.** (Default) Displays labels next to the axis. Clear this option to suppress labels.

- **Style Labels.** Click this icon to opens the Style dialog box, where you can style text.

- **Format Labels.** Select from a drop-down menu of present formats that can be applied to the labels. When a custom format is selected, the format must be defined using a custom format pattern. For a list and description of the characters that you can use in a custom format, see the table in *Formatting Data Labels* on page 190.

- **Custom Format.** Text field to enter the custom format that you want to use.

The Tick Marks tab contains options to format tick marks on a gauge chart.

The Tick Marks tab contains the following options for both major and minor ticks:

- **Automatic Grid Step.** (Default) Automatically calculates the number of major grid steps in a gauge chart. Clear this option to manually set the value by entering a number in the Value text box.

- **Value.** Enter the value in this text box if you have not selected Automatic Grid Step.

- **Tick Color.** Click this icon to open the Color dialog box, where you can select a color for the tick marks.

- **Tick Mark Length.** Enter a value for the relative length of major tick marks in a gauge chart. The valid range is from 0.0 to 0.5. If you set the smallest value, major tick marks do not appear.

The Bands tab contains options to format the color of the scale background on a gauge chart.
The Bands tab contains the following options:

- **Band 1.** Opens a drop-down menu of available bands.
  - **Add.** Adds the band selected from the drop-down menu of bands to the gauge chart. You can create up to five bands for a gauge chart.
  - **Remove.** Removes the band selected from the drop-down menu of bands to the gauge chart.

- **Minimum Value.** Enter a minimum value to a quality band in the gauge chart.
- **Maximum Value.** Enter a maximum value to a quality band in the gauge chart.
- **Border Color.** Opens the Color dialog box, where you can edit the color of the gauge band border.

**Fill**

- **No fill.** Removes fill from the quality band.
- **Solid fill.** (Default) Applies a solid color to the quality band.
- **Color.** Click this option to open the Color dialog box, where you can select the color for the quality band.
- **Transparency.** Move the slider to make the band opaque (0%) or transparent (100%). The default is 0%.

The Advanced tab contains options to set additional properties for the gauge needle.

The Advanced tab contains the following options:

- **Descending Axis.** Select this option to draw the gauge scale in descending order. When this option is cleared (default), the gauge scale is drawn in ascending order.
- **Show Zero Label.** Displays the zero label on the axis scale. Clear this option to start the gauge at another value. This is the default.
- **Gauge Center by Quality.** Select this option to have the center of the gauge needle appear in the same the color as the band to which it is pointing. This option is available for HTML charts only.
- **Gauge Start Angle.** Enter a value to rotate the gauge start angle to a specified number of degrees. Values can range from 0 to 359 degrees. The default is 220 degrees.
- **Gauge Stop Angle.** Enter a value to rotate the gauge stop angle to a specified number of degrees. Values can range from 0 to 359 degrees. The default is 320 degrees. Setting a start angle to 0, and a stop angle to 180, creates a semi-circle.

- **Relative Inner Radius.** Enter a value to define the inner radius of the gauge bands and labels relative to the outer background of the gauge. Smaller values, such as 0.0, place the inner radius closer to the center of the gauge. A maximum value of 1.0, places the inner radius close to the gauge outline.

- **Relative Thickness.** Enter a value to define the relative thickness of the gauge bands. Values can range from 0.0 to 1.0.

- **Same Size Gauges.** This option applies to multi-category gauge charts. If you are working with three or more gauges per row, you can select this option to have the gauges display in the same size.

### Gauge Elements Shortcut Menu

When you right-click a gauge chart, a menu containing the More Gauge Options becomes available. Select this option to open the Format Gauge dialog box. This is only available when using the HTML output format.

### Using Gauge Properties

The following sections contain procedures for gauge properties. The Gauges option can be found on the **Format** tab, in the **Features** group.

**Note:** This option is only available when you are working with a gauge chart.

**Procedure:** How to Set the Number of Gauges Per Row

If you have multiple gauges on a chart, you might want to specify how many gauges appear on each row.

1. Create a gauge chart that has multiple values.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the **Format** tab, in the **Features** group, click **Gauges**.
   - **Shortcut Menu:** Right-click the gauge chart and select **More Gauge Options**.

   The Format Gauge dialog box opens.
3. On the General options tab, in the Gauges per row field, enter or select the number of gauges that you want to appear on one row.
4. Click OK.

The gauges now appear on one row.

After changing the setting from the default of 2 gauges per row to 3 gauges per row, all the charts now appear on one row.

Procedure: How to Set the Minimum and Maximum Axis Scale Values

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:

   - **Ribbon:** On the *Format* tab, in the *Features* group, click *Gauges*.
   - **Shortcut Menu:** Right-click the gauge chart, and click *More Gauge Options*.

   The Format Gauge dialog box opens.

3. On the Axis Scale & Labels tab, in the Scale area, either accept the minimum and maximum values for the scale automatically supplied by the chart engine, or enter your own in the *Value* fields.

4. Click *Apply*.

   The gauge scale reflects the selections that you have made.

Procedure: How to Style Axis Labels

1. Create a gauge chart.

2. Open the Style dialog box in one of the following ways:

   - **Ribbon:** On the *Format* tab, in the *Features* group, click *Gauges* to open the Format Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In the Labels area, click the *Style Labels* icon.
   - **Shortcut Menu:** Right-click an axis label, and click *Style*.

   The Style dialog box opens.

3. Select your styling options.

4. Click *OK*.

   The scale labels reflect the style selections that you have made.

Procedure: How to Format Axis Labels

1. Create a gauge chart.
2. Access the menu of available format options for axis labels in one of the following ways:

- **Ribbon:** On the *Format* tab, in the *Features* group, click *Gauges* to open the Format Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab. In the Labels area, open the *Format Labels* drop-down menu.

- **Shortcut Menu:** Right-click an axis label, and point to *Format.*

The menu of available format options opens.

3. Select your format option.

   **Note:** If you select a custom format (for example, Use Pattern, or Use Pattern /100), from the Format Labels menu on the Format Gauge dialog box, the Custom Format menu becomes available. When you select a custom format, it must be defined using a custom format pattern. For a list and description of the characters that you can use in a custom format, see the table in *Formatting Data Labels* on page 190.

4. Click *OK.*

   The scale labels reflect the format selection that you have made.

**Procedure:** How to Rotate Axis Labels

1. Create a gauge chart.
2. Right-click an axis label.
3. On the shortcut menu, point to *Rotate,* then select the degree to which you want the labels rotated.

**Procedure:** How to Set Gauge Tick Marks

This procedure describes how to set the grid step, tick color, and tick length for the major and minor tick marks.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:

   - **Ribbon:** On the *Format* tab, in the *Features* group, click *Gauges.*

   - **Shortcut Menu:** Right-click the gauge chart and select *More Gauge Options.*

   The Format Gauge dialog box opens.
3. On the Tick Marks tab, for the *Automatic Grid Step,* either accept the value automatically supplied by the chart engine, or enter your own, in the Value fields.
4. Click the *Tick Color* icon, to open the Color dialog box, where you can select a color for the tick mark.
5. For the Tick Mark Length, either accept the value automatically supplied by the chart engine, or enter your own, in the Value fields.

**Procedure: How to Set Gauge Color Bands**

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the **Format** tab, in the **Features** group, click **Gauges**.
   - **Shortcut Menu:** Right-click the gauge chart, and click **More Gauge Options**.

   The Format Gauge dialog box opens.
3. On the Bands tab, set the minimum and maximum value for each band that you want to appear on the gauge chart.
4. Set the color of the fill and border for each color band.
   - **Note:** The gradient fill option is not available for color bands.
5. Click **OK** to close the Format Gauge dialog box.

   The bands are formatted accordingly.

**Procedure: How to Match Needle Center Color to Band Color (Gauge Center by Quality)**

This option matches the needle center color to the color of the band that the needle is pointing to.

1. Create a gauge chart.
2. On the **Format** tab, in the **Features** group, click **Gauges**.

   The Format Gauge dialog box opens.
3. On the Bands tab, set the minimum and maximum value for each band that you want to appear on the gauge chart.
4. Set the color of the fill and border for each color band.
   - **Note:** The gradient fill and transparency options are not available for gauge needles.
5. On the Advanced tab, select **Gauge Center by Quality**.
   - **Note:** This option displays in HTML, but not in HTML5.
6. Click **OK** to close the Format Gauge dialog box.

   The color of the center of the gauge needle now matches the color of the band.
Procedure: How to Style a Gauge Needle

This procedure explains how to change the gauge needle from the Normal style to the Pencil style.

1. Create a gauge chart.
2. Open the Format Gauge dialog box in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click Gauges.
   - **Shortcut Menu:** Right-click the gauge chart, and click More Gauge Options.
3. The Format Gauge dialog box opens.
4. In the General Options tab, in the Gauge Needle section, from the Style drop-down menu, select Pencil.
5. Click OK.
   The gauge needle changes to a pencil.

Procedure: How to Set Gauge Needle Colors in a Multi Series Gauge Chart

You cannot change the fill color and border color of the needles in a multi-series gauge chart through the General Options tab of the Format Gauge dialog box. You can do so through the Format Series dialog box. However, you can still use the General Options tab to change the style of the needle.

1. Create a gauge chart with more than one measure field.
2. On the Series tab, from the Series drop-down menu, select the series that you want to style.
3. In the Style group, click Style.
   The Format Series dialog box opens.
4. On the Fill tab, select the fill and color options for the gauge needle for the selected series.
5. On the Border tab, select the Show Border Color option, if you want the gauge needle to have a border. You can select the color for the border, as well.
6. Click Apply.
7. Repeat steps 2 through 5 for each series gauge needle that you want to style.
8. When you are finished, click OK to close the Format Series dialog box.
   The color of the gauge needles and their borders changes accordingly.
Formatting Page Headings and Page Footings

Page headings and page footings supply context and key information about a chart, such as its purpose, audience, and author. Page headings and page footings also enhance visual appeal.

**Procedure:** How to Add a Page Heading and Page Footing to a Chart

The procedure uses sample values, but you can supply values that apply to your own charts.

This feature is available in Query Design view, Live Preview, and Document mode.

1. Create a chart.
2. On the **Home** tab, in the **Report** group, click **Header & Footer**.

   The Header & Footer dialog box opens.

   **Tip:** Another way to access the Heading & Footing dialog box is to click the arrow next to the Header & Footer button. Doing so opens a drop-down menu from which you can select the heading or footing that you want to work with. After you make your selection, the Header & Footer dialog box opens, and the heading or footing that you selected is active.

3. Click the tab for the page heading or page footing, depending on which you want to add.

   By default, the Page Heading tab is selected. In this procedure, accept the default to add a page heading first.

4. Click inside the design area of the dialog box, and type the text for the page heading.

   For example, the text for a sample page heading might be Customers By Occupation.

5. Using the styling options, apply styling to the page heading text.

   For example, 14 pt. bold Helvetica with center alignment.

6. Click **Apply** to save the changes that you have made, without closing the dialog box.

7. To add a page footing, click the **Page Footer** tab.

   For this procedure, you are going to add one of the supplied quick text options, followed by some text of your own.

8. Click the down arrow next to the preformatted text button, and click **Created by** from the drop-down list.

9. Complete the text by typing the applicable value within the supplied text, for example, Sales Manager.

10. Change the styling as you want.

11. Click **OK** to save the page heading and page footing and close the Header & Footer dialog box.

   The chart contains the page heading and page footing that you added and styled.
The following image shows a chart with a styled header and footer.

12. To make changes to either the page heading or page footing, return to Design view. Right-click the header or footer, and click Edit from the drop-down menu.

**Procedure: How to Control the Rendering of a Page Heading and Page Footing**

You can control the way in which a page heading and page footing are rendered on a chart at run time.

1. Create a chart.
2. Open the Header & Footer dialog box, as described in *How to Add a Page Heading and Page Footing to a Chart* on page 244.
3. Click the Text options for chart button.

   A drop-down menu, with two options for rendering the page heading and page footing, opens.

   **Tip:** Your selection for a page heading also applies to a page footing, and vice versa.

   - Create Header and Footer as text renders the heading and footing as text elements that are separate from the chart image.
   - Embed Header and Footer in the chart renders the heading and footing text as part of the chart image. This is the default value.
4. Click OK to save your selection and close the Heading & Footing dialog box.

**Using Additional Formatting Features**

This section describes additional formatting features that are available for charts.

**Procedure:** How to Set 3D Depth on a Bar Chart

You can apply a 3D-effect to a 2D-chart.

**Note:** If you find that the depth of the 3D effect makes it difficult to distinguish the values on the Y-axis scale, then you can turn this option off. This procedure explains how to set the 3D effect for a default vertical bar chart.

The following image shows a bar chart before the 3D effect is applied.

![Bar Chart Before 3D Effect](image)

1. Create a 2D chart.

2. In Live Preview, apply the 3D effect in one of the following ways:
   - **Ribbon:** On the Format tab, in the Features group, click 3D Effect.
   - **Shortcut Menu:** Right-click the frame of the chart, point to Show 3D, and click On.
The 3D effect is applied to the chart, as shown in the following image.

**Procedure:** How to Rotate a Chart

You can rotate bar, line, and area charts to change the orientation of the data.

1. Create a chart.
2. On the **Format** tab, in the **Features** group, click **Rotate**.

   The chart is rotated 90 degrees clockwise.

**Procedure:** How to Sort a Chart by Total Value

Once you create a bar, line, or area chart, you can sort the results in ascending or descending order. While this feature was implemented specifically for Stacked Bar charts, it also applies to other chart types, as previously mentioned. This feature enables you to view your data in numerical order, allowing you to identify trends and determine what data points are priorities.

**Note:** This feature is available in Chart and Visualization mode.

1. Create a bar, line, or area chart with at least one measure and one dimension.
2. In the Query pane, right-click on the **Horizontal Axis** and select **Sort by Total Value**.
3. From the cascading menu, select *Ascending* to sort the chart from the lowest value to the highest value, as shown in the following image.

![Chart Image]

4. Select *Descending* to sort the chart from the largest value to the lowest value.

**Procedure:** How to Display a Static Reference Line

Reference lines draw attention to specific data locations on a chart. You can add up to three horizontal (X axis) and three vertical (Y axis) reference lines to a chart.

Reference lines can be created using either a constant or a computed field.

Field values allow a property to be dynamic, so that the reference line can change position dynamically on the chart depending on the value of the field that is assigned to it.

**Note:** A reference line value should be a single value, such as 10K, for example. In the Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for example), then InfoAssist plots the last value on the chart.

1. Create a chart.
2. On the *Format* tab, in the *Features* group, click *Reference*.
3. In the drop-down menu that opens, select one of the following:
   - Add Reference Line to Y-Axis
Add Reference Line to X-Axis

The Reference Line dialog box opens, as shown in the following image.

4. Create the reference line with a static value that you set.
   a. Select the Value option.
   b. In the Value text field, type the value that you want to distinguish with the reference line.

5. In the Text field, type the text for the reference line.

6. In the Position drop-down menu, select the position for the reference line on the chart. For example, Above Center.

7. Click the Style button to set the style for the reference line. For example, Solid.

8. Click the Color button to open the Color dialog box, where you can select a color for the reference line and the text.

9. Click the Weight button to select the weight of the reference line. For example, 1px - Light.

10. Click OK to save the options that you have selected, and close the Reference Line dialog box.

   The reference line is added to the chart.

   The following image shows a bar chart for accessories and camcorders, revenue for which exceeds 15 million dollars.
Procedure: How to Display a Dynamic Reference Line

Reference lines can be created using either a constant or a computed field.

Field values allows a property to be dynamic, so that the reference line can change position dynamically on the chart depending on the value of the field that is assigned to it.

Note: A reference line value should be a single value, such as 10K, for example. In the Reference line dialog box, if you select a field with multiple values, (Quantity Sold, for example), then InfoAssist plots the last value on the chart.

The following procedure provides an example of how to create a dynamic reference line, where the value changes based on the date. In this example, you can track the number of estimated delivery days per shipping company, where the number of days estimated for delivery are based on whether or not the sale date is a holiday.

1. Create a COMPUTE field to calculate the Reference Line.
   a. On the Data tab, in the Calculation group, click Summary (Compute).
      The Summary Field (COMPUTE) dialog box opens.
   b. In the Field text box, enter Reference.
   c. Set the format to D12.2.
   d. Enter IF WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_HOL EQ 'Y' THEN 5 ELSE 2 into the expression.
   e. Click OK to close the dialog box.
2. Hide the Reference field from the chart.
3. Add a dynamic reference line.
   a. On the Format tab, in the Features group, click Reference.
      The Reference Line dialog box opens.
   b. From the drop-down menu, select Add Reference Line to Y-Axis.
      The Reference Line dialog box opens.
   c. Select the Field option.
   d. From the Field drop-down menu, select Reference.
   e. In the Text field, enter Acceptable.
   f. From the Weight drop-down menu, select 2px - Medium.
   g. From the Position drop-down menu, select Above Left.
   h. Optionally, you can change the color and style of the Reference line.
   i. Click OK to close the Reference Line dialog box.
4. Run the chart.
   The reference line displays.

Procedure: How to Display Annotations

Annotations are explanatory notes or comments. You can add up to eight annotations on a chart.

1. Create a chart.
2. On the Format tab, in the Features group, click Annotate.
3. In the drop-down menu that opens, click Add an annotation.
   The Annotation dialog box opens.
4. In the text input field, type the text for the annotation.
5. In the Position drop-down menu, select the position for the annotation on the chart. For example, Top Left.
6. Click OK to save the options that you selected, and close the Annotation dialog box.
   The annotation is added to the chart.
7. Click Run to generate the report.
   The following image shows a chart with an annotation in the middle right position.
Creating and Customizing Documents

Designing documents in Document mode allows you to add text, images, form controls, reports, and charts to create documents that can be used to generate presentation-ready reports based on your data.

Document mode combines the features of report building with the ability to style and present customized documents.

In this chapter:

- Accessing Document Mode
- Building a Document
- Building Infographics in InfoAssist

Accessing Document Mode

In Document mode, you can:

- Build a new document.
- Open an existing document.
- Generate a new document from an existing single report.
A blank InfoAssist canvas in Document mode is shown in the following image.

Procedure: How to Access Document Mode to Build a New Document

You can build new documents by accessing Document mode from the InfoAssist splash screen.

1. Click Build a Document.
   
The Open dialog box opens.
2. Select a data source to begin building your document.

   **Note:** Documents can be built using more than one data source. The source you select here is the one you will begin with, but you can add more at any time. For more information on adding additional data sources, see Data Tab on page 39.
3. Click Open.
   
   InfoAssist opens a new canvas in Document mode.

Procedure: How to Access Document Mode by Opening an Item From the Splash Screen

You can access existing documents in Document mode from the InfoAssist splash screen.

1. Click Build a Document.
   
   The Open dialog box opens.
2. On the Quick Access toolbar, click *Create new report, chart, document or visualization.*
   The splash screen displays.

3. Click *Open Existing Item.*
   The Open dialog box opens.

4. Select one of the documents. Documents are represented by the Document icon.
5. Click *Open.*
   InfoAssist opens the document in Document mode.

   **Note:** If you select a single report in step 3, InfoAssist opens the report in either Query Design view or Live Preview. To view a copy of the report in Document mode, see *How to Access Document Mode From the Document Button on the Home and View Tabs* on page 255.

**Procedure:** How to Access Document Mode by Opening a Report From the Quick Access Toolbar

You can access documents in Document mode from the InfoAssist Quick Access Toolbar.

1. With InfoAssist open, click *Open existing item* from the Quick Access Toolbar.
   An Open dialog box appears.

2. Select one of the documents, which are represented by the Document icon.
3. Click *Open.*
   InfoAssist opens the document in Document mode.

   **Note:** If you select a single report in step 2, InfoAssist opens the report, in either Query Design view, or Live Preview. To view a copy of the report in Document mode, see *How to Access Document Mode From the Document Button on the Home and View Tabs* on page 255.

**Procedure:** How to Access Document Mode From the Document Button on the Home and View Tabs

With InfoAssist open in Live Preview or Query Design view, you can access Document mode by clicking the *Document* button in the Design group. The Design group appears on both the Home and View tabs.

Accessing Document mode by clicking the Document button creates a copy of the current single report as a document. You can use this method to promote the content of a report to a document.
You can also access Document mode in Reporting Objects by following this procedure.

**Note:** When a Reporting Object is promoted to Document mode, any reports and charts that the Reporting Object has are added to the canvas.

1. With an InfoAssist report open, click either the *Home* tab, or the *View* tab.
2. In the *Design* group, click *Document*.

InfoAssist enters Document mode.

**Note:** The single report you started with still exists in the original mode. Selecting Document mode while a single report is open does not convert the report to a document. It makes a copy of the report, with the copy becoming a document and the original remaining unchanged.

You can switch between the new document and the original report using the *Switch Report* button. The Switch button is found on the *View* tab, in the *Report* group. You can also switch between the document and the report using the Reports button on the status bar. For more information on switching between reports, see *View Tab* on page 41.

### Building a Document

Document mode allows you to build multiple reports and charts on the same canvas. The styling, design, and report building functionality of Live Preview and Query Design view is available in Document mode.

In addition, there are many other features that simplify building documents. You can build and insert multiple reports in the form of reports and charts into documents. You can also insert images and text for presentation and organizational purposes.

### Inserting Reports From Multiple Data Sources

With InfoAssist opened in Document mode, you can insert multiple charts and reports onto the canvas. These reports can be from different data sources. With documents, you have the option to add additional data sources to the document.

In order to insert reports from different data sources, the document must have multiple data sources loaded. For more information on adding and switching between data sources, see *Data Tab* on page 39.

**Note:** You cannot use multiple data sources when working with a Reporting Object.
Procedure: How to Insert Two Reports From Two Different Data Sources

A document can display multiple reports from multiple data sources in the same document.

1. With InfoAssist open in Document mode, click the Insert tab and select Chart or Report.

2. If your document has only one data source, insert additional data sources.
   
   For more detailed instructions on inserting multiple data sources, see Data Tab on page 39.

3. Switch to a data source different than the one used in step 1.
   
   For more detailed instructions on switching to a different data source, see Data Tab on page 39.

4. Insert a chart or report using this new data source, following the instructions given in Inserting a New Report on page 257.
   
   Your document is now populated with reports that have data from different data sources. You can add as many data sources as you need.

Inserting a New Report

With InfoAssist opened in Document mode, you can insert multiple charts and reports onto the canvas. The procedures in the following sections detail how to insert reports into documents.

In Document mode, you can insert a report in the following ways.

- Use the Insert tab.
- Double-click a data source field.
- Drag a data source field onto the canvas.

Note: When you use the Insert tab or double-click a data source field, a report placeholder is added to the canvas.

Dragging a data source field onto the canvas inserts the place holder at the location you dropped it.

The following procedures describe how to insert new reports. For more information on how to edit existing reports, see How to Style and Customize a Report on page 265.

Procedure: How to Insert a Report

Do one of the following, while in Document mode:

- On the Insert tab, in the Reports group, click Report. Add fields to the placeholder report.
On the Home tab, in the Format group, click Report. Double-click a data source to automatically create a report with that data.

On the Home tab, in the Format group, click Report. Drag a field to the canvas to create a report.

Inserting a New Chart

With InfoAssist opened in Document mode, you can bring multiple charts and reports onto the canvas. The procedures in the following sections describe how to insert charts into documents.

In Document mode, you can insert a chart in the following ways:

- Use the Insert tab.
- Double-click a data source field.
- Drag a data source field onto the canvas.

Note: When you use the Insert tab or double-click a data source field, a chart placeholder is added to the canvas.

Dragging a data source field onto the canvas inserts the placeholder at the location you dropped it.

The following procedures describe how to insert new charts. For more information on how to edit existing charts, see How to Style and Customize a Chart on page 266.

Procedure: How to Insert a Chart

1. Do one of the following, while in Document mode:

- On the Insert tab, in the Reports group, click Chart. Add fields to the placeholder chart.
- On the Home tab, in the Format group, click Chart. Double-click a data source to automatically create a chart with that data.
- On the Home tab, in the Format group, click Chart. Drag a field to the canvas to create a chart.

2. Optionally, change the chart format using the options on the Format tab, in the Chart Types group.
Inserting an Existing Report

With InfoAssist opened in Document mode, you can insert existing charts and reports onto the canvas from the Insert tab. When inserted, these components are referenced but remain independent, supporting modular development with reusable content. Modifications must be made in the individual components separately. These updates will then be reflected in the document during generation.

Note:

- When working in Document mode, you cannot insert an existing report that has a HOLD.
- When you insert an existing report, which has already been created and is referenced via INCLUDE syntax, and then select it on the Document canvas, the data fields do not display in the Query pane.
- When you insert an existing report that contains a field specified for multi-graph, the field will be placed in the Coordinated field container, by default. If you override this field with another and save the document, this change is not written back to the existing included report. The settings in the original report will be restored when the document is restored.

The following procedure describes how you can insert reports into new documents and documents that are already populated with reports, text, and images.

**Procedure:** How to Insert an Existing Report With the Insert Tab

You can create a document in the Custom Reports section of the domain and use Standard Reports items as Existing Report components. You cannot use other Custom Report items as components.

1. With InfoAssist open in Document mode, click the **Insert** tab.
2. In the **Reports** group, click **Existing Report**.
   An Open dialog box appears.
3. Browse to the report that you want to insert and click **Open**.
   The report placeholder is added to the canvas.

   **Note:** You cannot edit an existing report that is inserted into a document.

Creating a Document From a Single Report

You can take a single report created in Live Preview or Query Design view and convert it into a document, displaying it in Document mode.
When you convert a single report into a document, the original report is preserved and a copy of that report is opened as a document in Document mode. You can then add additional reports, charts, images, and text.

Inserting Text and Images

With InfoAssist opened in Document mode, you can bring text and images onto the canvas. The following procedures describe how you can insert text and images into new documents and documents that are already populated with reports, text, and images.

**Note:** You can only do this in Document mode.

The following procedures detail how to insert text and images. For more information on how to edit existing text and images, see *Editing Components in a Document* on page 260.

**Procedure:** How to Insert Text

1. With InfoAssist open in Document mode, click the *Insert* tab.
2. In the *Objects* group, click *Text Box*.
   
   A text component is added to the canvas, containing default text.
3. Double-click, or right-click, the text component to edit the text.
   
   For more information on editing and styling the text, see *How to Edit Text* on page 266.

**Procedure:** How to Insert an Image

1. With InfoAssist open in Document mode, click the *Insert* tab.
2. In the *Objects* group, click *Image*.
   
   An Open dialog box appears.
   
   **Note:** By default, the Open dialog box displays image files in the current WebFOCUS Content folder.
3. Browse to the desired image and click *Open*.
   
   The selected image is added to the canvas.

Editing Components in a Document

The reports, controls, and text in a document can be edited, moved, resized, and deleted. Each of these components has a context menu which can be accessed by right-clicking the component.
Images can be moved, resized, and deleted, but they have no context menu and cannot be edited. Right-clicking an image brings up the option to delete it.

**Procedure: How to Resize a Component**

You can resize a component in the following ways:

- Using the component sizing handles.
- Changing the height and width on the *Layout* tab, in the *Size & Arrange* group.
- Accessing the options on the Size tab in the Size and Position dialog box.

The resize feature is available for all components that can be added to a document.

1. Open or create a document with at least one report, text component, control, or image.
2. Resize the component in one of the following ways:

   - **Sizing Handles:** Select the component and drag the sizing handles that appear around it. As you manually increase the height and width of the component, the new values appear in the corresponding text boxes in the Size & Arrange group of the Layout tab.

   - **Ribbon:** You can use the ribbon in one of the following ways:
     - Select the component in the document. On the *Layout* tab, in the *Size & Arrange* group, enter values in the Height and Width fields.
     - On the *Layout* tab, in the *Size & Arrange* group, click the dialog box launcher to open the Size and Position dialog box, as shown in the following image.

   ![Size and Position dialog box](image)

   - **Shortcut Menu:** Right-click the component and select *Size and Position*. The Size and Position dialog box opens.

   **Note:** You must right-click the corner of the component. For charts, if you click on any other point in the chart, the Size and Position option will not display.
From the Size and Position dialog box, open the Size tab, as shown in the following image.

Use the Height and Width options to change the position of the selected component. You can adjust the pixel size of the object with the Size options or the scale percentage of the object with the Scale options.

You can lock the aspect ratio using the Aspect Ratio button, which is available when working with charts, images, and text boxes while working in Document mode. With the aspect ratio locked, changing the width automatically changes the height to keep the component to scale, and changing the height automatically changes the width.

**Note:** The Auto Overflow option is only available while working with reports in Document mode through the Size & Arrange group. With Auto Overflow set, you cannot manually set the height and width of a report. The area of the report expands automatically to show all data.

When two objects are selected, the Relative Position button sets the bottom-left corner of the component that is higher on the page to the upper-left corner of the one that is lower. Once a relationship is created, arrows appear to show that relationship while both items are still selected.
**Procedure: How to Move a Component**

You can move a component by clicking it, or by accessing the Position section of the Size and Position dialog box. This feature is available for all components that can be added to a document.

You can also align components with each other so that their horizontal or vertical position matches. For more information, see *How to Align Components* on page 263.

1. Open or create a document with at least one report, text component, control, or image.
2. Select the component and move it by using one of the following methods:
   - Drag the component anywhere on the canvas.
   - Right-click the component and click *Size and Position*.
     - On the Size and Position dialog box, click the *Position* tab.
     - Use the Horizontal and Vertical options to change the position of the selected component.

**Procedure: How to Align Components**

You can align components with each other so that their horizontal or vertical positions match. You must have multiple components selected to use the align options.

The alignment is anchored by the component that is in the farthest position of the selected alignment. For example, if you select two components and click *Align Left*, the components align horizontally with the component farthest to the left.

1. Open or create a document with at least two components.
2. Select a component.
3. Select a second component by holding the Ctrl key and clicking a component.

**Note:** You can select multiple components simultaneously by holding the Ctrl key and with the left mouse dragging a selection box around the components. When you release the mouse, sizing handles appear around each component that you selected. If the components display with light-grey coloring, this indicates that the components are selected.
Sizing handles appear around the components, as shown in the following image.

4. Align the components using one of the following methods:
   - Right-click one of the selected components and select an alignment option from the Align drop-down menu, as shown in the following image.

   or

   - Access the alignment options from the Align drop-down menu. The menu is available on the Layout tab, in the Size & Arrange group.
The selected components align, as shown in the following image.

5. Click anywhere in the canvas to deselect the components.

**Procedure: How to Style and Customize a Report**

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in *How to Move a Component* on page 263. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can right-click a component to select individual fields to edit through the context menu.

In addition to reports, you can style and customize charts and text. For more information on charts, see *How to Style and Customize a Chart* on page 266. For more information on text, see *How to Edit Text* on page 266.

**Note:** Images cannot be edited.

1. Open or create a document with at least one report.
2. Click the report.

The Query pane becomes active and you can now select fields within the report. Select a field by clicking it in the canvas or in the Query pane.

For more information on styling and customizing reports, see *Creating and Customizing Reports* on page 79.
**Procedure:** How to Style and Customize a Chart

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in *How to Move a Component* on page 263. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can double-click or right-click a component to select individual fields to edit through the context menu or Field tab.

In addition to charts, you can style and customize reports and text. For more information on reports, see *How to Style and Customize a Report* on page 265. For more information on text, see *How to Edit Text* on page 266.

**Note:** Images cannot be edited.

1. Open or create a document with at least one chart.
2. Click the chart.
   
   The Query pane becomes active and you can now select fields within the chart. Select a field by clicking it in the canvas or in the Query pane.

   You can now edit the selected chart using commands available through the context menu or the ribbon.

   For more information on styling and customizing charts, see *Creating and Customizing Charts* on page 119.

---

**Procedure:** How to Edit Text

When you select a component, you can perform various functions on the component, such as moving and resizing it, as explained in *How to Move a Component* on page 263. After clicking a component, you can use the ribbon to affect all settings of the selected component, except for fields. You can right-click a component to select individual fields to edit through the context menu.

In addition to editing text, you can style and customize reports and charts. For more information on reports, see *How to Style and Customize a Report* on page 265. For more information on charts, see *How to Style and Customize a Chart* on page 266.

**Note:** Images cannot be edited.

1. Open or create a document with at least one text component.
2. Click the text box.
   
   Sizing handles appear around the border and the text box toolbar becomes active.

3. Click anywhere in the text box and begin entering text.
4. Highlight the text you would like to edit, and right-click it. A menu of options appears, as shown in the following image.

![Menu options image]

5. Using the menu options, you can style the text and insert quick text.

The text component menu options are as follows:

- **Font.** Opens a list of available fonts for the selected text.
- **Size.** Opens a list of available text sizes for the selected text.
- **Bold.** Formats the selected text in bold.
- **Italic.** Formats the selected text in italics.
- **Underline.** Underlines the selected text.
- **Text color.** Opens the Color dialog box where you can select a color for the selected text.
- **Cut.** Cuts the selected text.
- **Copy.** Copies the selected text to the clipboard.
- **Paste.** Pastes the selected text from the clipboard.
- **Date.** Opens a list of date quick text in various formats.
Procedure: How to Delete a Component

The following procedure applies to all components in Document mode.

1. Open or create a document with at least one component.
2. Right-click the component and click Delete.

The component is deleted from the canvas.

Note: You can also delete a component by clicking it and pressing the Delete key.

Building Infographics in InfoAssist

With the TIBCO WebFOCUS® – Infographics Add-on, you can produce professional infographic images. These infographic images can be built using a web-based tool that offers thousands of customizable infographic templates and design objects. Information within these infographics can then be personalized using your corporate data.

When the infographic template is built, different objects can be tagged to be replaced with your data. The template can then be uploaded into the start page and used to create a new infographic procedure that places the data elements in the designated locations. The infographic procedure is a specialized InfoAssist document in which each of the tagged objects becomes a data component in a compound document. InfoAssist provides specially designed functionality to allow you to easily fill each of these data components and generate data-driven infographic images.

For more information, see the Creating WebFOCUS Infographics technical content.

Procedure: How to Create an infographic Procedure in InfoAssist

1. On the WebFOCUS start page, in the Workspaces area, on the Other tab, click Upload File to upload the tagged template that you downloaded from the WebFOCUS Infographics Creation Tool, powered by Easel.ly.
2. On the start page, locate the uploaded template, right-click it, and then select New Infographic.
3. Once you have designated whether your data source will be based on a Reporting Object or a Master File, you will be offered to select the data source.
The infographic opens in Infographic mode, as shown in the following image.

InfoAssist opens the infographic procedure in Infographics mode, which is a specialized version of Document mode. In Infographic mode, functionality has been customized to allow users to easily create infographics.

**Note:** If you attempt to create a new infographic, based on an .ely template, that has no tagged items, InfoAssist returns an error stating that the selected template cannot be used.

**Components Supported**

When working with infographics, you can insert data into four types of objects: text, images, WebFOCUS Charts, and basic charts available from the Creation Tool. Each of these objects becomes special components in the infographic document.

- **Text objects** become report components that allow you to place a single value into the designated location in the infographic. You can define the text to be inserted by placing existing database fields or Defines containing calculated expressions into the SUM field container. Additionally, extended text can be inserted using Headers and Footers. All styling of text objects is defined in the template. On the document canvas, you will see this styling applied to the data you place in the component field containers.

- **Image objects** also become report components. These images are defined by placing fields containing image references in your Sum field container. Image references can be a database BLOB or image field, the name of an image file in the Reporting Server application path, or a URL pointing to an image file in an external location.

- **WebFOCUS charts** become chart components and can take advantage of all of the standard chart functionality. A new infographics stylesheet (infographics.sty) is available as a good starting point to style your infographic charts, taking into account the limited real estate available.

- **Basic charts available from the Creation Tool** become limited chart components. As with the text objects, all styling is defined in the template. In InfoAssist, place the desired measures and dimensions in the chart field containers to fill the chart with your data.
Infographic images can be generated in image (.png) or PDF format.

- In Image format, the infographic image is embedded into an HTML page for display. When distributed through ReportCaster, the image can be embedded into the email message or included as an attachment.

- For PDF format, each individual infographic image is placed into a separate PDF document. Running a single infographic will display the image in the PDF.

You can define a coordinated key across all components in the infographic document. This will cause your procedure to generate individual, personalized images for each value of your selected key. In a coordinated infographic, the multiple images generated are presented embedded into HTML at run time so that they can be viewed for both image and PDF format. When burst and distributed in ReportCaster, individual images or PDF documents are generated and distributed for each key value in your target audience.

For more information, see the *Creating WebFOCUS Infographics* technical content.
Creating and Customizing Visualizations

Visualizations centralize information by providing different views of data that are pertinent to a particular objective. For example, reviewing trends or fluctuations in data over a period of time or within a region. A visualization provides you with a quick glance of information on a single screen.

Visualizations support the use of different types of charts, maps, and grids. For example, you may want to use a bar, pie, and line chart to show different views of the same data. Alternatively, you may want to offset a particular visual by showing other types of related data that employ a different type of visual. You can also add a text cell to your visualization to provide explanatory text or information that other users can reference.

Visualizations allow you to monitor changes in data. They also serve to provide information in real-time, based on changes in underlying data or other components. A visualization can be updated, changed, or revised at any time to account for shifts in data needs.

**In this chapter:**

- Creating a Visual
- Selecting a Visual
- Interacting With Visualizations
- Customizing Visualizations
- Using Storyboards
- Animating Visualizations
- Using Visualizations at Run-Time

**Creating a Visual**

You can create charts, maps, and grids to visually represent your data. You can add multiple visuals to the canvas to create a complete visualization.

The default visual is a bar stacked chart. You can use the Change option in the Visual group on the Home tab to change the visual type.
The following visual is a matrix marker chart that shows sales data for a range of electronic products.

![Matrix Marker Chart](image)

**Note:** Visualization takes advantage of the feature to provide the best user experience. To display date values within the visualization, use the legacy DATE formats which are supported with rather than DATE-TIME formats.

**Procedure:** How to Create a Visualization from Within WebFOCUS

You use this procedure to create a visualization within WebFOCUS.

1. Open InfoAssist in Visualization mode.
2. In the Open dialog box, select a data source and click **Open**.
3. Select fields for your visualization.

**Procedure:** How to Create a Visualization From InfoAssist

You can have multiple file types opened at once. To create a visualization:

1. On the Quick Access toolbar, click **New**.
   
   or

   Click the Application Main Menu button, and click **New**.
The InfoAssist splash screen displays.

2. Click **Build a Visualization**.

3. In the Open dialog box, select a data source and click **Open**.

   InfoAssist switches to Visualization mode.

### Changing the Visual Type

You can create a visual using the default chart type, which is a stacked bar chart. You can add your data to this chart and then change the chart type, or you can change the chart type prior to making your data selections.

Once you have started exploring your data, you can switch between the different types to obtain the graphical image that you wish to display.

You change the visual type from the Home tab.

**Procedure:** How to Change the Visual Type

1. On the **Home** tab, in the **Visual** group, click **Change**, as shown in the following image.

   ![Change Icon](image)

   **Note:** The **Change** icon updates depending on the chart, map, or grid that you select from the Select a Visual menu. By default, the **Change** icon displays a stacked bar chart.

   The Select a Visual menu displays.

2. On the Select a Visual menu, click the type of visual that you want to use.

   Your canvas refreshes and displays the visual that you selected.

   **Note:** Depending on the type of visual that you select, you may need to select additional or different data fields.

### Selecting a Visual

It is important that you select a chart, grid, or map that appropriately displays a meaningful view of your data. InfoAssist provides a library of visuals.

You can select a visual type from the Select a Visual menu, on the **Home** tab, in the **Visual** group. The following table describes the types of charts available.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Visual Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Grid Icon](102x545 to 128x569)</td>
<td>Grid</td>
<td>Grids provide a tabular view of data. They allow you to review data in a row and column format, similar to a printed report.</td>
</tr>
<tr>
<td>![Bar Chart Icon](102x496 to 125x520)</td>
<td>Bar chart</td>
<td>Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or variable measure fields that appear along the axis).</td>
</tr>
<tr>
<td>![Stacked Bar Chart Icon](102x433 to 127x457)</td>
<td>Stacked bar chart</td>
<td>A stacked bar chart is the default visual.</td>
</tr>
<tr>
<td>![Histogram Icon](102x386 to 136x418)</td>
<td>Histogram</td>
<td>Histograms graphically represent the distribution of numeric data. They facilitate the identification and discovery of the underlying frequency distribution within a set of continuous data. You can use histograms to identify trends and illustrate categorizations, or groupings, also known as bins. For more information, see Binning on page 163.</td>
</tr>
<tr>
<td>![Absolute Line Chart Icon](102x277 to 128x303)</td>
<td>Absolute line chart</td>
<td>Line charts allow you to trace the evolution of a data point by working backwards or interpolating. Highs and lows, rapid or slow movement, or a tendency towards stability are all types of trends well suited for a line chart.</td>
</tr>
<tr>
<td>![Area Chart Icon](102x203 to 127x227)</td>
<td>Area chart</td>
<td>Area charts analyze trends over time and look for differences in values.</td>
</tr>
<tr>
<td>![Stacked Area Chart Icon](102x162 to 127x187)</td>
<td>Stacked area chart</td>
<td>Stacked area charts allow you to stack data on top of each other.</td>
</tr>
<tr>
<td>![Pie Chart Icon](102x124 to 130x147)</td>
<td>Pie chart</td>
<td>Pie charts are circular charts that represent parts of a whole. A pie chart emphasizes where your data fits, in relation to the other components in the pie.</td>
</tr>
<tr>
<td>Icon</td>
<td>Visual Type</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>🌟</td>
<td>Ring pie chart</td>
<td>Ring pie charts are useful when you want to review the value of each segment, which represents the measure value for the selected dimension, as it relates to the total for the selected measure.</td>
</tr>
<tr>
<td>🧨</td>
<td>Scatter Plot</td>
<td>Scatter charts enable you to plot data using variable scales on both axes. When you use a scatter chart, the data is plotted with a hollow marker, so that you can visualize the density of individual data values around particular points, or discern patterns in the data.</td>
</tr>
<tr>
<td>🏷️</td>
<td>Bubble chart</td>
<td>Bubble charts can have two column fields representing X and Y data values, or have three column fields representing X, Y, and Z data values. The third variable (Z) represents size. The size of each bubble is used to show the relative importance of the data.</td>
</tr>
<tr>
<td>🎯</td>
<td>Matrix Marker chart</td>
<td>Matrix marker charts are useful for analyzing one or two measures against a crosstab of two categorical dimensions. The result is a color-scaled matrix chart that shows categorized trends.</td>
</tr>
<tr>
<td>🍃</td>
<td>Treemap</td>
<td>Treemaps are used to display large amounts of hierarchically structured data. Using a set of nested rectangles to illustrate data relationships, sections of a treemap represent branches of a tree.</td>
</tr>
</tbody>
</table>
Selecting a Visual

<table>
<thead>
<tr>
<th>Icon</th>
<th>Visual Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>🟢</td>
<td>Gauge</td>
<td>Gauges are used to display the value of a measure. In particular, circular gauges are used to represent a single data value within a given spectrum. You can create a single circular gauge for a measure or a matrix circular gauge, which shows the value of the selected measure across different dimensions, such as product category or yearly sales.</td>
</tr>
<tr>
<td>🟡</td>
<td>Choropleth map</td>
<td>A geographically-based heat map. It is useful for visualizing location-based data, trends, and distributions across a geographic area.</td>
</tr>
<tr>
<td>🟡</td>
<td>Proportional symbol map</td>
<td>A technique that uses symbols of different sizes to represent data associated with different areas or locations within the map.</td>
</tr>
<tr>
<td>🟡</td>
<td>Heatmap</td>
<td>A heatmap is a graphical representation of data where the individual values that comprise a matrix are represented as colors. Using radiant hues, you can track the intensity of a data relationship using the colors defined in the legend.</td>
</tr>
<tr>
<td>🟡</td>
<td>Leaflet map</td>
<td>Part of the Lightweight Mapping functionality, Leaflet maps enable you to visualize trends in your data. Choropleth and Proportional symbol maps are available.</td>
</tr>
</tbody>
</table>

**Note:**

- When new data is added to a bar, line, area, pie, scatter, bubble, gauge, or treemap chart, the chart will morph and rebuild, revealing the new values in a smooth transition.

- In addition to the standard visual types, your administrator can enable any number of chart extensions for you. These are downloaded and installed into your WebFOCUS installation. For more information, contact your administrator.
Microsoft Analysis Services are supported. However, in Visualization mode, parent-child hierarchies do not display in the Data pane.

Use the topics in this section to select and create your visuals.

Grids

Grids provide a tabular view of data. They allow you to review data in a row and column format, similar to a printed report.

In the following example, we review the product category and subcategory data for the following measure fields:

- Revenue
- Gross Profit

<table>
<thead>
<tr>
<th>Sale Year</th>
<th>Product Category</th>
<th>Revenue</th>
<th>Gross Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>2014</td>
<td>Accessories</td>
<td>$16,060,415.69</td>
<td>$4,945,779.69</td>
</tr>
<tr>
<td></td>
<td>Computers</td>
<td>$7,857,928.55</td>
<td>$3,376,380.55</td>
</tr>
<tr>
<td></td>
<td>Media Player</td>
<td>$30,105,200.05</td>
<td>$6,730,870.05</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>$9,295,726.31</td>
<td>$1,964,927.31</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>$7,313,170.38</td>
<td>$2,286,521.38</td>
</tr>
<tr>
<td>2015</td>
<td>Accessories</td>
<td>$35,619,872.81</td>
<td>$10,953,840.81</td>
</tr>
<tr>
<td></td>
<td>Computers</td>
<td>$24,176,475.33</td>
<td>$8,277,897.33</td>
</tr>
<tr>
<td></td>
<td>Media Player</td>
<td>$65,002,426.97</td>
<td>$14,480,370.97</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>$20,042,855.67</td>
<td>$4,262,155.67</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>$15,959,696.26</td>
<td>$4,938,902.26</td>
</tr>
<tr>
<td>2016</td>
<td>Accessories</td>
<td>$53,208,007.57</td>
<td>$16,362,313.57</td>
</tr>
<tr>
<td></td>
<td>Computers</td>
<td>$63,190,001.88</td>
<td>$18,677,664.88</td>
</tr>
<tr>
<td></td>
<td>Media Player</td>
<td>$99,448,235.40</td>
<td>$22,237,625.40</td>
</tr>
<tr>
<td></td>
<td>Televisions</td>
<td>$30,964,700.29</td>
<td>$6,560,087.29</td>
</tr>
<tr>
<td></td>
<td>Video Production</td>
<td>$23,810,094.17</td>
<td>$7,330,486.17</td>
</tr>
</tbody>
</table>

When working with grids, you can lasso or select a range of values at one time, enabling you to filter the grid or exclude values from it.
**Note:** If you have a large number of fields specified in a grid in Visualization mode, the server may be slow to respond.

**Procedure:** How to Create a Grid

1. Change the visual to a grid, or insert a new grid.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Rows or Columns - one or more data fields
   - Measure - one or more data fields

As you add, edit, or rearrange the fields in your Query field containers, your canvas refreshes.

**Bar Charts**

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or variable measure fields that appear along the axis). The length of a bar corresponds to a value or amount. You can clearly compare data series (fields) by the relative heights of the bars. Use a bar chart to display the distribution of numerical data. You can create horizontal and vertical bar charts.

**Note:** If you are working with a large dataset, a scroll bar displays under your chart, enabling you to easily scroll through your data from left to right. In Visualization mode, scroll bars are automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab and then click **Interactive Options**. In the Interactive Options dialog box, select the **Auto Enable X-Axis Scrolling** check box. If you are working in any other mode, you must enable this functionality.
Use a bar chart when individual values are important. For example, the following image is a basic vertical bar chart that compares the individual products sold to the total amount in sales for each product. A retailer would find it important to know which pieces of inventory are selling and how much revenue each item is generating for the company.
A horizontal bar chart becomes useful when you want to emphasize a ranking relationship in descending order, or the X-axis labels are too long to fit legibly side-by-side. For example, the following image is a basic horizontal bar chart that ranks which products are generating the most revenue for the retailer.

![Horizontal Bar Chart Example](image)

**Note:** You can swap the orientation of your data in a bar chart. To do so, on the Home tab, in the Visual group, click Swap.

**Procedure:** How to Insert a New Bar Chart

1. Change the visual to a bar chart or insert a new bar chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - **Vertical Axis** - one or more data fields
   - **Horizontal Axis** - one data field

**Note:** You can also double-click a data field to add it to your Query field containers.

The bar chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the bar chart.
Procedure: How to Create a Stacked Bar Chart

The bar stacked visual is the default visual.

1. Change the visual to a stacked bar chart or insert a new stacked bar chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual.

   The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one or more data fields
   - Color - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The stacked bar chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the stacked bar chart.

Procedure: How to Create a Matrix Bar Chart

1. Change the visual to a bar chart or insert a new bar chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual.

   The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one data field
   - Matrix Rows - one data field
   - Matrix Columns - one data field

Note: You can also double-click a data field to add it to your Query field containers.

The matrix bar chart displays on the canvas. You can add additional fields for comparative purposes. You can also view underlying data by hovering over any particular point on the matrix bar chart.

Line Charts

Line charts allow you to trace the evolution of a data point by working backwards or interpolating. Highs and lows, rapid or slow movement, or a tendency towards stability are all types of trends well suited for a line chart.

You can also plot line charts with two or more scales to present a comparison of the same value, or set of values, in different time periods.
Note: If you are working with a large dataset, a scroll bar displays under your chart, enabling you to easily scroll through your data from left to right. In Visualization mode, scroll bars are automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab and then click Interactive Options. In the Interactive Options dialog box, select the Auto Enable X-Axis Scrolling check box. If you are working in any other mode, you must enable this functionality.

Use a line chart when you want to trend data over time, for example, monthly changes in employment figures, or yearly sales of an item in your inventory. The following image is a line visual that shows the gross profit in monthly sales for products.

![Line Chart Example](image)

**Procedure:** How to Create a Line Chart

1. Change the visual type to a line chart or insert a new line chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one data field
   - Color - one data field (optional)

Note: You can also double-click a data field to add it to your Query field containers.
To add insight, you can drag a data field to the color Query field container. This displays the values for this field using color.

The line chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the line chart.

**Procedure:** How to Create a Matrix Line Chart

1. Change the visual type to a line chart or insert a new line chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one data field
   - Matrix Rows - one data field
   - Matrix Columns - one data field

**Note:** You can also double-click a data field to add it to your Query field containers.

The matrix line chart displays on the canvas. You can add additional fields for comparative purposes. You can also view underlying data by hovering over any particular point on the matrix line chart.

**Area Charts**

Area charts analyze trends over time and look for differences in values by using the see-thru nature of the area fills. Stacked area charts allow you to stack data on top of each other. Stacking allows you to highlight the relationship between data series, showing how some data series approach a second series.

**Note:** If you are working with a large dataset, a scroll bar displays under your chart, enabling you to easily scroll through your data from left to right. In Visualization mode, scroll bars are automatically enabled, but if you want to disable or re-enable scroll bars, click the Format tab and then click **Interactive Options**. In the Interactive Options dialog box, select the **Auto Enable X-Axis Scrolling** check box. If you are working in any other mode, you must enable this functionality.
Use an area chart when you want to distinguish the data more dramatically by highlighting volume with color. For example, the following image is a basic area chart that depicts the yearly gross profit for various electronic products.

**Procedure:** How to Create an Area Chart

1. Change the visual type to an area chart or insert a new area chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - **Vertical Axis** - one or more data fields
   - **Horizontal Axis** - one data field
   - **Color** - one data field (optional)

**Note:** You can also double-click a data field to add it to your Query field containers.

The area chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the area chart.
Procedure: How to Create a Stacked Area Chart

1. Change the visual type to a stacked area chart or insert a new stacked area chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one data field
   - Color - one data field (optional)

   Note: You can also double-click a data field to add it to your Query field containers.

The stacked area chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the stacked area chart.

Procedure: How to Create a Matrix Area Chart

1. Change the visual type to an area chart or insert a new area chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Vertical Axis - one or more data fields
   - Horizontal Axis - one data field
   - Matrix Rows - one data field
   - Matrix Columns - one data field

   Note: You can also double-click a data field to add it to your Query field containers.

A matrix area chart displays on the canvas. You can add additional data fields for comparative purposes. You can also view underlying data by hovering over any particular point on the matrix area chart.

Pie Charts

Pie charts are circular charts that represent parts of a whole. A pie chart emphasizes where your data fits, in relation to the other components in the pie. Pie charts work best when there are a limited number of slices (for example, less than 10) and the slices are all of a sufficient value as to reveal their fill color inside their wedge.
Use a pie chart when you have segments of data that you want to display as a whole. For example, the following image is a pie chart that shows the proportions of various electronic products based on the quarterly revenue.

You can add one or more measures to the Measure field container. Each measure will be used to create a separate, unique pie chart, to which you can add a measure or dimension to the Color field container to add color to your chart.

**Note:** When working with pie charts, you can add one measure field to the Color field container. This adds the measure as a By field, and determines how the pie chart is colored. Depending on your measure data, this may result in a large number of pie segments.

**Procedure: How to Create a Pie Chart**

1. Change the visual type to a pie chart or insert a new pie chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - **Measure** - one data field. Data in this category is used to indicate the size of the pie slice for the relevant category.
   - **Color** - one data field. Data in this category indicates the colors in your pie chart.
**Procedure: How to Create a Matrix Pie Chart**

1. Change the visual type to a pie chart or insert a new pie chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Measure - one data field
     - **Note:** Each unique measure field is represented by a separate pie chart.
   - Color - one data field
   - Matrix Rows - one data field
   - Matrix Columns - one data field
     - **Note:** You can also double-click a data field to add it to your Query field containers.

The matrix pie chart displays on the canvas. You can add additional data fields for comparative purposes, or to create another pie chart unique to the additional measure fields you select. You can also view underlying data by hovering over any particular point on the pie chart.

**Ring Pie Charts**

Ring pie charts are circular charts that display the total for the selected measure, as well as the individual segments that comprise the ring pie chart. You can hover over each segment to review the underlying data values. This is useful when comparing the measure value for an individual segment against the total for the measure, which displays in the center of the ring pie.

You can add one or more measures to the Measure field container. Each measure will be used to create a separate, unique ring pie chart, to which you can add a measure or dimension to the Color field container to add color to your chart.

- **Note:** The font size of the value label in the middle of the ring is automatically set by the chart engine.
Use a ring pie chart when you want to review the value of each segment, which represents the measure value for the selected dimension, as it relates to the total for the selected measure. The following image is an example of a ring pie chart.

![Ring Pie Chart Example](image_url)

**Procedure:** How to Create a Ring Pie Chart

1. Change the visual type to a ring pie chart or insert a new ring pie chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:

   - **Measure** - one data field. Data in this category is used to indicate the size of the ring pie segment for the relevant category.

   - **Color** - one data field. Data in this category indicates the colors in your ring pie chart.

**Note:** You can also double-click a data field to add it to your Query field containers.

The ring pie chart displays on the canvas. The total for the selected measure displays in the center of the ring pie chart. You can view underlying data by hovering over any of the ring pie chart segments.
Procedure: How to Create a Matrix Ring Pie Chart

1. Change the visual type to a ring pie chart or insert a new ring pie chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Measure - one data field
     
     **Note:** Each unique measure field is represented by a separate ring pie chart.
   - Color - one data field
   - Matrix Rows - one data field
   - Matrix Columns - one data field

   **Note:** You can also double-click a data field to add it to your Query field containers.

The matrix ring pie chart displays on the canvas. You can add additional fields for comparative purposes, or to create another pie chart unique to the additional measure fields you select. You can also view underlying data by hovering over any particular point on the matrix ring pie chart.

Scatter Charts

Scatter charts enable you to plot data using variable scales on both axes. When you use a scatter chart, the data is plotted with a hollow marker, so that you can visualize the density of individual data values around particular points, or discern patterns in the data. A numeric X axis, or sort field, always yields a scatter chart, by default.

**Note:** You can specify a non-measure (dimension) data field on the horizontal or vertical axis, or both.

If your chart reveals clouds of points, there is a strong relationship between X and Y values. If data points are scattered, there is a weak relationship, or no relationship.
Adding data fields to the Detail Query field container creates additional BY fields on the scatter chart. For example, the following image shows the results when adding the Product, SubCategory and Model dimension fields to Detail Query field container in a scatter chart which showed gross profit and MSRP data.

![Scatter Chart Image]

**Procedure:** How to Create a Scatter Chart

1. Change the visual type to a scatter chart or insert a new scatter chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Vertical Axis - one data field
   - Horizontal Axis - one data field
   - Detail - one or more data fields
   - Color - one data field

**Note:** You can also double-click a data field to add it to your Query field containers.

The scatter chart displays on the canvas. You can also view underlying data by hovering over any particular point on the scatter chart.
Bubble Charts

A bubble chart is a chart in which the data points are represented by bubbles. Bubble charts can have two column fields representing X and Y data values, or have three column fields representing X, Y, and Z data values, in that order. The Z variable represents size. The size of each bubble is used to show the relative importance of the data.

When you add a data field to the Size field container, this value is represented as the Z Axis Title in the legend. It displays as an empty Z Axis Title when a size data field is not specified. If you choose to indicate a Z, or size, data value, the data label displays in the legend. A Size Legend also displays, showing the estimated data value for a range of circle sizes. This allows you to estimate the value of the data based on the size of the circle.

Note:

- You can hover over the circles in the visual to obtain exact data values for any given point.

- You can specify a non-measure (dimension) data field on the horizontal or vertical axis, or both.

- In Visualization mode and for HTML5 charts, if you select the No fill option for your Series style when creating a Bubble chart, the series displays in shades of black. For , you must enable the Show Border Color option in order to view the bubbles in your chart at run time, otherwise the bubbles are invisible.
In the following image, a bubble chart is used to show the Manufacturer’s Suggested Retail Price (MSRP) plotted against Revenue for a variety of electronics products. It also shows the values for Gross Profit, which was specified in the Size field container in the Query pane.

**Procedure:** How to Create a Bubble Chart

1. Change the visual to a bubble chart or insert a new bubble chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual.
   
The following Query field containers must be populated for this visual:
   
   - Vertical Axis - one data field
   - Horizontal Axis - one data field
   - Detail - one or more data fields
   - Size - one data field
   - Color - one data field (optional). Labels for the values in this data field will comprise the legend.

**Note:** You can also double-click a data field to add it to your Query field containers.

The bubble chart displays on the canvas. You can also view underlying data by hovering over any particular point on the bar chart.
Matrix Marker

Matrix marker charts are useful for analyzing one or two measures against a crosstab of two categorical dimensions. You can use the Size Query field container for one measure and the Color Query field container for a second measure. The result is a color-scaled matrix chart that shows categorized trends, as shown in the following image.

![Matrix Marker Chart Example](image)

**Procedure:** How to Create a Matrix Marker Chart

1. Change the visual to a matrix marker chart or insert a new matrix marker chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Matrix Rows - one data field
   - Matrix Columns - one data field
   - Size - one data field. The data for this field determines the size of the marker.
   - Color - one data field. The data in this field determines the color of the marker.
   The matrix marker chart displays.
Treemaps

Treemaps are used to display large amounts of hierarchically structured data. Using a set of nested rectangles to illustrate data relationships, sections of a treemap represent branches of a tree. Each branch is given a rectangle, to which any number of smaller sub-branches can be assigned. The size of each branch is proportional to the summed values of the elements inside the branch.

The following treemap shows the categories of the selected dimension fields, using two data fields to determine the size and color of the treemap segments.

**Procedure:** How to Create a Treemap

1. Change the visual to a treemap or insert a new treemap.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - **Grouping** - one or more data fields, which establishes the hierarchy of the Treemap grouping.
   - **Size** - one data field. This data controls the size of the branches that display.
   - **Color** - one data field. This data controls the colors that display based on the accompanying gradient.
Gauges

Gauges are used to display the value of a measure. In particular, circular gauges are used to represent a single data value within a given spectrum. These gauges have a circular shape. You can create a single circular gauge for a measure or a matrix circular gauge, which shows the value of the selected measure across different dimensions, such as product category or yearly sales. The value of the measure that displays in a circular gauge is determined by the underlying data stored for that measure in the database.

The circular gauge functionality uses only one measure in its presentation. The legend reflects the color of the measure within the circular gauge.

In the following example, we review revenue data for each product category by quarterly sales in a matrix circular gauge chart.

<table>
<thead>
<tr>
<th>Sale Quarter</th>
<th>Accessories</th>
<th>Computers</th>
<th>Product Category</th>
<th>Media Player</th>
<th>Televisions</th>
<th>Video Production</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>25.7M</td>
<td>19.7M</td>
<td>47.8M</td>
<td>14.9M</td>
<td>11.4M</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>24.1M</td>
<td>22.0M</td>
<td>44.5M</td>
<td>13.6M</td>
<td>10.9M</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>24.5M</td>
<td>24.6M</td>
<td>45.4M</td>
<td>14.4M</td>
<td>11.0M</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>30.7M</td>
<td>29.0M</td>
<td>56.8M</td>
<td>17.4M</td>
<td>13.8M</td>
<td></td>
</tr>
</tbody>
</table>

**Procedure:** How to Create a Circular Gauge

1. Change the visual type to a gauge or insert a new gauge.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following query field containers must be populated for this visual:

- **Measure** - one data field. Data in this category is used to indicate the value of the selected measure, which displays within the gauge.

- **Tooltip** - one or more data fields. The fields that you add provide you with the ability to review additional related, underlying data for different measures. Tooltips are optional.

**Note:** You can also double-click a data field to add it to your Query field containers.

The circular gauge displays on the canvas. You can select additional measure fields for which to include in the tooltip.

**Procedure:** How to Create a Matrix Circular Gauge

1. Change the visual type to a gauge or insert a new gauge.

2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following query field containers must be populated for this visual:

- **Measure** - one data field. Data in this category is used to indicate the value of the selected measure, which displays within the gauge.

  **Note:** Since the gauge relies on a constant (measure field), each intersection of the matrix chart is calculated using that measure along with the various matrix rows and columns in the matrix chart.

- **Matrix Rows** - one data field.

- **Matrix Columns** - one data field.

- **Tooltip** - one or more data fields. The fields that you add provide you with the ability to review additional related, underlying data for different measures. Tooltips are optional.

  **Note:** You can also double-click a data field to add it to your Query field containers.

The matrix circular gauge displays on the canvas. You can select additional measure fields for which to include in the tooltip.

**Heatmaps**

A heatmap is a graphical representation of data where the individual values that comprise a matrix are represented as colors. Using radiant hues, you can track the intensity of a data relationship using the colors defined in the legend.
Heatmaps are useful when you are looking for hot spots in your data, or areas of focus or interest, as shown in the following image.

**Procedure: How to Create a Heatmap**

1. Change the visual to a heatmap or insert a new heatmap.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:
   - Color - one data field. This data controls the colors that display based on the accompanying gradient.
   - Horizontal field container - one data field.
   - Vertical field container - one data field

**Note:** You can optionally populate the Matrix Rows and Columns fields to increase the segmentation of your heatmap.

The heatmap displays.

**Matrix Charts**

Matrix charts are powerful, comparative tools. They provide enough detail to show a trend and they organize information in a categorical fashion.
Matrix charts display data in a grid, showing the comparative values on either axis. They provide you with a quick glance at trends over time, giving you a succinct synopsis of a situation (for example, sales or investment trends).

You can use various formats in your matrix chart (for example, pie or line chart).

In the following example, we review quarterly revenue data, by product category, for a range of years (2014 - 2016, specifically). Using a bar chart for the matrix, we are able to review how gross profit for each product category shifts over time.

You can plot one value on the X axis and one value on the Y axis. For example, sales against region. You can also plot just one value for the rows or columns in the matrix chart.

**Procedure:** How to Create a Matrix Chart

1. Change the visual type to bar chart or insert a new bar chart.
2. Drag data fields to the canvas or to the Query field containers to add them to your visual. The following Query field containers must be populated for this visual:

- Vertical Axis - one data field
- Horizontal Axis - one data field
- Matrix Row - one data field

The matrix chart displays on the canvas. You can view underlying data by hovering over any particular point on the chart.

**Note:** You can change the bar matrix chart to a line, area, or pie matrix chart by changing the type of visual in the **Visual** group on the **Home** tab.

### Interacting With Visualizations

A visualization is comprised of one or more visuals, such as charts, maps, or grids and text. You can create different views of your data in a single visualization, and share that visualization with others in your enterprise.

The following image shows a sample visualization. This visualization includes a map, a matrix grid, and a stacked area chart.
This section summarizes the tasks that are available to you when working with visuals. It provides centralized instructional information on performing each task and offers links to the most common topics when working with visuals.

<table>
<thead>
<tr>
<th>Task</th>
<th>How To</th>
</tr>
</thead>
</table>
| Change visual  | On the *Home* tab, in the *Visual* group, click *Change*.  
*Note:* The *Change* icon updates depending on the chart, map, or grid that you select from the Select a Visual menu. By default, the *Change* icon displays a stacked bar chart.  
Select a chart, map, or grid from the Select a Visual menu.                                      |
| Insert new visual | On the *Home* tab, in the *Visual* group, click *Insert*.  
Use the default stacked bar chart or click *Change* to select a different chart, map, or grid from the Select a Visual menu.  
*Note:* You can also add additional charts, maps, or grids to a visualization by dragging a data field onto the canvas and placing it using the handles that are available. |
| Rearrange visuals | Drag a visual on top of another visual to activate a shaded area that contains handles, which can be used to indicate placement. |
| Copying a visual | On the canvas, select a visual. On the *Home* tab, in the *Clipboard* group, click *Copy*.  
*Note:* You can also press CTRL+C to copy a selected visual.                                        |
| Pasting a visual | Copy a visual. On the *Home* tab, in the *Clipboard* group, click *Paste*.  
*Note:* You can also press CTRL+V to paste a copied visual on the canvas.                         |
### Task | How To
--- | ---
Duplicating a visual | On the canvas, select a visual. On the Home tab in the Clipboard group, click Duplicate. A duplicate visual is created and a sequential number is assigned based on the type of visual.
Delete visual | Select a visual. On the Home tab, in the Clipboard group, click Cut. You can click the Close button in the upper-right corner of the current visual. From the Query pane, right-click a visual and click Delete. You can also press the Delete key when a visual is selected.
Apply Filter | Drag a dimension field or measure field into the Filter pane to access the filter options that are available. To add filter options for a field that is already in the Query pane, select the field and on the Field tab, in the Filter group, click Filter.
Add visuals to the storyboard | Create a visual. On the Home tab, in the Storyboard group, click Add.

**Procedure:** How to Insert a New Visual

1. On the Home tab, in the Visual group, click the down arrow next to Insert.
2. On the menu, click one of the following options:
   - **Chart.** Inserts a stacked bar chart visual.
   - **Grid.** Inserts a grid visual.
   - **Text.** Inserts a blank text cell.
3. Populate your visual with data or add text to the text cell.

**Note:**
- By default, when you click Insert, a stacked bar chart visual is inserted.
You can also drag a data field from the Data pane to the canvas to insert a new visual. This inserts the default visual, a stacked bar chart. You can use the placement handles to position your new visual on the canvas, for example, above an existing visual or to the side of an existing visual.

**Procedure:** How to Add Text to Your Visualization

1. On the **Home** Tab, in the **Visual** group, click the down arrow on next to **Insert**.
2. On the menu, click **Text**.
   
   A text cell opens on the canvas.
3. Add text to your visualization.

   **Note:** You can resize the text cell and use the text formatting options to customize the display of any text that you add, as shown in the following image.

You can also position the text cell in your visualization by dragging the text cell on top of a visual. Use the placement handles to indicate placement of the text cell.

**Procedure:** How to Create a Visualization

1. Begin with the default canvas, which consists of a stacked bar chart template.
2. Insert a new visual in one of the following ways:
   a. Drag a data field from the Data pane onto the canvas. Handles display, which allow you to select the location for the new visual, for example, top (above) or left of the current visual, as shown in the following image.

   ![Image of visual insertion](image)


   **Note:** You can optionally click the down arrow on the Insert button to specify the addition of a chart, grid, or text.

3. Add another visual.

   Now, three visual cells display side-by-side.

4. Click a visual to select it.

   **Note:** You can click a visual to activate it, or double-click on the visual number or name in the Query pane.

5. Reorganize your visuals using the handles.

6. Once you have organized the placement of your visuals, select one and specify the visual type.
Note: The Change icon updates depending on the chart, map, or grid that you select from the Select a Visual menu. By default, the Change icon displays a stacked bar chart.

b. In the Select a Visual menu, click the type of visual you want to use. For example, Line, Area, or Map.

c. Repeat these steps for all three visuals on your canvas.

7. Populate each visual with your data.

You can change the type of visual that you previously selected at any time. You can also resize or reorganize the position of each visual as you add data.

For example, move the lower-left visual to the top of the visualization.
The bubble chart now runs across the top of the visualization.

8. Click Save to save your visualization.

Minimizing or Maximizing a Visual

When working on a visualization with more than one chart, map, or grid, you can maximize and minimize individual visuals. This allows you to focus on one visual at a time, and then minimize it to view it alongside the other visuals.

The maximize and minimize icons are located in the top-right corner of each visual, next to the Close button. When you click the Maximize icon, the current visual moves to the foreground and is the only visual that displays on the canvas. You can work on this visual, and then minimize it to view the other visuals.

Note: You can view other visuals in the maximized mode by selecting a different visual in the Query pane.

Procedure: How to Minimize or Maximize a Visual

1. Create a visualization with two or more visuals.
2. Perform the following actions to minimize or maximize your visual:

- Click the maximize icon or double-click on the Title bar to maximize your visual.
- Click the minimize icon or double-click on the Title bar to minimize your visual.

You can maximize one visual at a time, and you can switch between visuals in this mode by double-clicking a different visual in the Query pane.

Procedure: How to Delete a Visual

1. In your visualization, select the chart, map, or grid that you want to delete.
2. Perform one of the following tasks to delete the visual:

- Press the Delete key.
- On the Home tab, in the Clipboard group, click Cut.
- Click the Close button in the upper-right corner of the current visual.
- From the Query pane, right-click on a visual, and click Delete.

Note: You can use the Undo and Redo options on the Quick Access Toolbar to reverse or redo any prior actions.

Renaming a Visual

You can rename a visual on the canvas or within your visualization. You may want to do this for presentation and organizational purposes, as each visual has a default label (for example, Bar 1, Bar 2, and Bar 3). You can change these labels by renaming the visual in the Query pane.

Once new labels are in place, it is easier to recognize which visual you want to select at any given time.

Using the shortcut menu for a visual in the Query pane, you can also rename your visual.

Procedure: How to Rename a Visual

1. Create a visualization with one or more chart, map, or grid.
2. In the Query pane, right-click the visual number for which you want to modify the title.
3. Click Rename.
4. In the Edit Title dialog box, enter a new name for the visual.
5. Click OK.
The visual is renamed in the Query pane and the new title is reflected at the top of the selected visual.

**Using Paper-Clipping to Group Values in a Visual**

Paper-clipping gives you the advantage of lassoing values in a visual to create logical groups within your selected dimension. Paper-clipping uses the core functionality of dynamic grouping, giving you access to grouping capabilities that meet your business needs. You can also add additional groupings or fields to an existing group, and rename the groups and values, giving you control over how the information displays.

When you paper-clip values together, a new group is created using the naming convention of dimensiongroup_1. You can add values to this group by lassoing this grouped component, along with any additional components you want to add. These new values become part of that existing group.

**Note:** If you group two values and then add another value to that grouping, you must manually rename the group in order to update its display.

If you lasso other values in your visualization, and you do not capture or include a previously defined grouping, a new grouping is created for the selected fields in the current dimension. It is labeled using the original dimension label (dimensiongroup_1), but a new, unique grouping is created for these values. You can see the groupings by right-clicking the group in the Query pane and selecting *Edit Group*. If you want to add new values to an existing group, you must lasso the existing group, in addition to the fields that you want to add to it, in order to combine the additional fields into the existing grouping.
To enable paper-clipping, lasso the values that you want to group, release the mouse, and from the menu that displays, select *Group n Selection*, where *n* is the dimension associated with the values you select. This menu is shown in the following image.

![Menu Image](image)

**Note:** Paper-clipping allows you to group on the first BY field only. In this example, the first BY field is Product Category. If you are working with a matrix chart and you apply this rule, you are only able to group on the first BY field. In addition, you cannot group on a numeric field (for example, Sales_Year). In this case, if the numeric field was the first BY field, grouping is not available.
Once you group the values, they display in a unique group on the relevant axis. The group label is based on the original values stored for those components. For example, in the previous image, we grouped Camcorder and Computers in the PRODUCT_CATEGORY_1 group, as shown in the following image.

Once you create a group, you can easily perform the following functions:

- **Edit group.** Opens the Edit Group dialog box, where you can edit the values in the current group. For example, you can add additional values into the current group or delete them. For more information on editing an existing group, see Dynamic Grouping on page 70.

- **Rename group.** Enables you to rename the group using the Rename Group dialog box. The revised name displays along the relevant axis and replaces the existing field name in the Query pane.

- **Rename x.** Enables you to rename the group name (x) that is assigned based on your grouping. This is particularly useful in cases where space is an issue in your visualization. This revised value also replaces the original group name in the Edit Group dialog box.

- **Ungroup x.** Ungroups the values of the group (x) that were previously grouped.

- **Ungroup All.** Ungroups all existing groups, returning the visualization to its original state.

**Note:** Upon ungrouping all groups, the original dimension displays as a group in the Query pane, by default. However, no grouping is applied.
These options are shown in the following image.

**Note:** You can also edit an existing group by right-clicking the group in the Query pane and selecting *Edit Group.*
If you want to add another value to an existing group, lasso the existing group and the new value. From the menu, click *Merge with x*, where x is the value of the existing group, as shown in the following image.
The new value is added to the existing group. You can then rename the group so that its label contains all values in the group. You can optionally label it with a new, unique name. This option is shown in the following image.

![Image of bar chart with grouped values](image)

**Note:** You can also use the Edit Group dialog box to rename groups or groupings. For more information, see *Dynamic Grouping* on page 70.

You can use the following procedures to create and manage your paper-clipped values.

**Procedure:** How to Paper-Clip Two or More Values Together

1. In visualization mode, create a bar chart with one measure and one dimension. The bar chart displays.
2. Lasso two or more columns in the visualization.
3. From the menu that displays, click *Group n Selection*, where n is the name of the dimension in your bar chart.

   The two values are paper-clipped together, or grouped, as indicated on the x-axis.

   **Note:** If you have swapped the orientation of your visualization, the paper-clipped values display on the y-axis.

**Procedure:** How to Merge an Additional Value into an Existing Group

1. In visualization mode, create a bar chart with one measure and one dimension. The bar chart displays.
2. Lasso two or more columns in the visualization.

3. From the menu that displays, click *Group n Selection*, where n is the name of the dimension in your bar chart.
   
   The two values are paper-clipped together, or grouped, as indicated on the x-axis.

   **Note:** If you have swapped the orientation of your visualization, the paper-clipped values will display on the y-axis.

4. Lasso this existing group, as well another column, to merge this additional value into the group.

5. From the menu that displays, click *Merge with x*, where x is the name of the group you originally created.
   
   This value is merged into the existing group.

   **Note:** The name of the group is not dynamically updated. In order to reflect the contents of the revised group, you must edit the group using the right-click menu option or the Edit Group option that is available in the Query pane.

---

**Procedure:** How to Rename an Existing Group

1. In visualization mode, create a bar chart with one measure and one dimension. The bar chart displays.

2. Lasso two or more columns in the visualization.

3. From the menu that displays, click *Group n Selection*, where n is the name of the dimension in your bar chart.
   
   The two values are paper-clipped together, or grouped, as indicated on the relevant axis.

4. Lasso the grouped column and from the menu that displays, click *Rename x*, where x is the existing label of the group.

5. In the Rename Value dialog box, enter the new name for the group.

6. Click *OK*.
   
   The group is renamed, as shown on the relevant axis.

   **Note:** Optionally, you can rename a group using the Edit Group dialog box. This is available when you right-click on a grouped value in the Query pane and click *Edit Group*. For more information, see *Dynamic Grouping* on page 70.
Viewing Data Behind Visuals

You use InfoAssist to analyze your data by creating or building interactive visualizations. As you develop these visualizations, you can create different views of the data, and find patterns or trends.

As you gain insight and spot patterns, you may want to share only the underlying data that comprises a specific visual with others in your enterprise. You can do this using the data options, as shown in the following image.

The Show data option provides options for you to view and share this data. The Export data option enables you to export the data specific to your visualization in a summary or detailed format. You can also review related data by using the Show Data with Related Columns option.

The Show Data with Related Columns functionality allows you to review more specific underlying data based on the fields that you have selected. Specifically, it displays data related to other fields that are part of the dimension hierarchy that you select. For example, if you selected the Product, Category dimension field, the related column data would include data from the Product, Subcategory and Model dimension fields, because these data fields are part of that dimension hierarchy.

Similar to the Show data option, the Show Data with Related Columns option provides more detailed data based on the data fields that you select. You can sort and review the data columns, which display in a separate browser window. Depending on the size and breadth of your dimension hierarchy, a multiple page report may be produced.

**Note:** You can export data in .xls or .csv format.

When you select the option to show data or show data with related columns, a report is generated in a separate browser window. This report is an interactive report, which you can review, sort, and modify using the drop-down menus that are available. For more information on interactive reports, see the TIBCO WebFOCUS KnowledgeBase at: [http://documentation.ibi.com](http://documentation.ibi.com).

When you point to the Export Data option, you can:

- Export data in summary format, which includes totals for categories based on the data fields that you selected for your visual.

- Export more granular data based on the data values that you selected in your visual.
**Note:**

- When exporting data using the Summary or Data Detail options, you can save the resulting data file, which is in Microsoft® Excel® format, to your local machine for further analysis and sharing.
- The maximum number of records that can be exported is 100,000.

**Procedure:** How to Show the Data Behind Your Visual

1. Create a visual, such as a chart, map, or grid.
2. In the upper-right corner of the visual cell, click the down arrow.
3. In the menu that appears, click *Show Data*.

   A new browser window opens. This window displays the data for your visual as an interactive report in WebFOCUS. You can use this report to create and share lightweight, browser-based data discovery analytics that are portable, and only require access to a browser.

**Procedure:** How to Show Data With Related Columns

1. Create a visual, such as a chart, map, or grid.
2. In the upper-right corner of the visual cell, click the down arrow.
3. In the menu that appears, click *Show Data with Related Columns*.

   A new browser window opens. This window displays the data for your visual as an interactive report in WebFOCUS. You can use this report to sort and work with the underlying hierarchical data in your visual.

**Procedure:** How to Export the Data Behind Your Visual

1. Create a visual, such as a chart, map, or grid.
2. In the upper-right corner of the visual cell, click the down arrow.
3. In the menu that appears, point to *Export Data*, and then click one of the following:

- **Summary.** A prompt appears, asking you to open or save a Microsoft Excel file. This file is a summary of your data from a high level for a general analysis, as shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Name</th>
<th>Revenue</th>
<th>Gross Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Accessories</td>
<td>$9,341,397.65</td>
<td>$2,354,397.65</td>
</tr>
<tr>
<td>3</td>
<td>Cycle Energy Quick with Refresh Charger</td>
<td>$1,508,212.41</td>
<td>$666,612.41</td>
</tr>
<tr>
<td>4</td>
<td>Denon AH-D5000 Over-Ear Headphones</td>
<td>$9,272,133.77</td>
<td>$2,477,303.77</td>
</tr>
<tr>
<td>5</td>
<td>Grado RS1i Reference Series Headphones</td>
<td>$9,452,243.25</td>
<td>$2,208,713.25</td>
</tr>
<tr>
<td>6</td>
<td>Universal Remote</td>
<td>$14,419,020.31</td>
<td>$4,401,161.31</td>
</tr>
<tr>
<td>7</td>
<td>Control</td>
<td>$9,301,960.89</td>
<td>$1,518,526.89</td>
</tr>
<tr>
<td>8</td>
<td>Anywhere! Kit with Tabletop Sensor</td>
<td>$11,401,805.70</td>
<td>$2,616,237.70</td>
</tr>
<tr>
<td>9</td>
<td>Anywhere! Kit for Home Theater</td>
<td>$14,276,128.75</td>
<td>$4,825,372.75</td>
</tr>
<tr>
<td>10</td>
<td>Headphones</td>
<td>$8,028,218.25</td>
<td>$4,049,178.25</td>
</tr>
<tr>
<td>11</td>
<td>Samsung OEM 2.0 Amp Travel Charger</td>
<td>$2,514,022.50</td>
<td>$1,303,511.50</td>
</tr>
</tbody>
</table>

- **Data Detail.** Generates a detailed report that provides specific data regarding your data analysis.
Using Multi Drill in Visualization Mode

Similar to the functionality that is available in Chart mode, you can create multiple drill down links on a measure field in a visualization. This enables you to define custom links to other reports or websites, making it easy to link content from internal and external sources. Once defined, these links display on the shortcut menu that displays when you hover over a riser, as shown in the following image.
You create multiple drilldowns using the Drill Down dialog box, which you can access from the Links group on the Field tab. In the Query pane, click a measure to enable the Field tab. In the Links group, click Drill Down. The Drill Down dialog box displays, as shown in the following image.

![Drill Down Dialog Box](image.png)

**Note:** When creating a drill down in Visualization mode, the Auto Link Target option is not available.

For more information and instructional guidance, see *Using Multi Drill* on page 357.

**Creating Multi-Y Axis Comparative Visuals**

When creating a chart with more than one measure (numeric) field, you can split the Y axis to create multiple charts, based on each unique measure field.

**Note:** Measure fields are selected from the Data pane and display under the Vertical Axis (Y) in the Query pane.
This functionality is useful when analyzing trends for multiple measure fields, as you can view data for each measure field separately within the same chart, as shown in the following image.

This functionality is available for Bar, Bar Stacked, Line, Area, and Area Stacked charts.

**Procedure:** How to Create a Multi-Y Axis Comparative Visual

1. Launch InfoAssist in Visualization mode.
2. On the **Home** tab, in the **Visual** group, click **Change**.
3. Select one of the following visual types: Bar, Bar Stacked, Line, Area, or Area Stacked.
   
   **Note:** Bar Stacked is the default visual type.
4. Add multiple measure fields to the visual. For example, Gross Profit and Revenue.
5. Add at least one dimension field to the visual. For example, Product Category.
6. In the Query pane, right-click **Vertical Axis**.
7. Click **Multi-Y split**.

   The chart changes to display individual charts for each measure field.

   **Note:** You can revert your chart to an integrated display by right-clicking **Vertical Axis** and then clicking **Multi-Y split**.
Customizing Visualizations

Once you have created a visualization, you can customize and style individual visuals within the visualization. For example, you can add axis titles to a bar chart visual or a title or header for a visual within a visualization. For visuals, the customization options vary depending on the type of visual (for example, the formatting options for bar visuals differ from those that are available for pie visuals).

This section addresses the formatting options that are available for all visual types, including:

- Format Axis Dialog Box on page 320
- Using Axis Properties on page 325
- Formatting Data Labels on page 330
- Formatting the Legend on page 331
- Formatting a Series on page 331
- Formatting and Display Tools for Data in a Visual on page 332

Formatting Axis Labels

Vertical and horizontal axes are based on the orientation of the visual. For example, in a vertical visual, the horizontal axis refers to the X axis and the vertical axis refers to the Y axis. In a horizontal visual, the horizontal axis refers to the Y axis and the vertical axis refers to the X axis. This is important to consider, since options could change depending on the orientation of the visual.

A chart can contain the following types of axis labels:

- Horizontal axis labels represent the X axis.
- Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric scale, usually located on the left side of a vertical chart.
- Secondary horizontal and vertical labels can only be used when dual axes charts are selected.

Format Axis Dialog Box

The Format Axis dialog box includes options for formatting both vertical and horizontal axes. The Format Axis dialog box contains the following tabs:

- General (for horizontal axes)
Scale (for vertical axes)
Title
Labels
Advanced

Reference: Format Vertical Axis Dialog Box

You can use the Format Vertical Axis dialog box to specify formatting options for the vertical axis in your chart.

Use the Scale tab to modify scale properties.

The Scale tab contains the following options:

- **Automatic Minimum.** Supplies the minimum value on the Y-axis scale automatically. To use manual scaling, clear this option. You can then set the minimum value by entering a number into the Value text box.
  - **Value.** Type the minimum value in this text box if you have not selected Automatic Minimum.

- **Automatic Maximum.** Supplies the maximum value on the Y-axis scale automatically. To use manual scaling, clear this option. You can then set the maximum value by entering a number into the Value text box.
  - **Value.** Type the maximum value in this text box if you have not selected Automatic Maximum.

- **Automatic Grid Step.** Calculates the number of major grid steps automatically. To use manual scaling, clear this option. You can then set the value by typing the number into the Value text box.
  - **Value.** Type the value in this text box if you have not selected Automatic Grid Step.

- **Logarithmic Scale.** Controls whether or not the Y-axis scale progresses logarithmically instead of linearly. This option is disabled by default. When selected, the logarithmic base is set to 10.0, but can be changed by entering another value.

- **Include zero on scale.** Controls whether or not a zero (0) value appears on the scale. This option is enabled by default.
When working with vertical axis options in InfoAssist, the Include zero on scale check box is cleared by default when setScaleMustIncludeZero() is not present in the StyleSheet. When this setting is not present, the value is false. The TIBCO WebFOCUS® Reporting Server, however, sets the value to true. This produces inaccurate results at run time.

To resolve this issue, add the setScaleMustIncludeZero() setting to the StyleSheet. For example, setScaleMustIncludeZero(getY1Axis(),true);

You can also select the Include zero on scale check box in the Format Vertical Axis dialog box, which can be accessed from the Axes option in the Labels group on the Format tab, and then clear it. This writes the setting into the FOCEXEC and sets the value to false. Select the check box for this option again to set the value to true.

Use the Title tab to show or hide the axis title, and create and style the title for the axis.

The Title tab contains the following options:

- **Show title.** Select this check box to show the axis title (default) or clear the check box to hide the axis title.

- **Text.** Enter a title for the axis.

- **Style text.** Opens the Style dialog box, where you can style the text.

Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- **Show Labels.** Displays labels next to the axis. This is enabled by default. Clear this option to suppress labels.

- **Axis side.** Contains a list of position options for the labels on the axis. The options are Left (default), Right, or Both.

- **Style labels.** Opens the Style dialog box, where you can style text.

- **Format Labels.** Contains a list of preset formats that can be applied to the labels.

- **Custom Format.** Allows you to use a custom format. This option is activated when Use Pattern /100 and Use Pattern are selected as the format labels.

The Format Labels drop-down menu provides a list of preset formats that you can apply to labels. When you select a custom format, it must be defined using a custom format pattern. See the following table for a list and description of the characters that you can use in a custom format.
<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Is a digit.</td>
</tr>
<tr>
<td>0 (zero)</td>
<td>Shows as absent.</td>
</tr>
<tr>
<td>. (period)</td>
<td>Is a placeholder for a decimal separator.</td>
</tr>
<tr>
<td>, (comma)</td>
<td>Is a placeholder for a grouping separator.</td>
</tr>
<tr>
<td>; (semicolon)</td>
<td>Separates formats.</td>
</tr>
<tr>
<td>- (dash)</td>
<td>Is the default negative prefix.</td>
</tr>
<tr>
<td>% (percent)</td>
<td>Divides by 100 and shows as a percentage.</td>
</tr>
<tr>
<td>x</td>
<td>Determines that any other characters can be used in the prefix or suffix.</td>
</tr>
<tr>
<td>' (apostrophe)</td>
<td>Is used to quote special characters in a prefix or suffix.</td>
</tr>
</tbody>
</table>

Use the Advanced tab to modify additional axis properties.

The Advanced tab contains the following options:

- **Exclude Minimum Label.** Excludes the label with the lowest axis value from the chart.
- **Exclude Maximum Label.** Excludes the label with the highest axis value from the chart.
- **Descending Axis.** Draws the axis in descending order.
- **Show axis line.** Controls the display of the axis baseline.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the axis line.
- **Show zero line.** Controls the display of the zero line.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the zero line.
- **Custom Baseline.** Controls the display of the custom baseline.
  - **Value.** Type a value for the custom baseline.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the custom baseline.
For instructions on how to open this dialog box, see the procedures in *Using Axis Properties* on page 325.

**Reference:** Format Horizontal Axis Dialog Box

You use the Format Horizontal Axis dialog box to specify formatting options for the horizontal axis in your chart.

The General tab contains the Show axis line check box, which controls the display of the axis line. When this check box is selected, you can style the axis line.

The General tab contains the following options:

- **Show axis line.** Enables the display of the axis line.
  - **Line Style.** Opens the Line Style dialog box, where you can edit the color, weight, and style of the axis line.

Use the Title tab to create and style the title for the axis.

The Title tab contains the following options:

- **Show title.** Enables the display of the title.
- **Text.** Type a title for the axis.
- **Style.** Opens the Style dialog box, where you can style the text.

Use the Labels tab to format the layout of the axis labels.

The Labels tab contains the following options:

- **Show Labels.** Displays labels next to the axis. This is enabled by default. Clear this option to suppress labels.
  - **Axis side.** Contains a list of position options for the labels on the axis. The options are Left (default), Right, or Both.
  - **Style labels.** Opens the Style dialog box, where you can style text.
- **Stagger Labels.** Sets the labels to appear staggered.
- **Concatenate Labels.** Concatenates the labels in your visualization. This is enabled by default.

Use the Advanced tab to modify additional axis properties.
The Advanced tab contains the following options:

- **Exclude Minimum Label.** Excludes the label with the lowest axis value from the chart.
- **Exclude Maximum Label.** Excludes the label with the highest axis value from the chart.
- **Reverse Groups.** Reverses the order of the display of the groups on the horizontal axis.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties.

**Using Axis Properties**

The following sections contain procedures for customizing an axis. The procedures are organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

**Procedure:** How to Hide Axis Labels

1. Create a chart.
2. On the **Format** tab, in the **Labels** group, click **Axes**, point to the axis that you are working with, and clear the **Show Labels** option.
   
   The axis labels are hidden from the chart.

**Procedure:** How to Stagger Axis Labels

**Note:** You can only apply a staggered effect to horizontal axis labels.

1. Create a chart with at least one horizontal axis label on display.
2. On the **Format** tab, in the **Labels** group, click **Axes**, point to **Horizontal Axis**, and click **Stagger Horizontal Labels**.
   
   The axis labels are staggered.
The following image shows a chart with the horizontal axis labels staggered.

**Procedure: How to Rotate Axis Labels**

1. Create a chart with axis labels.
2. On the Format tab, in the Labels group, click Axes, point to the axis that you are working with, point to Rotate Labels, and then select the degree to which you want to rotate the axis labels.

   The axis labels are rotated.
The following image shows a chart with the vertical axis labels rotated 45 degrees.

**Procedure: How to Format Axis Labels**

1. Create a chart with an axis label.
2. On the Format tab, in the Labels group, click Axes, point to the axis that you are working with, and click More Vertical Axis Options, or More Horizontal Axis Options.
   
   The Format Axis dialog box opens.
3. Click the Labels tab.
4. From the Format Labels list, select the formatting option that you want.
   
   The axis labels are formatted accordingly.
The following image shows a chart with the vertical axis label styled in blue Arial font.

**Procedure:** How to Manually Set the Scale of an Axis

**Note:** You can only set axis scale to vertical axis labels.

1. Create a chart.
2. On the Format tab, in the Labels group, click Axes, point to Vertical Axis, and click More Vertical Axis Options.
   
The Format Axis dialog box opens.
3. On the Scale tab, clear the Automatic Minimum option and enter your own minimum value in the Value text box.
4. Clear the Automatic Maximum option, and enter your own maximum value in the Value text box.
5. Clear the Automatic Grid Step option, and enter your own grid step value in the Value text box.
6. Optionally, you can select the Logarithmic Scale option and enter the log scale base in the text field of that name. You can also clear the Include zero on scale option if you do not want zero to appear on the axis.
7. Click OK to close the dialog box.
The axis scale is set accordingly.

**Procedure:** How to Add an Axis Title

1. Create a chart with an axis label.

2. On the *Format* tab, in the *Labels* group, click *Axis*, point to the axis that you are working with, and click *More Vertical Axis Options*, or *More Horizontal Axis Options*.

   The Format Axis dialog box opens.

3. On the Title tab, type the axis title in the *Text* field.

4. Click the *Style text* icon to open the Style dialog box, where you can style the text.

   The axis title is styled accordingly.

   The following image shows a chart with titles added to the vertical and horizontal axis labels.

---

**Procedure:** How to Set Advanced Axis Properties

1. Create a chart with an axis label.

2. On the *Format* tab, in the *Labels* group, click *Axes*, point to the axis that you are working with, and click *More Vertical Axis Options*, or *More Horizontal Axis Options*. 

---

![Chart with titles added to the vertical and horizontal axis labels.](chart-image)
The Format Axis dialog box opens.

3. On the Advanced tab, set the following options, as described in the following table:

<table>
<thead>
<tr>
<th>Options</th>
<th>Available for Vertical Axis Labels</th>
<th>Available for Horizontal Axis Labels</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclude Minimum Label</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Exclude Maximum Label</td>
<td>✔️</td>
<td>✔️</td>
</tr>
<tr>
<td>Descending Axis</td>
<td>✔️</td>
<td>✗</td>
</tr>
<tr>
<td>Show axis line</td>
<td>✔️</td>
<td>✗</td>
</tr>
<tr>
<td>Show zero line</td>
<td>✔️</td>
<td>✗</td>
</tr>
<tr>
<td>Custom Baseline (Value)</td>
<td>✔️</td>
<td>✗</td>
</tr>
<tr>
<td>Reverse Groups</td>
<td>✗</td>
<td>✔️</td>
</tr>
</tbody>
</table>

You can edit the color, weight, and style of all the lines that you set in the Line Style dialog box.

4. Click OK.

The axis advanced options are set accordingly.

**Formatting Data Labels**

Data labels highlight important data points on a chart. They identify exact numbers. You can customize data labels in a variety of ways to make them stand out more clearly on the chart. For example, using the Format Labels dialog box, you can change the position, angle, color, or size of data labels.

**Note:** The Format Labels dialog box offers different options depending on the chart type that you are using.

**Procedure: How to Access the Format Legend Dialog Box**

The Format Legend dialog box contains options for formatting a legend on a chart.

1. Create a chart.
2. On the Format tab, in the Labels group, click Legend, and then click More Legend Options. The Format Legend dialog box displays.

3. Use the following options to modify your legend:

   - **Legend Options.** This allows you to set options for showing or hiding the legend, setting the legend position, and showing the legend in reverse order.

   - **Markers & Labels.** This allows you to set Marker Style and Position. It also lets you stylize labels using a Style editor.

   - **Fill.** Determines how items in the legend will be filled. Options include No Fill, Solid Fill, or Gradient Fill. The default is No Fill.

   - **Border Styles.** Enables you to activate the display of a border for your legend. You can also specify a color.

**Formatting the Legend**

A legend contains information that is necessary to accurately interpret the data on a chart. By default, a chart displays either a vertical axis title if there is a single measure field, or a legend if there are multiple measure fields.

You can use the Format Legend dialog box to format the legend and customize its appearance on a chart.

**Procedure: How to Access the Format Labels Dialog Box**

1. Create a chart.

2. On the Series tab, in the Properties Group, click Data Labels, and then click More Data Label Options.

   The Format Labels dialog box opens.

**Formatting a Series**

A series is a measure field that is included in a chart. You can format a series in a variety of ways. For example, you can change the color of a series or change the appearance of markers on a series.
**Procedure:** How to Change the Appearance of a Marker

Markers are used to display points of data on a line chart. They are also used in the legend to identify the data that is on the chart. The different marker shapes distinguish one series from another.

1. Create a line chart.
2. Select a series on the line chart.
3. On the Series tab, in the Line group, click Marker, then select the marker shape.

   The markers are formatted.

   The following image shows a diamond marker for Product Category.

---

**Formatting and Display Tools for Data in a Visual**

When working with visualizations, you can use various filtering and editing tools to format the display of measure and dimension data in any given visual. For example, for measures, you can use the Edit Format option to set the display of decimals in the values of your selected measure. For measures and dimensions, you can add filters to limit the display of information. These options, which can be found on the right-click menu of a field, are defined and described in the following table.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter Values</strong></td>
<td>Creates a filter for the selected measure or dimension. You can select all values or only the one the data values that you want to display. In this way, you can exclude unwanted data. For visualizations, prompts are created, by default. However, you can clear this option when setting your filter options. This option displays for both measures and dimensions.</td>
</tr>
<tr>
<td><strong>Sort</strong></td>
<td>Enables you to set sorting options for the measure or dimension that you select. For example, you can sort your data values in ascending or descending order, or you can set limits for the display of information, the value for which is set to No Limit, by default. This option displays for both measures and dimensions.</td>
</tr>
<tr>
<td><strong>Visibility</strong></td>
<td>Controls the display of the selected measure or dimension in a visual. The default value is Show, but if you set the option to Hide, the values are hidden from the visual. This option displays for both measures and dimensions.</td>
</tr>
<tr>
<td><strong>Change Title</strong></td>
<td>Enables you to edit the title of the measure or dimension. In the Edit Title dialog box, type the new title in the Enter Title field, and click OK. Depending on the axis that you select, the new label will be applied accordingly. This option displays for both measures and dimensions.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Edit Format</td>
<td>Enables you to change the format of a field. This includes field type, display options, field length, and the specification of applicable decimal points. For more information, see <em>Changing a Field Format</em> on page 100. This option displays for measure fields only. <strong>Note:</strong> Any changes to the format of a field will be reflected in the tooltip for visualizations at design and run time.</td>
</tr>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can create multiple drill down links on a data field to external procedures or websites. This option is available for any measure field in a visualization.</td>
</tr>
<tr>
<td>More</td>
<td>Provides access to Aggregation functions, which enables you to apply Aggregation functions (for example, Sum, Average, and Count) to the numeric field that you select. This option is only available for measure fields. This option displays for both measures and dimensions.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes the selected field. This option is available in every field container. <strong>Note:</strong> In the Query and Filter panes, you can select and delete multiple data fields at one time. Press the Ctrl key, select two or more data fields, right-click, and then click Delete.</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Create Group</td>
<td>Allows you to create a group of elements based on the field data type that you select. Once you define a new group, a higher-level field is created that contains the selected elements. This option is available for dimension fields of non-numeric format or attribute. For more information, see Dynamic Grouping on page 70.</td>
</tr>
</tbody>
</table>

**Using Handles to Organize Your Visualization**

A typical visualization contains multiple charts, maps, and grids. You begin with the default canvas and insert any number of visuals. You can control the placement of these visuals using the handles that display when you drag a data field onto the canvas or insert a new visual.

You can add a visual in one of two ways:

- Drag a data field from the Data pane onto the canvas. Handles display, allowing you to select the location for the new visual, for example, top (above) or left of the current visual.

- On the Home tab, in the Visual group, click Insert to add a new visual or text object to the canvas. To set positioning of the new visual, drag the visual on top of another visual and drop the visual on top of the handle that displays the relative position for the new visual.

When you drag a visual on top of another visual, this activates a shaded area. This shaded area provides a preview of where the visual cell will dock if you release the mouse. It also indicates the size of the resulting visual.
The handles display within the shaded area. They allow you to indicate where you would like to place the current visual relative to the others on your canvas. The handles are located in the upper-right corner of the selected visual, as shown in the following image.

**Procedure:  How to Place a Visual in a Visualization**

You can indicate the placement of a chart, map, grid, or text object in a visualization.

1. Launch InfoAssist.
2. Add and place one or more visuals using one of the following methods:
   a. Drag a data field from the Data pane onto the canvas.
      
      Use the handles that display in the upper-right corner of the selected visual to select the location for the new visual, for example, below or to the right.
   b. On the **Home** tab, in the **Visual** group, click **Insert** to add a new visual or text object to the canvas.
      
      To set positioning of the new visual or text object, drag it on top of another visual. Use the handles that display in the shaded area to select a position relative to the underlying visual.
Procedure: How to Move a Visual in a Visualization

1. Launch InfoAssist.
2. Add and place multiple visuals in your visualization.
3. Select and drag the visual that you want to reposition on top of an adjacent visual and drop it on top of the handle that indicates the relative position you want to use.
   Use the handles that display in the shaded area to select a position relative to the underlying visualization.

Using Storyboards

The Storyboard feature allows you to capture and preserve snapshots of your visualizations as you create them.

Each time you add something to the storyboard, it is placed onto a unique PowerPoint slide. When you click Show, you can open and review your slides in PowerPoint.

Since storyboards give you the ability to turn your visualizations into a PowerPoint presentation, you can modify your storyboard to create a customized demo. For example, you can rearrange or delete slides, or add titles and text.

You can also make your visualization portable by saving the PowerPoint files that you create and sharing the slides through email or other electronic distribution.

Procedure: How to Create a Storyboard

1. Create a visual, for example, a bar chart or a grid.
2. On the Home tab, in the Storyboard group, click Add.
   Note: When you receive the Added to Storyboard message, click OK.
   Note: You can also click the down-arrow on the Insert button to insert a chart, grid, or text.
   Repeat steps 2 through 4 until you complete your data analysis.
5. On the Home tab, in the Storyboard group, click Show.
   A new browser window opens, and you are prompted to open or save the PowerPoint file that contains your storyboard.
   If you click Open, the storyboard opens in PowerPoint. You can save the file as a PowerPoint presentation on your machine.
If you click Save, the storyboard will be saved to a PowerPoint (.pptx) file and placed in the Downloads folder on your machine. Click the down arrow on the right side of the Save button to perform a Save as. This allows you to specify the drive and directory to which the file will be saved.

In PowerPoint, each storyboard frame displays as a PowerPoint slide, as shown in the following image.

---

### Animating Visualizations

You can animate visuals in a visualization. Each individual visual can have different animation settings. The animations for each visual execute when you run the visualization.

**Procedure:** How to Add Animation to a Visual

1. Create a visualization with one or more visuals.
2. Select the visual that you want to animate.
3. On the Format tab, in the Interactive group, click Interactive Options.
4. On the Interactive Options dialog box, select the Show Animation check box.
   
   This animates the visual.
5. Set the duration for the animation, which determines the speed at which the animation occurs. The default value is 1400ms. Increase the value to make the animation slower, and decrease the value to make it faster.
6. Optionally, clear the *Enable Hover Over Effect* check box.

   This option lightens or adds a border to the segment of the visual that you move your mouse over.

7. Click *OK*.

8. Click *Run*.

   Your visual animates automatically based on the options that you specified.

**Using Visualizations at Run-Time**

In InfoAssist, you can run visualizations that are either saved or run dynamically at run time. In this case, the visualization opens in a separate browser window, as shown in the following image.

In the WebFOCUS Business Intelligence Portal, all users can run stored visualizations that are available to them. In this case, the visualization opens in a new page.
Working With Filters at Run Time

If you have added a filter to your visualization, you can use the Prompts panel to control the display of information. When you run your visualization, the Prompts panel appears. This enables you to select additional components by which to filter the visualization.

**Note:** The filters that you apply at run time can be removed using the Remove Filter option in the Run-Time toolbar. This does not apply to filters that were added prior to running the visualization.

The following image shows an example of a visualization with an open Prompts panel.

![Visualization Example](image)

**Note:** If you select (or lasso) components of your visualization, the Prompts panel does not automatically update to reflect your selections.

**Procedure:** How to Filter Data With Tooltips at Run Time

1. Run a visualization from one of the following locations:
   - From the WebFOCUS start page.
   - From the Application Main Menu or Quick Access Toolbar in InfoAssist.
2. Click, point to, or lasso data in your visualization.
A tooltip opens, as shown in the following image.

The tooltip includes the following options:

- **Filter Chart.** Filters the visualization by the data values that you have selected.
- **Exclude from Chart.** Excludes the selected data values from the visualization.
- **Remove Filter.** Removes the filter and returns the visualization to its original state.

**Note:**

- The same run-time options are available when you run your visualization on a mobile device.
- If you are working with a single bar, line, or other visualization object that displays a single point or value, the Filter Chart and Exclude from Chart options are not available. This applies when working in Live Preview and at run time.
**Viewing Data at Run Time**

When viewing data at run time, you can access the data behind each visual in your visualization. Using the Show Data option, which is available from the Run-Time toolbar, you can view your data in summary format. This grid display includes totals for the categories in your visual, based on the data fields that you selected. All InfoAssist users can use this option with the visualizations that are available to them.

**Procedure:** How to View Data at Run Time

1. Run a visual or visualization from one of the following locations:
   - From the Application Main Menu or Quick Access Toolbar in InfoAssist.
   - From the WebFOCUS start page.
2. In the bottom-right corner of the visual cell, click the arrow.
   The Run-Time toolbar opens.
3. Click the **Show Data** button.
   The visual changes to the grid view, displaying the underlying data for the selected visual.
   Click the **Show Data** button again to return to your visual.

   **Note:** The same run-time options are available when you run your visualization on a mobile device.

**Using the Run-Time Toolbar Options**

You can access the Run-Time toolbar by clicking the arrow button, which is located in the bottom-right corner of each visual cell at run time. The Run-Time toolbar is shown in the following image.

The Run-Time toolbar options are described in the following table:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Show Data</td>
<td>Alternates between the visual and the grid view, which shows the underlying data. To return to the visual view, click the Show Data button again.</td>
</tr>
<tr>
<td>Icon</td>
<td>Name</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Reset to Default</td>
<td>Resets all changes and returns the visualization to its original state.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Remove Filter</td>
<td>Removes the filter and returns the visualization to its original state. This option is only available if a filter is applied at run time.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Show/Hide</td>
<td>Shows or hides the options on the Run-Time toolbar.</td>
</tr>
</tbody>
</table>

**Note:** The same run-time options are available when you run your visualization on a mobile device.
Navigating Reports and Charts

Using features like Auto Drill, Auto Linking, and Multi Drill, you can easily navigate your reports and charts. For information on additional report navigation options, see *Creating Customized Report Outputs* on page 111.

**In this chapter:**

- Using Auto Drill
- Using the Auto Linking Feature to Link Content
- Using Multi Drill

### Using Auto Drill

Auto Drill enables you to navigate through different levels within the dimension hierarchy of your data source. This allows you to review underlying data for a particular area, and move through the structure of your data source based on your informational needs.

In order to use Auto Drill, you must enable it by clicking the Auto Drill button on the *Format* tab, in the *Run with* group.

Once you have enabled Auto Drill, you can develop your report or chart and run it to activate the hyperlinks that Auto Drill creates. This enables you to navigate up or down through the related hierarchy of your data source by clicking the links that display.

When you click a hyperlink, the option to drill up or drill down displays, depending on where you are in the hierarchy of your data. You can then select one of these options to begin navigating your data. For example, if you have Product Category in your hierarchy, you would be able to drill down to Product SubCategory. When you drill down, you can subsequently drill back up to the originating dimension sort field. If you have selected a data source that has multiple levels and your report or chart uses a component in the middle of the hierarchy, both the Drill up and Drill down options will display. Once you have started navigating your data using the Drill up and Drill down options, the Restore Original option displays, enabling you to start your data analysis over by re-executing the original Auto Drill request.
The drill up and drill down options are shown in the following image.

![Image of drill up and drill down options]

At run-time, the Auto Drill functionality displays a breadcrumb header. This defines your current location in the hierarchy of your data source and enables you to navigate back and forth between different levels in your data.

**Important:**

- The Auto Drill functionality is only available for data sources that have a dimension hierarchy.
- If you have Auto Drill enabled and you attempt to run your report or chart in deferred mode, the hyperlinks will not display. This is also true for Auto Drill enabled reports that are distributed through ReportCaster.
- With the exception of Visualization mode, Auto Drill is available at run-time, but not in Live Preview.
- Auto Drill is supported for HTML and HTML Analytic Document reports.
- Auto Drill is automatically enabled in Visualization mode for data sources that have a dimension hierarchy.
- Auto Drill is not supported for all HTML output format charts, or for HTML5 output format charts that do not support the new chart attributes syntax.
- Auto Drill is not supported on Across fields in reports.
- You must use dimension fields as a sorting field, either BY or ACROSS.
If you are creating a chart that has multiple dimension sort fields in the request and some of these belong to the same dimension hierarchy, you may encounter multiple links with the same label in the drill menu.

When working in Document mode, Auto Drill is unavailable.

Auto Drill functionality is not available in reports distributed by ReportCaster, because Auto Drill uses live data, in an interactive session, for data drilling. Data values and totals may not be the same if the data has changed since the last distribution. Mixing past data with current data could impact data analysis.

When Auto Drill is enabled, Accessibility is disabled. When Accessibility is enabled, Auto Drill is disabled. In Chart mode, Accessibility is disabled, by default.

Auto Drill is not supported with Save Parameters reports.

**Procedure:** How to Use Auto Drill to Navigate the Hierarchy of Your Data Source

1. Select a data source that has a dimension hierarchy. For example, *wf_retail_lite.mas*.
2. Create a report or chart with one or more hierarchical fields (for example, Product, Category), as shown in the following image.

3. On the *Format* tab, in the *Run with* group, click *Auto Drill*.
4. Click *Run*.

The report or chart displays.
5. For reports, click a hyperlinked field within your report. For charts, hover over a chart aspect (for example, a bar).

A menu appears, as shown in the following image.

6. Select a hierarchical value to which to drill down to.

Once you have drilled down on a field, you can subsequently drill up.
7. To return to the default state of the report or chart, click a hyperlink or hover over a chart aspect, and then click *Restore Original*, as shown in the following image.

Using the Auto Linking Feature to Link Content

Auto Linking makes it easy to connect reports and charts in your development environment, expanding the reporting capabilities of your organization. Using Auto Linking, you can dynamically link HTML reports, reports, and HTML5 charts with a single report or chart of any format, based on their common sort (BY) fields and parameters referenced in any filters. It is this commonality that dynamically links content in your WebFOCUS repository, allowing you to discover new possibilities in your data, and explore new relationships within your reporting enterprise. In addition, Auto Linking saves development time and effort, because drilldowns do not need to be manually created and maintained.

To use Auto Linking, you must use the Enable Auto Linking option in InfoAssist to set the reports or charts that can be auto-linked. In addition, you must also set reports or charts to be Auto Link targets. The options to enable and disable Auto Linking and Auto Link Target functionality are available on the Format tab, in the Auto Linking group, in InfoAssist.

**Note:**

- The Auto Link Enabled option is activated only when the HTML, HTML5, and format is selected.
You can open an existing report or chart and enable Auto Linking or set the item as an Auto Link target.

When Auto Link functionality is activated, your reports or charts display a link for each sort (BY) field with qualifying target reports or charts at run time. In Auto Link enabled reports, you must add sort (BY) fields in the BY field container. In Auto Link enabled charts, you can add sort (BY) fields to the Horizontal Axis, Vertical Axis, or Color field containers.

To qualify a report or chart as an Auto Link target, you must include filters that contain the parameters that you selected as the sort field or fields in the enabled report or chart. The parameter names defined in these filters must be the same as the sort (BY) field names in the Auto Link enabled report. When you select a report or chart as the Auto Link Target, it specifies that the parameter information should be catalogued, and will be evaluated when an Auto Link enabled report or chart is run.

For an Auto Link enabled report at run time, the qualifying target reports and charts are those that have filters with parameters for the selected sort field and the sort fields that precede it, which appear to the left. For an Auto Link enabled chart at run time, the target reports and charts are those that have filters with parameters for all sort fields. For run time for both reports and charts, the linked sort field values in the Auto Link enabled report or chart are passed to the Auto Link target report so that it can be filtered by the sort (BY) field values.

For example, you may have an Auto Link enabled report that contains sort (BY) fields Product Category and Model, with a measure (Sum) field, Revenue. To qualify as an Auto Link target, other reports or charts in your repository can contain a single filter with a parameter for Product Category, or two filters with parameters for both Product Category and Model. When you run the Auto Link enabled report, the Product Category field will link to target reports or charts that have a filter with a parameter for Product Category and the Model field will link to target reports or charts that have filters for both Product Category and Model.

If you use the same example for an Auto Link enabled chart instead of a report, you can access the target reports or charts from a tooltip option that displays when you point your mouse over an area of the chart, such as a bar that represents Revenue by Product Category and by Model.
Using Optional Parameters with Auto Linking to Enhance Drilldown Results

In addition to the basic Auto Linking functionality that is available in InfoAssist, you can also add optional parameters to your Auto Link reports and charts, extending the capability of this feature. An Auto Link Enabled report can link to any target content that you are authorized to access that satisfies the sort (BY) field to the Auto Link Target report filter parameter requirement. Auto Link Target reports that satisfy this requirement and also have optional filter parameters for other fields are included in the Auto Link target report evaluation, so that all possible combinations of run-time parameters are evaluated and available as links as you run the request. This may produce additional reports or charts in your list of available Auto Link targets, offering you access to an expanded network of related content.

Setting a parameter to optional is not required because the Auto Link Enabled report will pass the value for the fields being filtered to the Auto Link Target report. When a sort (BY) field value in an Auto Link Enabled report is selected, that value and the value of its parent sort fields are passed to the Auto Link Target. When a measure value in a chart is selected, all sort (BY) field values for that measure are passed to the Auto Link Target. If you select the Optional option, the Auto Link Target report can run on its own (from the Resources Tree or within InfoAssist) without being prompted by Autoprompt for a value for the parameter. This is because optional parameters are assigned a default value.

With Auto Linking, you can link as many reports and charts as you want, and Auto Link Enabled reports can also be an Auto Link Target which contributes to the development of a cascading linkage of reports. For more information, see Using Filters to Customize the Display of Data.

Note:

- The linked reports displayed are limited to those that you are authorized to run or run deferred.

- The Auto Link Enabled and Auto Link Target options can be set individually, or both can be set on the same report or chart if that item meets the Auto Linking requirements.

- Consideration should be given to how many reports or charts are indicated as Auto Link targets, as the run-time Multi-drill menu for the qualifying target reports may become long in length. In these cases, some browsers may display a script processing warning message.

- Auto Linking utilizes the Multi-drill feature with cascading menus, except when running an HTML report with On-demand Paging enabled or a chart request that is a legacy graph format (PFJ-based formats, such as PNG and non-bucket HTML5), which will display a single level list in the order the drill-downs are specified in the request.
The Multi-drill cascading menu displays:

- Horizontal lines to separate user-specified drilldowns and Auto Link navigation options.
- Auto Link Target reports in a single-level list that is sorted alphabetically, first by folder, and then the Auto Link Target reports within the folder. This may differ from the sort order of the resource tree that also applies the Properties Sort order option when sorting folders and items within folders.

When drilling down through a list of Auto Link target reports, a previously selected Auto Link target report will be excluded so that the available Auto Link targets are reports that you have not yet viewed.

**Procedure: How to Set an Existing Report or Chart as Auto Link Enabled**

1. On the WebFOCUS start page, select a file from within a folder, right-click, and select *Edit*. InfoAssist opens in the relevant mode.
2. Verify that there is a sort (BY) field in the report or chart.
   - For reports, sort fields are added to the BY field container.
   - For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.
3. On the *Format* tab, in the *Auto Linking* group, click *Enable Auto Linking*.
4. Save the report or chart.
   Your existing report or chart is now Auto Link enabled.

**Procedure: How to Set an Existing Report or Chart as an Auto Link Target**

1. On the WebFOCUS start page, select a file from within a folder, right-click, and select *Edit*. InfoAssist opens in the relevant mode.
2. On the *Format* tab, in the *Auto Linking* group, click *Auto Link Target*.

   **Note:** Selecting Auto Link Target specifies that the parameter information for this report or chart will be stored, adding it to the repository of reports and charts that will be evaluated when an Auto Link enabled report is run.

3. Verify if the report or chart has an existing filter, as qualifying target reports are those that have filters with parameters for the sort (BY) fields in Auto Link enabled reports or charts. If a filter does not exist, add a filter with a simple parameter to the target report or chart.
   a. From the Data pane, drag a sort (BY) field into the Filter pane.
b. Using the Create a filtering condition dialog box, select Parameter as the Type and use the default Name value, as shown in the following image. You may also select the Optional check box.

![Create a filtering condition dialog box](image)

**Note:** When creating a parameter for a field, the parameter name defaults to the fieldname that you select. In the previous image, the creation of a filter with parameter Product Category is shown. To ensure that the name of the parameter is the same as the sort (BY) field in the Auto Link enabled report or chart, do not change the name of the parameter that is generated by your field selection.

c. Click OK, and then click OK again to exit the Create a filtering dialog box.

4. Save the report or chart.

Your existing report or chart is now set as an Auto Link target.

**Procedure:** How to Create a New Auto Link Enabled Report or Chart

1. Open InfoAssist in Report or Chart mode.
2. From the Open dialog box, select a data source.
4. Add fields to the report or chart, ensuring that one is a sort (BY) field.

  - For reports, sort fields are added to the BY field container.
For charts, sort fields are added to the Horizontal, Vertical, or Color field containers.

5. Save the report or chart.
   Your report or chart is now set as Auto Link Enabled.

**Procedure:** How to Create a New Auto Link Target Report or Chart

1. Open InfoAssist in Report or Chart mode.
2. From the Open dialog box, select a data source.
3. On the **Format** tab, in the Auto Linking group, click **Auto Link Target**.

   **Note:** Selecting Auto Link Target specifies that the parameter information for this report or chart will be stored, adding it to the repository of reports that will be evaluated when an Auto Link enabled report is run.

4. Add fields to the report or chart.
5. Add a filter with a simple parameter to the target report or chart.
   a. From the Data pane, drag a sort (BY) field into the Filter pane.
b. Using the Create a filtering condition dialog box, select Parameter as the Type and use the default Name value, as shown in the following image. You may also select the **Optional** check box.

![Create a filtering condition dialog box](image)

**Note:** When creating a parameter for a field, the parameter name defaults to the fieldname that you select. In the previous image, the creation of a filter with parameter Product Category is shown. To ensure that the name of the parameter is the same as the sort (BY) field in the Auto Link enabled report or chart, do not change the name of the parameter that is generated by your field selection.

c. Click **OK**, and then click **OK** again to exit the Create a filtering dialog box.

6. Save the report or chart.

Your report or chart is stored as an Auto Link target.

**Procedure:** How to Run an Auto Link Enabled Report or Chart

You can run an Auto Link enabled report or chart from within InfoAssist or from the WebFOCUS start page.

1. Open and run an Auto Link enabled report or chart in one of the following ways:
   - In InfoAssist, open or create an Auto Link enabled report and on the Quick Access toolbar, click **Run**.
   - From the WebFOCUS start page, right-click a report or chart that is Auto Link enabled and click **Run**.
2. Use the hyperlinks to link to other reports and charts, based on the following information:

- **Reports.** Displays with hyperlinks on the sort (BY) fields that have qualifying target reports. Click a hyperlink to display the menu with the Auto Links option, which cascades to list the qualified Auto Link target reports and charts, as shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Revenue</th>
<th>Quantity Sold</th>
<th>Cost of Goods</th>
<th>Gross Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>$120,000,000</td>
<td>511,667</td>
<td>$89,753,898.00</td>
<td>$39,854,440.53</td>
</tr>
<tr>
<td>Camcorder</td>
<td>$104,866,857</td>
<td>455,244</td>
<td>$104,866,857.00</td>
<td>$49,598,845.24</td>
</tr>
<tr>
<td>Computers</td>
<td>$103,316,482</td>
<td>351,777</td>
<td>$69,807,664.00</td>
<td>$33,508,818.12</td>
</tr>
<tr>
<td>Media Player</td>
<td>$246,073,059</td>
<td>771,934</td>
<td>$190,240,481.00</td>
<td>$55,832,578.36</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>$291,294,933</td>
<td>1,114,332</td>
<td>$205,113,863.00</td>
<td>$86,181,070.52</td>
</tr>
<tr>
<td>Televisions</td>
<td>$78,381,132</td>
<td>105,188</td>
<td>$61,551,109.00</td>
<td>$16,830,023.81</td>
</tr>
<tr>
<td>Video Production</td>
<td>$58,053,276</td>
<td>199,749</td>
<td>$40,105,657.00</td>
<td>$17,947,619.62</td>
</tr>
</tbody>
</table>
Charts. Displays with aspects over which you can hover (for example, a bar) in the chart. A tooltip displays with the Auto Link target reports and charts, as shown in the following image.

Using Multi Drill

The Multi Drill functionality enables you to create multiple drill down links on a data field in a report or chart. This is useful when you want to define custom links to other visualizations, charts, reports, InfoMini procedures, or external URLs.

Using the Multi Drill functionality, you can define conditions for drilling down or through the data element that you select. Once drill down information is saved and you run the report or chart, the drill down options display when you click or hover over the defined area of a report or chart, respectively.
You can create drill down links by selecting a field in the Query pane. On the Field tab, in the Links group, click Drill Down to open the Drill Down dialog box. You can also right-click a field in the Query pane, and click Drill Down. The Drill Down dialog box is shown in the following image.

When you access the Drill Down dialog box, the name of the field that you selected displays in the title bar. This enables you to identify the current field and is useful when working with Drill Down parameters.

In the Drill Down dialog box, you can configure a hyperlink or drill-down procedure. When you run the report, you can click the link that is created, which would take you to the specified URL or execute the specified procedure.

You can also create multiple drilldowns for a selected field. The drill down links that you define display as separate entries in the drill down list, also known as the drill menu, at run-time. The display of these entries is based on the naming conventions that you applied when creating the multi-drill scenario.
Once your drilldown options are defined, you must run your report in order to access the drill down links that you have created. For reports, the links display when you click on a hyperlink for the data field that you selected. For charts, they display when you hover over an area of the chart for which the drill down has been defined (that is, the field that you selected when you defined the drill down).

These links enable you to drill directly through to an external procedure or URL.

For example, you can create one drill down link for an existing procedure, and another for a webpage. Both drill downs are stored for the underlying field that you selected. Once you define the first drill down, additional options display on the toolbar, as shown in the following image.

Note: You can rename a drill down using the Description field in the right pane of the Drill Down dialog box.
The following icons are available on the Drill Down dialog box toolbar:

- **Create a new drill down.** This option is enabled when all required information is provided for the first drill down. When you click *Create a new drill down*, a new drill down item is created. This switches the drill down functionality from a regular drill down to multi-drill. By default, the name of the drilldown is Drill Down n, where n is a consecutive integer, such as Drill Down 1, Drill Down 2, etc. This option is initially disabled, but is enabled after you have created at least one drill down link.

- **Duplicate the selected drill down.** When an existing drill down item is selected, clicking this option duplicates the item. A (Copy n) is appended to the name of the drill down, where n is the consecutive number assigned to the duplicated drill down. Once assigned, the name can subsequently be changed in the Description field. Consecutive copies can also be rearranged by dragging the drill down items into the desired order.

  **Note:** The Duplicate button is only active when sufficient information is available for the selected drill down item.

- **Rename the selected drill down.** This option enables you to rename an existing drilldown and is active, by default. When this option is selected, the Description field is selected, allowing you to provide a new name for the drill down link. You can enter a description up to 100 characters long. If you remove the description, the drilldown is renamed to the default name.

- **Remove the selected drill down.** If you have a drill down item selected, the Remove the selected drill down option is active. When you select this option, the current drilldown is deleted. If a drill down item is removed, the next drill down item is automatically selected. If you remove the last drill down item, the Drill Down dialog box resets to its initial state, restoring Drill Down 1 as the default value.

- **Options.** The Options functionality enables you to change the order of your drill down items. This allows you to control the order in which the items are presented in the drill menu when you run your report and click on a hyperlink. You can change the order by selecting a defined drill down in the list that is presented under Edit Order and then clicking the Move Up or Move Down button. You can also remove one or more drill down items from the list by selecting the desired items and then clicking the *Remove from List* button. If you multi-select your drill down items using the CTRL key, the Move Up and Move Down buttons are disabled.

  **Note:** Move Up, Move Down, and Delete are also available as context menu options when you right-click a drill down item in the Edit Order list.

The Drill Down dialog box contains the following options for specifying drill down information for the selected field:
Note: When specifying parameters for your drill down, click Add Parameter to add them to your parameters list.

- **Report.** Select this option to choose a report for the current drill down. This option is selected by default.

- **Report.** Enables you to browse to a stored report.

- **Description.** Provides a field in which to describe the report. If you selected a report by browsing, this field is automatically populated with the title of the procedure or the name where procedure titles are not accessible. This field is also used to rename a specified drill down.

- **Target.** Allows you to specify a target for the drill down. Options include: New Window, Same Window, or a value that you specify. The default value for report is New Window.

- **Parameters.** Displays the parameters that you have indicated for the current drill down.

Note: When you drill down to an InfoMini report with dynamic parameters, the child report is generated with the filter condition set by the parent report applied. You can access the AutoPrompt dialog box by clicking the **Show filter panel** button to modify the data selection with InfoMini.

- **Refresh BI Portal.** Select this option to refresh the components of the BI Portal and pass parameters to them.

- **Refresh.** Provides options by which to refresh the page. Options include Current Page and All Pages.

- **Description.** Provides a field in which to describe the refresh process. This field is also used to rename a specified drill down.

- **Target.** Reflects the target for the drill down. The only applicable value for Refresh BI Portal is Same Window.

- **Parameters.** Displays the parameters that you have indicated for the current drill down.

- **Auto Link Target.** Select this option to create an explicit list of Auto Link targets. Upon selection, these will be available in the drill down menu at run time.

Note: When working with reports, the Auto Link Target drill down option is only available for a selected dimension (BY) field. For more information, see *Using the Auto Linking Feature to Link Content* on page 349.

- **Auto Link Target.** Enables you to browse to a stored target report.
- **Description.** Provides a field in which to describe the target report. If you originally selected a report by browsing, this field is automatically populated with the report title or the name where titles are not accessible. This field is also used to rename a specified drill down.

- **Target.** Enables you to specify a target for the drill down. Options include: New Window, Same Window, or a value that you specify. The default value for Auto Link Target is New Window.

- **Parameters.** Displays the parameters that meet the column-to-parameter requirement for the selected target report.

  For more information, see *Using the Auto Linking Feature to Link Content* on page 349.

- **Web Page.** Select this option to indicate that you want to drill through to a webpage. Enter a value in the URL field.

- **URL.** Enables you to specify the URL for the webpage to which to drill down. This option is available only when Web Page is selected.

- **Description.** Enables you to enter additional comments related to the drill down. This field is also used to rename a specified drill down.

- **Target.** Enables you to specify a target for the drill down. Options include: New Window, Same Window, or a value that you specify. The default value is New Window.

- **Parameters.** Displays the parameters that you have indicated for the current drill down.
If you are working with a report that has parameters, the parameter names are automatically retrieved and made available from the Name control in the Parameters section of the Drill Down dialog box, as shown in the following image.

By default, the field is labeled with a value of Name. If there are multiple parameters to choose from, you can use the drop down list to make a selection. You can also manually enter a name to create a new parameter. The parameters that display are populated from the underlying report procedure (.fex) that you selected for your drill down.

The Type field enables you to specify a field or constant value. The options in the Value list are based on the fields that you selected for your report. The item that you select determines the value for the parameter (for example, Discount or Revenue).

Note: If you switch the Type field from Field to Constant or from Constant to Field, the Value field is reset, enabling you to specify a unique value.

Procedure: How to Create a Single Drill Down Link

You can create a single drill down link on a measure field.

1. Create a report or chart with at least one measure field.
2. In the Query pane, do one of the following:
   - Right-click the measure field and click Drill Down.
   - Click the measure field and on the Field tab, in the Links group, click Drill Down.
   The Drill Down Dialog box displays.
3. Select one of the following Drill Down options:
   - Report
   - Refresh BI Portal
   - Auto Link Target
   - Web Page
4. Populate the fields based on the drill down option you selected.
   **Note:** Descriptions for these fields are provided earlier in this topic.
5. Optionally, rename the Drill Down using the Description field. This dictates how the Drill Down will appear in the left pane of the Drill Down dialog box.
6. Click OK.
   The drill down link displays when you hover over the defined area of a report or chart, at run time.

**Procedure:** How to Create Multi Drill Links

You can create a multiple drill down links on a single dimension field.

1. Create a report or chart with at least one dimension field.
2. In the Query pane, do one of the following:
   - Right-click the dimension field and click Drill Down.
   - Click the dimension field and on the Field tab, in the Links group, click Drill Down.
   The Drill Down Dialog box displays.
3. Select one of the following Drill Down options:
   - Report
   - Refresh BI Portal
   - Auto Link Target
4. Populate the fields based on the drill down option you selected.  
   **Note:** Descriptions for these fields are provided earlier in this topic.

5. Optionally, rename the Drill Down using the Description field. This dictates how the Drill Down will appear in the left pane of the Drill Down dialog box.

6. Repeat steps 3-5 until you have added all of the drill down links required.  
   **Note:** The following image defines three unique drill down links for the selected dimension field.

7. Click **OK**.
The links display when you hover over the defined area of a report or chart, at run time, as shown in the following image.
You can style and customize reports, charts, and visualizations using the ribbon.

**In this chapter:**
- Customizing Reports
- Using the Report Style Dialog Box
- Using the Color Dialog Box
- Accessing Reporting Options in the Report Group
- Enabling Report Features
- Enabling Chart Features
- Labeling Charts
- Using Interactive Options
- Customizing Page Setup

**Customizing Reports**

You can customize reports using the various options on the Layout tab and Field tab.

- **Cell Padding.** Opens the Cell Padding dialog box, where you can set specific values to control the amount of space inserted between rows and columns in a report. For more information, see *How to Use Cell Padding in a Report* on page 99.

- **AutoFit.** Limits the width of columns in a report to be no wider than the largest value in each column. When additional fields are added, the report automatically grows at design time. AutoFit Column is selected, by default.

- **Page Break.** Starts a new page when the primary sort field changes. Clicking the drop-down icon enables you to select *Reset Page Numbers*, which allows you to reset page numbers on a page break to start at 1.

- **Line Break.** Inserts a line in the report output when the primary sort field changes.
- **Sub Header.** Opens a dialog box where you can type text to add a subheading just below the column titles in the report output when the primary sort field changes.

- **Sub Footer.** Opens a dialog box where you can type text to add a subfooting at the end of the data on each page of the report output when the primary sort field changes.

- **Subtotal.** Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields when the primary sort field changes.

The drop-down menu on the **Field** tab, in the **Format** group provides three field-type options for the selected column, which are Alphanumeric, Integer, and Decimal. Selecting the fourth option, More options, opens the Field Format Options dialog box, which provides further formatting options for the selected field. For more information, see *Changing a Field Format* on page 100.

Using the Currency Symbol drop-down list, you can apply options such as floating and non-floating currency. You also apply percent signs and commas using the check boxes on the Field Format Options dialog box.

To turn on the non-floating currency option, open the drop-down menu and select *Non floating Currency*. To turn off the non-floating currency option, click the Currency Symbol drop-down list again and make a different selection, or choose *None*.

The following options on the Field tab, in the Display group:

- **Hide Field.** Allows you to hide a selected field.

- **Hide Missing.** Allows you to hide fields that have no value.

- **Aggregation.** Opens a drop-down menu of the following options:
  - None (default)
  - Sum
  - Average
  - Count
  - Count Distinct
  - Percent of Count
  - Distinct Values
  - First Value
Last Value

Maximum

Minimum

Total

Percent

Row Percent

Median

Average Square

Sum is the default aggregation type value for all numeric fields added to the Measure Query field container in the Query pane. Changing the Measure Query field container from Sum to Print, Count, or List overrides all assigned aggregation type values. For more information related to reports, see How to Display Numeric Measure Data Using Aggregation Options in a Report on page 109. For more information related to charts, see How to Display Aggregations on Measure Data on page 186.

Traffic Lights. Opens the Traffic Light Condition dialog box. From this dialog box, you can do the following:

- add new conditional styling by applying traffic light (and other) colors to a selected field in the output when the field meets specified criteria
- modify existing conditional styling

For more information related to reports, see Styling Reports on page 90. For more information related to charts, see Traffic Light Condition Dialog Box on page 175.

Data Bars. (Reports only.) Adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values. For more information, see How to Add Data Visualization Bars to a Report on page 109.

Within. Allows you to use specific aggregation tasks at different report levels. You can use the Within phrase to manipulate display field values as they are aggregated within a sort group rather than a report column. For more information, see How to Access the Within Functionality on page 109.
Column(s). Allows you to indicate the number of columns in which you wish to display multiple graphs. The value can be between 1 and 512. The default is 1. This option is also available from the Query pane shortcut menu for a Multi-graph component.

Using the Report Style Dialog Box

The Report Style dialog box provides options to style your report, as described below. You can access this dialog box by clicking Style on the Home tab, in the Report group.

- **Font.** Use the drop-down menu to change the font.
- **Font size.** Use the drop-down menu to change the numeric value for the font size.
- **Font style.** Click the appropriate button (bold, italic, underline) to style the selected text.
- **Text alignment.** Click the appropriate button (left, center, right) to align the selected text.
- **Font Color.** Click the button to open the Color dialog box, where you can select the font color. For more information, see *Using the Color Dialog Box* on page 371.
- **Background Color.** Click the button to open the Color dialog box, where you can select the background color for the report.
- **Currency Symbol.** Click the button to access the following currency symbols US Dollar, British Pound, Japanese Yen, Euro, New Israeli Shekel.

**Note:** The New Israeli Shekel currency symbol can be displayed with the following settings only:
- **Server codepage = 1255, 65001, 424, or 65002.**
Client codepage = 1255 or 65001.

Application server encoding = Cp1255 or UTF8.

Font name = Lucida Sans Unicode or Arial Unicode MS.

Reset to Quick Styles from Template. Click the button to reset all settings to the default settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK, all changes are committed. To undo global styling after it has been committed, you must use the Undo command on the Quick Access Toolbar.

Using the Color Dialog Box

The Color dialog box provides options for working with color in your report.

The Color dialog box options are:

- **Standard Color Swatches.** Provides a set of 48 predefined colors from which to choose on the left side of the dialog box. Your selection appears in the Selected Color field.

- **Custom Color Palette.** Provides a palette on the right side of the dialog box to define a custom color. Your selection appears in the Selected Color field.

- **Luminosity bar.** Drag the slider to change the luminosity (relative lightness or darkness) of a color. The corresponding numerical value appears in Lum.

- **Hue.** Indicates the hue value of your selected color. You can enter a value, or increase or decrease the hue value by using the up and down arrows, respectively.

- **Sat.** Indicates the saturation value of your selected color. You can enter a value, or increase or decrease the saturation value by using the up and down arrows, respectively.

- **Lum.** Indicates the luminosity (lightness or darkness) of your selected color. You can enter a value, or increase or decrease the luminosity value by using the up and down arrows, respectively.

- **Red.** Represents the numeric value of red (0 to 255).

- **Green.** Represents the numeric value of green (0 to 255).

- **Blue.** Represents the numeric value of blue (0 to 255).

- **Selected Color.** Displays the color that you selected.
Accessing Reporting Options in the Report Group

- **Transparent.** Makes the color transparent. This is only available for background colors.

Accessing Reporting Options in the Report Group

The Report group contains commands to enhance a report.

- **Theme.** Opens a dialog box where you can select a theme to style your report. You can use the default style sheet by clicking the *Use Default Stylesheet* button.

  You can also select a document styling theme or an application theme to style all reports created. Use the Environment and Styling section of the Options window, which is accessible by clicking *Options* in the Application main menu.

- **Style.** Opens the Report Style dialog box for applying global styling to the entire report. For more information about the Report Style dialog box, see *Using the Report Style Dialog Box* on page 370. For more information about styling reports, see *Styling Reports* on page 90.

- **Banded.** Opens a Color dialog box for choosing a color that provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report. For more information about the Color dialog box, see *Using the Color Dialog Box* on page 371. For more information about banded styling, see *How to Style Rows of Data With Alternating Colors in a Report* on page 95.

- **Header & Footer.** Opens the Header & Footer dialog box, from which you can add and style headings and footings.

  For a report, you can add and style report headings, page headings, page footings, and report footings. In the dialog box, the tab for Report Header is active, by default.

  For a chart, you can add and style page headings and page footings. Page Header is active, by default.

  You can drag fields from the Data pane into the Header & Footer dialog box.

  Another way to access the Header & Footer dialog box is to click the down arrow next to the Header & Footer button. It opens a drop-down menu from which you can select the heading or footing that you want to work with (Report Header, Page Header, Page Footer, Report Footer). After you make your selection, the Header & Footer dialog box opens, and the heading or footing that you selected is active.
From the Header & Footer dialog box, you can add and style the active heading or footing, or choose a different heading and footing to work with by selecting the applicable tab. You can switch among tabs, but InfoAssist does not save changes made on the tabs until you click Apply or OK. If you click Apply, the Header & Footer dialog box remains open. If you click OK, the dialog box closes.

You can style a selected heading or footing using the options on the styling toolbar. From left to right, you can customize the font type, font size, and font style (bold, italic, or underline). You can justify text (left, center, or right), select the font color and background color, and restore styling settings to their default value from the template.

You can also add page footings to your reports or charts. From the Header & Footer dialog box, select Page Footer. When working with reports, you may use the Additional alignment options icon, to specify whether you want to align the footer relative to the data (default) or relative to the page. The Align Relative to Data option places the footer directly below the data, and the Align Relative to Page option positions the footer at the bottom of the page. When working with charts, only the default page footer alignment option is supported.

**Note:** The Align Relative to Page option works with reports that use positioned formats (for example, PDF, PS, DHTML, PPT, and PPTX).

You can also insert *quick text* into a heading or footing. Quick text is supplied for you. It includes information that is typically useful in identifying a report or chart. From the preformatted text drop-down menu, you can select:

- Draft
- Page X of Y
- Confidential
- Date (multiple formats)
- Time (multiple formats)
- Created by (followed by a name)

For charts, an icon on the far right of the styling ribbon is enabled. This icon provides two options for controlling the way in which the page heading and page footing are rendered. The default option, Create Header and Footer as text, renders the heading and footing as text elements that are separate from the chart image. The option, Embed Header and Footer in the chart, renders the heading and footing text as part of the chart image.
Once you have added a heading or footing to a report or chart, you can double-click it on the canvas in design mode to reopen the Header & Footer dialog box. You can also right-click an existing heading or footing in design mode and click Edit from the menu to open the dialog box.

For more information on adding and styling headings and footings, see *How to Add Headings and Footings to a Report* on page 92 and *Formatting Page Headings and Page Footings* on page 244.

- **Column Totals.** (Reports only) Adds a grand total row to the bottom of the report to sum numeric data in each column. For more information, see *How to Add Column Totals to a Report* on page 108.

- **Row Totals.** (Reports only) Adds a grand total column to the right side of the report to sum numeric data in each row. For more information, see *How to Add Row Totals to a Report* on page 108.

**Enabling Report Features**

The options on the Format tab, in the Features group, while in Report mode, allow you to add pop-up titles to columns, stack measures, and more.

- **Title Popup.** Displays pop-up titles when the mouse pointer hovers over a column title in the report output. For more information, see *How to Add Pop-Up Titles to a Report* on page 108.

- **Accordion.** Creates expandable views of data for each vertical sort field. This option displays data values only for the first vertical sort field when you first view the output. You can manually expand your view to expose the data values of lower-level sort fields. For more information, see *How to Create Accordion Reports* on page 117.

  **Note:** You cannot use the Table of Contents with the Accordion feature.

- **Repeat Sort Value.** Displays all repeated sort values instead of blanks in the output after the first instance of a new sort value, which is the default behavior.

- **Stack Measures.** Displays all numeric measure field names in a column of the report output with the corresponding numeric data values. For more information, see *How to Implement Stack Measures* on page 118. For more information on Stacked Measures, see the *Stacking Columns* topic in the *Creating Reports With TIBCO WebFOCUS® Language* manual.

- **Analytic Document Options.** Opens the Analytic Document Options dialog box where you can configure your interactive report options such as menu items, graph engine, and colors. For more information, see *Creating Interactive Content* on page 475.
Accessibility. Allows a title to be added to a report, chart, or document that is Section 508-compliant.

The following table lists the output for which each feature is available. Yes means the output is available for the feature. No means that the output is not available for the feature.

<table>
<thead>
<tr>
<th>Feature</th>
<th>HTML</th>
<th>HTML5</th>
<th>PDF</th>
<th>Excel</th>
<th>PowerPoint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Popup</td>
<td>yes</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Accordion</td>
<td>yes</td>
<td>no</td>
<td>yes</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Repeat Sort Values</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
<td>yes</td>
</tr>
<tr>
<td>Stack Measures</td>
<td>yes</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>no</td>
</tr>
<tr>
<td>Accessibility (reports, charts)</td>
<td>yes</td>
<td>no</td>
<td>no</td>
<td>yes</td>
<td>no</td>
</tr>
<tr>
<td>Accessibility (documents)</td>
<td>no</td>
<td>no</td>
<td>no</td>
<td>yes</td>
<td>no</td>
</tr>
</tbody>
</table>

Enabling Chart Features

The options on the Format tab, in the Features group, when in Chart mode, allow you to add effects and different functionality to your charts.

Note: When working with maps, all options in the Features group are disabled with the exception of Frame & Background and Accessibility.

3D Effect. Sets the three-dimensional view to on or off. The 3D Effect feature is disabled for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types. This is the default.

Rotate. Toggles between a vertical display or horizontal display of a chart. For more information, see How to Rotate a Chart on page 247. The Rotate feature is disabled for pie, scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types.
Enabling Chart Features

- **Reference.** Opens a drop-down menu that provides the Add Reference Line to Y-Axis and Add Reference Line to X-Axis options. Selecting one of these options opens the appropriate Reference Line dialog box, where you can set the specific X-axis or Y-axis value, type the text that you want, and position the reference line on a chart. For more information, see *How to Display a Static Reference Line* on page 248. The Reference feature is disabled for pie, 3D, stock, gauge, gauge thermometer, spectral map, and funnel chart types.

  **Note:** The reference line option is not available in InfoAssist Basic.

- **Annotate.** Opens a drop-down menu that provides the Add an annotation option. Selecting this option opens the Annotation dialog box, where you can type the text that you want and position the annotation on a chart. For more information, see *How to Display Annotations* on page 251.

  **Note:** The annotation option is not available in HTML5. The annotation option is not available in InfoAssist Basic.

- **Grid.** Opens a drop-down menu allowing you to expand options for Horizontal or Vertical Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking *More Options* opens the Format Grid Lines dialog box. For more information, see *Formatting Gridlines* on page 205.

- **Frame & Background.** Opens the Frame & Background dialog box where you can edit the background style and frames for charts. The dialog contains different options depending on the chart type selected. For more information, see *Formatting a Frame and a Background* on page 225.

- **Gauges.** Opens the Gauge dialog box where you can edit your gauge chart. This button is only available when a gauge chart type is selected. For more information, see *How to Style a Gauge Needle* on page 243.

  **Note:** Gauge options are not available in InfoAssist Basic.

- **Analytic Document Options.** Opens the Analytic Document Options dialog box where you can configure your report options, such as menu items, graph engine, and colors. This button is available when the output type is set to or PDF Analytic Document.

- **Accessibility.** Allows a title to be added to a report, chart, or document that is Section 508 compliant. This option is only available for reports and charts when the output type is HTML or PDF. For documents, the output type must be set to PDF.

  **Note:** The chart features are unavailable when designing a chart that will be output in HTML Analytic Document or PDF Analytic Document formats.
Labeling Charts

You can add labels to charts using the Labels group on the Format tab.

**Note:** When working with maps, the Axes option is disabled.

- **Axes.** Opens a drop-down menu, where you can enable, stagger, and rotate horizontal and vertical axis labels. You can also edit the axis labels by clicking *More Horizontal Axis Options* or *More Vertical Axis Options*. For more information, see *Formatting Axis Labels* on page 215.

  **Note:** The Axes option to change the position of data labels is not available in InfoAssist Basic.

- **Legend.** Opens a drop-down menu, where you can select the *Show Legend* option to display the legend on the chart, or clear your selection to hide the legend, change the default legend position, and change the default legend orientation. For more information, see *Format Legend Dialog Box* on page 200.

Using Interactive Options

To add interactive options to a chart, on the *Format* tab, in the *Interactive Options* group, click *Interactive Options*.

**Note:** The Interactive group is enabled only when the HTML5 output format is selected for your chart.
When you click *Interactive Options*, the Interactive Options dialog box displays. The Interactive Options dialog box enables you to specify animation, mouse over, and scrolling effects in your chart.

Options on the Interactive Options dialog box include:

**Animation section**

- **Show Animation.** Enables you to specify options for animation in your chart. Clear this check box to disable animation. This option is selected by default.

  **Note:** If the Show Animation check box is cleared, the option to Animate Once is not available.

- **Animate Once.** Enables you to specify the frequency of chart animation. Select this check box to indicate that the chart should be drawn the first time a procedure is executed, but not on subsequent executions of that procedure. If this check box is not selected, the chart will animate every time the chart is redrawn.

- **Duration.** Defines the duration of the animation in milliseconds. You can manually enter a millisecond value (ms) or use the arrows to adjust the default value, which is 1400. This value may vary depending on the theme that you select.

  **Note:** When specifying a duration for an animation, larger numbers produce slower animation.
Mouse Over section

- **Enable Hover Over Effect.** Controls the display of the mouse over indicator, which shows chart component information when you hover your mouse over an object. This option is selected by default. However, settings in your theme may override this setting.

Scrolling section

- **Auto Enable X-Axis Scrolling.** Enabled by default in Visualization mode, this option controls the display of scroll bars for bar, line, area, scatter, bubble, and all matrix charts. In all other modes, you must enable the functionality in the Interactive Options dialog box on the Format tab. If you are working with a large dataset, this functionality enables you to use scroll bars to review your data from left to right. If your dataset is smaller, the scroll bar functionality automatically determines if a scroll bar is needed. You can disable and re-enable this option, depending on your display or data viewing requirements.

Customizing Page Setup

You can customize how your pages display when working with reports, charts, documents. These options can be found on the Layout tab, in the Page Setup group.

- **Margins.** Enables you to set margin values by choosing Normal (1 inch all around), Narrow (.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom. Choosing Custom opens the Margins dialog box, where you can set specific margins as needed.

- **Orientation.** Enables you to set the orientation of your report to portrait or landscape.

- **Size.** Enables you to select the size of the paper for printing output. You can choose A3, A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size (34 x 44 Inches).

- **Units.** Enables you to select the unit of measurement used for customizing the dimension fields of your report or chart. You can choose Inches, Centimeters, or Points.

- **Page Numbers.** (Reports only). Enables you to select page numbering options. You can choose one of the following:
  - No Lead (no space for headers)
  - On (page numbers only in headers)
  - Off (space for headers, but no page numbering)

  The Page Numbers value is overridden by header and footer text options.
Creating Maps to Illustrate Trends

Using InfoAssist, you can create maps to identify patterns or trends in your data. By converting data into values that can be displayed on a map, you are able to visualize scenarios, illustrate hot spots, and identify potential problem areas. For example, a law enforcement agency may use mapping functionality to identify areas of higher crime within the locations they cover. You can also use maps to determine how places are related, understand where things are located, and identify the best actions to take. By illustrating trends on a map, a decision maker can identify patterns easily, and reach conclusions sooner.

In this chapter:

- A Brief History of Mapping
- InfoAssist and Esri Integration
- Customizing the List of Geographic Roles
- Customizing the List of Basemap Definitions
- Enabling Additional Territories in a Leaflet Map
A Brief History of Mapping

An early example of how maps can be used to illustrate trends is the case of Dr. John Snow, an epidemiologist who was one of the first to use data to map occurrences of cholera to find the cause of infection. By plotting the cholera data on a map of a town, Dr. Snow was able to visualize a trend that showed higher incidences of cholera closest to water pumps. This example is shown in the following image.

Maps also allow you to measure size, shape, and distribution to detect and quantify patterns, and even perform predictive analytics. An example of how maps can help detect and quantify patterns is the scenario in which a state agency used a WebFOCUS mapping application to solve a problem with their food stamp system. Using this application, odd food stamp redemptions, such as rounded numbers transactions, were discovered. By plotting those transactions on a map, the agency discovered that the redemptions appeared in the same geographic location. Upon further investigation, the agency identified that individuals were selling their food stamps at reduced prices, $50 worth of food stamps for $40 in cash, to others instead using them as intended. This map example is shown in the following image.
When working with maps, the concepts of location intelligence and business intelligence are important to understand. A Geographic Information System (GIS) captures, stores, analyzes, manages, and presents data linked to a location, while Business Intelligence (BI) relies on the conversion of raw data into meaningful information. Location intelligence is the process of analyzing data to make better business decisions. It combines GIS and BI/Analytics to allow the recognition of patterns in your data, including the visualization and discovery of geospatial outliers, which would not be easily discovered if you use the technology independently and separately.

More specifically, maps use non-intrusive GIS workflows with existing data. You can view symbol layers for data bound to a geo-location, such as state, country, and ZIP code, in an integrated map viewer. Using metrics from your data, you can also visualize geographic roles or dimensions. Geographic roles, or dimensions, can be built directly into your Metadata or assigned to a data field when you create a map.

**InfoAssist and Esri Integration**

Using WebFOCUS InfoAssist with the Esri integration, you can create maps that help you illustrate or identify trends so you can take action quickly. WebFOCUS architecture provides the framework in which this system operates. Using a JavaScript map viewer, you can navigate the interface easily, as shown in the following image.
In addition, this integration utilizes the capabilities of Esri by leveraging the ArcGIS JavaScript API and content. Specifically, you can integrate data into maps with published content in ArcGIS Online platform. For more information, see http://www.esri.com/software/arcgis/arcgisonline. Additionally, by using this integration, you can include information about demographics, spending habits, crime, and lifestyle to maps that contain your data. These maps include layers with extensive demographic or reference detail and topography and allow you to view information about people, businesses, climate, and much more.

You can create the following maps in InfoAssist:

- **Choropleth.** A common thematic map that uses geographical measures (for example, states and countries), representing the values aerially while employing a varying intensity of colors. It is useful for visualizing location-based data, trends, and distributions across a geographic area. The color hues for Choropleth maps are dictated by the legend, based on the selected measure, enabling you to determine data concentration across your map.

- **Proportional Symbol (Bubble).** A map that represents coordinates, such as an address or intersection, using symbols of different sizes to represent any measure. These maps focus on specific areas, for which data concentrations may vary. When the data concentration is larger, the bubble will be bigger.

Both maps can be created in Chart or Visualization mode. Built-in zooming capabilities allow you to drill down to a specific geographic area of focus easily. This allows you to get a closer look at regional or local data, draw inferences, and make recommendations, without changing the initial view of your data.

In Chart mode, you can also use the Auto Drill and Auto Linking features that are available when you create charts or reports in InfoAssist. In Visualization mode, you can also drill up and down within different levels in a data hierarchy in a map. Auto Drill allows you to navigate through the geographical hierarchy of your map data at run time. You can use this information to visualize the same measure at different geographical hierarchies, such as Countries to States and States to Cities. Auto Linking allows you to connect to related charts or reports in your environment that share similar data parameters.

Using the Esri integration in InfoAssist, you can also add the following layers to your map:

- **Backgrounds.** Display a layer that positions data as it is located, in context to other geographical features, such as streets, terrain, and imagery. Some standard Background options may combine road, aerial, and topographic data using a variety of symbols. Hosted on ArcGIS, you can change your background at any time, to review your data in a different context.
When you apply a Background to your map, its appearance changes. You can then adjust the view of your data, showing different terrain or geographical views. Backgrounds provide at least 17 levels of zoom. For more information, see [https://developers.arcgis.com/javascript/jsapi/esri.basemaps-amd.html](https://developers.arcgis.com/javascript/jsapi/esri.basemaps-amd.html).

- **Reference Layers.** Display a layer of boundaries and locations that range from a continental scale to country, state, and even local neighborhood. For example, if you are viewing World data on electricity usage, you may want to add a Reference Layer that displays the borders and concentration of your data within each country.

- **Demographic Layers.** Display a layer of information about people and businesses in a specific demographic area. This includes the United States and 120 other countries. Demographic Layers are thematic maps that provide additional information about the location, such as spending habits, population, and lifestyles. You can add Demographic Layers to a map about sales data, to identify new locations for stores, based on the spending habits for a specific area.

Both mapextent and the Layers menu functionality are applied to your map when you select a Background, Reference Layer, or Demographic Layer. Mapextent is an automatic view of the map. Layers is a menu that appears on the map and provides access to options that allow you to adjust the information that is being displayed.

The map example in the following image shows the use of layers.

![Map Example](image.png)

**Note:** Backgrounds, Demographic Layers, and Reference Layers can be accessed from the Format tab for maps in both chart and Visualization mode. These layers are static, standard options that Esri provides for use with InfoAssist, and do not change based on the data source that you select.
Configuring an Esri On Premise Environment

The Esri On Premise functionality enables you to download and access mapping files through the use of a local Application Programming Interface (API). Once you download and configure the API, you do not need an internet connection to utilize the robust mapping features that Esri provides. For information on downloading and configuring the API that controls this feature, see How to Download and Configure the ArcGIS JavaScript API on page 386.

The Esri On Premise functionality provides you with local access to Esri mapping files. This is particularly useful if you are away from your office or without an internet connection. You may also be using a mobile device, such as an iPad or smartphone with a large screen, without an internet connection. The following mapping components are supported when using the Esri On Premise functionality:

- **Offline Basemaps.** Basemaps are an offering from ArcGIS. Standard basemaps are provided for your use offline. For example, there is an Oceans basemap and a Terrain with Labels basemap. In InfoAssist, these basemaps are also known as backgrounds. In an online setting, there are 10 basemaps available. In order to use offline basemaps you need to use a tiled mapservice published in the ArcGIS Server.

- **Offline Geographic Roles.** Geographic Roles are used to visualize measures with commonly known dimensions (for example, Country, State, Cities, and so on). These provide the location information often in the form of (x/y) needed to plot on a map. Geographic roles are pre-defined for online users through ArcGIS Online. In InfoAssist, a geographic role defines the geographic component that you can select when creating a map (for example, State or Continent). For an offline user, the options that display can be customized in the geoservices.xml file.

**Note:** Demographic Layers are not supported in an Esri On Premise environment.

**Procedure:** How to Download and Configure the ArcGIS JavaScript API

You can use this procedure to download and configure the API that controls the Esri On Premise environment.

1. Sign in to Esri ArcGIS.
2. In your browser, navigate to the following URL to download the API: https://developers.arcgis.com/downloads#javascript
3. Navigate to Version 3.28 of the ArcGIS API for JavaScript, as shown in the following image.

![Version 3.28 Release Notes](image)

4. Click `arcgis_js_v328_api.zip` to download the API.

5. In `drive:\ibi\WebFOCUS\nn\config\web_resource`, create a folder named `arcgis_api`.

6. Open the `arcgis_js_v328_api.zip` file downloaded in step 4 and navigate to `arcgis_js_v328_api\arcgis_js_api\library\3.28\3.28`.

7. Extract the files in that folder to the `drive:\ibi\WebFOCUS\nn\config\web_resource\arcgis_api` folder.

8. Next, verify the path to the API in the WebFOCUS Administration Console, as shown in the following image.

![WebFOCUS Administration Console](image)

**Note:** This is the path to which you extracted the API files. For example, `/web_resource/arcgis_api`

This field identifies the path to the internal ArcGIS Javascript API Source that develops ESRI-based maps. This setting is blank, by default, indicating that the use of the internal API source to develop ESRI maps is not activated. The API that is referenced is `https://js.arcgis.com/3.28/`, by default. To direct WebFOCUS to use the internal ArcGIS Javascript API to develop ESRI maps, enter the path to the local API files that you extracted into this setting. For more information, see the TIBCO WebFOCUS® Security and Administration manual.
**Note:** This path should be a relative path that is accessible within the local WebFOCUS install.

9. Click *Save*.

10. Next, open the following two local API files in a text editor:

    - `drive:\ibi\WebFOCUSnn\config\web_resource\arcgis_api\init.js`
    - `drive:\ibi\WebFOCUSnn\config\web_resource\arcgis_api\dojo\dojo.js`

   In both files, search for `HOSTNAME_AND_PATH_TO_JSAPI` to locate the `baseUrl` property. Replace the string `[HOSTNAME_AND_PATH_TO_JSAPI]` in `baseUrl:"https://[HOSTNAME_AND_PATH_TO_JSAPI]dojo"` with the path to your on-premise ArcGIS server. For example:

   ```javascript
   baseUrl:"https://localhost/arcgis/jsapi/jsapi/dojo"
   ```

11. In the WebFOCUS Administration Console, click *Clear Cache* to clear the browser cache. Your configuration is complete.

### Creating and Customizing Maps in InfoAssist

The following procedures provide step-by-step instructions on how to create and customize maps.

As you create your maps, you can use the following built-in map viewer features:

- You can use the plus (+) and minus (-) symbols, `+`, `−`, within the map to zoom in and out of different areas of the map. You can also click your left mouse button to zoom in to a specific location.

- Like all HTML5 visualizations, the highlighted markers and regions on a map support drill, multi-drill, auto-linking, and informational tooltip features.

- When working with maps in Chart mode, you can use the Pan / Selection button to alternate between the Pan and Selection controls. This option is in the upper-right corner of the map.

- When working with maps in Visualization mode, you can toggle the Pan or Selection button to make a selection. The Pan control allows you to click, hold, and move the map with your mouse. The Selection control allows you to lasso a specific area of the map and select data in the map.
Creating a map chart using the US Zipcode 5 Georole with more than 2000 polygons will fail to draw.

**Procedure:** How to Create an Esri Choropleth Map

**Note:** The default option of creating a map utilizes the ArcGIS JavaScript API that Esri provides.

1. Launch InfoAssist in Chart or Visualization mode.
   - In Chart mode, on the *Format* tab, in the *Chart Types* group, click *Choropleth*.
   - In Visualization mode, on the *Home* tab, in the *Visual* group, click *Change* and click *Choropleth*.

A blank map displays and the Layer field container is enabled, as shown in the following image.

2. Add a Geolocation field to the Layer field container.
This field, which already has a geographic role assigned, is denoted with a Layer icon, ✚, in the Data panel, as shown in the following image. You can also hover over a data field to view the geographic role assignment.

For more information, see Geographic Roles on page 403.

The canvas refreshes, and your map displays.

3. Before saving your map, to add insight, you can also do following:

☐ Click Run, to preview your map.

☐ Add a measure or dimension to the Color field container, to color your chart by that underlying data value. When you add a measure or dimension field to the Color field container, a legend displays for that data value. If you specify a dimension in the Color field container, the label changes to Color BY.

☐ Add a dimension or measure to the Tooltip field container, which will display tooltip information when you place your mouse over an area of the map.

☐ Add a Background, Demographic Layer, or Reference Layer.

4. Click Save to save your map.

**Procedure:** How to Create an Esri Proportional Symbol (Bubble) Map

1. Launch InfoAssist in Chart or Visualization mode.

☐ In Chart mode, on the Format tab, in the Chart Types group, click Proportional Symbol.

☐ In Visualization mode, on the Home tab, in the Visual group, click Change and select Proportional Symbol.

A blank map displays and the Layer field container is enabled.
2. Place a data field with a defined geographic role in the Layer field container.

This field, which already has a geographic role assigned, is denoted with a Layer icon, in the Data panel, as shown in the following image. You can also hover over a data field to view the geographic role assignment.

For more information, see Geographic Roles on page 403.

A basic bubble map displays, as shown in the following image.
3. Before saving your map, to add insight, you can also do following:

- Click Run, to preview your map.
- Add a measure or dimension to the Color field container, to color your chart by that underlying data value.
- Add a measure to the Size field container, to control the size of the bubbles on your map.
- Add a measure to the Tooltip field container, to display tooltip information when you place your mouse over an area of the map at run time.
- Add a Background, Demographic Layer, or Reference Layer.

4. Click Save to save your map.

**Procedure: How to Assign a Geographic Role to a Data Field**

1. Launch InfoAssist in Chart or Visualization mode.

   - In Chart mode, on the Format tab, in the Chart Types group, click Choropleth or Proportional Symbol.
   - In Visualization mode, on the Home tab, in the Visual group, click Change and click Choropleth or Proportional Symbol.

2. In the Data pane, select a data field without a geolocation assignment.

3. Perform one of the following tasks to open the Map dialog box and assign a geographic role:

   - Right-click the desired data field, click Map As and select a geographic role, as shown in the following image.
Drag the desired data field into the Layer field container.

The Map dialog box displays, as shown in the following image.

4. In the Map dialog box, select a geographic role. For example, State.

   **Note:** When specifying a geographic role, you can use Name or an ISO-2 value for countries. The ISO-2 codes are recognized worldwide, as published in [http://www.iso.org/iso/country_codes](http://www.iso.org/iso/country_codes).

   The Map dialog box refreshes and shows the Depends on section, as shown in the following image.

   **Note:** If you used the Map As option, the Depends on section automatically displays, since a geographic role was selected at that time.

5. In the Depends on section, choose from the following options:

   - **Field.** Identifies a specific field on which the geographic role depends. For example, you can select Country or Continent.

   - **User Defined.** Enables the definition of a specific value from the data source. Selections can be as simple as a specific country. For example, you can select US.

   The Geographic Role field automatically populates based on the hierarchy of your data source. For example, if your primary geographic role was State, and in your metadata hierarchy, State depends on Country, this option displays.
6. Click OK.
If you used the Map As option, you must place the data field with the defined geographic role in the Layer field container. If you placed a data field in the Layer field container and defined a geographic role, the field is automatically added to the Layer field container.

A basic map displays, as shown in the following image.

7. Before saving your map, to add insight, you can also do following:

- Click Run, to preview your map.
- Add a measure or dimension to the Color field container, to color your chart by that underlying data value.
- Add a measure to the Size field container, to control the size of the bubbles on your map.
- Add a measure to the Tooltip field container, to display tooltip information when you place your mouse over an area of the map at run time.
Procedure: How to Change the Geographic Role of a Geolocation Field

You can change the geographic role assignment of any geolocation field using the following steps.

1. Launch InfoAssist in Chart or Visualization mode.
   - In Chart mode, on the Format tab, in the Chart Types group, click Choropleth.
   - In Visualization mode, on the Home tab, in the Visual group, click Change and click Choropleth.
2. From the Data pane, right-click a geolocation field and click Map As.
3. Select a geographic role.
   The Map dialog box displays using the selected Geographic Role.
4. In the Map dialog box, optionally select a geographic role from the drop-down list. For example, Country.
   Note: This changes the selection that you made on the Map As list.
5. Accept the default value for Stored As, or choose a new value from the drop-down list, for example, ISO code. Stored As indicates how the data values are represented in the table.
6. Click OK.
   The geographic role changes for the selected Geolocation field in the Data pane, and the map refreshes using the new geolocation that you specified.

Procedure: How to Change the Default Background of a Map

1. Create a new map or open an existing map in InfoAssist.
2. On the Format tab, expand the Map group and click *Background*, as shown in the following image.

3. Select one of the following options:
   - World Street Map
   - Terrain with Labels
   - Oceans Basemap
   - OpenStreetMap
   - World Imagery
   - Imagery with Labels
   - Light Gray Canvas
   - National Geographic World Map
   - Dark Gray Canvas
   - None

**Note:** The Imagery with Labels Background provides the terrain for your map, ranging from land contours to city streets.

Once you make a selection, the background of the map refreshes. You can continue to change your background until it displays the desired information.
Procedure: How to Add Demographic Layers to a Map

1. Create a new map or open an existing map in InfoAssist.
2. On the Format tab, expand the Map group and click Demographic Layers.
3. Select from various population and lifestyle groups, as shown in the following image.

Note: These are pre-defined demographic profiles, provided by ArcGIS. You can select multiple options in either category to gain additional insight into your data. Specifically, each Demographic Layer has its own profile and provides a layering option, when comparing values across different layers or profiles.

4. Click OK.
The Demographic Layers that you select are applied to your map. The map engine displays the different groups with unique hues and coloring. You can use the Table of Contents or Layers option, to toggle between the different layers that you have specified. The Layers option is shown in the following image.

![Layers](image)

**Note:** You can select and clear the check boxes to enable the display of one or more Demographic Layers to compare and contrast the different demographic scenarios.

**Procedure:** How to Add Reference Layers to a Map

1. Create a new map or open an existing map in InfoAssist.
2. On the Format tab, expand the Map group and click Reference Layers.
3. Select one or more Reference Layers, such as World Countries, to add to your map, and then click OK.
Your map refreshes, and the definitions and borders of the References Layers display on the canvas. You can use the Table of Contents or Layers option, to toggle different Reference Layers in your map. These options are shown in the following image.

**Procedure:** How to Create a Leaflet Map

You can use the following procedure to create Leaflet maps, which are part of the Lightweight Mapping functionality.

**Note:**

- For charts, you must use the HTML5 output format to access this functionality.

- Data labels display for choropleth Leaflet maps, providing you with information about your underlying data directly on the map. For information on enabling this functionality, see the Creating HTML5 Charts With TIBCO WebFOCUS® Language manual.

1. Launch InfoAssist in Chart mode or Visualization mode.
2. Create a Leaflet map using one of the following options:

   To create a Leaflet map as a chart:
   1. On the Format tab, in the Chart Types group, click Other.
   2. In the left pane, select Map.
      
      All map options display, including Leaflet maps. Click either Leaflet Choropleth or
      Leaflet Bubblemap.
   
   To create a Leaflet map in a visualization:
   2. On the Select a visual menu, click Map.
      
      The Select a map dialog box opens.
   3. From the Type group, select a map.

   3. From the Location group, using the Territory drop-down list, select a territory (for example,
      United States of America).

      This section allows you to pick geographic locations for which maps are available. You can
      select a territory option from the drop-down list. Options include: United States of America,
      World, Europe, Africa, Asia, Australia, Austria, Denmark, Germany, Japan, North America,
      South America, and Sweden. For more information on adding or enabling additional
      territories, see Enabling Additional Territories in a Leaflet Map on page 420.

   4. Click OK.

   5. From the Data pane, add a data source containing geolocation data to the Layer field
      container in the Query pane.

      **Note:** For bubble maps, Layer, Latitude, and Longitude field containers display. You can
      specify latitudinal and longitudinal data using these fields. The Size field container also
      displays for bubble maps.

      The Location Type dialog box displays, as shown in the following image.
The Location Type is needed for geocoding, which is a process through which fields are assigned to a specific geographic dimension (for example, Zip Code, State, or Country) so that it can be matched correctly to the geographic coordinates. The geocoding process will occur once you add a geographic field to the Location data container.

6. Select a geographic role from the drop-down list and click OK.

The map displays.

**Note:** You can change the geographic role by right-clicking the location dimension in the Query pane, and clicking *Geographic Role*. The Location Type dialog box opens.

7. Optionally, add a field to the Color field container, or add a field to the Size field container if you are creating a bubble map.

The map displays based on your data and selections for geolocation and optionally, color and size. The legend identifies the data in the map by color, based on the data field specified in the Color field container.

**Reference:** *Query Field Containers by Map Type*

This section presents the Query field containers that display for both charts and visualizations, by map type.

<table>
<thead>
<tr>
<th>Query field container</th>
<th>Chart mode</th>
<th>Visualization mode</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Layer.</strong> One data field, specifically a field containing location data (for example, State).</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Latitude.</strong> One data field, containing latitude data.</td>
<td>✗</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Longitude.</strong> One data field, containing longitude data.</td>
<td>✗</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Color.</strong> One data field.</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Tooltip.</strong> Up to one data field (not required).</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Multi-graph.</strong> Up to one data field (not required).</td>
<td>✓</td>
<td>✓</td>
</tr>
<tr>
<td><strong>Size.</strong> One data field.</td>
<td>✗</td>
<td>✓</td>
</tr>
</tbody>
</table>
Reference: Geographic Roles

Note: Geographic roles are only available with Esri maps.

<table>
<thead>
<tr>
<th>Geographic Role</th>
<th>Description</th>
<th>Maps Supported</th>
</tr>
</thead>
<tbody>
<tr>
<td>CONTINENT</td>
<td>World Continents</td>
<td>Choropleth, Proportional Symbol</td>
</tr>
<tr>
<td>COUNTRY</td>
<td>World Countries</td>
<td>Choropleth, Proportional Symbol</td>
</tr>
<tr>
<td>STATE</td>
<td>World Admin Divisions</td>
<td>Choropleth, Proportional Symbol</td>
</tr>
<tr>
<td>CITY</td>
<td>World Cities</td>
<td>Proportional Symbol</td>
</tr>
<tr>
<td>COUNTY</td>
<td>World Counties</td>
<td>Choropleth, Proportional Symbol</td>
</tr>
<tr>
<td>POSTAL-CODE</td>
<td>Postal Code</td>
<td>Choropleth, Proportional Symbol</td>
</tr>
</tbody>
</table>

The following table summarizes additional geographic role information.

Note: All of the following roles are geographic roles, with the exception of Latitude and Longitude, which are coordinates.

<table>
<thead>
<tr>
<th>Role Name</th>
<th>Role Format</th>
<th>Geographic Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td>Full</td>
<td>ADDRESS_FULL</td>
</tr>
<tr>
<td></td>
<td>Line</td>
<td>ADDRESS_LINE</td>
</tr>
<tr>
<td>City</td>
<td>Name</td>
<td>CITY</td>
</tr>
<tr>
<td>Continent</td>
<td>ISO-3166 code</td>
<td>CONTINENT_ISO2</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>CONTINENT</td>
</tr>
<tr>
<td>Role Name</td>
<td>Role Format</td>
<td>Geographic Role</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Country</td>
<td>FIPS code</td>
<td>COUNTRY_FIPS</td>
</tr>
<tr>
<td></td>
<td>ISO-3166-2 code</td>
<td>COUNTRY_ISO2</td>
</tr>
<tr>
<td></td>
<td>ISO-3166-3 code</td>
<td>COUNTRY_ISO3</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>COUNTRY</td>
</tr>
<tr>
<td>Country (NUTS level 0)</td>
<td>NUTS code</td>
<td>NUTS0_CC</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>NUTS0</td>
</tr>
<tr>
<td>District (NUTS level 3)</td>
<td>NUTS code</td>
<td>NUTS3_CC</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>NUTS3</td>
</tr>
<tr>
<td>Geometry area</td>
<td></td>
<td>GEOMETRY_AREA</td>
</tr>
<tr>
<td>Geometry line</td>
<td></td>
<td>GEOMETRY_LINE</td>
</tr>
<tr>
<td>Geometry point</td>
<td></td>
<td>GEOMETRY_POINT</td>
</tr>
<tr>
<td>Latitude</td>
<td></td>
<td>LATITUDE</td>
</tr>
<tr>
<td>Longitude</td>
<td></td>
<td>LONGITUDE</td>
</tr>
<tr>
<td>Postal code</td>
<td></td>
<td>POSTAL-CODE</td>
</tr>
<tr>
<td>Province (NUTS level 2)</td>
<td>NUTS code</td>
<td>NUTS2_CC</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>NUTS2</td>
</tr>
<tr>
<td>Region (NUTS level 1)</td>
<td>NUTS code</td>
<td>NUTS1_CC</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>NUTS1</td>
</tr>
<tr>
<td>State</td>
<td>FIPS code</td>
<td>STATE_FIPS</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>STATE</td>
</tr>
<tr>
<td>US County FIPS</td>
<td>FIPS code</td>
<td>USCOUNTY_FIPS</td>
</tr>
</tbody>
</table>
The following table illustrates the geographic roles and their dependencies. Level 1 indicates the highest level of hierarchy and level 5 is the lowest level of hierarchy.

<table>
<thead>
<tr>
<th>Region</th>
<th>Hierarchy Level</th>
<th>Geographic Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>United States</td>
<td>1</td>
<td>COUNTRY, COUNTRY_ISO_CC</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>USSTATE, USSTATE_ABBR, USSTATE_FIPS</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>USCOUNTY, USCOUNTY_FIPS</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>USCITY, USCITY_FIPS</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>ZIP3, ZIP5</td>
</tr>
</tbody>
</table>
Customizing the List of Geographic Roles

Customers with Enterprise Data often have map layers that represent their territories, events, or logistical information. These are published as Map Services to either a subscription based in the Esri Cloud (ArcGIS.com) or on an internal portal. This portal is available with ArcGIS Server 10.3 installations. More information can be found at http://server.arcgis.com/en/portal/.

InfoAssist comes with a configuration file (geo_services.xml) that contains elements that describe all of the geographic roles, geographic hierarchies, URLs to the map services, and base maps available to InfoAssist. This file is located in the catalog directory under the server home directory:

_edahome/catalog/

**Note:** Optionally, on the WebFOCUS® Reporting Server, you can show this directory on the application tree by clicking Show edahome, edaconf, edaprfu, scaroot, edatemp, edalog and foccache for all users on the Filter menu of the Reporting Server Console Applications page. Then, you can edit the geo_services.xml file directly in the Reporting Server Console.

The geographic role selections that you can make in InfoAssist are built dynamically using this configuration file. Each role definition in the configuration file, when selected in InfoAssist, generates metadata and a request that is sent to Esri in order to download the appropriate map and place the markers or polygons on the map.

A geographic role can be part of a hierarchy. For example, the World geographic role is at the top of a hierarchy that contains continents, countries, states, and cities. These hierarchies are also described in the geo_services.xml file.

### Geographic Roles and Hierarchies

<table>
<thead>
<tr>
<th>Region</th>
<th>Hierarchy Level</th>
<th>Geographic Role</th>
</tr>
</thead>
<tbody>
<tr>
<td>World</td>
<td>1</td>
<td>CONTINENT, CONTINENT_ISO_CC</td>
</tr>
<tr>
<td></td>
<td>2</td>
<td>COUNTRY, COUNTRY_FIPS, COUNTRY_ISO_CC, COUNTRY_ISO2, COUNTRY_ISO3</td>
</tr>
<tr>
<td></td>
<td>3</td>
<td>STATE, STATE_ISO_SUB</td>
</tr>
<tr>
<td></td>
<td>4</td>
<td>CITY</td>
</tr>
<tr>
<td></td>
<td>5</td>
<td>POSTAL CODE</td>
</tr>
</tbody>
</table>
To add a custom geographic role, you must add the necessary parameters for the geography to this file.

You can also customize the geographic roles available by deleting geographic role definitions from the `<GEO_ROLES>` object. To configure Esri On Premise, you should remove any geographic role definition that references a URL that points to a location outside of your locally hosted Esri server.

Following standard XML syntax rules, each element is enclosed in element start and end tags (`<elementname>`, `</elementname>`), and attribute values are enclosed in double quotation marks (").

**Reference:** Geographic Role Definitions

A geographic role is stored as a `geo_role` element in the `geo_roles` object of the `geo_services.xml` file. A geographic role must be defined with:

- An ID that will identify the role in the configuration file.
- A format and length for the data to be returned.
- A role name.
- A display title for the role name (to appear as a selection in Map dialog box in InfoAssist).
- An optional role format (if the role can have multiple formats, such as a name and an abbreviation).
- A display title for the format.
- A role type (`geography` for geographic objects such as country or state, `geometry` for geometry points, geometry areas, or geometry lines, or `coordinate` for longitude or latitude).
- An optional vocabulary rule element containing vocabulary elements for associating the role with a field in the metadata.

The syntax is

```
<geo_role id="id" value_size="size" unified="false" role_name="rname"
    role_name_title="rname_title" role_format="rformat"
    role_format_title="rformat_title" geo_type="gtype"
    type="datatype" >
    <vocabulary_rules>
        <vocabulary>vrule</vocabulary>
    </vocabulary_rules>
</geo_role>
```
where:

\[ \text{id=\"id\"} \]

Is an alphanumeric uppercase value, up to 50 characters, used to identify the geographic role.

\[ \text{type=\"datatype\"} \]

Is the data type for the ID. Can be one of the following.

- \"alpha\" for alphanumeric data, formats An or In.
- \"integer\" for integer numeric data, format In.
- \"numeric\" for fractional numeric data, formats Pn.m, Dn.m, or Fn.m.
- \"text\" for text data, format TXn.

\[ \text{value_size=\"size\"} \]

Is the optional number of characters in USAGE format length (any, if not set).

\[ \text{role_name=\"rname\"} \]

Is the name of the geographic role.

\[ \text{role_name_title=\"rname_title\"} \]

Is the title of the geographic role, to be displayed in the Map dialog box for selection.

\[ \text{role_format=\"rformat\"} \]

Is an optional format for the geographic role, useful when the role can be referenced using multiple formats, such as a name, an ISO code, and an abbreviation. Standard role titles include the following.

- **NAME.** Specifies that the role defines the name of a geographic entity, such as Florida.
- **ABBR.** Specifies that the role defines an abbreviation, such as FL.
- **ZIP3.** Specifies that the role defines a 3-digit zip code.
- **ZIP5.** Specifies that the role defines a 5-digit zip code.
- **FIPS.** Specifies that the role defines a FIPS (Federal Information Processing Standard) code.
- **ISO2.** Specifies that the role defines an ISO 3166-2 code published by the International Organization for Standardization (ISO).
- **ISO3.** Specifies that the role defines an ISO 3166-3 code published by the International Organization for Standardization (ISO).

- **LINE.** Specifies that the role defines one line of a role, just as an address line.

- **FULL.** Specifies that the role defines a full geographic role, such as a full address.

```plaintext
role_format_title="rformat_title"
```

Is an optional title for the format of the geographic role. It will be shown in parentheses along with the role title in the Map dialog box, for example, State (Abbreviation).

```plaintext
geo_type="gtype"
```

Is one of the following predefined role types.

- "**geography**" for geographic objects, such as country or state.
- "**geometry**" for geometry objects, such as geometry point, geometry line, and geometry area.
- "**coordinate**" for coordinates, such as latitude and longitude.

```plaintext
<vocabulary>vrule</vocabulary>
```

Is an element that consists of a group of vocabulary elements that explicitly describe column names for the geographic role. These rules will be used to select the best geographic data for the role.

Elements in a rule are connected by the Boolean logic operation OR (only one needs to be satisfied). Each vocabulary element contains words enclosed with special characters. Words in the rule element are connected by the Boolean logic operation AND (all need to be satisfied).

A word may be prefixed and/or suffixed with the percent character (%), which is a placeholder for any sequence of characters. If an element contains more than one word, each word has to be prefixed by the character plus (+) or minus (-). Plus indicates that the word must be found in the column name. Minus indicates that the word must not be found in the column name.

Once you have added a geographic role definition, you can run the geo_srv_roles procedure on the WebFOCUS Reporting Server to see that the parameters were added correctly.
**Example:**  **Sample Geographic Role Definitions**

The following defines the State Abbreviation geographic role. The role ID is USSTATE_ABBR. The role name is USSTATE with a role format of ABBR. The titles that show in the Map dialog box are US state (Abbreviation). The format is A2, and the vocabulary rules specify that the characters state must be present, but the characters iso, capital, and population must not be present. The geo type is geography, indicating that the returned data will be a geographic area.

```xml
<geo_role id="USSTATE_ABBR" value_size="2" type="alpha" role_name="USSTATE" role_name_title="US state" role_format="ABBR" role_format_title="Abbreviation" geo_type="geography">
  <vocabulary_rules>
    <vocabulary>+%state%-%iso%-%capital%-%population%</vocabulary>
  </vocabulary_rules>
</geo_role>
```

The following is a role definition for latitude values. The role ID is LATITUDE. The role name is also LATITUDE. Its format is numeric. The title that displays in the Map dialog box is Latitude. The geo type is coordinate, indicating that the returned data will be points. The vocabulary rules specify that the characters latitude must be present.

```xml
<geo_role id="LATITUDE" type="numeric" role_name="LATITUDE" role_name_title="Latitude" geo_type="coordinate">
  <vocabulary_rules>
    <vocabulary>%latitude%</vocabulary>
  </vocabulary_rules>
</geo_role>
```
The following is the definition for the city role. The ID is CITY. The role name is also CITY. Its format is NAME. The title that displays in the Map dialog box is City (Name). The definition has a set of vocabulary elements. Only one of the elements in the list must be true. Therefore, the characters city, or town, or country plus capital, or state plus capital must be present.

```xml
<geo_role
  id="CITY"
  type="alpha"
  role_name="CITY"
  role_name_title="City"
  role_format="NAME"
  role_format_title="Name"
  geo_type="geography">
  <vocabulary_rules>
    <vocabulary>+city%-population%</vocabulary>
    <vocabulary>+town%-population%</vocabulary>
    <vocabulary>+country%+capital%-population%</vocabulary>
    <vocabulary>+state%+capital%-population%</vocabulary>
  </vocabulary_rules>
</geo_role>
```

**Reference:** Geographic Role URI Definitions

After adding a geographic role, you must add its URI to the `<URIS>` object in the `geo_services.xml` file. The syntax is.

```xml
<uri description="description">
  <returned_geometry>type </returned_geometry>
  <returned_georole>role</returned_georole>
  <url type="esri" authorization="auth" synonym="">
    "url_to_georole"
  </url>
  <parameters>
    <parm order="number" parm_name="pname" parm_georole="parmrole"/>
  </parameters>
</uri>
```

where:

"description"

Is a description for the geographic role to which the URI is pointing.

`type`

Is any supported geometry type, such as GEOMETRY AREA.

`role`

Is the name of the returned geographic role.

"auth"

Is the type of authentication needed to access this geographic role. Valid values are:

- **silent**. Credentials for your ArcGIS application are provided in the connection string of the Adapter for Esri.
- **none.** No authorization is needed.
- **named.** User credentials are provided in the connection string of the Adapter for Esri.
- **on premise.** User credentials for a locally hosted ArcGIS server are provided in the connection string of the Adapter for Esri.

"url_to_georole"
Is the URL for the geographic role.

param order="number"
Is the number of a parameter needed to retrieve the correct geographic role.

param_name="pname"
Is the name of the parameter associated with param order.

param_georole="parmrole"
Is the name of the geographic role associated with param order.

Once you have added the URI, you can run the geo_srv_map_uris procedure on the Reporting Server to see that the parameters were added correctly.

**Note:** You must add the base URL to the list of proxy URLs in the esri_arcgis_rest.xml file. For example:

```xml
<ESRI_URL URL="/services7.arcgis.com/L95Ww90jR0tjAs/ArcGIS" DESCRIPTION="Custom Data" />
```

**Reference:** Adding the WebFOCUS Retail Regions Geographic Role

These steps describe how to add the WebFOCUS Retail Regions geographic role to the geo_services.xml file.

1. Open the geo_services.xml file. The default location is:

   C:\ibi\WebFOCUSnn\srv\home\catalog\geo_services.xml

   where nn is your release of TIBCO WebFOCUS. For example, 82 for release 8.2

2. Add the role to the end of the GEO_ROLES object:

   ```xml
   <geo_role id="REGION" value_size="50" unified="false"
   role_name="WF_Region" role_name_title="WF_Region"
   role_format="NAME" role_format_title="NAME"
   geo_type="geography" type="alpha" >
   <vocabulary_rules>
   <vocabulary>+%region%</vocabulary>
   </vocabulary_rules>
   </geo_role>
   ```
The ID is REGION. The role name is WF_Region. Its format is NAME. The title that displays in the Map dialog box is WF_Region. The definition has a vocabulary rule. The characters region must be present.

Run the geo_srv_roles procedure on the Reporting Server to see that the role was added correctly. The output is shown in the following image.

<table>
<thead>
<tr>
<th>ROLE_NAME</th>
<th>ROLE_FORMAT</th>
<th>GEO_ROLE</th>
<th>GEO_TYPE</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td>Full</td>
<td>ADDRESS_Full</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Line</td>
<td>ADDRESS_LINE</td>
<td>geography</td>
</tr>
<tr>
<td>City</td>
<td>Name</td>
<td>CITY</td>
<td>geography</td>
</tr>
<tr>
<td>Continent</td>
<td>ISO-3166 code</td>
<td>CONTINENT_ISO2</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>CONTINENT</td>
<td>geography</td>
</tr>
<tr>
<td>Country</td>
<td>FIPS code</td>
<td>COUNTRY_FIPS</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>ISO-3166-2 code</td>
<td>COUNTRY_ISO2</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>ISO-3166-3 code</td>
<td>COUNTRY_ISO3</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>COUNTRY</td>
<td>geography</td>
</tr>
<tr>
<td>County</td>
<td>Name</td>
<td>COUNTY</td>
<td>geography</td>
</tr>
<tr>
<td>Geometry area</td>
<td>.</td>
<td>GEOMETRY_AREA</td>
<td>geometry</td>
</tr>
<tr>
<td>Geometry line</td>
<td>.</td>
<td>GEOMETRY_LINE</td>
<td>geometry</td>
</tr>
<tr>
<td>Geometry point</td>
<td>.</td>
<td>GEOMETRY_POINT</td>
<td>geometry</td>
</tr>
<tr>
<td>Latitude</td>
<td>.</td>
<td>LATITUDE</td>
<td>coordinate</td>
</tr>
<tr>
<td>Longitude</td>
<td>.</td>
<td>LONGITUDE</td>
<td>coordinate</td>
</tr>
<tr>
<td>Postal code</td>
<td>.</td>
<td>POSTAL-CODE</td>
<td>geography</td>
</tr>
<tr>
<td>Seattle Onprem Neighborhoods</td>
<td>Seattle Neighborhoods</td>
<td>SEATON_NBRHDS</td>
<td>geography</td>
</tr>
<tr>
<td>State</td>
<td>FIPS code</td>
<td>STATE_FIPS</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>ISO subdivision code</td>
<td>STATE_ISO_SUB</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>STATE</td>
<td>geography</td>
</tr>
<tr>
<td>US city</td>
<td>FIPS code</td>
<td>USCITY_FIPS</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>USCITY</td>
<td>geography</td>
</tr>
<tr>
<td>US county</td>
<td>FIPS code</td>
<td>USCOUNTY_FIPS</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>USCOUNTY</td>
<td>geography</td>
</tr>
<tr>
<td>US postal code</td>
<td>3 digits</td>
<td>ZIP3</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>5 digits</td>
<td>ZIP5</td>
<td>geography</td>
</tr>
<tr>
<td>US state</td>
<td>Abbreviation</td>
<td>USSTATE_ABBR</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>FIPS code</td>
<td>USSTATE_FIPS</td>
<td>geography</td>
</tr>
<tr>
<td></td>
<td>Name</td>
<td>USSTATE</td>
<td>geography</td>
</tr>
<tr>
<td>WF_Region</td>
<td>NAME</td>
<td>REGION</td>
<td>geography</td>
</tr>
</tbody>
</table>
3. Add the URI to the map server layer for this role at the end of the URIS object:

```xml
<uri description="WF Retail Regions">
  <returned_geometry>GEOMETRY_AREA</returned_geometry>
  <returned_georole>REGION</returned_georole>
  <parameters_georoles>
    <parm position="1" parm_georole="REGION" />
  </parameters_georoles>
  <urls>
    <url type="esri" authorization="none" synonym="">
      value="/services7.arcgis.com/L95Wwv90jRQ0tjAs/ArcGIS/rest/services/wfretail_sub_regions/FeatureServer/0"
      provider="Esri">
        <keys key="default" />
        <parameters_names>
          <parm position="1" parm_name="SUB_REGION" />
        </parameters_names>
    </url>
  </urls>
</uri>
```

**Note:** You must add the base URL to the list of proxy URLs in the esri_arcgis_rest.xml file. For example:

```xml
<ESRI_URL URL="/services7.arcgis.com/L95Wwv90jRQ0tjAs/ArcGIS" DESCRIPTION="Custom Data" />
```

Optionally, on the Reporting Server, run the geo_srv_map_uris procedure to see if the parameters were added correctly. The output is shown in the following image.
You will now be able to select this role from the Map As menu the next time you start WebFOCUS, as shown in the following image.

**Example:** Using the WebFOCUS Retail Regions Role in a Map Layer

This example configures a map layer using the WF_Role region role.
In the Data pane, right-click a field that contains subregion data, for example. On the shortcut menu, select Map As and then select the WF_Region role, as previously illustrated. The output is shown in the following image:

![Map with subregion data](image)

**Customizing the List of Basemap Definitions**

You can add custom basemaps for use with maps.

**Adding a Custom Basemap**

The list of basemaps available to InfoAssist is built dynamically on the server using the list of `<basemap>` objects in the `geo_services.xml` file, which is located in the catalog directory under the server home directory:

```
_edahome/catalog/
```

**Note:** Optionally, on the Reporting Server, you can show this directory on the application tree by clicking `Show edahome, edaconf, edaprifu, scaroot, edatemp, edalog and foccache for all users` on the Filter menu of the Reporting Server Console Applications page. You can then edit the `geo_services.xml` file directly in the Reporting Server Console.
Following are some sample standard basemap definitions from this file that exist prior to customization.

```xml
<BASEMAPS>
  ...
  <basemap custom="false" default="false" name="streets"
    title="World Street Map" icon="qb/streets_map_108x72.png" />
  <basemap custom="false" default="false" name="satellite"
    title="World Imagery" icon="qb/imagery_map_108x72.png" />
  <basemap custom="false" default="false" name="terrain"
    title="Terrain with Labels" icon="qb/terrain_map_108x72.png" />
  <basemap custom="false" default="true" name="gray"
    title="Light Gray Canvas Map" icon="qb/gray_map_108x72.png" />
  ...
</BASEMAPS>
```

The properties defined for the standard basemaps are `custom` (which is `false` for the standard basemaps), `default`, `name`, `title`, and `icon`.

To define a custom basemap, you must define these properties for your custom basemap, and add a URL that points to the map service that has the basemap image.

**Note:** Any basemap you add must be a tiled map layer.

You can also customize the list of basemaps by deleting basemap definitions from the `<basemaps>` object. To configure Esri on Premise, you should remove any basemap definition that references a URL that points to a location outside of your locally hosted Esri server.

The syntax for a basemap definition is

```xml
<basemap custom="boolean" default="boolean" name="mapname"
  title="maptitle" icon="url_to_icon" url="url_to_basemap" />
```

where:

- **custom="boolean"**
  Specifies whether the basemap is standard or custom. Valid values are true and false. To add a custom basemap, specify custom="true".

- **default="boolean"**
  Specifies whether this basemap should be the default basemap if the user does not select a basemap. Valid values are true and false.

- **name="mapname"**
  Is a name for the basemap.

- **title="maptitle"**
  Is a title that will display in the Basemap drop-down list in the list of basemaps in InfoAssist.
**Example: Adding a Custom Basemap**

The following `<basemap>` object defines the soil survey basemap.

```xml
```

Add this definition to the list of basemap objects in the `geo_services.xml` file. Note that the entire URL string must be on one line in the file, even if it breaks in this document because of the page size.

Optionally, on the Reporting Server, run the `geo_srv_basemaps` procedure. The output is shown in the following image.

<table>
<thead>
<tr>
<th>NAME</th>
<th>TITLE</th>
<th>DEFAULT</th>
<th>CUSTOM</th>
<th>URL</th>
<th>ICON</th>
</tr>
</thead>
<tbody>
<tr>
<td>Defchosen</td>
<td>Default</td>
<td>false</td>
<td>true</td>
<td><a href="http://services.arcgisonline.com/ArcGIS/rest/services/Specialty/Defchosen/MapServer/MapServer/info/thumbnail">http://services.arcgisonline.com/ArcGIS/rest/services/Specialty/Defchosen/MapServer/MapServer/info/thumbnail</a></td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>darkgray</td>
<td>Dark Gray</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>gray</td>
<td>Light Gray</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>Loose</td>
<td>World Imagery with Labels</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>national-geographic</td>
<td>National Geographic World Map</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>recent</td>
<td>Recent</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>satellite</td>
<td>World Imagery</td>
<td>false</td>
<td>true</td>
<td>;</td>
<td>![thumbnail.png]</td>
</tr>
<tr>
<td>soil_survey</td>
<td>Soil_Survey_Basemap</td>
<td>false</td>
<td>true</td>
<td><a href="https://server.arcgisonline.com/ArcGIS/services/Specialty/Soil_Survey_Map/MapServer/MapServer/info/thumbnail">https://server.arcgisonline.com/ArcGIS/services/Specialty/Soil_Survey_Map/MapServer/MapServer/info/thumbnail</a></td>
<td>![thumbnail.png]</td>
</tr>
</tbody>
</table>
When you create a map, your custom basemap appears in the Basemap drop-down list in InfoAssist, as shown in the following image.
Enabling Additional Territories in a Leaflet Map

InfoAssist provides a number of territories, out of the box, for Leaflet maps, which are provided through Leaflet Open Source API. These pre-packaged territories are listed in Default Territories on page 422 and are contained in JavaScript Object Notations (.json) files.

Note: This functionality is only available for maps built with the Leaflet API.

In addition to the out of the box territories that are available, you can also enable other territories for use in creating custom maps. These additional territories are contained in .json or .csv files.

Note: Files in .csv format can be used for latitude and longitude data values. This could be for an exact point or for the centroid of a location. When using .csv files, there is a csvfields field class that is used to specify latitude and longitude values. For example, csvfields=’country, lat, lng’. The .csv must have at least latitude and longitude specified. In addition, all fields require the use of quotes and a comma-delimited format.

You can also use GeoJSON files if you have access to location files in GeoJSON format. For more information, see the following webpages:

- [http://geojson.org](http://geojson.org)
- [http://converter.mygeodata.eu<vector](http://converter.mygeodata.eu<vector) (Convert Shape Files to GeoJSON)
In order to enable a new territory, you must copy the .json, .csv, or .geojson file to the appropriate directory and then modify the CustomUIMaps.xml file to reference it, as described in the following procedure.

**Procedure: How to Enable Additional Territories in a Leaflet Map**

**Note:** This functionality is only available for maps built with the Leaflet API.

1. To enable one of the location files installed with WebFOCUS, identify the pre-packaged .json file that you want to enable in the following directory:

   `drive:\ibi\WebFOCUS82\webapps\webfocus\tdg\jschart\distribution\map`

2. Copy the selected .json file to the following directory:

   `drive:\ibi\WebFOCUS82\config\web_resource\map`

   **Note:**

   - If you want to use a .geojson or .csv file, copy it to this directory.
   - If you are using a .json file, a layer must be defined, as .json files can contain multiple layers. The specification of layers is not required for .geojson files.
   - In this example, the primary layer = regions must be set in the .json file. You can verify this by opening the .json file in a standard text editor, such as Notepad or Textpad.

3. In the `drive:\ibi\WebFOCUS82\config\web_resource\map` directory, open the CustomUIMaps.xml file using a standard text editor.

4. Remove the commenting characters from the line that you wish to create. Specifically, remove <!-- from the beginning of the line of code and remove --> from the end. This activates the .json file that you are including.

5. Specify the following criteria within the `<Json>` tag for each territory that you want to enable:

   - **Map file:** This is the .json or .csv file name. For example, uszip3.json.
   - **Name:** The label, or identifying name, that displays in the Territory drop-down list when using the Lightweight Mapping functionality. For example, Zip 3.
Layer: Files may have multiple layers in them, such as landmarks and the actual item you want to symbolize. If they do, you must specify which layer to use. In the following example, regions is used.

```xml
<xml version="1.0" encoding="UTF-8">
<?-- Copyright 1996-2013 Information Builders, Inc. All rights reserved. -->
<?--$Revision: 1.7 $:-->
<Maps>
  <Json>
    <!--
    <Map file="zip-Wyoming.json" name="zip-Wyoming" layer='regions'>
    </Map>-->
    <!--
    <Map file="us-state-centroids.csh" name="us-state-centroids"
           cayfields='fred.lat,lng'>
    </Map>-->
    <!--
    <Map file="sample_gpsales_regions.geojson" name="GPSales Sample Regions">
    </Map>-->
    <!--
    <Map file="sample_wfretail_regions.geojson" name="WFRetail Sample Regions">
    </Map>-->
    <!--
    <Map file="uszip3.json" layer='regions' name="Zip 3"></Map>
    </Json>
</Maps>
```

7. Restart your application server.

The name of the territory that you enabled displays in the Territory drop-down list when you create a map chart.

Default Territories

InfoAssist comes pre-packaged with a number of default territories. These include:

- United States of America
- World
- Europe
- Africa
- Asia
- Australia
- Austria
- Denmark
- Germany
- Japan
- North America
- South America
- Sweden

**Note:** A full list of maps is available in your local installation directory:
drive:\ibi\WebFOCUS82\webapps\webfocus\tdg\jschart\distribution\map
Chapter 10

Manipulating Data

The robust features of InfoAssist enable you to perform such tasks as joining data or blending data. In environments where additional data sources may be utilized or combined, you can use the functionality in this section to manipulate your data and data source.

In particular, you may have data sources that you want to join with another data source. Optionally, you may want to blend the data in another data source with your data source. Both of these features enable you to create larger, more customized data sets for reporting, and charting, or for creating visualizations.

In this section, we describe and discuss the concepts of data manipulation, including Defines, Computes, Joins, Blends, and filtering options.

In this chapter:

- Missing Data in a Chart
- Adding and Switching Data Sources
- Setting the Source of Your Data
- Creating Virtual Fields in TIBCO WebFOCUS
- RStat Scoring Routines in InfoAssist
- Joining and Blending Data
- Using Filters to Customize the Display of Data
- Output Formats

Missing Data in a Chart

When working with charts, you can use the options for missing data to control the display of values that are missing in a chart.

**Note:** This option is disabled for reports.

**Procedure:** How to Specify an Option for Missing Data

1. Create a chart with at least one measure and one dimension.
2. On the Data tab, in the Display group, click Missing Data.

3. On the menu that displays, select one of the following options:

   - **Gap.** Displays missing values as a gap in bar, line, and area charts.
   - **Zero.** Displays a bar on the zero line in a bar chart. Displays a solid line that connects the missing value with the succeeding value in a line chart. Displays an area on the zero line in an area chart.
   - **Interpolated Line.** Displays missing values as an interpolated dotted line that connects the plot points preceding and succeeding the missing value in a line chart. Displays missing values as an interpolated bar in a bar chart. Displays missing values as an area in an area chart.

   Your chart displays based on the option you selected.

Adding and Switching Data Sources

When working in Document mode, you can add an additional data source. Once you have multiple data sources available, you can then switch between them. These options are on the Data tab, in the Data Source group. The ability to switch data sources is particularly useful in Document mode, as you may often switch between a report and a chart.

**Note:** The Data Source group is not available when working with Reporting Objects.

**Procedure:** How to Add and Switch Data Sources

1. Open InfoAssist in Document mode.
2. Add a report or chart.
3. On the Data tab, in the Data Source group, click **Add**.
4. In the Open dialog box, select a Master File and click **Open**.
   
   This option allows you to add additional data sources to a document, enabling you to insert reports from different data sources into the same document. The Resources panel refreshes with the newly selected data source.
5. Click **Switch** to select from the available data sources.
   
   This option opens a drop-down list of all the data sources that have been added. You can choose which data source is currently active and being used to create new reports. You can also switch data sources by selecting a report that is using a data source that is different from the one that is currently active. The Resources panel will reflect the structure of the data source that you choose.
Setting the Source of Your Data

You can preview your data using sample data, or data directly from the source that you have selected. You can also set the number of rows that should be retrieved from the data source when Live Preview is selected.

**Note:** In Live Preview, an exclamation point is placed next to fields that are too large to be displayed within the space allotted. The allotted space is determined by the page-level styling. Page-level styling includes page size, orientation, margins, and font size.

Content that fits or is displayed on a page depends on the font used and its size. Margins, gaps, and page elements, such as headers and footers, also determine how much material is displayed on a page.

**Procedure:** How to Set the Source of Your Data

1. Create a report, chart, or document using data from an available Master File (.mas).
2. On the **Home** tab, in the **Design** group, click **Use Sample Data**.
   
   Your report or chart displays using sample data, which reduces processing time by eliminating the need to access the actual data source.
3. Click **Data from Source** to use the data source that you originally selected.
   
   InfoAssist uses the selected data source to display a live preview of the output on the canvas.
4. Optionally, enter a number of rows or click the drop-down menu for Records, where you can set the number of rows to be retrieved from the data source when Live Preview is selected. The default is 500, but other preset choices include: All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.
   
   **Note:** If you are working with a large amount of data, this feature is useful in reducing response time.

Creating Virtual Fields in TIBCO WebFOCUS

A temporary field is a field whose value is not stored in the data source, but can be calculated from the data that is there, or assigned an absolute value. A temporary field takes up no storage space in the data source, and is created only when needed. DEFINE fields and COMPUTE fields are two different types of temporary fields.

When you create a temporary field, you determine its value by writing an expression. You can combine fields, constants, and operators in an expression to produce a single value. For example, if your data contains salary and deduction amounts, you can calculate the ratio of deductions to salaries using the following expression: deduction / salary.
You can specify the expression yourself, or you can use one of the many supplied functions that perform specific calculations or manipulations. In addition, you can use expressions and functions as building blocks for more complex expressions, as well as use one temporary field to evaluate another.

**Note:** When creating a DEFINE or a COMPUTE field, the following characters are suppressed and cannot be entered in the Format text box.

```
space ! " # $ & ' ( ) * + , / : ; < = > ? @ \ ] ^ _ ` { | } ~
```

**Selecting a Temporary Field**

The following information is provided to help you choose the kind of temporary field that you need.

- **Choose a virtual field** when you want to:
  - Use the temporary field to select data for your report. You cannot use a calculated value, since it is evaluated after data selection takes place.
  - Use the temporary field to sort on data values. A calculated value is evaluated after the data is sorted. With the BY TOTAL phrase, you can sort on this type of field.

- **Choose a calculated value** when you want to:
  - Evaluate the temporary field using total values or prefix operators (which operate on total values). You cannot use a virtual field, since it is evaluated before any totaling takes place.
  - Evaluate the temporary field using fields from different paths in the data structure. You cannot use a virtual field, since it is evaluated before the relationship between data in the different paths is established.

**Detail (DEFINE)**

A virtual field (DEFINE) is evaluated as each record that meets the selection criteria is retrieved from the data source. The result of the expression is treated as though it were a real field stored in the data source.

The calculation that determines the value of a virtual field is performed on each retrieved record that passes any screening conditions on real fields.

You can define a virtual field in the following ways:

- **In a Master File.** These virtual fields are available whenever the data source is used for reporting. These fields cannot be cleared by JOIN or DEFINE FILE commands.
In a procedure. A virtual field created in a procedure lasts only for that procedure.

A DEFINE field is an optional attribute used to create a virtual field for reporting. You can derive the virtual field value from information already in the data source (that is, from permanent fields).

You may define fields simultaneously (in addition to fields defined in the Master File) for as many data sources as desired. The total length of all virtual fields and real fields cannot exceed 32,000 characters.

The Detail Field (DEFINE) dialog box allows you to create a defined field, type a name for the field, and enter a format.

The Detail (DEFINE) dialog box is shown in the following image.

![Detail Field (DEFINE) dialog box](image)

Summary (COMPUTE)

A calculated value (COMPUTE) is evaluated after all of the data that meets the selection criteria is retrieved, sorted, and summed. Therefore, the calculation is performed using the aggregated values of the fields. Calculated values are available only for the specified report request. You specify the COMPUTE command in the body of the report request, following the display command and optionally, introduced by AND. You can compute more than one field with a single COMPUTE command.

The Summary Field (COMPUTE) dialog box allows you to create a computed field, type a name for the field, and enter a format.
The Field List provides similar functionality, including options to display data source fields in a Logical, List, or Structured view. You can also view a complete set of functions, instead of data source fields, by clicking the Functions button.

The Summary (COMPUTE) dialog box is shown in the following image.

Using Field Titles in a Define or Compute

When working with Defines and Computes, field titles automatically display as you build your criteria in the Define (or Compute) text area.

Field titles are an attribute of a field. They are defined in the metadata and display only when specified for the field that you select. If a field title has not been defined in the metadata, the title that displays will be the physical field name.
The Use field titles feature enables you to see the field title (for example, Cost of Goods) rather than the fully qualified name of the field (for example, WF_RETAIL_LITE.WF_RETAIL_SALES.COGS_US). This facilitates easy identification of field names while building your Define or Compute. You can switch between the display of field titles and fully qualified field names by unchecking the Use field titles option, which you can access by clicking Additional Options, as shown in the following image.
If your Define or Compute uses more than one field with the same title (for example, Sale,Year), then only the first field will be added using field titles. Any other reference to this identical field will use the fully qualified field name. For example, in a sample InfoAssist data source, Sale,Year displays as the field title for two unique fields:
WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_YEAR and WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_DATE_YEAR_COMPONENT. In this case, only WF_RETAIL_LITE.WF_RETAIL_TIME_SALES.TIME_YEAR would display (using field titles) as Sale,Year. The other field would display using the fully qualified field name, as shown in the following image.

Note: When reviewing a procedure (.fex) that contains Define or Compute code, field names always display as fully qualified field names, not field titles.

**Procedure:** How to Use Field Titles in a Define or Compute

1. In Report or Chart mode, create a Define or a Compute.
2. Add fields by double-clicking them in the metadata tree.
   
   **Note:** The fields that you select display with field titles, as this is the default option. If you specify a field with a duplicate field title, the fully qualified field name is used for the second (and any subsequent) instance.
3. Click **Additional Options** and then click **Use field titles** to disable the use of field titles, which results in the display of fields using the fully qualified field name.
Resizing the Text Area of a Define or Compute

When working with Defines and Computes, you can adjust the width of the text area to accommodate the size of the fields in your query. This is particularly useful if you are using fully qualified names or long formulas, which can span more than the standard width of the text area.

In its original state, the text area is aligned with the calculator, as shown in the following image.
When fully expanded, the text area removes the metadata tree and toolbar from view, as shown in the following image.

**Procedure:** How to Resize the Text Area of a Define or Compute

1. Open InfoAssist in Report or Chart mode.
2. Select a Master File.
3. On the Data tab, click **Detail (Define)** or **Summary (Compute)**.
   The Define or Compute dialog box displays, respectively.
4. Hover over the right border of the text area until double arrows display.
5. Click and drag the field to the right.
   The text area is resized.

**Note:**

- If you expand the text area in a current session, InfoAssist will retain that expanded state for use in other areas of the application. For example, if you expand the text area when creating a Define, the expanded state will be present when you create a Compute.
- When working with the text area in an expanded state, you can reinstate the metadata tree and toolbar by hovering over the right border of the text area until double arrows displays. Click and drag the arrows to the left and right, as needed.
Creating Temporary Fields Independent of a Master File

The temporary fields that you create with the DEFINE and COMPUTE commands are tied to a specific Master File, and in the case of values calculated with the COMPUTE command, to a specific request. However, you can create temporary fields that are independent of either a Master File or a request using the DEFINE FUNCTION command.

A DEFINE function is a named group of calculations that use any number of input values and produce a return value. When calling a DEFINE function, you must first define the function.

A DEFINE function can be called in most of the same situations that are valid for supplied functions. Data types are defined with each argument. When substituting values for these arguments, the format must match the defined format. Alphanumeric arguments shorter than the specified format are padded with blanks, while longer alphanumeric arguments are truncated.

All calculations within the function are done in double precision. Format conversions occur only across equal signs (=) in the assignments that define temporary fields.

Enabling the Display of Missing Values for a DEFINE or COMPUTE

When working with DEFINEs and COMPUTEs, you can use the Missing Values option to enable or disable the display of missing values for a DEFINE or COMPUTE field. This allows you to accurately display missing values in reports, charts, and visualizations. The Missing Values option, which is accessible through the Additional Options button, is shown in the following image.

![Missing Values Option](image)

The following descriptions explain each option on the Missing Values drop-down list:

- **Off.** When selected, MISSING syntax is removed from the DEFINE or COMPUTE field definition. This is the default selection. MISSING treats missing values for numeric fields as zeros and missing values for alphanumeric fields as blanks.

- **On.** When selected, MISSING ON is added after the format in the DEFINE or COMPUTE field definition. MISSING ON interprets the temporary field as missing.
On All. When selected, MISSING ON ALL is added after the format in the DEFINE or COMPUTE field definition. MISSING ON ALL indicates that if all fields in the expression have values, then the temporary field has a value. If at least one field in the expression has a missing value, the temporary field also has a missing value.

RStat Scoring Routines in InfoAssist

The Define and Compute functionality in InfoAssist, which is used to create virtual fields, supports the use of functions. These functions can be used to create expressions and calculations for use in your reports and charts.

Predictive models or scoring routines, built with the separately licensed WebFOCUS RStat for Predictive Analytics, allow you to add predictive analytics to your reports and charts in InfoAssist. In order to access a scoring routine, an administrator or other designated individual must first deploy the scoring routine using TIBCO WebFOCUS® App Studio. Once the scoring routine is deployed, it will appear in the RStat Scoring Routines folder and can be used when creating a virtual field.

For more information on scoring routine deployment and creating scoring routines, see the TIBCO WebFOCUS® App Studio User’s Manual and the Using WebFOCUS RStat for Predictive Analytics manual.

To access functions in InfoAssist, open the Define or Compute dialog box and click the Functions button, as shown in the following image.

The list of available functions is displayed, including the RStat Scoring Routines folder. If one or more scoring routines have been deployed, the RStat Scoring Routines folder will have a plus sign (+) next to it, indicating that the scoring routines are available and ready for use.

Using the RStat Scoring Routines in InfoAssist

When a RStat predictive model is deployed, it is transformed into a function that is similar to any other WebFOCUS function. You can create expressions for incorporating predictive analytics into your report or chart.
Note: The success of this procedure is contingent on the availability of the scoring routines, which must be deployed prior to accessing the RStat Scoring Routines folder in the Functions list in the Define and Compute dialog boxes.

**Step 1: Creating the Report or Chart**

1. From the WebFOCUS start page, create a report or chart.
2. In the Tool Setup dialog box, click the Assign Applications check box so it is selected.
3. In the Tool Setup dialog box, click the Application Paths button.

   This enables you to assign an application path, giving you access to the folder containing the deployed scoring routine(s) and Master Files (.mas) to be used in the report or chart.

   **Note:** Scoring routines are not globally available. Therefore, you must obtain the correct application folder name from an administrator or the individual who performs the deployment of scoring routines within your organization.

4. Choose from the available Application Paths, then click OK.

   InfoAssist opens.

5. From the Open dialog box, choose the .mas file to be used in the report or chart.
6. Add data fields to the report or chart.

**Step 2: Creating the Virtual Field: Define or Compute**

1. On the Data tab, in the Calculation group, click one of the following options:

   - Detail (Define)
   - Summary (Compute)

2. On the relevant dialog box that displays, click the Functions button on the toolbar.

   The functions are listed.

3. Click the RStat Scoring Routines folder to access the deployed, stored functions.
4. Double-click a scoring routine to add it to the Formula text box.
5. Once you have selected the scoring model, replace the model’s parameters with the actual field names from the Master File, if needed.

   **Note:** On the dialog box’s toolbar, click View Fields in a Sortable Grid. This will enable the display of the field names in the Master File.

6. Highlight a parameter in the Formula text box and double-click the parallel or replacement value in the Master File list.
This places the value of the field from the Master File in the Define or Compute, overwriting the originating parameter supplied from the scoring routine. This enables you to use the scoring routine to develop a unique Define or Compute using fields from your Master File. Optionally, you can type over the parameters and replace them with the corresponding field names.

**Note:**

- The parameters used in a scoring routine are positional parameters, meaning that the order of the fields must be correct. In addition, take note of the placement of commas and other facets of your scoring routine to ensure the accuracy of your Define or Compute.
- A Compute becomes a COMPUTE statement in the body of the TABLE or GRAPH statement. A Define statement is placed prior to the TABLE or GRAPH statement in the procedure (.fex).

**Step 3: Handling Missing Values**

Missing data refers to variables that have no data value in the current observation or record. In order for a scoring routine to recognize input parameter values and for the algorithm to derive the score appropriately, you must add the SET MISSINGTEST command to the procedure (.fex). For more information, see the *Missing Data in Scoring Routines* topic in the *Using WebFOCUS RStat for Predictive Analytics* manual or the online Help.

When using the deployed RStat Scoring Routines, you must set the option to Preserve Null Values. This directive appears in the tooltip when you hover over the RStat Scoring Routines folder, as shown in the following image.

To set the option to preserve null values:

1. From the toolbar in the Define or Compute dialog box, click *Additional Options* and select *Preserve null value.*
This sets the WebFOCUS environment parameter MISSINGTEST to SPECIAL (that is, SET MISSINGTEST=SPECIAL).

2. Optionally, on the Quick Access toolbar, click View code.

The following image displays the SET MISSINGTEST=SPECIAL value in the procedure (.fex).

In order for a scoring routine to recognize missing input parameter values, the SET MISSINGTEST=SPECIAL command must be in the procedure (.fex).

3. Once you are finished, click OK. The resulting Define or Compute is placed in the Data pane for selection and inclusion in your report or chart.

   Note: Computes are also placed in the Query pane, by default.

### Joining and Blending Data

You can join two or more related data sources to create a larger integrated data structure from which you can report in a single request. The joined structure is virtual. It is a way of accessing multiple data sources as if they were a single data source. This can greatly increase the number of fields available for use in your content, giving you an expanded selection for your reporting and charting purposes.
Joins

Using conditional joins, you can establish joins based on conditions other than equality between fields. In addition, the host and cross-referenced join fields do not have to contain matching formats, and the cross-referenced field does not have to be indexed.

**Note:** You can edit the description of a join by clicking *Edit* in the Join dialog box and typing in the Description section. You can only use letters, numbers, and underscores in your description. No special characters are allowed.

The conditional join is supported for TIBCO FOCUS® and all relational data adapters. Because each data source differs in its ability to handle complex conditional criteria, the optimization of the WHERE syntax differs depending on the specific data sources involved in the join and the complexity of the conditional criteria.

For FOCUS® data sources, if the host and cross-referenced join fields do not have common matching formats, the following message appears.

![Where-Based Join](image)

**Note:** If you click Yes, the Filter dialog box opens, where you can create a Where-Based Join.

If the cross-referenced join field does not have an index, the following message appears.

![Where-Based Join](image)

**Note:** If you click Yes, the Filter dialog box opens, where you can create a where-based join.

To create a where-based join, create a filtering condition.
Blending Data

The blend option allows you to explicitly select the data fields that you want to include. More specifically, you can join multi-fact data structures and combine pertinent external data into your current data source, creating a blended data resource. This can be from local or other system resources.

Blending is used to create customized data sources. For example, you may have some of the basic fields available in the current data source, but you can use the blend option to add relevant data fields from a different data source to the current data source in order to create a unique data set.

The blend option allows a new fact table to be added to a cluster master as a parent segment to an existing child segment. This option is available from the Join dialog box. You may want to blend data if you are reporting from two different fact tables that share a common dimension, such as a product dimension. For an example of this, you can view the sample retail database, wf_retail_lite. The wf_retail_lite Master File contains the WF_RETAIL_STORE_SALES segment and the WF_RETAIL SALES segment. The WF_RETAIL SALES segment is defined as the parent of the WF_RETAIL STORE SALES segment. You may want to add a second fact table to the report. The second fact table in this example will be an Excel spreadsheet that you upload to InfoAssist for use with a report or chart. The data in the spreadsheet file that you upload will be joined to the wf_retail_lite database using a common field.

Note: You can find supported, common fields in your selected database (for example, wf_retail_lite) using the search feature in the Data pane. If necessary, you may need to add a field in your spreadsheet to map your data to the structure of the database. For example, ID_CUSTOMER. In addition, the name of the primary sheet in Microsoft Excel becomes the name of your data source, so be sure to name the file accordingly.

The following list provides some general rules that apply to the Blend option:

1. The result of blending is that a single dimension is shared between two fact tables. The table must be based on a cluster with at least two segments. One segment is for Fact table 1, the second segment is for the dimension.

2. Two uploaded files cannot be blended because they result in single segment Master Files.

3. Do not use the fields from the blended table as a sort field, since these fields will not have a common field when used with fields from other fact tables.

Procedure: How to Blend Data

This procedure describes how to blend data from an external data source into an existing data source. This example uses a Microsoft Excel spreadsheet file.

1. On the Data tab, in the Join group, click Join.
The Join dialog box displays.

2. Click Add New.

The Open dialog box displays.

**Note:** The options that display on the Open dialog box depend on your user privileges.

3. At the top of the Open dialog box, click Upload Data.

The Upload wizard opens.

4. Drag your Microsoft Excel spreadsheet file onto the Upload pane, or click Select Upload File to locate the file on your local drive.

The next screen of the Upload wizard opens. You can use the options on this screen to preview and change spreadsheets and delimited data files before you upload them to the target environment. This screen shows you the default breakdown of your data as measures, dimensions, and hierarchies.

5. On the ribbon, click Load and Next.

The Target Load Options dialog box opens.

**Note:** By default, the Bulk Load check box is selected. Clear this check box if you do not have a bulk load program that supports your target environment. For example, if you are using Microsoft SQL Server, you may use a Bulk Copy Program (BCP). If you are unsure about whether you have a bulk load program installed, contact your system Administrator.

6. Click Proceed to Load.

The Upload wizard closes, and you return to the Open dialog box.

**Note:** If there are informational messages or if your upload is unsuccessful, the Status screen opens.

7. In the Open dialog box, click the name of your uploaded data source and then click Open.

8. In the Join dialog box, create a connection between the common fields by dragging your mouse pointer from the field in the Master File to the common field in the newly uploaded file.

9. Click Blend, and then click OK.

The blended data source fields are now available in the Data pane.

**Using Filters to Customize the Display of Data**

Filters enable you to customize the display of data in your report, chart, document, or visualization. This gives you the advantage of viewing only the data that you want to see and use.
When creating a report, you refer to fields in several parts of the request. For example, in display commands (PRINT, SUM), in sort phrases (BY, ACROSS), and in selection criteria (WHERE, WHERE TOTAL, IF).

**Note:** When using ESSBASE hierarchical data sources, creating a filter on a sort field is not supported.

The WHERE phrase selects records from the data source to be included in a report. The data is evaluated according to the selection criteria before it is retrieved from the data source. You can use as many WHERE phrases as necessary to define your selection criteria.

In WHERE TOTAL tests, however, data is selected after all the data has been retrieved and processed.

You can group conditions and expressions within filter criteria. In addition, you can apply functions and calculations within criteria. For more information on filtering options, see *Field Tab* on page 42.

You can create Where and Where Total filters in the Filter dialog box by clicking *WHERE*.

Double-clicking the *Double-click or press F2 to edit!* text opens drop-down menus for Fields and Subqueries, Operators, and Values, as shown in the second image to follow.
You can retrieve fields and values from the Master File and data source and Subqueries from a HOLD file.
The Field drop-down menu provides a field list from the Master File. The Field list can be viewed as follows:

- In business order (default)
In a sortable grid

In a hierarchical structure of the data

If you select Subquery, then the Operator drop-down menu is replaced by a menu with the
options of *In list* and *Not in list*, as shown in the following image.

![Create a filtering condition](image)

**Note:** The Subquery option is not available in the Filter dialog box if you are creating a report from a Reporting Object.

- **In list.** Activates a drop-down menu in the right-most part of the expression. The drop-down menu contains a list of all subqueries that you have created from the Master File in use, and an EXISTING option.
  
  Click *EXISTING* to open the Open dialog box, where you can select a subquery from a different Master File.

- **Not in list.** Opens the Open dialog box, where you can select a subquery from a different Master File.

  The Operator (default) drop-down menu provides various operators for your filter. For example, Equal to.
The Value drop-down menu opens a dialog box with multiple options, as shown in the following image.

![Value drop-down menu](image)

**Note:** If you are creating a filter on a full date field, the Value field will have a calendar icon adjacent to it. You can use this icon to select a date using a calendar control.

The Type drop-down menu contains the following options:

- **Constant.** Enables the entry of a literal value. This value can be a positive number, a negative number, or any character string.

- **Parameter.** Enables you to specify a parameter by entering a name and description in the provided text input areas, as well as selecting the type of parameter (Simple, Static, or Dynamic).

**Note:** If you create a filter that specifies a simple parameter, QUOTEDSTRING will be inserted at the end of the line that defines the simple parameter, as specified in the procedure (.fex), by default. In this case, when you run a .fex that contains this value, you will not be able to enter multiple values, at run time, for simple parameters.
You can also select *Optional* to set the parameter as optional. This adds the default value of _FOC_NULL, which removes the parameter from the procedure. Indicating *Optional* also disables the prompt for parameters functionality within the procedure. Therefore, if a report has an optional parameter, it would run without any prompting. However, if another report drilled down to it, the parameter would be accepted and it would run with that value. The *Optional* option is used primarily for other reports that would be drilling down to the current report and passing the parameter to this report. For more information, see *Using Multi Drill* on page 357 and *Using the Auto Linking Feature to Link Content* on page 349.

When defining WHERE clauses in the Create a filtering condition dialog box, you can also create simple, static, and dynamic parameters. These parameter values are transformed into local variables that allow the content of your report to be defined at runtime by a context in your data or a selection by the user. Additionally, you can change to scope of this parameter amper variable from local to a global scope so that its value is available across multiple components on a page or in a document. To transform the parameter to have global scope, enter a single & (amper) symbol in the first character position of the parameter name field.

**Note:** The & symbol can only be entered in the first position of the parameter name where it defines the parameter scope. Parameter field names cannot contain a & symbol in any other character position.

The parameter description is used as the defining parameter prompt. In the description, a space can be placed in any position. The first character cannot be a single quotation mark (’) and the following characters cannot be used within the parameter prompt: & . ; ( )

The parameter options are shown in the following image.

![Parameter Options](image)

- **Field.** Enables the specification of a field name to compare against.
The value area generally contains a text input box that you can use to manually insert values. However, if you are working with a date field, the Value field is set to Today. You can optionally select Beginning of Month, End of Month, Beginning of Quarter, End of Quarter, Beginning of Year, End of Year, or you can specify a Custom date using the calendar that displays when you make that selection.

**Note:** The default date of Today applies to Report, Chart, and Document modes only.

The value area also contains a Get Values drop-down menu, which supplies the following options:

- **All.** Retrieves all the values from the selected field.
- **First.** Retrieves the first value from the selected field.
- **Last.** Retrieves the last value from the selected field.
- **Minimum.** Retrieves the minimum value from the selected field.
- **Maximum.** Retrieves the maximum value from the selected field.
- **From File.** Retrieves a value that you specify. Selecting this option opens the Select From File dialog box, where you can browse to a local file and specify a file format, such as a flat file (CSV) or an Excel spreadsheet (XLS or XLSX).

Numeric data values can be imported into the available filter values from a flat file or a CSV as pure numbers. This import supports numbers containing leading signs (negative), numeric digits, and decimal points. Numbers containing currency symbols or commas will be imported but as shown in the Values box in the Create a filtering condition dialog box, may not be interpreted correctly. Text or CSV files with values requiring complex formatting can be opened and saved with the appropriate formatting in Excel. This Excel file can then be imported with the formatting retained.

**Note:** The Get Values drop-down menu is only accessible if you have already selected a field.
Once you have retrieved the values for your filter using one of the Get Values options, you can use the Search values option to quickly locate a record in the list. For example, you can type in the letter S to go to that section in the list. Also known as type ahead search, this functionality can bring you directly to the value that you want to include, making it easy to identify the required values. Wildcards, such as an asterisk, are also supported. The Search values option is shown in the following image.

After selecting the values that you want, you can move them into and out of the Multiple Values area with the left and right arrows. You can also change the value order and delete values with the up and down arrows and the Delete icon.

After creating a condition, you can insert additional conditions before and after the selected condition by using the Insert Before and Insert After buttons at the top of the Filter dialog box. You can use either the And or the Or conjunction to link conditions and the Group and Ungroup buttons to nest and organize conditions.

You can also add an expression to your filter by clicking the New Expression button. This creates a new WHERE clause and allows you to build an expression dynamically.
You can create additional filters by clicking the New Filter button at the top of the Filter dialog box.

After creating the filters that you want, click OK to save and apply the filters. You can access them from the Filter pane of the Resources panel.

**Note:** Dates shown in the live preview reflect the format specified in the data source. However, when Filters are applied to a date formatted field, the format of dates shown in the Filter interface is derived from the locale. When the report, chart, or visualization is executed, the output, as well as any prompt will reflect the format specified in the data source.

**Including or Excluding a Filter**

Once you have created a filter, you can make decisions about when and where you want to include it in your report. For example, you might want to include one filter and exclude another. Using the Include and Exclude options in the Filter group on the Home or Field tabs, you can set filters accordingly.

You can use the following information to make decisions about your filters:

- **Exclude.** Removes, but does not delete, the filter from the report.
- **Include.** Restores a filter that was previously excluded from a report.

**Using the Prompt Functionality to Select Field Information at Run Time**

Using the prompt functionality, you can create an auto prompting parameter for which you can define a value at run time. This feature is located in the Filter Group on the Field tab.

To create an auto prompting parameter:

1. Select a field for which you want to create a parameter in your report.
2. On the Field tab, in the Filter group, click **Prompt**.
   
   The Create a filtering condition dialog box displays.

3. Double-click the **Value** field.
   
   **Note:** Parameter is selected, by default, when you are defining a prompt.

   The following options display, from which you can make a selection:

   - **Simple.** This is used for prompts using Text Input. This is the default value.
   - **Static.** This is used for prompts using Selection. This option allows you to select multiple values at run time.
Dynamic. This is used for prompts using Data Values. This option allows you to select multiple values at run time.

Note: You can also select Optional to indicate that the selected value (Simple, Static, or Dynamic) is optional.

4. Click OK, and click OK again to close the Create a filtering condition dialog box.

When you run your report, you will be prompted for information based on the parameters you created.

Output Formats

You can change your output format on the Home tab, in the Format group.

Current Output Format. Displays a drop-down menu of all supported output formats.

- HTML (the default for charts and reports)
- HTML5 (only available for charts)
- HTML Analytic Document (default for documents)
- PDF
- PDF Analytic Document
- Excel (xlsx) (reports designed in Live Preview and Query Design views only)
- Excel Formula (xlsx) (reports designed in Live Preview and Query Design views only)
- Excel (csv)

Note: You can control the display of Excel output formats from the InfoAssist Properties section in the WebFOCUS Administration Console.

- PowerPoint (pptx)

When you run a report, the output is created in the format that is currently selected. You can also select output format options on the status bar, from the Output Types menu.

Note: If you are running InfoAssist Basic, your output format options are limited. PowerPoint and PDF Analytic Document are not supported for charts and reports. PDF, Excel, and HTML Analytic Document are not supported for charts.
Report or Chart. Determines whether report-specific or chart-specific functionality is available in the InfoAssist tool. The default name ReportX or ChartY is given for each new report or chart created in a given InfoAssist session. X and Y are numbers that start at 1 and increase by 1 for each report or chart created. For more information on switching between multiple reports, see View Tab on page 41.

File. Creates an image file from a chart, or a data file from a report. For more information, see Output Formats for Reports and Charts on page 460.

Note: The File menu is not available in InfoAssist Basic.

<table>
<thead>
<tr>
<th>Format</th>
<th>Reports</th>
<th>Charts</th>
<th>Documents</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>HTML5</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>HTML Analytic Document</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PDF</td>
<td>Available</td>
<td>Available</td>
<td>Available (document default)</td>
</tr>
<tr>
<td>PDF Analytic Document (requires Adobe Reader® 9.0 or later)</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>Excel formats</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PowerPoint (pptx)</td>
<td>Available</td>
<td>Available</td>
<td>Available</td>
</tr>
<tr>
<td>PDF/GIF (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>Format</td>
<td>Reports</td>
<td>Charts</td>
<td>Documents</td>
</tr>
<tr>
<td>--------------</td>
<td>-----------------</td>
<td>----------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>PNG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>GIF (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>JPEG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>SVG (must be set to display in InfoAssist Properties)</td>
<td>Not Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
</tbody>
</table>

**HTML5**

HTML5 is the default output format for charts. It allows you to render a chart in the browser using a built-in JavaScript engine. Charts with this output format utilize the very latest capabilities of the HTML5 web standard, including animation, high-quality vector output, and attractive alpha-channel and gradient effects.

**Enabling Additional Output Types**

The output types of PNG, GIF, JPEG, and SVG do not appear on the status bar, in the Output Types menu, by default. In addition, User Selection is not available, by default. You can enable these options by opening the Administration Console, selecting Utilities, and then InfoAssist Properties.
If these formats are not enabled and you try to open an existing procedure with PNG, then HTML becomes the output. In addition, the following warning messages could open:

- When opening an existing procedure with JPEG, GIF, or SVG, a warning message opens, indicating that the request is not allowed with the current configuration and that the procedure will be converted to HTML output.

- When opening an existing procedure with PDF or GIF, a warning message opens, stating that the request is not allowed with the current configuration and that the procedure will be converted to PDF output.

When you run a report, the output is created in the format that is currently selected. You can also set output format options from the output format button in the status bar.

**User Selection**

The User Selection output format allows you to change the output type of your report at run time. User Selection can be accessed on the status bar, in the Output Types menu.

**Note:** User Selection must be enabled in the Administration Console in order to access the functionality.

Once it is enabled, you are prompted, at run time, to select an output type. This is shown in the following image.

You can select one of the following output types for your report, chart, or document:

- For reports, you can select HTML, HTML Analytic Document, PDF, PDF Analytic Document, Excel (xlsx), Excel Formula (xlsx), and PowerPoint (pptx).

- For charts, you can select HTML, HTML5, HTML Analytic Document, PDF, PDF Analytic Document, Excel (xlsx), and PowerPoint (pptx).
**Note:** When working with charts that do not employ the new chart attribute syntax, all output formats will display when User Selection is selected. If you are working with a chart that uses the new chart attribute syntax, HTML5 and HTML Analytic Document are the only output formats available for selection. Exceptions to this rule are the HTML5 specific charts that do not use the new attribute syntax, but are only available in HTML5 or HTML or PDF Analytic Document formats, including: Tagcloud, Parabox, Mekko, and Streamgraph.

- For documents, you can select HTML, HTML Analytic Document, PDF, PDF Analytic Document, Excel (xlsx), and PowerPoint (pptx).
Output Formats
Chapter 11

Creating HOLD Files

A HOLD file is the output of a report request stored in a file that you can use as input to another WebFOCUS procedure.

You can then create new report requests that extract data from the HOLD file, resulting in a multi-step report.

HOLD files can be created to use in a report, chart, document, or visualization.

In this chapter:

- Valuable Applications of HOLD Files
- Storing HOLD Files
- Output Formats for Reports and Charts
- Creating HOLD Files
- Creating a Subquery Filter Using a HOLD File

Valuable Applications of HOLD Files

A HOLD file is valuable when you want to do the following:

- Extract fields from a large data source for faster and more efficient retrieval in subsequent requests. This reduces processing time, enabling you to create reports and charts rapidly against a smaller, more specialized data set. This improves efficiency while giving you the flexibility that you need when working with smaller subsets of your data.

- Store virtual field values or summary values calculated in one request for further processing in another request. This allows you to reuse calculated values, decreasing the effort required to recreate certain scenarios.

Storing HOLD Files

HOLD files can be created for immediate use and saved temporarily or they can be stored for future and repeated use. This gives you the flexibility to use and store HOLD files, as needed, based on how you want to use the files that you create.
Output Formats for Reports and Charts

You can save a HOLD file for a report in the following formats:

- Binary (*.ftm)
- FOCUS (*.foc). For more information, see *TIBCO FOCUS Format Index Fields* on page 467.
- Comma Delimited with Titles (*.csv)
- Plain Text (*.ftm)
- Tab Delimited (*.tab)
- Tab Delimited with Titles (*.tab)
- Database Table (*.sql)

**Note:** The Database Table output is only available when working against an SQL database.

- SQL Script (*.sql)
- Hyperstage (*.bht)

**Note:** The Hyperstage output is only available when the WebFOCUS Reporting Server has a Hyperstage adapter configuration.

- XML (*.xml)
- JSON (*.json)

You can save a HOLD file for a chart in the following formats:

- PNG (*.png)
- GIF (*.gif)
- SVG (*.svg)
- JPEG (*.jpg)

Creating HOLD Files

This section contains examples of how you would use a HOLD file.

**Note:**

- Across fields are not allowed in HOLD files.
Using the Change Title option in the Query pane, you can change the title of a field prior to creating a HOLD file. A blank space in the title will be replaced by an underscore. This functionality enables you to control the names used for the fields included in the HOLD file, and makes it easier to find the fields when creating a report, chart, or document.

When creating a HOLD file, the Temporary dialog box displays only those Reporting Server applications to which you have access.

You can use Auto Linking when working with HOLD files. For more information, see Using the Auto Linking Feature to Link Content on page 349.

When working with charts in HTML5 format, you cannot create a HOLD file. You can do so, however, in HTML format.

When a report contains a HOLD procedure, dots or periods (.) in the AS name of the Define field are automatically converted to an underscore (_).

Within a single procedure, you cannot add a HOLD file and then build a table request based on that HOLD file, which contains a dynamic parameter requiring values from the HOLD file. InfoAssist has added special processing to allow this to work when the procedure is executed within InfoAssist. But the procedure, as generated in InfoAssist, will return a server error when it is executed outside of InfoAssist. The HOLD file must exist prior to the execution of the procedure.

**Procedure:** How to Create Multiple Components in a Document From a HOLD File

This procedure describes how to extract fields into a HOLD file and then create multiple components in a document from the HOLD file.

1. Open InfoAssist in Document mode.
2. Select a data source.
3. Add fields that need to be extracted for use in subsequent requests.
4. On the Home tab, in the Format group, click **File**.
5. In the Temporary dialog box, name the file, choose the format of the HOLD file from the format drop-down list, and click **Save**.

   **Note:** The default is to create a temporary HOLD file, which is deleted after the report or chart is run. Alternatively, you can create a permanent HOLD file by selecting an application path folder location. This file will remain in this location after the procedure is run for future use.

6. On the **Insert** tab, in the **Reports** group, click **Chart**.
7. Add fields to the chart.
8. Insert another chart.
9. Add fields to that chart.
10. On the Format tab, in the Chart Types group, click Pie.
12. Add fields to the report.
13. Add as many reports and charts as you want to complete your document.

**Procedure:** How to Create a Tabular Report From a HOLD File

To create a tabular report from a HOLD file, begin by creating a report.

1. In the Open dialog box, select the **wf_retail_lite** Master File.
2. Add the following measure fields to the report:
   - Cost of Goods
   - Discount
   - Gross Profit
   - Quantity,Sold
   - Revenue
3. Add the following dimension fields to the report:
   - Product Category
   - Product,SubCategory
   - Sale,Year
   The Temporary dialog box opens.
5. In the Temporary dialog box, name the HOLD file, keep the default file type, Binary (*.ftm), and click Save.
6. At the bottom of the canvas, click Create Report.
   The custom database structure displays in the Resources panel. The canvas is returned to a default blank state, enabling the development of a new report using the HOLD file.
7. From the HOLD file, drag Quantity,Sold to the canvas.
8. On the canvas, select the Quantity,Sold column heading.

9. On the Field tab, in the Display group, click Aggregation, and then click First Value.

   **Note:** The heading changes to FST Quantity Sold.

10. Select the FST Quantity Sold heading.

11. On the Field tab, in the Display group, click Hide Field to hide Quantity,Sold, as it will be used in a subsequent calculation.

12. On the Data tab, in the Calculation group, click Summary (Compute).

13. In the Summary Field (COMPUTE) dialog box, do the following:
   
   - In the Format field, type D8.2%.
   - Double-click the Quantity,Sold field to add it to the formula box.
   - Add / 100 after the Quantity Sold field to calculate the percentage.

   The following image is an example of the Summary Field (COMPUTE) dialog.

   ![Summary Field (COMPUTE) dialog](image)

14. Click OK to close the dialog box.

15. Drag Product,Category to the By Query field container.

16. In the Query pane, select the Product,Category field.

17. On the Field tab, in the Break group, select Subtotal to create Subtotals on Product,Category.

18. Drag Product, Subcategory to the By Query field container.
19. Drag Sale,Year to Across.

The final report displays.

_Procedure:_ **How to Rearrange HOLD File Components**

The following procedure describes how to rearrange file components in a HOLD file.

**Note:** This procedure creates a binary HOLD file and a subquery to illustrate how to rearrange HOLD files. It also shows the result of this rearrangement.

1. Create a new document, using the wf_retail_lite Master File for the data source.
2. On the Insert tab, in the Reports group, click Report. Populate the report with the following fields from the Data pane:
   - Gross Profit
   - Quantity,Sold
   - Revenue
   - Product,Category
   - Product,Subcategory

The report is shown in the following image.
3. On the *Home* tab, in the *Format* group, click *File* to create a HOLD file.
   In the Temporary dialog box, enter a name for the file. For example, File1_binary.

4. Click Save.

5. Create a report using the HOLD file, specifying Product, Category, Product, Subcategory, and Quantity, Sold, as shown in the following image.

6. Next, using the following steps, add a subquery SQL script for use as a filter on the first report.
   a. On the *Data* tab, in the *Data Source* group, click *Switch*.
      Select the original Master File (*wf_retail_lite*).
   b. Locate and double-click the *Product, Category* dimension field.
      This creates a second report, which you can drag and resize as needed on the Document canvas.
c. Create a filter on Product,Category, where the product category is equal to Televisions.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Product Subcategory</th>
<th>Quantity</th>
<th>Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>Charger</td>
<td>105,257</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Headphones</td>
<td>228,349</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Universal Remote Controls</td>
<td>178,061</td>
<td></td>
</tr>
<tr>
<td>Camcorder</td>
<td>Handheld</td>
<td>250,167</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Professional</td>
<td>12,872</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Standard</td>
<td>102,205</td>
<td></td>
</tr>
<tr>
<td>Computers</td>
<td>Smartphone</td>
<td>205,049</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tablet</td>
<td>146,728</td>
<td></td>
</tr>
<tr>
<td>Media Player</td>
<td>Blu Ray</td>
<td>678,495</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DVD Players</td>
<td>18,835</td>
<td></td>
</tr>
<tr>
<td></td>
<td>DVD Players - Portable</td>
<td>5,694</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Streaming</td>
<td>67,910</td>
<td></td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>Boom Box</td>
<td>9,370</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Home Theater Systems</td>
<td>399,092</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Receivers</td>
<td>150,568</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Speaker Kits</td>
<td>244,199</td>
<td></td>
</tr>
<tr>
<td></td>
<td>iPod Docking Station</td>
<td>311,103</td>
<td></td>
</tr>
<tr>
<td>Televisions</td>
<td>CRT TV</td>
<td>4,638</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Flat Panel TV</td>
<td>92,501</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Portable TV</td>
<td>8,049</td>
<td></td>
</tr>
<tr>
<td>Video Production</td>
<td>Video Editing</td>
<td>199,749</td>
<td></td>
</tr>
</tbody>
</table>

7. With the new component selected, click the Home tab and in the Format group, click File.

   In the File name field, enter File2_subquery and select the SQL Script (*.sql) format from the file types menu.

8. Click Save.
9. Rearrange the order of the HOLD files so that the File2_subquery is positioned above the File1_binary HOLD file using the following steps:
   a. Right-click Files in the Query pane and click Arrange Files, as shown in the following image.
      
      ![Arrange Files dialog box](image)
      
      The Arrange Files dialog box opens.
   b. Using the Arrange Files dialog box that displays, select File2_subquery and click Move Up to move the file above File1_binary, as shown in the following image.
      
      ![Move Up](image)
      
   c. Click OK.

10. Edit the first report and create a filter using the subquery.
11. Click OK to exit the Create a filtering condition dialog box.

Your report is refreshed to reflect the filtering you have applied.

**TIBCO FOCUS Format Index Fields**

FOCUS is the only format that supports an index field. The maximum number of fields to index is four. If the file format is FOCUS, then Index appears on the Query pane.
Creating a Subquery Filter Using a HOLD File

You can create a subquery using a HOLD file. A subquery is a nested query that is added to the Where clause of an SQL statement. A subquery is valuable because it is highly reusable.

**Note:** When creating a chart or report in InfoAssist, on the *Home* tab, in the *Design* group, you can click *Query* to create your content in Query mode. This hides the canvas and uses only the Query and Filter panes for content creation. In Query mode, if a subquery is present and there is no ACROSS field in the request, the data is refreshed only at run time. It is not refreshed at design time as you edit your content, improving performance. Since the canvas is hidden at design time, data does not need to be refreshed at that point.

**Procedure:**  How to Create a Subquery Filter Using a HOLD File

This procedure describes how to create a subquery filter using a HOLD file created in the previous procedure.

1. Build a report.

2. On the Data tab, in the Filter group, click *Filter*.

   The Filter dialog box opens.

3. In the Create a filtering condition dialog box, from the Type drop-down menu, select *Subquery* as the filter type for the left-most part of the expression.

4. From the Subquery drop-down menu, select *In list* as the comparison operator.

5. From the list of subqueries, select the subquery that was created (in this example, File1) for the right-most part of the expression.

6. Click *OK*.

   The report is filtered by the subquery that you created.

   **Note:** To view the SQL statements generated by the request, go to the Quick Access Toolbar, open the Run drop-down menu, and select *SQL Trace*.
Creating Multi-Page Documents

In Document mode, content can be created on multiple pages. The available output formats are: HTML, HTML Analytic Document, PDF, PDF Analytic Document, Excel (xlsx), and PowerPoint (pptx). Additional Excel formats are available, as well.

**Note:** When working in Document mode using the HTML Analytic Document format, you can create a rich, multi-object document that integrates various reports and charts, closely resembling a dashboard.

Microsoft Excel 2007 and Microsoft PowerPoint 2007 are enabled, by default, in the Administration Console. To enable or disable formats, you must do so in the Administration Console.

- The output format combines multiple reports and charts into one document, resulting in a tabbed dashboard.
- Excel combines multiple reports as different sheets in a workbook.
- PowerPoint combines multiple reports and charts in a single slide.

**In this chapter:**

- Creating Multi-Page Documents
- Creating a Multi-page In-Document Analytics Dashboard
- Navigating the Page Menu
- Using the Cache Option
- Enabling Cache Through InfoAssist

### Creating Multi-Page Documents

You can create multi-page documents, allowing you to display an array of information across different pages.

**Procedure:** How to Create a Multi-Page Document

1. Create a new document.
2. Add content, such as a new or existing report, chart, text, and images to Page 1.

3. To add another page, do one of the following:
   - On the Insert tab, in the Pages group, click Page.
   - On the canvas title bar, click the page icon. From the Page menu that opens, select New Page.

   A new page, for example, Page 2, is inserted after the current page, and appears on the canvas.

   Each new page that you add is named Page n, where n is a unique number increasing by an increment of 1.

4. Add content to Page 2.

5. Repeat steps 3 - 4 until your document is complete.

   To navigate between pages, open the Page menu by clicking the Page icon at the top of the canvas, as shown in the following image.
Creating a Multi-page In-Document Analytics Dashboard

You can create a multi-page interactive dashboard using InfoAssist.

Procedure: How to Create a Multi-page In-Document Analytics Dashboard

1. Create a new interactive dashboard by setting the output format to interactive report. Page 1 appears on the canvas title bar.
2. Add content, such as a new or existing report, chart, text, images, and interactive dashboard prompts to Page 1.
3. To add another page, do one of the following:
   - On the Insert tab, in the Pages group, click Page.
   - On the canvas title bar, click the page icon. From the Page menu that opens, select New Page.
   A new page, for example, Page 2, is inserted after the current page, and appears on the canvas.
   Each new page that you add is named Page n, where n is a unique number increasing by an increment of 1.
4. Add content to Page 2.
5. Repeat steps 3 - 4 until your dashboard is complete.
   To navigate between pages, open the Page menu by clicking the Page icon at the top of the canvas.
6. Run the interactive dashboard.
Navigating the Page Menu

The tabs appear at the top of the canvas, as shown in the following image.

![Page menu image](image)

Navigating the Page Menu

You can access the Page menu by clicking the Page icon in Design mode, as shown in the following image.

![Page menu image](image)

The Page menu lists the pages in the order in which you created them. You can rearrange the pages using drag-and-drop functionality. You can also select multiple pages and delete them.

In addition, the Page menu contains the New Page option to add a new page to the document. The Duplicate option creates a duplicate page.
The Page menu also contains *Page Options* which you can click to launch a dialog box of the following options:

- Rename Page
- Duplicate Page
- Move Page Up
- Move Page Down
- Delete

The Page Options dialog box is shown in the following image.

![Page Options dialog box](image)

When you select a page, the Duplicate, Rename, Move Up, Move Down, and Delete options become active in the menu bar at the top of the dialog box. Also, when you right-click a page, a context menu of these same options opens.

The position of the page that you have selected determines which directional options are available. For example, *Move Up* would not be an option for Page 1. *Move Down* would not be an option for the last page.

To close the dialog box, click *OK*. 
Using the Cache Option

Because all post-retrieval processing is performed in the memory of the web browser, an report has a processing limit of approximately 5,000 records or 100 pages of output. The active cache option enables you to send only the first page of report output to the browser and retrieve subsequent pages from a temporary cache on the Reporting Server.

**Tip:** It is recommended that you set the number of rows retrieved five times greater than the number of lines retrieved per page (as indicated in SET LINES). The minimum number of rows retrieved is 100.

Enabling Cache Through InfoAssist

Cache is enabled when you select *HTML Analytic Document* as the output type and the *Pages on Demand* button (Format tab, Navigation group) is enabled.

The Advanced tab on the Analytic Document Options dialog box contains the Rows Retrieved drop-down list. Use this setting to establish the increments in which the cached data stored in a binary file is returned to the output window. The default is 100.

**Note:** In a multi-page document, cache must be enabled per component. It is not globally set. Therefore, when creating a document in AHTML format, you must select each component separately to enable cache. When you do so, the Pages on Demand button is activated.
Creating Interactive Content

This content describes how you can enable In-Document Analytics to create interactive reports, charts, or dashboards that users can analyze and interact with offline.

In this chapter:

- Overview of In-Document Analytics
- Enabling In-Document Analytics in InfoAssist
- Developing Interactive Content
- Working With Interactive Content

Overview of In-Document Analytics

Content that uses In-Document Analytics provides users with an interactive interface that allows the generation of real-time, dynamic reports, charts, and dashboards. Its versatility allows you to package a data set with a combination of analytical views, resulting in highly intuitive and interactive self-service business intelligence. This gives you an edge in presentation and analysis, making it easy to develop and share concepts, ideas, and scenarios. An interactive report is a self-contained report, meaning that it contains all the data and JavaScript® within the HTML output file. Packaging the data and the interactive functions in the HTML file also makes the output highly compressible for email and transparent to security systems. If you are working with a larger data set, you can also zip the output files to reduce the file size when sending them through email.

Note: You may need to zip interactive content output files to reduce the file size, and send them through your email client.

Your users can explore and interact with your data using various analytical tools such as sorting, filtering, calculations, roll-ups, and pivoting. They can also experiment with different scenarios using various options.
All of the interactive content that you create functions independently of a server, and is portable, making it easy for your users to work with and analyze complex data without requiring the use of an external application, such as Microsoft Excel. With two types of users (developer and end user), the roles in development and delivery of materials are clear. The end user interacts with the content that the developer creates and deploys. They can obtain content without any additional plug-ins or programs should they choose to access your content remotely or offline, independent of a server.

**Note:** Each artifact that you create at run time is given a unique number for easy identification. This number is incremental but not consecutive, and is assigned automatically.

In InfoAssist, there are two output formats that you can use to enable In-Document Analytics functionality: HTML Analytic Document format (formerly known as AHTML) and PDF Analytic Document format (formerly known as APDF). Using Analytical Document format (ADF), you can generate dynamic content and distribute it offline, even when you are disconnected from a browser. When working with the new Designer style, only AHTML format is supported.
**Note:** These formats are enabled in the Administration Console by your administrator. As a developer, once you have access to these output formats, you can begin generating content that you can distribute across your enterprise. The HTML Analytic Document format, as it appears in InfoAssist, is shown in the following image.
There are also two available styles that you can apply from the Procedure Settings dialog box. If you created interactive content in an earlier release, you can continue to use this style, which is known as Legacy. Legacy provides options like the Chart/Rollup and Pivot tools. An example of legacy style in a report is shown in the following image.

Alternatively, you can use the Designer Style, which currently presents some of the same options, but displays more like a page that you create in TIBCO WebFOCUS® Designer. An example of Designer style in a chart, is shown in the following image.
When you run your content, you can review and continue to develop it using the available menus. For example, when you run a chart, you can select the chart menu to change the type of chart you are showing, as shown in the following image.
To add a new chart or edit your content, you can use the options available from the vertical Ellipsis menu, which is shown in the following image.

![Vertical Ellipsis Menu]

When you view your report or chart at full screen, a hamburger menu also displays, as shown in the following image. From this menu, you can exit full screen, save changes, or restore the dashboard.

![Hamburger Menu]

Interactive content that you create in TIBCO WebFOCUS, such as reports and charts, are saved as procedures. You can view the code that is stored in the procedure from within InfoAssist, or the WebFOCUS Text Editor. When you view the code for interactive content, you will be able to see which style the procedure uses, with the ARVERSION setting. Interactive content using the Legacy Style is ARVERSION=1, while the Designer style is ARVERSION=2.
By default, all new content that you create in InfoAssist uses the Designer style, ARVERSION=2. If you edit an existing item that uses the Legacy style, that style will remain unless you change the ARVERSION to ARVERSION=2. This would reset the content to display in Designer style.

You can also password protect your interactive content to restrict users from viewing it unless they enter a password. Data is encrypted using the 256-bit Advanced Encryption Standard (AES) specification, and the password is used as the key for decrypting and encrypting the data. Therefore, the password is not stored in the interactive content, and you do not need a connection to go back to the server for password verification.

The HTML page, enabled with In-Document Analytic capabilities, contains both the JavaScript and the data for the content so you can interact with the data in a disconnected mode. Internet Explorer detects the JavaScript and issues a warning. If you look at the Internet Explorer warning, it mentions explicitly the detection of interactive content, which is the JavaScript. The same warning appears when pop-ups are blocked in the browser.

Because all post-retrieval processing is performed in the memory of the web browser, interactive content that has In-Document Analytics enabled has a processing limit of approximately 5,000 records or 100 pages of output. Using the cache option, you can send only the first page of content output to the browser and retrieve subsequent pages from a temporary cache on the TIBCO Reporting Server. The server also becomes the resource for performing all calculations, sorting, and filtering when caching is enabled. Since caching uses on-demand paging functionality, WebFOCUS Viewer is not supported.

Content with the cache option in the clustered server environment, using Cluster Manager, will maintain the connection with the TIBCO WebFOCUS® Reporting Server on which the temporary cache is created. This enables the retrieval of subsequent pages from the browser, while it is in the same browser session.

**Note:** When working in CACHE OFF mode, in AHTML (or In-Document Analytics) format, you can export to CSV (comma-separated values) format at run time. The file is automatically sent to the Downloads folder, and applies to all browsers.

The caching feature uses a POST instead of a GET in an HTTP request.
You can save interactive content from your web browser to another location, such as your repository or an FTP server. You can also send interactive content by email or by using a distribution list. This sends the interactive report, chart, or dashboard as an email attachment, distributing it to one or more people through email, as an HTML attachment. If you are sending an interactive dashboard that contains one or more reports or charts, you can burst the distribution by defining parameters in ReportCaster, which sends relevant sections of the dashboard and saves each section as a separate file. Whichever way you choose to send your interactive content, you must keep in mind how it will be viewed.

For example, when you send a report as an HTML attachment to email, many client email programs on a mobile device can block the JavaScript in the attachment. A third-party tool, such as the TIBCO WebFOCUS® Mobile App for a mobile device, may be used to correctly view the attachment.

When you create interactive documents that contain more than one report or chart, you can also share the document by setting up a burst distribution by defining parameters in ReportCaster. This functionality distributes relevant sections of the dashboard to individual users you specify, and saves each section to a separate file.

If you try to view an interactive report in a web browser, and JavaScript is blocked or disabled on your web browser, you will receive a message reminding you that JavaScript must be enabled on the browser. If you are using a mobile device, the message directs you to use the WebFOCUS Mobile App. If the app is not installed, you can download it from the App Store® for iOS devices or from the Google Play™ store for Android™ devices. In the message, App Store and Google Play store are hyperlinks to the WebFOCUS Mobile app.

The message is displayed on the Desktop or on a supported mobile device when JavaScript is disabled in a web browser used to open an online or offline report. It is also displayed on the Preview pane or window of an application used to preview the content of an offline report.
Enabling In-Document Analytics in InfoAssist

In InfoAssist, you can create content, including reports, charts, and dashboards that leverage the interactive capabilities of In-Document Analytics. Enabling this option provides your users with the ability to interact with and modify the content you created for their own analysis.

**Note:** If you use the Designer style, you will only be able to select the AHTML output format. APDF can only be used with the Legacy style.

**Procedure: How to Enable In-Document Analytics in InfoAssist**

1. Open InfoAssist.
2. Create a report, chart, or dashboard.
Developing Interactive Content

3. On the **Home** tab, in the **Format** group, click **HTML Analytic Document** or **PDF Analytic Document**.

   **Note**: Your administrator must enable these output options in the Administration Console.

4. Run your content.

Your report, chart, or dashboard now displays with interactive menu options that can be used for end-user analysis. You can change the style of your interactive content from the Procedure Settings dialog box. The two styles available to you are Legacy or Designer Style. Some of the options available from the interactive menu options may change between the styles.

Developing Interactive Content

This topic describes how you can develop and enhance interactive content that has enabled In-Document Analytics capabilities.

Interactive Reports

As a developer, you can create effective, useful reports and share them easily using In-Document Analytics for offline analysis.

A report is used to show the intersections of data between rows and columns. Once created, you can style your report, add headers, and footers, and apply other formatting options to make your data stand out. When you have completed creating your report, you enable In-Document Analytics. Using this format, your users can interact with data, using analysis options similar to those found in an Excel workbook. Since no connection to a server is required to view the data or use the analysis options (for example, filtering, charting, and sorting), you can save and use the report anywhere.

**Note**: All reports display with HFREEZE ON, a feature that freezes the headings in your report, in In-Document Analytics.

Configuring Analytic Document Options for Reports

You can configure analytic document options for interactive reports, including menu options, based on user role, through the Analytic Document Options dialog box.

You can access the dialog box on the Format tab, in the Features group, by clicking the button. The button is available when **HTML Analytic Document** or **PDF Analytic Document** is selected as the output type.

The Analytic Document Options dialog box contains the following tabs:

- General
Menu Options
Colors
Advanced

General Tab
Use the General tab to set common properties specific to interactive, analytic reports.

The General tab contains the following options:

Display. This area contains options to set the window to cascade or tabs, and options to freeze columns.

Window. Select the window setting. The options are Cascade and Tabs.

Freeze Columns. Select the columns you would like to freeze. You can also select None.

Page Options. This area contains options to set the number of records per page, enable the display of page information, edit the alignment, and set the location of the page information.

Records Per Page. Select or type the number of records that you would like to display per page. The default value is 57.

Display Page Information. Select this option to display page navigation information. Clear this option to disable the display of page navigation information.

Alignment. Click the appropriate button to set the alignment of the page navigation information. Options are Left, Center, and Right.

Location. Select the location for the page navigation information. The options are Top Row and Bottom Row.

Chart Options. This area contains options that pertain to charts when the output format is PDF Analytic Document.

Note: Chart Options do not display when the output format is HTML Analytic Document.

Legend (check box). Select this option to collapse the legend if necessary. Clear this option if you do not want the legend to collapse.

Legend (menu). Select the location for the legend. The choices are:

- Bottom Left
- Bottom Center
Menu Options Tab

Use the Menu Options tab to select a user type and which options to display in the menu.

The Menu Options tab contains the following options:

- **User Type.** The options are Power, Analyst, Basic, and Custom.
  - **Power.** This is the default user type. It enables all functionality.
  - **Analyst.** This user type has the following functionality: Show Records, Freeze, Hide/Unhide, Export, Sorting, Pivot, Filter, Calculations, Chart, Visualize, Restore Original, Save Changes, and Accordion.
  - **Basic.** This user type has the following functionality: Show Records, Freeze, Hide/Unhide, Sorting, Filter, Calculations, Visualize, and Restore Original.
  - **Custom.** If you select a combination of options that does not match one of the existing user types (Power, Analyst, Basic), the User level name that appears in the User Type field is Custom. This is not a default user type or a selectable user type. It indicates that options for this user do not match any of the existing user types.

The options available according to user type include the following:

- **Show Records.** Shows all records or specific numbers of records.
- **Freeze.** Freezes and unfreezes columns.
- **Hide/Unhide.** Hides and shows columns.
- **Export.** Exports data to HTML, CSV, Excel, or PDF if cache is enabled, or to HTML, CSV, or XML (Excel) if cache is disabled.
- **Sorting.** Sorts data in ascending or descending order.
- **Pivot.** Lists the fields available to create a Pivot table.
- **Window Type.** Shows windows as cascade or tabs.
- **Send as Email.** Enables you to save the current changes and send a report as email.
- **Print.** Prints all records or filtered-only records.
- **Advanced Tools.** Accesses the Chart/Rollup, Pivot, and Grid Tools.
- **Filter.** Opens the Filter Selection dialog box.
- **Calculations.** Performs the following calculations: Sum, Avg, Min, Max, Count, Distinct, % of Total.

- **Chart.** Converts a report to a pie, line, bar, or scatter chart.

- **Visualize.** Adds data visualization bars to a report.

- **Rollup.** Performs rollup on data.

- **Comments.** Adds comments.

- **Restore Original.** Restores the In-Document Analytics enabled report to the default state specified in the report procedure.

- **Save Changes.** Saves the current changes.

- **Accordion.** Produces accordion reports.

- **Grid Tool.** Opens the Grid Tool dialog box.

### Colors Tab

Use the Colors tab to select colors for various objects on the report.

The Colors tab contains the following options:

- **Page.** This area contains options to set the colors for the font and background of the page text.

- **Font.** Opens the Color dialog box, where you can select the font color.

- **Background.** Opens the Color dialog box, where you can select the background color for the page text.

- **Row Selection.** This area contains options to set the colors that appear when you point to or select a row on the report.

- **Hover.** Opens the Color dialog box, where you can select the color that the row becomes when you hold the mouse over the row.

- **Selected.** Opens the Color dialog box, where you can select the highlight color that the row becomes when you use the highlight option.

- **Visual.** This area contains options to set the colors for the data visualization bars.

- **Positive.** Opens the Color dialog box, where you can select the color for a data visualization bar that represents a positive number.
Negative. Opens the Color dialog box, where you can select the color for a data visualization bar that represents a negative number.

Calculations. This area contains options to set the colors for values in a calculation.

Font. Opens the Color dialog box, where you can select the font color for the calculation.

Background. Opens the Color dialog box, where you can select the background color for the calculation.

Menu. This area contains options to change the color of the menu.

Normal

Font. Opens the Color dialog box, where you can select the color for the text of the options on the column menus.

Background. Opens the Color dialog box, where you can select the background color for the column menus.

Border. Opens the Color dialog box, where you can select the color for the border of the column menus.

Hover

Font. Opens the Color dialog box, where you can select the color for the text of the options on the column menus when you point to them.

Background. Opens the Color dialog box, where you can select the background color that appears behind options on the column menus when you point to them.

Advanced Tab

Note: Cache is enabled when you select as the output type, and click Pages On Demand on the Format tab, in the Navigation group.

The Advanced tab contains the following options:

Cache. Enables a report to cache the data in a binary file and return the data to the output window in pre-set increments.

Rows Retrieved. Select the number of rows retrieved in the output. The default value is 100.

Security. This area allows you to set a password to access the report and enable expiration by date or by days. This option is only available for the reports that have enabled an In-Document Analytics report output.
**Note:** When setting security options for interactive reports, be aware that security options can be set for each individual component on the canvas, but only one password can be set for the entire document.

**Using Paging to Navigate Pages in a Report**

You can navigate between pages in an interactive report or grid (AHTML) using the page navigation options in the pagination bar. These options make it easy to view large amounts of data quickly, without scrolling. For stand-alone items, such as a single report that contains a large amount of data, the pagination bar appears at the bottom of the container. When you are creating a page that contains multiple reports, the pagination bar appears at the bottom of the page container.

An example of the pagination bar for a single interactive report are shown below.
The pagination bar contains two components: a record count that dynamically changes as you move between pages and a set of controls that you can use to advance pages, return to pages, or enter specific page numbers. A pagination bar example is shown in the following image.

The following table identifies the page controls that you can use to navigate between pages of an interactive report.

<table>
<thead>
<tr>
<th>Button</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Control</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>&lt;</td>
<td>Takes you to the first page of the report.</td>
</tr>
<tr>
<td>&lt;</td>
<td>Takes you to a previous page of a report.</td>
</tr>
<tr>
<td>1</td>
<td>Indicates the current page number of the report that you are viewing. You can click this number, and enter a new number to jump to a different page of the report.</td>
</tr>
<tr>
<td>›</td>
<td>Takes you to the next page in the report.</td>
</tr>
<tr>
<td>››</td>
<td>Takes you to the last page of the report.</td>
</tr>
</tbody>
</table>

Controls in the pagination bar are contextual and become available as you move between the pages of the report. If you create or receive a report that contains filters, the record information and pagination reflect the filtered report, and may not reflect the total number of records in the report. By default, each page displays 57 records, and right justifies the paging controls. This pagination bar automatically adjusts to the size of the container, and changes the display of information, when you minimize the report. An example of this behavior is shown in the following image.

![Report_Paging](image)

Page navigation options also display when users create new grid components offline. Specifically, a new report component that is saved to the Analysis Panel displays with the same page navigation options, as shown in the following image.
If you are creating interactive reports using InfoAssist, you can customize the display of the pagination bar, including the number of records shown, justification of page detail, and more. On the Format tab, in the Features group, click Analytic Document Options.

Adding a Comment to an In-Document Analytics Report

You can add comments to the individual cells within an interactive report that use In-Document Analytics capabilities, to include information explaining your data, where it appears. For example, if you include data for Gross Profit, and you would like to include a comment about the decrease over the course of a quarter or year, you could add a comment to the Gross Profit cell that you want to call out. Recipients of this interactive report can view, and reply to your comments. Commenting is only available from the Cell menu on any given cell when creating a report.
You can insert a comment by clicking a cell in a report, as shown in the following image.

In the Comments dialog box, you can enter a name for the comment, as well as comment text itself. An example of a comment is shown in the following image.
Click **Save** to save the comment. The comment is saved, as shown in the following image.

![Comments dialog box](image)

If you exit the Comments dialog box without saving, your comment will not be preserved.
You can add multiple comments in a session, or interactively add comments with other users in your enterprise, as shown in the following image.

When you close the Comments dialog box, a bubble icon displays, indicating that there is a comment associated with the cell on which you commented, as shown in the following image.
When you hover over this bubble, the most recent comment displays. Clicking `<strong>View All</strong>` opens the Comments dialog box, where you can view the history of comments related to this cell value, as shown in the following image.

**Comments**

**Add Comment**

Name: Anonymous

Comment:

**Comments (2)**

Compare Gross Profit Values from Q2 to Q3
10/18/2019 3:00:41 PM

Linda, please pull our Q2 values for our Gross Profits for Chargers

Gross Profit Decrease Alert
10/18/2019 2:48:20 PM

Bob, please take a look at the Gross Profit for this area. It appears to have declined rapidly in the 3rd quarter.

**Interactive Charts**

Charts are graphical representations of data, showing trends, tendencies, and even possible predictions. A chart often conveys meaning more clearly and effectively than data displayed in tabular form. Charts show summaries on a higher level, giving you a better view of your most important data.

A chart enables you to visually communicate quantitative information. Using a chart, you can give data a shape and form, and reveal patterns and relationships among many data values. A chart can highlight anomalies that require further investigation.

It is important that you choose a chart that is appropriate for your data. InfoAssist provides a complete chart library of both basic and advanced charts. You can choose from a wide variety of charts to best represent the data that you want to display.
In InfoAssist with In-Document Analytics enabled, you can create an interactive chart, change the type of chart, and run the chart to take advantage of the tools that are available to you for online or offline analysis.

Interactive charts support the use of HTML5 extensions, which are user-supplied, custom chart types that access resources external to WebFOCUS. For details on the structure of an extension and the steps for creating your own, as well as the process for adding it to the chart library, see the Adding Your Own Chart Types to the Chart Library chapter in the Creating HTML5 Charts With TIBCO WebFOCUS® Language manual.

If you are working with an AHTML chart that does not have the new chart properties (specifically, non-bucket AHTML charts), you will encounter problems if you change the chart type to one of the following chart types using the Advanced Chart tool at run time:

- Tag Cloud
- Funnel
- Pyramid
- Waterfall
- Histogram
- Radar Line
- Radar Area
- 3D Area

By default, these chart types are hidden in the Advanced Chart tool when the original chart is an AHTML bucket chart. These chart types are available under the following circumstances:

- When the original chart is a non-bucket chart
- When the chart is created from a tabular report

**Interactive Dashboards**

You can create an interactive dashboard by inserting multiple content types, such as reports, charts, images, and text, into a document. It will run any report or chart using the In-Document Analytics output format, even if the report or chart itself is not interactive.

You can also insert interactive prompts into a document to act as filters for the reports and charts on the dashboard, as well as cascading (chaining) prompts to populate them based on the selections from the previous prompts.
The output format of the interactive dashboard must be HTML Analytic Document or PDF Analytic Document in order to add interactive dashboard prompts.

**Analytic Document Prompts**

The Analytic Document prompts group contains buttons that insert components in your dashboard. This group is only visible when the output format of the dashboard is set to HTML Analytic Document or PDF Analytic Document. You can access these options from the Insert tab, in the Analytic Document Prompts group.

The following are the types of prompts that you can use to apply filters to a dashboard:

- **Drop Down.** Inserts a drop-down prompt placeholder in the upper-left corner of the canvas.
- **List.** Inserts a list prompt placeholder in the upper-left corner of the canvas.
- **Checkbox.** Inserts a check box prompt placeholder in the upper-left corner of the canvas.
- **Radio Button.** Inserts a radio button prompt placeholder in the upper-left corner of the canvas.
- **Text.** Inserts a text area prompt placeholder in the upper-left corner of the canvas.

**Note:** The display of values populated in the prompts is dependent on the data setting. For example, if sample data is turned on, then the prompts will show sample data, such as:

WF_RETAIL1
WF_RETAIL2
WF_RETAIL3

**Target Reports**

When you bind a field to an Analytic Document prompt, the default target report is the report from which you dragged the field. You can add or remove target reports from the prompt through the Analytic Document Options dialog box.

A report must meet one of the following requirements to be a target report:

- The report must contain a field with the same name as the source field (actual field name or AS name).
- The Master File of the report must contain a field with the same name as the source field.

If a report is eligible to be a target report because the field has the same user-supplied title and the title is changed, the report is automatically removed as a target.
**Procedure:** How to Add an Analytic Document Prompt to a Dashboard

This procedure describes how to begin to create a dashboard by creating one report and binding a single prompt to one of the fields of the report.

With InfoAssist in Document mode:

1. On the status bar, in the Output Types menu, accept the default output type, or click *PDF Analytic Document*.
2. On the *Insert* tab, in the *Reports* group, click *Report*.
   A placeholder appears on the canvas.
3. Drag fields onto the canvas, or into the Query pane, to create the report and start building the dashboard.
4. On the *Insert* tab, in the *Analytic Document Prompts* group, select a prompt type, such as Drop Down, List, Checkbox, Radio Button, or Text.
   The prompt type you selected now appears in the upper-left corner of the canvas. If the report is located in the upper-left corner of the canvas, you will have to drag the prompt off the report.
5. Select the report and bind one of its data source fields to the prompt in one of the following ways:
   - **Query pane**: Select the report. From the Query pane, drag the field that you want to bind onto the prompt.
   - **Report on the canvas**: Click the report on the canvas. You can now edit it. Highlight the column that contains the data that you want and drag it onto the prompt.
   Once you have bound the field to the prompt, the values of the field appear in the prompt.

   **Note**: Once a prompt is added to the canvas, the document is locked in an In-Document Analytics output format, and you cannot change the format. To switch to a non-interactive output format, you must remove all prompts.

**Using Multiple Reports as Targets and Sources**

You can add multiple reports and charts to an interactive dashboard. Each report can have multiple prompts associated with it.
**Procedure: How to Build a Dashboard With Multiple Reports**

The following procedure describes how to set up Analytic Document Prompts for two reports on a dashboard. In the example that is used, the first report contains information about the categories of electronics products sold in various regions. The Product,Category field will be bound to a group of radio buttons. Each radio button will represent a particular product category of electronics. When you select a radio button for a product category, for example, Accessories, the report will be filtered by your selection.

The second report contains information about the gender and geographic location of electronics consumers. The Gender field will be bound to a drop-down list. The list will display the values, F (female) and M (male). When you select a gender from the drop-down list, the report will be filtered by your selection.

1. Open InfoAssist in Document mode using the wf_retail_lite Master File.
2. Create an interactive dashboard by adding two reports with the following components, respectively:
   - **Report 1:**
     - Product,Category
     - Store,Business,Region
     - Discount
     - Gross Profit
   - **Report 2:**
     - Gender
     - Customer,Continent
     - Product,Category
3. On the Insert tab, in the group, add the following prompts to the dashboard, positioning them relative to each respective report.
   - **Radio Button:** This prompt will be used for Report1.
   - **Drop Down:** This prompt will be used for Report2.
4. Right-click the radio button prompt for which you want to bind a field to and click Properties.
   - The Prompts list displays the two prompts (for example, radiobutton_1 and combobox_2) that were added to the dashboard in Step 3.
5. From the Report drop-down menu, select the report that contains the field to which you want to bind a prompt.

In this example, the radio button list (radiobutton_1) has been selected as the prompt for the region report (Report 1), as shown in the following image.

The next step describes how to bind the Product,Category field from the region report to the radio button list to filter that report.

6. From the Field drop-down menu, select the field to which you want to bind the prompt.

In this example, the Product,Category field has been selected for the radio button list (radiobutton_1), as shown in the following image.

**Note:** You can optionally specify an ascending or descending sort order for the current scenario.

7. Click OK.

The prompt is now bound to the field on the dashboard.
In the following image, the radio button list is bound to the Product, Category field. It displays all product categories by which you can filter the report.

8. Right-click the Drop Down prompt for which you want to bind a field and click Properties.

The Analytic Document Prompt Properties dialog box opens again.

Notice that combobox_2, the prompt selected on the dashboard, is selected in the Prompts list.

9. From the Report drop-down menu, select the report (Report2) that contains the field to which you want to bind a prompt.

The following steps describe how to bind the Gender field in the gender report (Report2) to the drop-down list prompt.
The next step describes how to bind the Gender field from the gender report to the drop-down list to filter that report.

10. From the Field drop-down menu, select the field (Gender) to which you want to bind the prompt.

Once the Gender field has been selected, Report2 (gender report) appears in the Targets list and Report1 (region report) appears in the Candidate Reports list.

**Note:** To move a report from the Candidate Reports list box to the Targets list box, select it and click the *Add to List* arrow. To remove a report from the Targets list box, select it and click the *Remove from List* arrow. You can select multiple reports by holding down the Ctrl key and clicking each one.

11. Click OK.
The prompt is now bound to the Gender field on the dashboard. You can now filter the gender report by female or male, as shown in the following image.
Procedure: How to Change the Field

You can change the field to which the prompt is bound.

1. Create an interactive dashboard in Document mode, or open an existing dashboard, and bind a prompt to a field.

2. Right-click the prompt that you want to configure, and click Properties.

   The Analytic Document Prompt Properties dialog box opens.

3. From the Field menu, select a different field.

   A warning message alerts you that changing the source field for the prompt will remove the existing prompt and any dependent (child) prompts from the cascades.

4. Click OK to close the warning.

5. Click OK to close the Analytic Document Prompt Properties dialog box.

   The prompt is updated with the new source field.

Procedure: How to Change the Filter Condition

1. Create an interactive dashboard in Document mode, or open an existing dashboard, and bind a prompt to a field.
2. Right-click the prompt that you want to work with, and from the shortcut menu, select Properties.

   The Analytic Document Prompt Properties dialog box opens.

3. From the Condition drop-down menu, select the filter condition for the prompt. The options are Equal to, Not equal to, Less than, Less than or equal to, Greater than, and Greater than or equal to.

4. Click OK.

   The filter condition is applied to the prompt.

Procedure: How to Add Multiple Prompts to a Dashboard

1. Create an interactive dashboard in Document mode, or open an existing dashboard containing at least one report, and add at least two prompts.

2. Bind the fields to prompts that you have added.

Procedure: How to Cascade Prompts

When you have more than one prompt on the canvas, you can cascade prompts to populate them based on the selections of the previous prompts. Cascading prompts have a parent-child relationship, in which the parent filters the available options of the child.

A prompt can be the parent of more than one other prompt, but cannot be a child of more than one prompt.

1. Create an interactive dashboard in Document mode, or open an existing dashboard, and bind at least two prompts to fields.

2. Right-click the prompt that you want to configure, and click Properties.

   The Analytic Document Prompt Properties dialog box opens.

3. Click Cascades.

   By default, a cascade named Cascade1 appears in the Cascades section of the Analytic Document Prompt Properties dialog box.

   You can click the Create a new cascade button to create a new cascade.

   You can click the Delete selected cascade button to delete the selected cascade.

4. Select the cascade to which you want to add prompts.

5. From the Available Prompts list box, select the prompt that you want to add.

6. Click the Add to List arrow to move the selected prompt to the Selected Prompts list box.
7. Add any additional prompts you want to be part of the cascade by repeating steps 5 and 6.

By default, the hierarchy of the prompts is determined by the order in which they are added to the Selected Prompts list. The cascade of the prompts is from top to bottom. The prompts that come first in the Selected Prompts list are the parents of the lower prompts.

8. You can change the hierarchy of the prompts by selecting a prompt in the Selected Prompt list box and clicking the Move Up and Move Down arrows.

9. Click OK.

The cascade is created.

10. Run the report.

   **Note:** If you set up more than one cascade, the cascade that you interact with last is the one that filters the report.

**Working With Interactive Content**

Using the power and flexibility of In-Document Analytics, you can work with interactive content online or offline (disconnected from any servers) in a unique browser session within your environment. Reports, charts, and dashboards, which are comprised of one or more interactive reports or charts, can be distributed or emailed to you, or accessed from the WebFOCUS start page. You can interact with these items in an environment that supports discovery and exploration, giving you customized content, delivered right to your desktop or mobile device.

Interactive content is created and distributed in your environment by developers. When this content is saved by the developer with an analytic output format, you can leverage the functionality of In-Document Analytics by creating new reports and charts that show aspects of your data that you otherwise might not notice. For example, you can access interactive content and add reports and charts to maximize your analysis. You can drill through to other reports and charts or utilize the Auto Drill functionality to navigate the hierarchy of your data. You can change the chart type or access other formatting options that are available to you. This gives you the flexibility of analyzing your data in different ways, including the ability to export data right from the interactive component to continue your analysis using tools such as Microsoft Excel and HTML.
Developers share these interactive reports, charts, and dashboards with users for the purpose of analyzing and reviewing data and informational trends. For example, you may receive a report or chart that shows a pattern in your data. You can dive deeper into your analysis by creating new reports or charts from this content, enabling you to view different scenarios as you navigate your interactive content.

The interactivity of the content is supported by standard Graphical User Interface (GUI) options that enable you to perform tasks quickly. For example, the Ellipsis menu offers options for creating new items, as well as printing and exporting. The hamburger menu allows you to return from maximized view. The following tools will enable you to effectively navigate In-Document Analytics interactive content.

You can use the options on the vertical Ellipsis menu to perform some of the basic commands, including Export, as well as other options shown in the following image.

You can use the following options on the Ellipsis menu to alter the component:

**New.** Creates a new report or chart that is based on the fields that you had selected for the original artifact. If your component is a report, a new report will be created. Similarly, if your component is a chart, a new chart will be added.

**Edit.** Edits the contents of the existing report or chart. Brings up the Chart tool where you can make alternate selections.

**Duplicate.** Creates a copy of the existing component, which you can use as a template for creating a contrasting artifact. This item is placed in the Analysis panel where it can be viewed and modified.
Export. Exports the underlying data or image for the current component. For reports, you can export in Excel, CSV (comma delimited), and HTML format. For charts, you can export to Excel, CSV (comma delimited), and PNG (image) format.

Print. Prints your report or chart through your browser.

Save Changes. Saves a copy of your chart output, in its current state, to the Downloads folder on your machine. The default name of the output file is ARhtml.html, and includes a Coordinated Universal Time (UTC) date/time stamp.

Restore Original. Returns your report or chart back to its original status.

When you create a new report or chart from an interactive component, it displays in the Analysis panel, where you can interact separately with the new component. This panel appears to the right of the screen. The Analysis panel is shown in the following image.

Using the Analysis panel, you can review unique scenarios as you build them, giving you a broader view of your data by allowing you to compare different outcomes. You can also change chart types and lock and unlock results. This is used in cases where you want to avoid manipulating the result in any way. You can duplicate any of the artifacts in the Analysis panel by clicking Duplicate on the Ellipsis menu. This allows you to perform comparative analyses of a specific component by copying an existing artifact. You can also edit artifacts in the Analysis panel by clicking Edit on the Ellipsis menu. This opens the Chart tool, where you can modify your selections for the current component.
You can also change the chart type for the original chart or on any new charts that you create, as shown in the following image.

You can develop something progressive for your enterprise using these tools and functionality.

For primary components, as well as those in the Analysis panel, you can maximize your content by clicking the maximize button, as shown in the following image.
When your interface is maximized, you can return to the original view or exit full screen by clicking the hamburger menu, as shown in the following image.

![Hamburger menu](image)

When your interface is not in maximized mode (default), the toolbar has a maximize button, as well as a button to quickly change the chart type, which applies only to a chart component. There is also a vertical Ellipsis menu that allows you to navigate to additional options. These options are shown in the following image.

![Toolbar options](image)

You can also use sort column indicators when you want to sort data in a report component. You can sort a column in ascending and descending order. When you sort a column, a corresponding indicator appears within the column title, as shown in the following image.

![Sort indicators](image)
In this example, the Gross Profit data is sorted in ascending order, from lowest to highest. If you click the arrow again, the column sorts in descending order, from highest to lowest. If you click the arrow again, it returns to the default arrow that points in both directions, indicating that no sort has been applied, as shown in the following image.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Cost of Goods</th>
<th>Gross Profit</th>
<th>Revenue</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>$89,753,888.00</td>
<td>$39,854,440.53</td>
<td>$129,608,336.53</td>
<td>511,667</td>
</tr>
<tr>
<td>Camcorder</td>
<td>$104,056,857.00</td>
<td>$49,596,845.24</td>
<td>$154,465,702.24</td>
<td>455,244</td>
</tr>
<tr>
<td>Computers</td>
<td>$69,807,664.00</td>
<td>$33,508,818.12</td>
<td>$103,315,482.12</td>
<td>351,777</td>
</tr>
<tr>
<td>Media Player</td>
<td>$190,240,481.00</td>
<td>$55,382,578.36</td>
<td>$246,073,059.36</td>
<td>771,934</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>$205,113,863.00</td>
<td>$86,101,070.52</td>
<td>$291,294,933.52</td>
<td>1,114,332</td>
</tr>
<tr>
<td>Televisions</td>
<td>$81,551,109.00</td>
<td>$16,830,023.81</td>
<td>$78,381,132.61</td>
<td>105,189</td>
</tr>
<tr>
<td>Video Production</td>
<td>$40,105,657.00</td>
<td>$17,947,619.62</td>
<td>$58,053,276.62</td>
<td>199,749</td>
</tr>
</tbody>
</table>

7 of 7 records, Page 1 of 1
You can hide and show columns at run time. Once a column is hidden by clicking *Hide column* in the menu on the column level, the *Show columns* option displays in the report toolbar, allowing you to unhide it, as shown in the following images.

**Note:** If the column is hidden with the use of the NOPRINT request, the *Show Columns* menu does not appear. You must hide another column at run time to display the menu, then use it to unhide both hidden and NOPRINT columns.
When working with charts, you can change the chart type to see your data differently. For reports, you can use the Column menu to create Chart Rollups or Pivot tables and you can use the Cell menu to highlight items. You can use these options on the initial report, chart, or dashboard that is distributed to you, or from any of the new components in the Analysis panel. If your report developer has enabled the following features, you can also navigate different levels of your data (for example, a hierarchy or another report) using Multi Drill, Auto Drill or Auto Linking. These links appear as blue, underlined hyperlinks when you hover over an area of a chart or select an option from a list, as in the case of a report. These links can be clicked as you are navigating the hierarchy of your data or drilling through to a different item in your interactive content.

The Multi Drill functionality enables the interactive content developer to create multiple drill down links on a data field in a report or chart. This is useful when custom links are beneficial, such as a link to a website, other visualizations, or additional reports. If your interactive content developer has enabled it, Auto Drill lets you navigate through different levels within the dimension hierarchy of your data source. This allows you to review the underlying data for a particular area, and move through the structure of your data source based on your information needs. When working with interactive content, the basic functionality of Auto Drill produces different results. For example, you can use Auto Drill functionality in interactive content to drill up or down within the hierarchies of your data for additional analysis. However, because the interactive content refreshes to display a new report or chart when you drill up or down, any content you create from the Chart Rollup menu will disappear. This also applies to any new content that you create using the New option on the Ellipsis menu in an existing report or chart.

If enabled, Auto Linking makes it easy to connect reports and charts in your development environment, expanding the reporting capabilities of your organization. Using Auto Linking, you can dynamically link HTML reports, interactive reports, and HTML5 charts with a single chart of any format, based on their common sort (BY) fields and parameters referenced in any filters.

When you create new reports and charts from interactive content in a browser session, each new piece of content will be given a unique, sequential identification number that enables you to view and manage what you create. This identification number that displays at the top left of the new report or chart, is incremental, and automatically assigned. However, it may not be consecutive.

In addition, when you are adding new information, for example, multiple reports and charts, into the Analysis panel, you cannot save each instance of your analysis as an end-user. Each session is dedicated to the current analysis only. If any of your artifacts contain multi drill or auto drill links, for example, you can interact with these at run time.
Procedure: How to Create a New Report or Chart (as an end user)

1. Click the link or distributed attachment to open the interactive content. Optionally, open the interactive content from the WebFOCUS start page. The interactive content displays.

2. Click the Ellipsis menu and then click New. The Chart Tool opens, as shown in the following image.

![Chart Tool Image]

3. From the left pane, select the data values that you want to include in the new report by placing them in the relevant field container.

4. Click the check mark, \( \checkmark \), to close the report or chart to accept the selections and add it to the Analysis panel. Your new component now appears in the Analysis panel, as shown in the following image.

![Analysis Panel Image]

Note: This works the same way for new reports, with a label of Report1, Report2, etc.
**Procedure:** How to Export the Underlying Data (or Image) for a Report or Chart

1. Click the link or distributed attachment to open the interactive content. Optionally, open the interactive content from the WebFOCUS start page. The interactive content displays.
2. On the Ellipsis menu, click *Export*, as shown in the following image.

3. From the left pane, select an output type for the export, as shown in the following image.

4. Click *Export* to export the data from the component.
5. In your local drive, open the Downloads folder to locate the downloaded file.
6. Open the file in the relevant application (for example, Microsoft Excel or a browser).

**Interactive Content Usage Considerations**

As you develop or interact with content that uses In-Document Analytics, you should reference the following usage considerations.

The following notes apply to browser support.

- Active PDF (APDF) is an In-Document Analytics Legacy style output format. It is not supported in Microsoft Edge®, since APDF requires the Adobe Reader plug-in that supports Flash Player.
ActiveX, a technology from Microsoft, is not supported in Microsoft Edge. Any In-Document Analytics feature that requires the use of ActiveX controls is therefore not available in Microsoft Edge. These include the following, which are accessible in other browsers at run time, using the column drop-down menu on an interactive report:

- Send as E-mail (supported only in Internet Explorer)
- Save Changes (supported only in Internet Explorer)
- Export to XML (Excel) when active cache is disabled

If you are using a Firefox® browser and you export an AHTML report to Excel, the file extension that displays is incorrect (for example, .xls.xls). You can override this default value using the settings of the browser. Specifically, if you click the Always ask me where to save files radio button, which is located under Options, you will be prompted, upon download, to either open or save the file. You can then provide a name and extension for the file.

The following notes apply to interactive reports.

- At run time, when fields are added to, or removed from, a report that includes drilldowns that pass parameter values, the drilldowns are disabled. This is because the parameter values that are passed may no longer apply.

- If multiple report components with different security passwords are included in an AHTML document, the password for the last report component is used.

- Interactive reports employ left and right cell padding, by default. This enables you to view the report consistently, without the concatenation of any values or spacing issues related to the cell padding. In cases where these settings are not defined in the StyleSheet, the default settings for the left and right cell padding are used.

- By default, the name specified in the Master File displays to identify a column in an ACROSS group on a tabular report that has only one display field. With the following SET command, you can display the title specified in the Master File, instead of the name, to identify the column:

  \[ \text{SET ACRSVRBTITL} = \text{ON} \]

  It derives the title from the TITLE attribute in the Master File (for example, TITLE = 'Product ID'). It derives the name from the FIELDNAME or FIELD attribute (for example, FIELD = PCD).
The Sort Ascending, Sort Descending, and Restore Original options are accessible on a column drop-down menu on a report. When cache is enabled on the report, the Restore Original option does not return the report output to its original state after sorting the data. Instead, you receive the following message: Warning: Original sort could not be determined.

When using interactive content in Cache Mode, filtering may not work properly if the content contains a text field (for example, TX50). As a workaround, consider using an alphanumeric field (for example, A50).

The following notes apply to interactive charts.

When working with filters in an AHTML chart, certain filtering options do not display if you have only one column on which to filter and it has a decimal format which includes a decimal point. In this case, the Filter Chart and Exclude from Chart filtering options are not available in the chart tooltip at run time.

As of Release 8.2 Version 02, the new chart attribute syntax has been applied to the following chart types: Dual Bar and Line, Tag Cloud, Streamgraph, Mekko, Funnel, and Pyramid. This process adds additional relevant field containers for these chart types, which can be used to specify fields in a specific area of the chart. For example, Horizontal Axis, Color, and Tooltip are field containers that are part of the new chart attribute syntax.

In InfoAssist, specific field containers display for each chart type. For more information on the underlying syntax used to create each chart type, see Creating HTML5 Charts With WebFOCUS Language.

When you run a chart, the output displays a chart toolbar with a number of options that you can select. These options are represented by icons. The chart toolbar provides an Aggregation icon that allows you to select the aggregation method (that is, the type of calculation, such as Sum or Avg) that will be used on the selected data in the chart.

If you run a chart that does not have a measure field to which an aggregation method can be applied, the Aggregation icon:

- Appears on the chart toolbar, but cannot be selected.
- Displays None as the aggregation method. None is dimmed on the label. It indicates that there will be no aggregation performed on, or applied to, the selected data in the chart.

Once you run the chart with data that applies to an aggregation method, the Aggregation icon is activated. Its label reflects the aggregation method currently in use (for example, Sum).
The following note applies to exporting from content using In-Document Analytics.

- If you create a report that contains ACROSS sort fields, and you attempt to export the data using the Excel, CSV, and XML(Excel) options, the ACROSS column titles and field values are not included in the exported content. The same is true for the report headings and footings.

The following note applies to tools available from your interactive content.

- The comma inclusion edit option is not implemented in Rollup tables and Pivot tables when cache is enabled.

The following note applies when using the Cache option.

- Date-time format fields are not supported.

The following notes apply when using the Export to Excel functionality.

- When using the Export to Excel option while creating and generating a report with cache enabled, the request will be generated in XLSX format, rather than EXL2K. This applies to the following browsers: Microsoft Edge, Internet Explorer, Firefox, and Chrome.

The export behavior is controlled by the WebFOCUS® Reporting Server. When the export is performed, an Office Open XML document is produced, which you can download and save in the required format (the default is .xlsx).

- When using the Export to XML (Excel) option with cache disabled, the export behavior is controlled by the active JavaScript layer. When the export is performed, a Microsoft Office XML document is produced, which you can download and save in the required format (the default is .xls). This applies to the following browsers: Microsoft Edge, Internet Explorer, Firefox, and Chrome.

The following note applies when using mobile devices.

- The Chrome browser "Force enable zoom" Accessibility setting on Android mobile devices overrides a website request to prevent zooming. If this setting is enabled when executing an AHTML report on an Android mobile device using Chrome, it interferes with active report functionality, such as Freeze Column and manual resizing. The Accessibility setting needs to be disabled for reports to be fully functional.

**Running Content in Full-Screen Mode**

When you run interactive content in maximized (full-screen) mode, there are a number of navigational features that you can use. For example, you can change the position of report and chart components in full-screen mode using drag and drop. To drag and drop, simply click the toolbar of any component and, holding the mouse, drag the object to the desired position.
In this mode, output is responsive and automatically adjusts when the width of the window is wider than its height. This is particularly useful when you have a number of components in view. In addition, full-screen mode displays a taskbar at the bottom of the screen, with an item for each report or chart component. The component currently selected on the screen is highlighted in the taskbar.

When switching from one dashboard tab to another, each page reflects the correct components that are currently available on that page. You can use the page taskbar at the bottom of the screen to review the report and chart components on the page.

You can also hide a component in full-screen mode. This enables you to hide a component from display, particularly in cases where that object is not currently needed or is irrelevant. If you wish to bring a hidden component back into view, you can click the corresponding item in the taskbar, as shown in the following image.

In cases where you have spawned components (for example, items created using the chart, pivot, rollup, or duplicate options) in full-screen mode, they are numbered in the page taskbar that corresponds to the table/chart component. The number is shown in the right corner, and an item is appended to the right of it for the spawned component. The number indicates how many components have been spawned from that component item. When you click an item in the taskbar, the window is split to display the spawned components along with the currently displayed components.
You can also drag and drop a component to the left or right of another component (in landscape mode) or above or below another component when working in portrait mode. You can reposition a table/chart component using the left or right arrows in the toolbar. This makes it easy to move just one component to the left or right in a single motion.

Another feature of full-screen mode is the ability to display report and chart components side by side while in full-screen mode. You can click on a component button while holding the Ctrl key to display multiple components at a time on the screen. The screen splits evenly to fit all selected component. If you click an item in the taskbar, the corresponding component is displayed in maximized (full-screen) mode and will occupy the full screen, as shown in the following image.

Using the Options Menu to Perform Common Tasks

Each interactive report or chart that uses In-Document Analytics contains an Options menu that you can use to modify the component further for advanced data analysis. In addition to minimizing and maximizing the component, you can also change the type of chart used, and access other options, such as Edit, Duplicate, and Print.
The following image shows the Options menu, expanded to show the options that are available for an interactive chart component.

The Options menu includes the following:

**New.** Launches a WebFOCUS Designer canvas, where you can place the data into corresponding buckets to create a new component.

**Edit.** Opens the component in a modified WebFOCUS Designer canvas so you can edit it.

**Duplicate.** Creates a copy of the component that you can modify.

**Export.** Exports the data for your report, table or chart to your Downloads folder. The supported export options for charts include Data to Excel, CSV, and PNG. The supported export options for reports include Excel, CSV, and HTML. In addition, when you filter an interactive component during run time, you can choose to export all records or only the filtered records. You can also multi-select different export options.

**Print.** Launches a window, with options that enable you to print the component. When you filter interactive components during run time, you have the option to print the entire component or only the filtered records. The Print button launches your browsers Print dialog box where, you can set up your page for printing.

**Save Changes.** Saves your current chart output in its current state to the Downloads folder of your machine with a default name of ARsave.html and a Coordinated Universal Time (UTC) date time stamp.

**Restore Original.** Returns the component to its original state.
To close the Options menu, click it a second time.

When you have duplicated or created a new report or chart from another one, the Options menu on the duplicated item displays an option to close your component, as shown in the following image.

**Procedure:** How to Create a New Component

1. Select *New* from the Options menu on an interactive component.
2. Drag a measure to one of the corresponding buckets for your component type, for example, the Vertical bucket.
3. Drag a dimension to one of the corresponding buckets for your component type, for example, the Horizontal bucket.
4. Continue to add the available measures and dimensions to your component. You can also customize the component in the following ways:
   - Create a new calculation, and add the field to your component.
   - Use the corresponding options above the buckets to modify a chart.
   - Lasso data on the canvas to create a filter.
5. Click the checkmark button to save your component, and return to the original report or chart.

Your new component now appears in the Analysis panel.

**Procedure:** How to Edit a Component

1. Choose a component that you want to modify.
2. Click the *Options menu*, and then select *Edit*. This returns you to the design canvas, where you can modify your field selections, change your chart type, and more.
3. Click the checkmark button to save the changes.

**Procedure:** How to Duplicate a Component

1. Choose a component that you want to duplicate.
2. Click the *Options menu*, and then select *Duplicate*. A duplicate version of the original component now appears in the Analysis Panel.
3. Optionally, lock the duplicate component, modify it by changing the chart type, exporting the data, or printing the component.
Procedure: How to Export the Data from an Interactive Component

1. Choose the component from which you want to export data.
2. Click the Options menu, and then select Export. The component opens in a new window that contains options for your export.
3. Select the options that you want to use for the exported file. For example, you can select Filtered only, which only exports the filtered data. You can also choose the output format. For charts, select Data to Excel, CSV, or PNG. For reports, select Excel, CSV, or HTML.
4. Once you have selected your export options, click Export.
   
   Note: All exported data is automatically sent to the Downloads folder.

Procedure: How to Save the Changes You Make to an Interactive Component

Click Save Changes from the Options menu to save the most recent changes to the interactive component.

Note: Any saved changes are automatically saved to the Downloads folder, where you can access the data that is stored with a file name of ARsave.html and a Coordinated Universal Time (UTC) date time stamp. If you are working with a chart and you edit it or change the chart type, the changes are automatically saved in the output file.

Procedure: How to Print an Interactive Component

1. Choose a component that you want to print.
2. Click the Options menu, and then select Print. The component opens in a new window.
3. Click the Print button, which opens the standard Print dialog box for your browser.
4. Select the print destination, page detail, copies, and other settings that you want to configure, and then click Print.

   The options available to you, as well as the format of your output are determined by the browser you are using to access your content. In addition, results may vary depending on whether you print in color or in black and white. This includes appearance of line weights and fonts.

Specific browser considerations are highlighted below:

- Printing landscape in Microsoft Edge results in a narrower display of the chart.
- When printing charts in portrait, using Microsoft Edge, you are unable to resize the chart using fit to page.
- Chrome browsers only enable printing in landscape.
In-Document Analytic Options for Reports

You can use a variety of menus and options when performing analysis of an interactive report that uses In-Document Analytics. Depending on the style that you use, these options may be different.

**Designer Style Report Cell Menu Options**

Using the Designer Style interactive report, the cell menu allows you to customize the display of your report, while adding the ability to quickly add filters. The cell menu displays when you click on each cell in a report. This enables you to highlight an individual value or a row or add comments about this individual cell in your report. You can also reverse a previously highlighted aspect. The cell menu is shown in the following image.

![Cell Menu Example](image)

The Filter Cell option enables you to filter the report for just that row in the report. For example, if you want to see Accessories, you would click on Accessories in the report to enable the cell menu. In this case, the request returns just the values for Accessories, as shown in the following image.

![Filtered Report Example](image)
You can subsequently remove the filter by clicking *Remove Cell Filter*, as shown in the following image.

![Image showing a table with filter options]

This returns the report to its original, unfiltered state.

### Legacy Report Cell Menu Options

When you are working in an interactive report, that uses the Legacy style, the following data cell options display.

<table>
<thead>
<tr>
<th><strong>Option</strong></th>
<th><strong>Definition</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Drill down</td>
<td>Enables you to drill down one level in the hierarchy of your data source. This option displays for reports that have Auto Drill enabled.</td>
</tr>
<tr>
<td>Drill up</td>
<td>Enables you to drill up one level in the hierarchy of your data source. This option displays for reports that have Auto Drill enabled.</td>
</tr>
<tr>
<td>Restore Original</td>
<td>Restores the report to the default state specified in the report procedure.</td>
</tr>
<tr>
<td>Auto Links</td>
<td>Displays a list of target reports that are linked to the Auto Link enabled report. This option displays for reports that have Auto Linking enabled.</td>
</tr>
<tr>
<td>Comments</td>
<td>Enables you to add comments about data in your report. The result is an annotation that displays when you hover over it at run time.</td>
</tr>
<tr>
<td>Highlight Value</td>
<td>Enables you to highlight a particular value in your report.</td>
</tr>
<tr>
<td>Highlight Row</td>
<td>Applies highlighting to the selected row in your report.</td>
</tr>
</tbody>
</table>
### Option

<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unhighlight All</td>
<td>Removes any applied highlighting from values or rows in your report.</td>
</tr>
<tr>
<td>Filter Cell</td>
<td>Enables you to filter the output, showing only a selected row of data.</td>
</tr>
<tr>
<td>Remove Cell Filter</td>
<td>Removes any applied cell filters.</td>
</tr>
</tbody>
</table>

#### Using the Column Menu for Reports

The column menu displays when you click a column heading in a report. This provides you with access to formatting tools, chart type options, and filters, giving you more control over what displays in your report.

For a non-measure or dimension column, there are three primary sections to the column menu, as shown in the following image.

You can customize each column in your report. For example, you may want to filter on specific product categories while displaying column totals for others. This allows you to create and customize your report column by column.

You can use the following information to identify column menu components as you build your report:

- **Ascending.** Sorts the selected column in ascending order.
- **Descending.** Sorts the selected column in descending order.
- **Show Column Total.** Displays the column total for the currently selected column. Column totals display at the bottom of the report.
- **Hide Column.** Hides the currently selected column. This removes the currently selected column from view.
**Chart Rollup.** Select a chart type and, optionally, specify an aggregation other than the default value, Sum. Select a column for which to create the chart and click Create. The chart is created in a separate dialog box, enabling you to interact with the chart using the chart features and options.

**Rollup.** Use the Rollup option to select an aggregation for the currently selected column. You can also select a Group By value, options for which include the list of different columns in the report. Once you have made your selections, click Create to create the rollup, as shown in the following image.

**Pivot.** Use the Pivot option to create a cross-tab Pivot table. You can select an aggregation for the currently selected column. Next, specify a column value by which to group the report. Indicate an Across value to create the across values in your table. Click Create to create the pivot table, which displays in the analysis panel, as shown in the following image.

**Note:** The available group and across values include the dimension column values in your report (for example, Product Category).
**Numeric Slider.** If you are working with a measure value (for example, MSRP), you can use the slider tool to narrow the values you want to display. The slider shows the lowest to highest values in your measure, as shown in the following image.

You can specify a range of values by entering the values into the text boxes. This allows you to specify a range of values for a specific measure. If a value falls outside of the range of the data values, it will be crossed out, indicating that the value is invalid, as shown in the following image.

**Filter.** Use the filter option to narrow the data in your report. The filter option allows you to search on a value, or use the check boxes to select one or more values. You can use the **Select** option to select all values in your data hierarchy. Click **Clear** to clear the selected values. Once a filter is in place for a column, you can use the funnel-shaped icon, located next in the column heading, to clear the filter. This icon is shown in the following image.
If you are working with a date field, you can filter on a specific date using the filter control in the column menu. The filter control enables you to filter on a specific date or a range of dates, which you can indicate by holding the Ctrl key and clicking, while indicating the starting and ending dates. The range of dates is highlighted after you make your selection. The calendar filter is shown in the following image.

**Note**: When a calendar filter is specified, you can remove the filter by clicking the *Remove Filter* icon at the top of the date column.

**Highlight.** Select *Highlight* to highlight select components of your report. For example, Camcorder, Media Player, and Stereo Systems are highlighted in the following image.

Once the highlight filter is in place, you can remove it by clicking the *Remove Highlight* filter icon.

For measures, there are two additional options:

- **Visualize.** Adds visualization bars to, or removes them from, the selected column.
% of Total. This is a calculation of the current value against the total for the values in a column. When you click Create, a new column is added, showing the calculated values.

These options are shown in the following image.

Using Sort Column Indicators in Your Report

Interactive reports support the use of sort column indicators when you want to sort data in a report. You can sort a column in ascending and descending order, giving you control over the display of information in your report. The indicator that shows how a column has been adjusted by a previous action shows to the right of the column, as shown in the following image.

As shown above, the selected column is sorted in ascending order, where the values in the column are sorted from lowest to highest. If you click the arrow again, the column will be sorted in descending order, where the values are sorted from highest to lowest. If you click the arrow again, it will return to the default arrow that points in both directions, indicating that no sort has been applied.
In-Document Analytics Options for Charts

Similar to the options that are available in an interactive report, you can use chart-specific In-Document Analytics menus and options to perform your analysis.

Working With Charts Using the Chart Rollup Tool

If you are working with a chart using the Chart Rollup Tool and you subsequently create a new chart, the new chart launches with a metadata tree, buckets, and the chart picker. This look and feel is similar to the common interface of WebFOCUS Designer, as shown in the following image.

![Chart Rollup Tool Interface](image)

The interface loads with the fields that you had originally selected. This makes it easy to select different fields to create different types of charts at run time.

You can drag or double-click items to add items into the buckets. In this way, you can model different scenarios to create a chart that meets the needs of your organization. Once you have selected the fields to include, you can select a chart type from the chart picker, which displays on the right of the interface.

When you are done, click the checkmark, located at the top right of the interface, to apply the specified changes to your chart and return to the original canvas.

You can test out various scenarios and review different results, all within one session.

Legacy Style Chart Options

Options for an interactive chart that used the Legacy styling are described in the following table.

**Note:** For charts that employ the new attribute syntax, only the following four icons display: More Options, Advanced Chart, Original Chart, and Aggregation. If you have applied a filter, the Remove Filter icon displays.
<table>
<thead>
<tr>
<th>Option</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>More Options</td>
<td><strong>New.</strong> Creates a new instance of the chart. This option is available only when the chart is created from a column menu on a tabular report.</td>
</tr>
<tr>
<td></td>
<td><strong>Group By (X).</strong> Changes groups by the horizontal sort field.</td>
</tr>
<tr>
<td></td>
<td><strong>Add (Y).</strong> Adds a vertical sort field.</td>
</tr>
<tr>
<td></td>
<td><strong>X-Axis.</strong> Specifies a measure or dimension sort field. Applies to scatter charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Y-Axis.</strong> Specifies a measure. Applies to scatter charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Arrange By.</strong> Specifies the marker color. The marker color depends on the field assigned to the color attribute. If no field is assigned to this category, then all of the markers will be the same color. Applies to scatter charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Export to.</strong> Exports to Excel, Word, or PowerPoint.</td>
</tr>
<tr>
<td></td>
<td><strong>Stacked.</strong> Stacks the risers on top of each other, with the length of each riser representing the data value. Applies to column charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Top.</strong> Displays the top values. Options are Top 3, Top 5, Top 10, and Clear Top. Applies to pie charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Trend.</strong> Draws a trendline and equation label for an individual series. Applies to scatter charts.</td>
</tr>
<tr>
<td></td>
<td><strong>Chart/Rollup Tool.</strong> Opens the Chart/Rollup Tool, which you can use to select multiple group fields in the chart or rollup table generated. The Chart/Rollup Tool contains a list of columns available in the report and Group By and Measure sort fields. Drag the columns into the desired sort field.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> When working with the Chart/Rollup Tool for charts (specifically those with the new chart attribute syntax), the Series tab is not supported. It is available with charts that are created with tabular reports or stand-alone charts that do not use the new chart attribute syntax.</td>
</tr>
<tr>
<td></td>
<td><strong>Restore Original.</strong> Restores the report to the default state specified in the report procedure.</td>
</tr>
<tr>
<td>Column</td>
<td>Displays data as a column chart.</td>
</tr>
<tr>
<td><strong>Option</strong></td>
<td><strong>Definition</strong></td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Pie</td>
<td>Displays data as a pie chart.</td>
</tr>
<tr>
<td>Line</td>
<td>Displays data as a line chart.</td>
</tr>
<tr>
<td>Scatter</td>
<td>Displays data as a scatter chart.</td>
</tr>
<tr>
<td>Rollup</td>
<td>Displays the chart as a rollup table.</td>
</tr>
<tr>
<td>Advanced Chart</td>
<td>Opens the Chart/Rollup Tool.</td>
</tr>
<tr>
<td>Original Chart</td>
<td>Restores the chart to the chart type specified in the report procedure.</td>
</tr>
<tr>
<td>Lock/Unlock</td>
<td>Freezes the chart or rollup table. You can link or unlink a chart or rollup table to the filters that you have applied in your report using the Freeze Chart or Freeze Rollup icon. The icon indicates whether the report is linked to the filter (Freeze Chart or Freeze Rollup) or not (Unfreeze Chart or Unfreeze Rollup). This option is available only when the chart is created from a column menu on a tabular report.</td>
</tr>
<tr>
<td>Aggregation</td>
<td>Applies the following options to a Measure field: Sum, Avg, Min, Max, Count, and Distinct. The default value is Sum.</td>
</tr>
</tbody>
</table>
**Option** | **Definition**
--- | ---
Remove Filter | Removes a filter from a chart. You can apply a filter by pointing to or lassoing an area of the chart and then clicking the *Filter Chart* or *Exclude from Chart* option from the chart tooltip.

**Creating Content Using the Chart Rollup Tool**

You can access the Chart Rollup Tool from the column menu in a Designer Style interactive chart or report enabled. There are three tabs: Chart, Rollup, and Pivot. As you create charts, rollups, or pivot tables, each artifact displays in the analysis panel.

You can use the Chart Rollup Tool to select multiple group fields to generate the chart, rollup or pivot table.

For the Chart tab, you can select a chart type, an aggregation, and a column for the chart, as shown in the following image.

![Chart Rollup Tool Image](image)

**Procedure: How to Use the Chart Tool**

1. Create a report with multiple dimensions and measures.
2. Click on the primary dimension.
3. From the Chart Rollup tool, select a chart type.
4. Optionally, add an aggregation for the currently selected dimension.
5. Select a dimension or measure from the field list.
6. Click *Create*.

The chart displays in the analysis panel. You can interact with the chart in the same way as any other artifact.
For the Rollup, you can perform an aggregation on the current report column. You can also select a Group By value, which lists all columns in the report, as shown in the following image.

![Rollup Image]

**Procedure:** How to Use the Rollup Tool

1. Create a report with multiple dimensions and measures.
2. Click on the primary dimension.
3. From the Chart Rollup tool, select the Rollup tab.
4. Optionally, select an aggregation to be applied to the selected column.
5. For the Group By field, select a dimension or measure for which to perform the rollup.
6. Click Create.
   
The Rollup displays in the analysis panel.

For Pivot tables, you can similarly select an aggregation for the currently selected column in the report. You can select from the existing dimensions for the Group By and Across fields, as shown in the following image.

![Pivot Table Image]

**Procedure:** How to Use the Pivot Tool

1. Create a report with multiple dimensions and measures.
2. Click on the primary dimension.
3. From the Chart Rollup tool, select the *Pivot* tab.
4. Optionally, select an aggregation to be applied to the selected column.
5. For the Group By field, select a dimension by which to group the table.
6. For the Across field, select another dimension that will display as an across field.
7. Click *Create*.

   The Pivot table displays in the analysis panel.
Slicers provide a quick and easy way to add dynamic user controls to a chart, report or document, giving you the ability to filter the data in use as you create or view content. Slicers are dynamic filters that can be changed by making a selection from a menu of fields. You can use them to filter your content by modifying a slicer in the Slicers tab and running the chart or report, or you can use them at run time when running a report in InfoMini with the Slicers tab selected.

In this chapter:

- Creating Slicers
- Filtering With Slicers
- Edit Slicers Dialog Box

Creating Slicers

You can create slicers by dragging fields to the Slicers tab or through the context menu of a field.

**Note:** If you are working in Chart mode in WebFOCS App Studio, slicer functionality is not available.

When you create a slicer group, it appears on the Slicers tab, as shown in the following image.

You can use slicers to dynamically filter reports at design time.

You can dynamically filter reports at run time when they are included in an InfoMini application. For more information on InfoMini, see *Building InfoMini Applications* on page 551.
Procedure: How to Create a Slicer

1. Click the Slicers tab.

2. Create a new slicer by using one of the following methods:
   - Click the New Group button to create a new slicer group.
     Select a field from the Data pane and drag it onto the Drag Fields Here to Create Slicers text on the Slicers tab.
     Note: You cannot drag parent-child hierarchies onto the Slicers tab.
     The field is added to the new group.
   
or
   - Right-click a field in the Data pane, point to Slicers, and then click New Group, as shown in the following image.

The field is added to the new group.
If you are creating a slicer on a full date field, a calendar icon displays adjacent to the field. You can use this icon to select a date using a calendar control, as shown in the following image.

![Calendar Icon Example](image)

**Procedure:** How to Add a Field to an Existing Slicer Group

1. Click the Slicers tab.
2. Add a field to an existing slicer group using one of the following methods:
   - Select a field from the Data pane and drag it onto an existing slicer group.
   - or
   - Right-click a field in the Data pane, point to Slicers, and then click Existing Group.

   Select an existing group from the menu, and then click OK.

   The field is added to the existing group. For more information, see Group Tab on page 549.

**Procedure:** How to Add a Hierarchy as a Slicer Group

**Note:** You cannot drag parent-child hierarchies onto the Slicers tab.

1. Click the Slicers tab.
2. Add a hierarchy as a slicer group using one of the following methods:

   - Select a hierarchy from the Data pane and drag it onto an existing slicer group.
The hierarchy is added as a new group, not as a slicer in the existing group. The new group is given the same name as the hierarchy.

or

- Click the **New Group** button to create a new slicer group.

Select a hierarchy from the Data pane and drag it onto the *Drag Fields Here to Create Slicers* text of the Slicers tab.

The hierarchy is added to the new group. The name of the new group changes to the name of the hierarchy automatically. For example, if you create a slicers group using the Product hierarchy, Product, Category, Product, Sub, Category, and Model are added and the group is automatically named *Product*.

**Note:** Hierarchies cannot be added to existing slicer groups. If a hierarchy is dragged onto an existing slicer group, a new group is created automatically.

There is no right-click context menu for hierarchies. To add a hierarchy as a slicer group, you must drag it into a new slicer group.

**Filtering With Slicers**

Once you add slicers to an InfoAssist report, you can use them to filter the report. You can select values from the slicers menus, change the number of records that appear, create new slicer groups, clear existing slicer groups, and update the report preview.

Slicers that are not selected have their values filtered by the selected slicers. Only values that meet the criteria for previously selected slicers will appear in the menu for the next slicer. Slicers are not filtered in the order they appear in the slicer group, but by the order they are selected. Cascading of slicers is only valid for hierarchies.

**Procedure:** How to Change the Relationship Operator in a Slicer

1. With at least one slicer added to the report, click the *Slicers* tab.
2. Click the operators button on the slicer for the operation you want to change.
   
   A list of operators (numeric) appears in the menu.
Note: Alpha fields just flip between equal and not equal.

3. Select the operator that you want from the menu. You can rest the mouse on an operator to display a tooltip describing the operation.

How Slicers Cascade Together

Slicers cascade within a hierarchy (cube or dimension builder-based), rather than in the order of user interaction, eliminating potential performance issues.

Procedure: How to Cascade Slicers

Controls with fields from the same hierarchy are cascaded together.
In the following example, a report has been created that shows the quantity of products, by category, sold each year.

<table>
<thead>
<tr>
<th>Product Category</th>
<th>Sale Year</th>
<th>Quantity Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Accessories</td>
<td>2014</td>
<td>63,836</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>139,977</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>209,571</td>
</tr>
<tr>
<td>Camcorder</td>
<td>2014</td>
<td>56,782</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>123,972</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>187,033</td>
</tr>
<tr>
<td>Computers</td>
<td>2014</td>
<td>34,626</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>89,626</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>188,736</td>
</tr>
<tr>
<td>Media Player</td>
<td>2014</td>
<td>92,435</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>199,311</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>315,783</td>
</tr>
<tr>
<td>Stereo Systems</td>
<td>2014</td>
<td>138,850</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>302,717</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>451,751</td>
</tr>
<tr>
<td>Televisions</td>
<td>2014</td>
<td>11,542</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>24,940</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>38,123</td>
</tr>
<tr>
<td>Video Production</td>
<td>2014</td>
<td>25,032</td>
</tr>
<tr>
<td></td>
<td>2015</td>
<td>54,953</td>
</tr>
<tr>
<td></td>
<td>2016</td>
<td>81,585</td>
</tr>
</tbody>
</table>

1. Create a report.
2. Create multiple slicer groups, as described in How to Create a Slicer on page 540.
In the following example, two groups have been created for this report: Product and Time (Sales). Both are from hierarchies, so they will cascade.

In the next example, Televisions is selected as the first control for the Product group.

**Note:** You can select multiple values by holding down the Ctrl key while selecting items in the drop-down list box. In cases where multiple items are selected, the label for the drop-down list is set to Multiple. You can click the drop-down list to review the selections.
Once you click OK, the new control appears in the drop-down menu.

The 1 prior to the decimal point indicates that this is the first cascade you have interacted with. The 1 after the decimal point indicates that it is the first control in that cascade.

In the next example, Flat Panel TV is selected as the second control for the Product group, as shown in the following image. This is filtered to only show subcategories for Televisions.

Flat Panel TV appears in the Product Subcategory drop-down menu.

The number 1.2 indicates that this is the second control for the first cascade.

Now, a second group, Time (Sales) is created. It has two controls: the first is Sale,Years and the second is Sale,Quarter.
3. Filter the report using the controls in the slicer groups that you created.

   In the following example, the report has been filtered to show the number of flat panel televisions that were sold in the first quarter of 2019.

   ![Image showing slicers and a table of sales data]

   **Note:** The order of a cascade is dynamic. For example, if you selected Camcorder from Product Subcategory first, then the Product Category control would have a value of Video Production.

   **Edit Slicers Dialog Box**

   You can access the Edit Slicers dialog box by clicking the edit button next to the group labels on the Slicers tab, as shown in the following image.

   ![Image of the Edit Slicers dialog box]

   The Edit Slicers dialog box contains the following tabs:

   - General
   - Record Limit
   - Group # (tab for each slicer group)
General Tab

Use the General tab to show or hide the Options group and to automatically update the Interactive preview. You can also reorder or delete existing groups on this tab.

The General tab is shown in the following image.

The General tab contains the following options:

- **Show Options group.** Select this option to display the Options group on the Slicers tab.

  The Options group contains the following options:

  - **New Group.** Adds a new slicers group to the Slicers tab.
  
  - **Clear Slicers.** Clears all selected values from existing slicers.
  
  - **Update Preview.** Updates the design time canvas with any changes that have been made.
- **Auto Update Preview.** Enables auto updating of the canvas.

- **Edit Group Order.** Select a group, then use the up and down arrows to change its position.

- **Hide & Exclude.** Select a group, then select this option to hide and exclude the group.

**Note:** To delete the group completely, select the group and click *Remove from List*.

### Record Limit Tab

Use the Record Limit tab to show or hide the Record Limit group, the Preview control, and the Run Time control. You can also use this tab to select the number of preview and run-time records that will be shown.

The Record Limit tab contains the following options:

- **Show Record Limit group.** Select this option to display the Record Limit group on the Slicers tab.

  The Record Limit group contains the following menus:

  - **Preview.** Use this menu to control how many records are displayed in the design-time preview.

  - **Run Time.** Use this menu to control how many records are displayed at run time.

- **Show Preview control.** Select this option to display the Preview menu in the Record Limit group on the Slicers tab. You can set the default number of records to be shown at design time with the Records menu in the Preview section.

- **Show Run Time control.** Select this option to display the Run Time menu in the Record Limit group on the Slicers tab. You can set the default number of records to be shown at run time with the Records menu in the Run Time section.

### Group Tab

Use the Group tab to change the name of the group, change the order of the slicers in the group, and set a required option for slicers. Selecting a slicer and clicking the Remove from List button deletes the slicer.

The Group tab contains the following options:

- **Group Name.** Use this field to enter or edit the name of a Slicer group.

- **Edit Slicer Order.** Select a slicer, then use the up and down arrows to change its position.
**Required.** Select this option to set a slicer to be required. A slicer that is set to required must have a value selected before the report can run. A required slicer is indicated by an asterisk (*).
Building InfoMini Applications

InfoMini applications are built from an InfoAssist report and contain a subset of InfoAssist functionality available at run time.

You can build an InfoMini application and provide the run-time user with the option to interact with and edit the report.

In this chapter:

- Understanding InfoMini Applications
- Creating an InfoMini Application

Understanding InfoMini Applications

When you create a report in InfoAssist, you have the option to activate InfoMini. You can run a report with InfoMini activated, which creates an InfoMini application. An InfoMini application contains a subset of the functionality available in the full version of the report or chart interface. You can limit or expand the functionality that is available to the user at run time when you build the report or chart in InfoAssist.

An InfoMini application opens in its own browser window when it is run from within InfoAssist. An InfoMini application has many of the components an InfoAssist report has, with the following exceptions:

- The main menu is not accessible.
- The New, Open, and View code buttons on the Quick Access Toolbar are not available.
- Certain tabs and groups are unavailable or limited.
- The status bar is not accessible.
- The navigation taskbar is not accessible.
- InfoMini does not support referencing existing procedures.

For more information on the available components and their functionality, see InfoAssist Application Window on page 22.
Using the InfoMini Button

The InfoMini button can be found on the Format tab, in the Destination group. You can click the InfoMini button to activate the InfoMini option. With the InfoMini button active, you can run a report to open the InfoMini application.

To deactivate the InfoMini option, click the InfoMini button again. There must be at least one option selected from the InfoMini button menu for InfoMini to be activated.

You can set the options available to the user at run time from the menu on the InfoMini button. If you select an option from the menu when the InfoMini button is inactive, the InfoMini option is activated. The options are:

- Home Tab
- Format Tab
- Slicers Tab
- Data Tab
- Slicer Tab (Edit)
- Layout Tab
- Series Tab
- Resources/Field Tab
- Run Immediately
- Run Deferred
- Save

When you select an option from the menu, a check mark appears next to the option. The check mark indicates the option is available for the user at run time within the InfoMini application. If you select a checked option to clear it, the check mark disappears, and the option is no longer available through the InfoMini application. If you clear all of the options from the menu, InfoMini is deactivated. All options are selected by default.

The Run Immediately option enables reports to run immediately when InfoMini first launches. You might want to clear this option so that the user can choose a format and pick slicers before running a report.
Understanding the InfoMini Layout

The InfoMini layout is similar to the InfoAssist layout. The options that are available in InfoMini vary based on what you select from the InfoMini menu in InfoAssist. Since it is customized, the InfoMini ribbon contains subsets of the InfoAssist ribbon.

InfoMini has two modes: Interactive and Edit.

Interactive mode is used to format your content while Edit mode allows you to develop it.

Interactive Mode

Interactive mode is the default mode when an InfoMini application runs. You can access Interactive mode from the Quick Access Toolbar of an InfoMini application. The Resources panel is not available in Interactive mode.

If no options are selected from the InfoMini button menu when the application runs, the tool still opens in Interactive mode with no ribbon options available. The following options can be activated in Interactive mode:

- Home Tab
- Format Tab
- Slicers Tab

In Interactive mode of InfoMini, the tabs that you select in the first grouping on the InfoMini menu display when you run InfoMini.

For more information on a specific area of the ribbon, see Ribbon on page 554.

Edit Mode

Edit mode provides access to the additional tabs that you enabled when you configured InfoMini. The options in Edit mode allow you to edit and develop your content using the Resources panel. If no options are selected from the InfoMini button menu when the application runs, an error message displays, indicating that you must select at least one tab.

Note: If you did not select at least one tab in the Edit section of the InfoMini button menu, Edit mode will not display at run time.

You can access Edit mode from the Quick Access Toolbar of an InfoMini application.

In addition to the tabs that are available in Interactive mode, the following options can be activated in Edit mode:

- Insert Tab (documents only)
Understanding InfoMini Applications

- Data Tab
- Slicers Tab
- Layout Tab
- Resources/Field Tab (displays as Field on the ribbon)
- Series Tab (charts only)

Ribbon

This section defines the tabs on the InfoMini ribbon.

Depending on the options that you enable for InfoMini in InfoAssist, the tab options vary.

Home Tab

In InfoMini mode, the Home tab has the following exceptions:

- The Report and Chart buttons, which are on the Home tab, in the Format Group in InfoAssist, are not available in an InfoMini application.
- The Design group, which is on the Home tab in InfoAssist, is not available in an InfoMini application.
- Create a Data File option is not available.

For more information on the functionality of the available groups on the Home tab, see Home Tab on page 36.

Insert Tab

From the Insert tab, you can access the Pages, Reports, Objects, and interactive dashboard Prompts (for AHTML, PDF Analytic Document, and HTML Analytic Document only) groups. The Insert tab is only available in Document mode.

The Existing Reports button, which is available in the Reports group, is not available in an InfoMini application.

For more information on the functionality of the available groups on the Insert tab, see Insert Tab on page 37.

Format Tab

In Edit mode, the following groups display for reports on the Format tab: Output Types and Auto Linking. For charts, the following additional groups display: Chart Types, Labels, and Interactive.
In InfoMini mode, the Format tab has the following exceptions:

- The Destination and Features groups, which are on the Format tab in InfoAssist, are not available in an InfoMini application. The Navigation group is available for charts only.

- The Other button, which is on the Format tab, in the Chart Types group in InfoAssist, is not available in an InfoMini application.

The Output Types group contains commands to create output in any of the supported formats. For reports and charts, you also have access to the Auto Linking group. This group contains options for enabling the functions of Auto Linking, a feature that allows you to create a suite of referenceable reports or charts in your Enterprise.

For more information on the functionality of the available groups on the Format tab, see Format Tab on page 37.

Data Tab

In Edit mode, the following groups display on the Data tab: Calculation, Filter, Display, and Data Source.

In InfoMini mode, the Data tab has the following exceptions:

- The Join group, which is on the Data tab in InfoAssist, is not available in an InfoMini application.

- The Add option, which is on the Data tab in the Data Source group in InfoAssist, is not available in an InfoMini application. For more information about the functionality of the available groups on the Data tab, see Data Tab on page 39.

Slicers Tab

In Edit mode, the following groups display on the Slicers tab: Options, Record Limit, and Group 1.

In InfoMini mode, the Slicers tab has the following exceptions:

- The Update Preview option, which is on the Slicers tab, in the Options group in InfoAssist, is not available in an InfoMini application.

- The Preview list, which is on the Slicers tab, in the Record Limit group in InfoAssist, is not available in an InfoMini application.

For more information on the functionality of the available groups on the Slicers tab, see Slicers Tab on page 39.
Layout Tab

From the Layout tab, you can access the Page Setup and Reports groups for reports. For charts, you can access the features of the Size & Arrange group. For more information on the functionality of the available groups on the Layout tab, see Layout Tab on page 40.

Field Tab

From the Resources/Field (Field) tab, you can access the Filter, Sort, Break, Style, Format, Display, and Links groups. For more information on the functionality of the available groups on the Field tab, see Field Tab on page 42.

Series Tab

From the Series tab, you can access the Select, Style, Properties, and Line groups. For more information on the functionality of the available groups on the Series tab, see Series Tab on page 43.

Creating an InfoMini Application

To create an InfoMini application in InfoAssist, build a report as you normally would, then activate InfoMini and add the functionality you want the user to have available to them at run time. For more information on what functionality is available to InfoMini applications, see Understanding InfoMini Applications on page 551.

Procedure: How to Activate InfoMini

1. With a report or chart open, click the Format tab.
2. In the Destination group, click InfoMini.

   Note: At least one option from the InfoMini menu must be selected in order to activate InfoMini. By default, the Format tab and Slicers tab are selected on the menu when you activate InfoMini in a new report. For more information on enabling InfoMini options, see How to Enable and Disable InfoMini Application Options on page 557.

   The InfoMini button is highlighted and the InfoMini mode is activated. For more information about running an InfoMini application, see How to Test an InfoMini Application on page 557.
Procedure: How to Enable and Disable InfoMini Application Options

You can choose which options will be available at run time in an InfoMini application. By default, the Format tab and Slicers tab are selected on the menu when you activate InfoMini in a new report. For more information about the functionality of each option, see Understanding InfoMini Applications on page 551.

1. With a report or chart open, click the Format tab.
2. Click the arrow next to the InfoMini button. A menu of available tabs and options displays.
   InfoMini does not have to be active for you to access the menu. When you select an option from the menu, InfoMini is activated.
3. From the menu, select any options you want to display in your InfoMini application.

Procedure: How to Test an InfoMini Application

1. With an InfoAssist report open, activate InfoMini as described in How to Activate InfoMini on page 556.
2. Enable the options that you want, as described in How to Enable and Disable InfoMini Application Options on page 557.
3. Run the report.
   An InfoMini application opens in a new window.

Procedure: How to Interact With an InfoMini Application

With an InfoMini application open, you can edit the application using the functionality that was enabled in InfoAssist. You have access to certain options, depending on which options were enabled.

You have the ability to alter the InfoMini application at run time. Changes to the application are not reflected on the canvas dynamically and you must run the report to see the updates.

1. Run a report with InfoMini activated, as described in How to Test an InfoMini Application on page 557.
   An InfoMini application opens in a new window.
2. By default, the ribbon is hidden in an InfoMini application. To display the ribbon, do one of the following:
   - In Interactive mode, click one of the tabs.
   - Click the down arrow next to the Help icon.

   The available options on these tabs provide the same functionality as they do in InfoAssist. You can use this embedded functionality to change the report at run time.
3. After making your changes, click *Run* to see an updated version of the report.
The ribbon is contextual and changes depending on the type of file that you are developing. This topic describes each of the available ribbons and commands for each InfoAssist tool.

In this appendix:
- Ribbon Commands for Reports
- Ribbon Commands for Charts
- Ribbon Commands for Documents
- Ribbon Commands for Visualizations

**Ribbon Commands for Reports**

When creating and customizing reports in Report mode, you can use the following ribbons and commands to customize report functionality.

### Home Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format Group</strong></td>
<td></td>
</tr>
<tr>
<td>Output File Format</td>
<td>Displays a drop-down menu of all supported output formats.</td>
</tr>
<tr>
<td>Chart</td>
<td>Switches to Chart mode. Converts a report to a chart using the fields specified in the report.</td>
</tr>
<tr>
<td>Report</td>
<td>Indicates that you are in Report mode.</td>
</tr>
<tr>
<td>File</td>
<td>Creates a data file from a report.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Query (Design view)</td>
<td>Displays the Data, Query, and Filter panes across the entire canvas, eliminating Live Preview. This view provides a larger work area for creating the report.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>Displays the report on the canvas as you create the report. You can use the Live Preview to add, remove, and arrange fields, as well as style the report.</td>
</tr>
<tr>
<td>Document (Design view)</td>
<td>Converts a report into a document. Opens the document on canvas, which you can use to add text, images, lines, reports, and charts to create documents.</td>
</tr>
<tr>
<td>Data from Source</td>
<td>Uses the selected data source to display a live preview of the output on the canvas.</td>
</tr>
<tr>
<td>Use Sample Data</td>
<td>Displays sample data, which reduces processing time by eliminating the need to access the actual data source.</td>
</tr>
<tr>
<td>Records</td>
<td>Limits the number of rows retrieved from the data source when Live Preview is selected. This feature is useful in reducing response time if you are working with a large amount of data. Type the number of rows that you want directly in the Records field, or use the drop-down menu to select one of the preset record limits. The preset choices are All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.</td>
</tr>
</tbody>
</table>

**Filter Group**

<table>
<thead>
<tr>
<th>Filter</th>
<th>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exclude</td>
<td>Turns off a filter.</td>
</tr>
<tr>
<td>Include</td>
<td>Turns on a filter.</td>
</tr>
</tbody>
</table>

**Report Group**
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Theme</td>
<td>Opens a dialog box where you can select a theme to style your report or chart. You can use the default style sheet by clicking the <em>Use Default Stylesheet</em> button. You can also select a document styling theme or an application theme to style all reports created. Use the Environment and Styling section of the Options window, which is accessible by clicking <em>Options</em> in the Application main menu.</td>
</tr>
<tr>
<td>Style</td>
<td>Opens a Report Style dialog box for applying global styling to the entire report. For more information about styling reports, see <em>Styling Reports</em> on page 90.</td>
</tr>
<tr>
<td>Banded</td>
<td>Opens a Color dialog box for choosing a color that provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report.</td>
</tr>
<tr>
<td>Header &amp; Footer</td>
<td>Opens the Header &amp; Footer dialog box, from which you can add and style headings and footings.</td>
</tr>
<tr>
<td>Column Totals</td>
<td>Adds a grand total row to the bottom of the report to sum numeric data in each column.</td>
</tr>
<tr>
<td>Row Totals</td>
<td>Adds a grand total column to the right side of the report to sum numeric data in each row.</td>
</tr>
</tbody>
</table>

**Format Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Destination Group</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>InfoMini</td>
<td>Enables the creation of an InfoMini application. For more information on using InfoMini, see <em>Building InfoMini Applications</em> on page 551.</td>
</tr>
<tr>
<td>Chart</td>
<td>Switches to Chart mode. Converts a report to a chart using the fields specified in the report.</td>
</tr>
<tr>
<td>Report</td>
<td>Indicates that you are in Report mode.</td>
</tr>
<tr>
<td>File</td>
<td>Creates a data file from a report.</td>
</tr>
</tbody>
</table>

**Navigation Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Table</td>
<td>Generates standard browser output. This is the default.</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>Generates output by displaying a table of contents icon in the upper-left corner where report output typically appears. Clicking <em>Table of Contents</em> opens a menu that enables you to select (view) individual values of the first Sort By (By) field, one value at a time. You can also select options to view the entire report or remove the table of contents.</td>
</tr>
<tr>
<td>Freeze</td>
<td>Generates output with column titles that freeze (remain in view) when you scroll through pages of the report output.</td>
</tr>
<tr>
<td>Pages On Demand</td>
<td>Provides access to two distinct features, depending upon the output type that you have selected.</td>
</tr>
<tr>
<td>OLAP Analysis</td>
<td>Enables Online Analytical Processing capabilities for online reports, including showing or hiding the OLAP panel. You can select from different options using the drop-down menu on the split button.</td>
</tr>
</tbody>
</table>

**Features Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title Popup</td>
<td>Displays pop-up titles when the mouse pointer hovers over a column title in the report output.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Accordion</td>
<td>Creates expandable views of data for each vertical sort field. This option displays data values only for the first vertical sort field when you first view the output. You can manually expand your view to expose the data values of lower-level sort fields.</td>
</tr>
<tr>
<td>Repeat Sort Value</td>
<td>Displays all repeated sort values instead of blanks in the output after the first instance of a new sort value, which is the default behavior.</td>
</tr>
<tr>
<td>Stack Measures</td>
<td>Displays all numeric measure field names in a column of the report output with the corresponding numeric data values. For more information on Stacked Measures, see the Stacking Columns topic in the Creating Reports With TIBCO WebFOCUS® Language manual.</td>
</tr>
<tr>
<td>Analytic Document Options</td>
<td>Opens the Analytic Document Options dialog box where you can configure your interactive report options such as menu items, graph engine, and colors. For more information, see Creating Interactive Content on page 475.</td>
</tr>
<tr>
<td>Accessibility</td>
<td>Allows a title to be added to a report, chart, or document that is Section 508-compliant.</td>
</tr>
</tbody>
</table>

### Run with Group

| Auto Drill          | Enables you to navigate through different levels within the dimension hierarchy of your data source. Click Auto Drill to enable the functionality. For more information, see Using Auto Drill on page 345. |

### Auto Linking Group

| Enable Auto Linking | Enables auto linking. For more information, see Using the Auto Linking Feature to Link Content on page 349. |
| Auto Link Target    | Sets procedure as an available target for auto linking. |
## Data Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calculation Group</strong></td>
<td></td>
</tr>
<tr>
<td>Detail (Define)</td>
<td>Opens the Detail Field (DEFINE) dialog box, where you can create a defined field, type a name for the field, and enter a format. A Define field is an optional attribute used to create a virtual field for reporting. You can derive the virtual field value from information already in the data source (that is, from permanent fields).</td>
</tr>
<tr>
<td>Summary (Compute)</td>
<td>Opens the Summary Field (COMPUTE) dialog box, where you can create a computed field, type a name for the field, and enter a format.</td>
</tr>
<tr>
<td><strong>Join Group</strong></td>
<td></td>
</tr>
<tr>
<td>Join</td>
<td>Opens the Join dialog box, where you can create a new join, edit or delete existing joins, and add data sources to a join.</td>
</tr>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td><strong>Display Group</strong></td>
<td></td>
</tr>
<tr>
<td>Missing Data</td>
<td>This option is disabled for reports.</td>
</tr>
<tr>
<td><strong>Data Source Group</strong></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>Opens the Open dialog box, where you can add additional data sources to a document, enabling you to insert reports from different data sources into the same document. This option is activated when you add a HOLD file. This option is unavailable, by default.</td>
</tr>
</tbody>
</table>
### Command Reference

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch</td>
<td>Opens a drop-down list of all the data sources that have been added. You can choose which data source is currently active and being used to create new reports. This option is activated when you add a HOLD file. This option is unavailable, by default.</td>
</tr>
</tbody>
</table>

### Slicers Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Options Group</strong></td>
<td></td>
</tr>
<tr>
<td>New Group</td>
<td>Creates a new group of similar slicers.</td>
</tr>
<tr>
<td>Clear Slicers</td>
<td>Resets all slicers so that no filtering is done.</td>
</tr>
<tr>
<td>Update Preview</td>
<td>Applies slicers to preview.</td>
</tr>
<tr>
<td>Options</td>
<td>Opens the Edit Slicers dialog box to the General tab, where you can set general options for your slicers.</td>
</tr>
<tr>
<td><strong>Record Limit Group</strong></td>
<td></td>
</tr>
<tr>
<td>Preview</td>
<td>Sets the number of records retrieved from the data source for preview.</td>
</tr>
<tr>
<td>Run Time</td>
<td>Sets the number of records retrieved at run time.</td>
</tr>
<tr>
<td>Record Limit</td>
<td>Opens the Edit Slicers dialog box to the Record Limit tab, where you can set record limits for your slicers.</td>
</tr>
<tr>
<td><strong>Group Number Group</strong></td>
<td></td>
</tr>
<tr>
<td>Group n</td>
<td>Contains a group for each Slicer group that is added. Group 1 is the default slicer group to which you can drag fields to create slicers. To access slicer group options, click Group n to open the Edit Slicers dialog box where you can rename the slicer group and modify the order of the slicers in the group.</td>
</tr>
</tbody>
</table>
## Layout Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Setup Group</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Margins</strong></td>
<td>Enables you to set margin values by choosing Normal (1 inch all around), Narrow (.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom. Choosing Custom opens the Margins dialog box, where you can set specific margins as needed.</td>
</tr>
<tr>
<td><strong>Orientation</strong></td>
<td>Enables you to set the orientation of your report to portrait or landscape.</td>
</tr>
<tr>
<td><strong>Size</strong></td>
<td>Enables you to select the size of the paper for printing output. You can choose A3, A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size (34 x 44 Inches).</td>
</tr>
<tr>
<td><strong>Units</strong></td>
<td>Enables you to select the unit of measurement used for customizing the dimension fields of your report. You can choose Inches, Centimeters, or Points.</td>
</tr>
<tr>
<td><strong>Page Numbers</strong></td>
<td>Enables you to select page numbering options. You can choose one of the following: No Lead (no space for headers), On (page numbers only in headers), Off (space for headers, but no page numbering)</td>
</tr>
<tr>
<td></td>
<td>The Page Numbers value is overridden by header and footer text options.</td>
</tr>
<tr>
<td><strong>Report Group</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Cell Padding</strong></td>
<td>Opens the Cell Padding dialog box, where you can set specific values to control the amount of space inserted between rows and columns in a report. For more information, see How to Use Cell Padding in a Report on page 99.</td>
</tr>
</tbody>
</table>
### View Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Design Group</strong></td>
<td></td>
</tr>
<tr>
<td>Query (Design view)</td>
<td>Displays the Data, Query, and Filter panes across the entire canvas, eliminating Live Preview. This view provides a larger work area for creating the report.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>Displays the report on the canvas as you create the report. You can use the Live Preview to add, remove, and arrange fields, as well as style the report.</td>
</tr>
<tr>
<td>Document (Design view)</td>
<td>Converts a report into a document. Opens the document on canvas, which you can use to add text, images, lines, reports, and charts to create documents.</td>
</tr>
<tr>
<td><strong>Show/Hide Group</strong></td>
<td></td>
</tr>
<tr>
<td>Resources</td>
<td>Minimizes the Resources panel and expands the size of the canvas to also occupy the area where the Resources panel typically appears. The canvas can display a preview of a report, output of a report, or the Query Design pane.</td>
</tr>
<tr>
<td><strong>Data Panel Group</strong></td>
<td></td>
</tr>
<tr>
<td>Logical</td>
<td>Displays the data source fields by type. This is the default view. The Logical view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td><strong>Command</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>List</td>
<td>Displays the data source fields in a tabular list format. This list contains a header row. You can sort fields differently by clicking a column header. The List view options include Title, Description, Field, Alias, Format, Segment, Filename, and Reference.</td>
</tr>
<tr>
<td>Structured</td>
<td>Displays the hierarchical structure of the data source files. The Structured view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td><strong>Query Panel Group</strong></td>
<td></td>
</tr>
<tr>
<td>Areas 2x2</td>
<td>Displays data in a two column by two-row grid.</td>
</tr>
<tr>
<td>Areas 1x4</td>
<td>Displays data in a one column by four-row grid.</td>
</tr>
<tr>
<td>Tree</td>
<td>Displays data in a tree. This is the default.</td>
</tr>
<tr>
<td><strong>Output Window Group</strong></td>
<td></td>
</tr>
<tr>
<td>Arrange</td>
<td>Opens a drop-down menu where you can choose how to display multiple output windows. The options are Cascade, Tile Horizontally, and Tile Vertically.</td>
</tr>
<tr>
<td>Output Location</td>
<td>Opens a drop-down menu where you can choose how to direct new output. The options are Single tab (default), New Tab, Single Window, and New Window.</td>
</tr>
<tr>
<td>Switch Output</td>
<td>Opens a drop-down menu for choosing to view any active output window.</td>
</tr>
<tr>
<td><strong>Report Group</strong></td>
<td></td>
</tr>
<tr>
<td>Switch Report</td>
<td>Lists any active reports, charts, documents, and visuals to which you can switch.</td>
</tr>
</tbody>
</table>
# Field Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Removes, but does not delete, the filter from the report.</td>
</tr>
<tr>
<td>Include</td>
<td>Restores a filter that was previously excluded from a report.</td>
</tr>
<tr>
<td><strong>Prompt</strong></td>
<td></td>
</tr>
<tr>
<td>Prompt</td>
<td>Opens the Create a filtering condition dialog box for creating an auto prompting parameter that you can select when you run a report. The Create a filtering condition dialog box is used to create both filters and auto prompting parameters. The following prompt options are available when Parameter is selected from the Type dropdown menu:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Simple.</strong> This is used for prompts using Text Input. This is the default value.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Static.</strong> This is used for prompts using Selection. This option allows you to select multiple values at run time.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Dynamic.</strong> This is used for prompts using Data Values. This option allows you to select multiple values at run time.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Optional.</strong> This is used for prompts using Single or Multiselect parameters.</td>
</tr>
<tr>
<td><strong>Sort Group</strong></td>
<td></td>
</tr>
<tr>
<td>Up</td>
<td>Sorts the selected field in ascending order. This option is activated when you click on a measure or dimension.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Down</td>
<td>Sorts the selected field in descending order. This option is activated when you click on a measure or dimension.</td>
</tr>
<tr>
<td>Rank</td>
<td>Inserts a rank column immediately to the left of the report if a Sort By field is selected. It also adds a rank column to the left of the Sort By field if a Measure field is selected. Ranking a Measure field results in two copies of the field, the original Measure field, and the Sort By field that is created during ranking. This option is activated when you click on a measure or dimension.</td>
</tr>
<tr>
<td>Group</td>
<td>Opens the Create a Group dialog box where you can create a group to combine values together. This option is activated when you click on a dimension.</td>
</tr>
<tr>
<td>Limit</td>
<td>Opens a drop-down menu that allows you to specify the number of unique values to display for a sort group that has been added. This option is activated when you click on a measure or dimension.</td>
</tr>
</tbody>
</table>

**Break Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Break</td>
<td>Starts a new page when the primary sort field changes. Clicking the drop-down icon enables you to select Reset Page Numbers, which allows you to reset page numbers on a page break to start at 1. This option is activated when you click on a dimension.</td>
</tr>
<tr>
<td>Line Break</td>
<td>Inserts a line in the report output when the primary sort field changes. This option is activated when you click on a dimension.</td>
</tr>
<tr>
<td>Subtotal</td>
<td>Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields when the primary sort field changes. This option is activated when you click on a dimension.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Sub Header</td>
<td>Opens a dialog box where you can type text to add a subheading just below the column titles in the report output when the primary sort field changes. This option is activated when you click on a dimension.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>Opens a dialog box where you can type text to add a subfooting at the end of the data on each page of the report output when the primary sort field changes. This option is activated when you click on a dimension.</td>
</tr>
</tbody>
</table>

**Style Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font</td>
<td>Opens the Font list, which you can use to change the font.</td>
</tr>
<tr>
<td>Font Size</td>
<td>Opens the Font Size list, which you can use to change the numeric value for the font size.</td>
</tr>
<tr>
<td>Font Color</td>
<td>Opens the Color dialog box, where you can select the font color.</td>
</tr>
<tr>
<td>Style Reset</td>
<td>Resets all settings to the default settings from the template.</td>
</tr>
<tr>
<td>Bold</td>
<td>Applies bold font formatting to the selected text.</td>
</tr>
<tr>
<td>Italic</td>
<td>Applies italic font formatting to the selected text.</td>
</tr>
<tr>
<td>Underline</td>
<td>Underlines the selected text.</td>
</tr>
<tr>
<td>Justify Left</td>
<td>Aligns the text to the left of the report.</td>
</tr>
<tr>
<td>Justify Center</td>
<td>Aligns the text to the center of the report.</td>
</tr>
<tr>
<td>Justify Right</td>
<td>Aligns the text to the right of the report.</td>
</tr>
<tr>
<td>Background Color</td>
<td>Opens the Color dialog box, where you can select the background color for the report.</td>
</tr>
<tr>
<td>Data Style</td>
<td>Styles only the data for the selected data source field.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Title Style</td>
<td>Styles only the column title for the selected data source field.</td>
</tr>
<tr>
<td>Data + Title</td>
<td>Styles both the data and the column title for the selected data source field.</td>
</tr>
</tbody>
</table>

**Format Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal</td>
<td>The default value for the data format of the selected measure is Decimal. Use the drop-down menu to select Alphanumeric, Integer, or More options to open the Field Format Options dialog box.</td>
</tr>
<tr>
<td>Change currency options</td>
<td>Changes the currency options for the selected field. This option is activated when you click on a measure.</td>
</tr>
<tr>
<td>Percent</td>
<td>Specifies the value of the field as a percentage. This option is activated when you click on a measure.</td>
</tr>
<tr>
<td>Comma</td>
<td>Specifies the use of commas for the selected field. This option is activated when you click on a measure.</td>
</tr>
<tr>
<td>Increase Decimal Places</td>
<td>Increases the number of decimal places that display for the selected field. This option is activated when you click on a measure.</td>
</tr>
<tr>
<td>Decrease Decimal Places</td>
<td>Decreases the number of decimal places that display for the selected field. This option is activated when you click on a measure.</td>
</tr>
</tbody>
</table>

**Display Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Field</td>
<td>Allows you to hide a selected field.</td>
</tr>
<tr>
<td>Hide Missing</td>
<td>Allows you to hide fields that have no value.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Aggregation</td>
<td>Enables you to apply an aggregation function to a field in a report. Opens a drop-down menu of the following options: None (default), Sum, Average, Count, Count Distinct, Percent of Count, First Value, Last Value, Maximum, Minimum, Total, Percent, Row Percent, Median, Average Square.</td>
</tr>
<tr>
<td>Traffic Lights</td>
<td>Opens the Traffic Light Condition dialog box. From this dialog box, you can add new conditional styling by applying traffic light (and other) colors to a selected field in the output when the field meets specified criteria, modify existing conditional styling, and enable conditional drill-down.</td>
</tr>
<tr>
<td>Data Bars</td>
<td>Adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values.</td>
</tr>
<tr>
<td>Within</td>
<td>Allows you to use specific aggregation tasks at different report levels. You can use the Within phrase to manipulate display field values as they are aggregated within a sort group rather than a report column.</td>
</tr>
<tr>
<td>Column(s)</td>
<td>This option is disabled for reports.</td>
</tr>
</tbody>
</table>

**Links Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can configure a hyperlink or a drill-down procedure for the selected field. Clicking that field in the report output, at run time, redirects you to the URL you specified or executes the indicated procedure.</td>
</tr>
</tbody>
</table>
Ribbon Commands for Charts

When creating and customizing charts in Chart mode, you can use the following ribbons and commands to customize chart functionality.

**Home Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format Group</strong></td>
<td></td>
</tr>
<tr>
<td>Output File Format</td>
<td>Displays a drop-down menu of all supported output formats.</td>
</tr>
<tr>
<td>Chart</td>
<td>Indicates that you are in Chart mode.</td>
</tr>
<tr>
<td>Report</td>
<td>Switches to Report mode. Converts a chart to a report using the fields specified in the chart.</td>
</tr>
<tr>
<td>File</td>
<td>Creates an image file from a chart. This option is disabled by default and is only enabled for HTML format.</td>
</tr>
<tr>
<td><strong>Design Group</strong></td>
<td></td>
</tr>
<tr>
<td>Query (Design view)</td>
<td>Displays the Data, Query, and Filter panes across the entire canvas, eliminating Live Preview. This view provides a larger work area for creating the chart.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>Displays the chart on the canvas as you create the chart. You can use the Live Preview to add, remove, and arrange fields, as well as style the chart.</td>
</tr>
<tr>
<td>Document (Design view)</td>
<td>Opens the document on canvas, which you can use to add text, images, lines, reports, and charts to create documents.</td>
</tr>
<tr>
<td>Data from Source</td>
<td>Uses the selected data source to display a live preview of the output on the canvas.</td>
</tr>
<tr>
<td>Use Sample Data</td>
<td>Displays sample data, which reduces processing time by eliminating the need to access the actual data source.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Records</td>
<td>Limits the number of rows retrieved from the data source when Live Preview is selected. This feature is useful in reducing response time if you are working with a large amount of data. Type the number of rows that you want directly in the Records field, or use the drop-down menu to select one of the preset record limits. The preset choices are All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.</td>
</tr>
</tbody>
</table>

**Filter Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Turns off a filter.</td>
</tr>
<tr>
<td>Include</td>
<td>Turns on a filter.</td>
</tr>
</tbody>
</table>

**Report Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Theme</td>
<td>Opens a dialog box where you can select a theme to style your report or chart. You can use the default style sheet by clicking the <em>Use Default Stylesheet</em> button. You can also select a document styling theme or an application theme to style all reports created. Use the Environment and Styling section of the Options window, which is accessible by clicking Options in the Application main menu.</td>
</tr>
<tr>
<td>Style</td>
<td>This option is disabled for charts.</td>
</tr>
<tr>
<td>Banded</td>
<td>This option is disabled for charts.</td>
</tr>
<tr>
<td>Header &amp; Footer</td>
<td>Opens the Header &amp; Footer dialog box, from which you can add and style headings and footings.</td>
</tr>
<tr>
<td>Column Totals</td>
<td>This option is disabled for charts.</td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row Totals</td>
<td>This option is disabled for charts.</td>
</tr>
</tbody>
</table>

**Format Tab**

### Command Description

#### Destination Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>InfoMini</td>
<td>Enables the creation of an InfoMini application. For more information on using InfoMini, see <em>Building InfoMini Applications</em> on page 551.</td>
</tr>
<tr>
<td>Chart</td>
<td>Indicates that you are in Chart mode.</td>
</tr>
<tr>
<td>Report</td>
<td>Switches to Report mode. Converts a chart to a report using the fields specified in the chart.</td>
</tr>
<tr>
<td>File</td>
<td>Creates an image file from a chart. This option is disabled by default and is only enabled for HTML format.</td>
</tr>
</tbody>
</table>

**Chart Types Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar</td>
<td>Changes the chart type to a bar chart.</td>
</tr>
<tr>
<td>Pie</td>
<td>Changes the chart type to a pie chart.</td>
</tr>
<tr>
<td>Line</td>
<td>Changes the chart type to a line chart.</td>
</tr>
<tr>
<td>Area</td>
<td>Changes the chart type to an area chart.</td>
</tr>
<tr>
<td>Scatter</td>
<td>Changes the chart type to a scatter chart.</td>
</tr>
<tr>
<td>Choropleth</td>
<td>Changes the chart type to a choropleth map.</td>
</tr>
<tr>
<td>Proportional Symbol</td>
<td>Changes the chart type to a proportional symbol (bubble) map.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Other</td>
<td>Opens the Select a chart dialog box. The chart types, depicted by icons, display on the left side of the dialog box. The first chart type represents the bar chart category, which is selected by default. When a chart type is selected, the dialog box displays thumbnail images of bar chart variations that are supported.</td>
</tr>
<tr>
<td><strong>Map Group</strong></td>
<td></td>
</tr>
<tr>
<td>Background</td>
<td>Provides terrain options and various other geographical views. This option only displays when a map is selected as the chart type.</td>
</tr>
<tr>
<td>Demographic Layers</td>
<td>Allows you to apply one or more pre-defined demographic layers, which can narrow the scope of your data using these underlying layers of demographic categorization. This option only displays when a map is selected as the chart type.</td>
</tr>
<tr>
<td>Reference Layers</td>
<td>Enables you to define one or more reference layers, which creates borders based on your geographical selection. This option only displays when a map is selected as the chart type.</td>
</tr>
<tr>
<td><strong>Features Group</strong></td>
<td></td>
</tr>
<tr>
<td>3D Effect</td>
<td>Sets the three-dimensional view to on or off. The 3D Effect feature is disabled for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types. This is the default. This option is not available for maps.</td>
</tr>
<tr>
<td>Rotate</td>
<td>Toggles between a vertical display or horizontal display of a chart. For more information, see <a href="#">How to Rotate a Chart</a> on page 247. The Rotate feature is disabled for pie, scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types. This option is not available for maps.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Reference</td>
<td>Opens a drop-down menu that provides the Add Reference Line to Y-Axis and Add Reference Line to X-Axis options. Selecting one of these options opens the appropriate Reference Line dialog box, where you can set the specific X-axis or Y-axis value, type the text that you want, and position the reference line on a chart. For more information, see <em>How to Display a Static Reference Line</em> on page 248. The Reference feature is disabled for pie, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel chart types. This option is not available for maps. The reference line option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Annotate</td>
<td>Opens a drop-down menu that provides the Add an annotation option. Selecting this option opens the Annotation dialog box, where you can type the text that you want and position the annotation on a chart. For more information, see <em>How to Display Annotations</em> on page 251. The annotation option is not available in HTML5. This option is not available for maps. The annotation option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Grid</td>
<td>Opens a drop-down menu allowing you to expand options for Horizontal or Vertical Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking <em>More Options</em> opens the Format Grid Lines dialog box. This option is not available for maps. For more information, see <em>Formatting Gridlines</em> on page 205.</td>
</tr>
<tr>
<td>Frame &amp; Background</td>
<td>Opens the Frame &amp; Background dialog box where you can edit the background style and frames for charts. The dialog contains different options depending on the chart type selected. For more information, see <em>Formatting a Frame and a Background</em> on page 225.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Gauges</td>
<td>Opens the Gauge dialog box where you can edit your gauge chart. This button is only available when a gauge chart type is selected. This option is not available for maps. For more information, see <em>How to Style a Gauge Needle</em> on page 243. Gauge options are not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Analytic Document Options</td>
<td>Opens the Analytic Document Options dialog box where you can configure your interactive report options, such as menu items, graph engine, and colors. This button is available when the output type is set to HTML Analytic Document. This option is not available for maps.</td>
</tr>
<tr>
<td>Accessibility</td>
<td>Allows a title to be added to a report, chart, or document that is Section 508 compliant. This option is available for reports and charts when the output type is HTML, HTML5, or PDF. This includes JS Charts, which encompasses any chart that is drawn in an HTML environment using a defined data set and JavaScript Option Notation (JSON) definitions. For more information, see the <em>Creating HTML5 Charts With TIBCO WebFOCUS® Language</em> manual. For documents, the output type must be set to PDF. The chart features are unavailable when designing a chart that will be output in format.</td>
</tr>
</tbody>
</table>

**Labels Group**

<p>| Axes                         | Opens a drop-down menu, where you can enable and rotate horizontal and vertical axis labels, and stagger horizontal axis labels. You can also edit the axis labels by clicking <em>More Horizontal Axis Options</em> or <em>More Vertical Axis Options</em>. For more information, see <em>How to Format Axis Labels</em> on page 240. This option is not available for maps. |</p>
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Legend</td>
<td>Opens a drop-down menu, where you can select the Show Legend option to display the legend on the chart, or clear your selection to hide the legend, change the default legend position, and change the default legend orientation. For more information, see <em>Format Legend Dialog Box</em> on page 200.</td>
</tr>
<tr>
<td><strong>Interactive Group</strong></td>
<td></td>
</tr>
<tr>
<td>Interactive Options</td>
<td>Opens the Interactive Options dialog box, which enables you to specify animation and mouse over effects in your chart. This option is only available for HTML5 and outputs. This option is not available for maps.</td>
</tr>
<tr>
<td><strong>Run with Group</strong></td>
<td></td>
</tr>
<tr>
<td>Auto Drill</td>
<td>Enables you to navigate through different levels within the dimension hierarchy of your data source. Click <em>Auto Drill</em> to enable the functionality.</td>
</tr>
<tr>
<td><strong>Note:</strong> Auto Drill functionality requires the specification of at least one dimension sort field in the request. For more information, see <em>Using Auto Drill</em> on page 345.</td>
<td></td>
</tr>
<tr>
<td>Insight</td>
<td>Enables you to activate Insight, a powerful visualization tool that allows for the interactive selection of measures and dimensions. This allows you to create dynamic charts in real-time. This feature is available in HTML5 Chart mode only. Click <em>Insight</em> to enable the feature, and then click <em>Run</em> to launch it. For more information, see <em>Using Insight to Analyze Dynamic Charts</em> on page 120.</td>
</tr>
<tr>
<td><strong>Auto Linking Group</strong></td>
<td></td>
</tr>
<tr>
<td>Enable Auto Linking</td>
<td>Enables auto linking.</td>
</tr>
<tr>
<td>Auto Link Target</td>
<td>Sets procedure as an available target for auto linking.</td>
</tr>
</tbody>
</table>
## Data Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calculation Group</strong></td>
<td></td>
</tr>
<tr>
<td>Detail (Define)</td>
<td>Opens the Detail Field (DEFINE) dialog box, where you can create a defined field, type a name for the field, and enter a format. A Define field is an optional attribute used to create a virtual field for reporting. You can derive the virtual field value from information already in the data source (that is, from permanent fields).</td>
</tr>
<tr>
<td>Summary (Compute)</td>
<td>Opens the Summary Field (COMPUTE) dialog box, where you can create a computed field, type a name for the field, and enter a format.</td>
</tr>
<tr>
<td><strong>Join Group</strong></td>
<td></td>
</tr>
<tr>
<td>Join</td>
<td>Opens the Join dialog box, where you can create a new join, edit or delete existing joins, and add data sources to a join.</td>
</tr>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box, enabling you to set filtering options. Filter options include Where, Where Total, the And conjunction, and the Or conjunctions in a single expression.</td>
</tr>
<tr>
<td><strong>Display Group</strong></td>
<td></td>
</tr>
<tr>
<td>Missing Data</td>
<td>Includes options for how to display missing values in charts.</td>
</tr>
<tr>
<td><strong>Data Source Group</strong></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>Opens the Open dialog box, where you can add additional data sources to a document, enabling you to insert reports from different data sources into the same document. This option is only enabled if the chart was created from a HOLD file.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Switch</td>
<td>Opens a drop-down list of all the data sources that have been added. You can choose which data source is currently active and being used to create new reports. This option is only enabled if the chart was created from a HOLD file.</td>
</tr>
</tbody>
</table>

**Slicers Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Options Group</strong></td>
<td></td>
</tr>
<tr>
<td>New Group</td>
<td>Creates a new group of similar slicers.</td>
</tr>
<tr>
<td>Clear Slicers</td>
<td>Resets all slicers so that no filtering is done.</td>
</tr>
<tr>
<td>Update Preview</td>
<td>Applies slicers to preview.</td>
</tr>
<tr>
<td>Options</td>
<td>Opens the Edit Slicers dialog box to the General tab, where you can set general options for your slicers.</td>
</tr>
<tr>
<td><strong>Record Limit Group</strong></td>
<td></td>
</tr>
<tr>
<td>Preview</td>
<td>Sets the number of records retrieved from the data source for preview.</td>
</tr>
<tr>
<td>Run Time</td>
<td>Sets the number of records retrieved at run time.</td>
</tr>
<tr>
<td>Record Limit</td>
<td>Opens the Edit Slicers dialog box to the Record Limit tab, where you can set record limits for your slicers.</td>
</tr>
<tr>
<td><strong>Group Number Group</strong></td>
<td></td>
</tr>
<tr>
<td>Group $n$</td>
<td>Contains a group for each Slicer group that is added. Group 1 is the default slicer group to which you can drag fields to create slicers. To access slicer group options, click Group $n$ to open the Edit Slicers dialog box where you can rename the slicer group and modify the order of the slicers in the group.</td>
</tr>
</tbody>
</table>
## Layout Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Setup Group</strong></td>
<td></td>
</tr>
<tr>
<td>Margins</td>
<td>Enables you to set margin values by choosing Normal (1 inch all around), Narrow (.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom. Choosing Custom opens the Margins dialog box, where you can set specific margins as needed.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Enables you to set the orientation of your report to portrait or landscape.</td>
</tr>
<tr>
<td>Size</td>
<td>Enables you to select the size of the paper for printing output. You can choose A3, A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size (34 x 44 Inches).</td>
</tr>
<tr>
<td>Units</td>
<td>Enables you to select the unit of measurement used for customizing the dimension fields of your report or chart. You can choose Inches, Centimeters, or Points.</td>
</tr>
<tr>
<td>Page Numbers</td>
<td>This option is disabled for charts.</td>
</tr>
<tr>
<td><strong>Size &amp; Arrange Group</strong></td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>Sets the height of the chart.</td>
</tr>
<tr>
<td>Width</td>
<td>Sets the width of the chart.</td>
</tr>
<tr>
<td>Auto Overflow</td>
<td>This option is disabled for charts.</td>
</tr>
<tr>
<td>Aspect Ratio</td>
<td>Lock the height and width aspect ratio. With the aspect ratio locked, changing the width automatically changes the height to keep the component to scale, and changing the height automatically changes the width.</td>
</tr>
<tr>
<td>AutoFit</td>
<td>Expands the chart, at design time, when additional fields are added. At run time, the chart is resized dynamically to fit into the container in which it is placed. AutoFit is enabled, by default.</td>
</tr>
</tbody>
</table>
### Command | Description
--- | ---
Align | This option is available in Document mode only.
Relative Position | This option is available in Document mode only.

### View Tab

#### Design Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query (Design view)</td>
<td>Displays the Data, Query, and Filter panes across the entire canvas, eliminating Live Preview. This view provides a larger work area for creating the chart.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>Displays the chart on the canvas as you create the report. You can use the Live Preview to add, remove, and arrange fields, as well as style the chart.</td>
</tr>
<tr>
<td>Document (Design view)</td>
<td>Converts a chart into a document. Opens the document on canvas, which you can use to add text, images, lines, reports, and charts to create documents.</td>
</tr>
</tbody>
</table>

#### Show/Hide Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resources</td>
<td>Minimizes the Resources panel and expands the size of the canvas to also occupy the area where the Resources panel typically appears. The canvas can display a preview of a report, output of a report, or the Query Design pane.</td>
</tr>
</tbody>
</table>

#### Data Panel Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logical</td>
<td>Displays the data source fields by type. This is the default view. The Logical view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>List</td>
<td>Displays the data source fields in a tabular list format. This list contains a header row. You can sort fields differently by clicking a column header. The List view options include Title, Description, Field, Alias, Format, Segment, Filename, and Reference.</td>
</tr>
<tr>
<td>Structured</td>
<td>Displays the hierarchical structure of the data source files. The Structured view options include Title, Description, Field, and Alias.</td>
</tr>
</tbody>
</table>

**Query Panel Group**

| Areas 2x2   | Displays data in a two column by two-row grid. This option is disabled for charts that use the new field container syntax.                        |
| Areas 1x4   | Displays data in a one column by four-row grid. This option is disabled for charts that use the new field container syntax.                     |
| Tree        | Displays data in a tree. This is the default.                                                                                               |

**Output Window Group**

| Arrange      | Opens a drop-down menu where you can choose how to display multiple output windows. The options are Cascade, Tile Horizontally, and Tile Vertically. |
| Output Location | Opens a drop-down menu where you can choose how to direct new output. The options are Single tab (default), New Tab, Single Window, and New Window. |
| Switch Output | Opens a drop-down menu for choosing to view any active output window.                                                                          |

**Report Group**

| Switch Report | Lists any active report or chart to which you can switch.                                                                                     |
### Field Tab

**Note:** The Format group is disabled in Chart mode.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Removes, but does not delete, the filter from the chart.</td>
</tr>
<tr>
<td>Include</td>
<td>Restores a filter that was previously excluded from a chart.</td>
</tr>
</tbody>
</table>
| Prompt | Opens the Create a filtering condition dialog box for creating an auto prompting parameter that you can select when you run a chart. The Create a filtering condition dialog box is used to create both filters and auto prompting parameters. The following prompt options are available when Parameter is selected from the Type drop-down menu:  

- **Simple.** This is used for prompts using Text Input. This is the default value.
- **Static.** This is used for prompts using Selection. This option allows you to select multiple values at run time.
- **Dynamic.** This is used for prompts using Data Values. This option allows you to select multiple values at run time.
- **Optional.** This is used for prompts using Single or Multiselect parameters. |
<p>| <strong>Sort Group</strong> | |
| Up | Sorts the selected field in ascending order. |</p>
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Down</td>
<td>Sorts the selected field in descending order.</td>
</tr>
<tr>
<td>Rank</td>
<td>This option is disabled for charts.</td>
</tr>
<tr>
<td>Group</td>
<td>Opens the Create a Group dialog box where you can create a group to combine values together. This option is enabled for dimension fields only.</td>
</tr>
<tr>
<td>Limit</td>
<td>Opens a drop-down menu that allows you to specify the number of unique values to display for a sort group that has been added.</td>
</tr>
</tbody>
</table>

**Format Group**

*Note:* These options are disabled for charts.

**Display Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Field</td>
<td>Allows you to hide a selected field.</td>
</tr>
<tr>
<td>Hide Missing</td>
<td>Allows you to hide fields that have no value. This option is disabled for charts.</td>
</tr>
<tr>
<td>Aggregation</td>
<td>Opens a drop-down menu of the following options: None (default), Sum, Average, Count, Count Distinct, Percent of Count, First Value, Last Value, Maximum, Minimum, Total, Percent, Row Percent, Median, Average Square. This option is only available for measure fields or dimensions (alpha field only) that are in a numeric field container. Otherwise, aggregations will not display.</td>
</tr>
<tr>
<td>Traffic Lights</td>
<td>Opens the Traffic Light Condition dialog box. From this dialog box, you can add new conditional styling by applying traffic light (and other) colors to a selected field in the output when the field meets specified criteria, modify existing conditional styling, and enable conditional drill-down. This option is only available for measure fields.</td>
</tr>
<tr>
<td>Data Bars</td>
<td>This option is disabled for charts.</td>
</tr>
</tbody>
</table>
### Command Description

**Within**
Allows you to use specific aggregation tasks at different report levels. You can use the Within phrase to manipulate display field values as they are aggregated within a sort group rather than a report column. This option is disabled for charts.

**Column(s)**
Allows you to indicate the number of columns in which you wish to display multiple graphs. The value can be between 1 and 512. The default is 1. This option is also available from the Query Design pane shortcut menu for a Multi-graph component. This option is only enabled when the multi-graph field container is populated.

### Links Group

**Drill Down**
Opens the Drill Down dialog box, where you can configure a hyperlink or a drill-down procedure for the selected field. Clicking that field in the report output, at run time, redirects you to the URL you specified or executes the indicated procedure. This option is available for measure fields only. If you are working in PDF format, this option is disabled.

### Series Tab

#### Command Description

**Select Group**

| Series drop-down list | Lists the available series in the current chart. |

**Style Group**

<p>| Style | Opens the Format Series dialog box, where you can edit the styling options for the selected series. You can also open this dialog box by right-clicking a series, and then clicking More Style Options. |</p>
<table>
<thead>
<tr>
<th><strong>Command</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Properties Group</strong></td>
<td></td>
</tr>
<tr>
<td>Data Labels</td>
<td>Adds data labels to the chart. The drop-down menu contains the following data position options for selecting where to display data values as labels on a chart: Above (default), On top edge, Below top edge, Center, and Base. If you are working with a Pie chart, the options are: On Slice, Outside Slice, and Outside with feeler lines. Clicking <em>More Data Label Options</em> opens the Format Labels dialog box, where you can further edit your data labels.</td>
</tr>
<tr>
<td>Type</td>
<td>Opens a drop-down menu with the following options for selecting different chart types: None (default), Bar, Line, and Area. <strong>Note:</strong> When you make a change to the chart type using the Type button on the Series tab, changes to the chart type on the Format tab are overwritten.</td>
</tr>
<tr>
<td>Trendline</td>
<td>Opens a drop-down menu that provides options for adding a trendline to a chart.</td>
</tr>
<tr>
<td>Equation</td>
<td>Displays the associated mathematical equation for the selected trendline on the chart. The equation is not available in HTML5. The equation option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td><strong>Line Group</strong></td>
<td></td>
</tr>
<tr>
<td>Smooth Line</td>
<td>Draws the chart using smooth lines. The smooth line option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Connect Lines</td>
<td>Controls the display of connecting lines between markers on a line or scatter chart. By default, lines are connected on a line chart and disconnected on a scatter chart.</td>
</tr>
</tbody>
</table>
Ribbon Commands for Documents

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Marker</td>
<td>Opens a drop-down menu from which you can select options to change the display of the default data and legend markers on line and scatter chart types. For more information, see <em>How to Change the Appearance of a Marker</em> on page 183. The marker option is not available in InfoAssist Basic.</td>
</tr>
</tbody>
</table>

**Pie Group**

*Note:* The following options are only enabled when you are working with a pie chart.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand</td>
<td>Expands pie slices.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides pie slices.</td>
</tr>
</tbody>
</table>

**Ribbon Commands for Documents**

When creating and customizing documents in Document mode, you can use the following ribbons and commands to customize document functionality.

**Home Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Format Group</strong></td>
<td>Displays a drop-down menu of all supported output formats.</td>
</tr>
<tr>
<td>Output File Format</td>
<td></td>
</tr>
<tr>
<td>Chart</td>
<td>Determines whether chart-specific functionality is available in the InfoAssist tool. The default name Chart (data source) is given for each new chart created in a given InfoAssist session, where data source is the name of the underlying data source you are using. You can rename the chart by right-clicking Chart in the Query pane and clicking Rename.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Report</td>
<td>Determines whether report-specific functionality is available in the InfoAssist tool. The default name Report (data source) is given for each new report created in a given InfoAssist session, where data source is the name of the underlying data source you are using. You can rename the report by right-clicking Report in the Query pane and clicking Rename.</td>
</tr>
<tr>
<td>File</td>
<td>Creates a data file from a report component of a document.</td>
</tr>
<tr>
<td><strong>Design Group</strong></td>
<td></td>
</tr>
<tr>
<td>Query (Design view)</td>
<td>This option is disabled in Document mode.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>This option is disabled in Document mode.</td>
</tr>
<tr>
<td>Document (Design view)</td>
<td>Once you are in Document mode, it is selected by default in the Design group. The document displays on the canvas, to which you can add text, images, lines, reports, and charts.</td>
</tr>
<tr>
<td>Data from Source</td>
<td>Uses the selected data source to display a live preview of the output on the canvas.</td>
</tr>
<tr>
<td>Use Sample Data</td>
<td>Displays sample data, which reduces processing time by eliminating the need to access the actual data source.</td>
</tr>
<tr>
<td>Records</td>
<td>Limits the number of rows retrieved from the data source when Live Preview is selected. This feature is useful in reducing response time if you are working with a large amount of data. Type the number of rows that you want directly in the Records field, or use the drop-down menu to select one of the preset record limits. The preset choices are All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.</td>
</tr>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Turns off a filter.</td>
</tr>
<tr>
<td>Include</td>
<td>Turns on a filter.</td>
</tr>
</tbody>
</table>

**Clipboard Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Paste</td>
<td>Enables you to paste a text, report, or chart object that you have copied to or placed on the clipboard.</td>
</tr>
<tr>
<td>Cut</td>
<td>Enables you to cut a text, report, or chart object from your document, placing it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Enables you to copy a text, report, or chart object to the clipboard.</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Enables you to duplicate a text, report, or chart object in your document, placing it on the clipboard.</td>
</tr>
</tbody>
</table>

**Report Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Theme</td>
<td>Opens a dialog box where you can select a theme to style your report or chart. You can use the default style sheet by clicking the <em>Use Default Stylesheet</em> button. You can also select a document styling theme or an application theme to style all reports created. Use the Environment and Styling section of the Options window, which is accessible by clicking <em>Options</em> in the Application main menu.</td>
</tr>
<tr>
<td>Style</td>
<td>Opens a Report Style dialog box for applying global styling to the entire report. This option is disabled for charts in Document mode. For more information about styling reports, see <em>Styling Reports</em> on page 90.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Banded</td>
<td>Opens a Color dialog box for choosing a color that provides an alternating color scheme for the report. The report output displays alternating rows of data, using a white background for one row and a background of the selected color for the next row. This pattern continues throughout the report. This option is disabled for charts in Document mode.</td>
</tr>
<tr>
<td>Header &amp; Footer</td>
<td>Opens the Header &amp; Footer dialog box, from which you can add and style headings and footings.</td>
</tr>
<tr>
<td>Column Totals</td>
<td>Adds a grand total row to the bottom of the report to sum numeric data in each column. This option is disabled for charts in Document mode.</td>
</tr>
<tr>
<td>Row Totals</td>
<td>Adds a grand total column to the right side of the report to sum numeric data in each row. This option is disabled for charts in Document mode.</td>
</tr>
</tbody>
</table>

**Insert Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pages Group</td>
<td></td>
</tr>
<tr>
<td>Page</td>
<td>Adds a new page to a document.</td>
</tr>
<tr>
<td>Reports Group</td>
<td></td>
</tr>
<tr>
<td>Report</td>
<td>Inserts a report placeholder on the canvas.</td>
</tr>
<tr>
<td>Chart</td>
<td>Inserts a chart placeholder on the canvas.</td>
</tr>
<tr>
<td>Existing Report</td>
<td>Opens the Open dialog box, where you can browse to the report that you want to insert in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>Objects Group</td>
<td></td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text Box</td>
<td>Inserts an inline text object in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>Image</td>
<td>Opens the Open dialog box, where you can browse to the image that you want to insert in the upper-left corner of the canvas.</td>
</tr>
</tbody>
</table>

#### Analytic Document Prompts group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drop Down</td>
<td>Inserts a drop-down control placeholder in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>List</td>
<td>Inserts a list control placeholder in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>Checkbox</td>
<td>Inserts a check box control placeholder in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>Radio Button</td>
<td>Inserts a radio button control placeholder in the upper-left corner of the canvas.</td>
</tr>
<tr>
<td>Text</td>
<td>Inserts a text area control placeholder in the upper-left corner of the canvas.</td>
</tr>
</tbody>
</table>

### Format Tab

#### Destination Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>InfoMini</td>
<td>Enables the creation of an InfoMini application. For more information on using InfoMini, see <em>Understanding and Building InfoMini Applications</em>.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Report</td>
<td>Makes report-specific functionality available. In Document mode, if you select a report object, the Report option is enabled on the Home tab and the ribbon options change. For more information, see <em>Ribbon Commands for Reports</em> on page 559.</td>
</tr>
<tr>
<td>Chart</td>
<td>Makes chart-specific functionality available. In Document mode, if you select a chart object, the Chart option is enabled on the Home tab and the ribbon options change. For more information, see <em>Ribbon Commands for Charts</em> on page 574.</td>
</tr>
<tr>
<td>File</td>
<td>Creates a data file from a report component of a document.</td>
</tr>
<tr>
<td>Navigation Group</td>
<td></td>
</tr>
<tr>
<td>Table</td>
<td>Generates standard browser output. This is the default. This option is only available for reports in Document mode.</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>Generates output by displaying a table of contents icon in the upper-left corner where report output typically appears. Clicking <em>Table of Contents</em> opens a menu that enables you to select (view) individual values of the first Sort By (By) field, one value at a time. You can also select options to view the entire report or remove the table of contents. This option is unavailable for charts in Document mode, and is disabled for reports in Document mode.</td>
</tr>
<tr>
<td>Freeze</td>
<td>Generates output with column titles that freeze (remain in view) when you scroll through pages of the report output. This option is unavailable for charts in Document mode, and is disabled for reports in Document mode.</td>
</tr>
<tr>
<td>Pages On Demand</td>
<td>Provides access to two distinct features depending upon the output type that you have selected. This option is available for reports in Document mode.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Features Group</strong></td>
<td></td>
</tr>
<tr>
<td>Title Popup</td>
<td>Displays pop-up titles when the mouse pointer hovers over a column title in the report output. When working with reports in Document mode, this option is disabled.</td>
</tr>
<tr>
<td>Accordion</td>
<td>Creates expandable views of data for each vertical sort field. This option displays data values only for the first vertical sort field when you first view the output. You can manually expand your view to expose the data values of lower-level sort fields.</td>
</tr>
<tr>
<td>Repeat Sort Value</td>
<td>Displays all repeated sort values instead of blanks in the output after the first instance of a new sort value, which is the default behavior.</td>
</tr>
<tr>
<td>Stack Measures</td>
<td>Displays all numeric measure field names in a column of the report output with the corresponding numeric data values. For more information on Stacked Measures, see the Stacking Columns topic in the Creating Reports With TIBCO WebFOCUS® Language manual.</td>
</tr>
<tr>
<td>Analytic Document Options</td>
<td>Opens the Analytic Document Options dialog box where you can configure your interactive report options such as menu items, graph engine, and colors. For more information, see Creating Interactive Content on page 475.</td>
</tr>
<tr>
<td>Accessibility</td>
<td>Allows a title to be added to a report, chart, or document that is Section 508-compliant.</td>
</tr>
<tr>
<td><strong>Run with Group</strong></td>
<td></td>
</tr>
<tr>
<td>Auto Drill</td>
<td>This option is disabled in Document mode.</td>
</tr>
<tr>
<td>Insight</td>
<td>This option is disabled in Document mode.</td>
</tr>
</tbody>
</table>
## Data Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Calculation Group</strong></td>
<td></td>
</tr>
<tr>
<td>Detail (Define)</td>
<td>Opens the Detail Field (DEFINE) dialog box, where you can create a defined field, type a name for the field, and enter a format. A Define field is an optional attribute used to create a virtual field for reporting. You can derive the virtual field value from information already in the data source (that is, from permanent fields).</td>
</tr>
<tr>
<td>Summary (Compute)</td>
<td>Opens the Summary Field (COMPUTE) dialog box, where you can create a computed field, type a name for the field, and enter a format.</td>
</tr>
<tr>
<td><strong>Join Group</strong></td>
<td></td>
</tr>
<tr>
<td>Join</td>
<td>Opens the Join dialog box, where you can create a new join, edit or delete existing joins, and add data sources to a join.</td>
</tr>
<tr>
<td><strong>Filter Group</strong></td>
<td></td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box, enabling you to set filtering options. Filter options include Where, Where Total, the And conjunction, and the Or conjunctions in a single expression.</td>
</tr>
<tr>
<td><strong>Display Group</strong></td>
<td></td>
</tr>
<tr>
<td>Missing Data</td>
<td>Includes options for how to display missing values in charts.</td>
</tr>
<tr>
<td><strong>Data Source Group</strong></td>
<td></td>
</tr>
<tr>
<td>Add</td>
<td>Opens the Open dialog box, where you can add additional data sources to a document, enabling you to insert reports from different data sources into the same document.</td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch</td>
<td>Opens a drop-down list of all the data sources that have been added. You can choose which data source is currently active and being used to create new reports.</td>
</tr>
</tbody>
</table>

### Slicers Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Options Group</strong></td>
<td></td>
</tr>
<tr>
<td>New Group</td>
<td>Creates a new group of similar slicers.</td>
</tr>
<tr>
<td>Clear Slicers</td>
<td>Resets all slicers so that no filtering is done.</td>
</tr>
<tr>
<td>Update Preview</td>
<td>Applies slicers to preview.</td>
</tr>
<tr>
<td>Options</td>
<td>Provides access to the Edit Slicers dialog box. For more information, see <em>Using Slicers</em> on page 539.</td>
</tr>
<tr>
<td><strong>Record Limit Group</strong></td>
<td></td>
</tr>
<tr>
<td>Preview</td>
<td>Sets the number of records retrieved from the data source for preview.</td>
</tr>
<tr>
<td>Run Time</td>
<td>Sets the number of records retrieved at run time.</td>
</tr>
<tr>
<td>Record Limit</td>
<td>Provides access to the Edit Slicers dialog box, where you can modify record limit settings. For more information, see <em>Using Slicers</em> on page 539.</td>
</tr>
<tr>
<td><strong>Group Number Group</strong></td>
<td></td>
</tr>
<tr>
<td>Group n</td>
<td>Contains a group for each Slicer group that is added. Group 1 is the default slicer group to which you can drag fields to create slicers.</td>
</tr>
</tbody>
</table>
## Layout Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Page Setup Group</strong></td>
<td></td>
</tr>
<tr>
<td>Margins</td>
<td>This option is disabled in Document mode.</td>
</tr>
<tr>
<td>Orientation</td>
<td>Enables you to set the orientation of your report to portrait or landscape.</td>
</tr>
<tr>
<td>Size</td>
<td>Enables you to select the size of the paper for printing output. You can choose A3, A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size (34 x 44 Inches).</td>
</tr>
<tr>
<td>Units</td>
<td>Enables you to select the unit of measurement used for customizing the dimension fields of your report or chart. You can choose Inches, Centimeters, or Points.</td>
</tr>
<tr>
<td>Page Numbers</td>
<td>Enables you to select page numbering options. You can choose one of the following:</td>
</tr>
<tr>
<td></td>
<td>- No Lead (no space for headers)</td>
</tr>
<tr>
<td></td>
<td>- On (page numbers only in headers)</td>
</tr>
<tr>
<td></td>
<td>- Off (space for headers, but no page numbering)</td>
</tr>
<tr>
<td></td>
<td>The Page Numbers value is overridden by header and footer text options.</td>
</tr>
<tr>
<td><strong>Size &amp; Arrange Group</strong></td>
<td></td>
</tr>
<tr>
<td>Height</td>
<td>Sets the height of the selected document component.</td>
</tr>
<tr>
<td>Width</td>
<td>Sets the width of the selected document component.</td>
</tr>
<tr>
<td>Auto Overflow</td>
<td>Automatically expands the query area to show all data.</td>
</tr>
<tr>
<td>Aspect Ratio</td>
<td>Lock the height and width aspect ratio.</td>
</tr>
<tr>
<td>AutoFit</td>
<td>In Document mode, this option is disabled.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Align</td>
<td>Opens a drop-down menu of available alignment options, when two or more document components are selected.</td>
</tr>
<tr>
<td>Relative Position</td>
<td>Positions the top-left corner of the lower component, to the bottom-left corner of the higher component, when two or more document components are selected.</td>
</tr>
<tr>
<td>Size and Arrange</td>
<td>Opens the Size and Position dialog box where you can set size and position options for the object in your document.</td>
</tr>
</tbody>
</table>

**Report Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cell Padding</td>
<td>Opens the Cell Padding dialog box, where you can set specific values to control the amount of space inserted between rows and columns in a report. For more information, see How to Use Cell Padding in a Report on page 99.</td>
</tr>
<tr>
<td>Autofit Column</td>
<td>When working with a report component, this option automatically compresses the columns in the report to the width of the widest data instance. Autofit Column is selected, by default.</td>
</tr>
</tbody>
</table>

**View Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Group</td>
<td></td>
</tr>
<tr>
<td>Query (Design view)</td>
<td>This option is unavailable in Document mode.</td>
</tr>
<tr>
<td>Live Preview (Design view)</td>
<td>This option is unavailable in Document mode.</td>
</tr>
<tr>
<td>Document</td>
<td>Enables Document mode by default.</td>
</tr>
</tbody>
</table>

**Show/Hide Group**
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Resources</td>
<td>Minimizes the Resources panel and expands the size of the canvas to also occupy the area where the Resources panel typically appears. The canvas can display a preview of a report, output of a report, or the Query Design pane.</td>
</tr>
<tr>
<td>Ruler</td>
<td>Displays a ruler above the canvas and to the left of the canvas for a document.</td>
</tr>
<tr>
<td>Grid</td>
<td>Displays a grid as a visual aid for aligning objects in a document.</td>
</tr>
<tr>
<td>Relationships</td>
<td>Shows the relative positioning relationship among objects.</td>
</tr>
<tr>
<td><strong>Data Panel Group</strong></td>
<td></td>
</tr>
<tr>
<td>Logical</td>
<td>Displays the data source fields by type. This is the default view. The Logical view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td>List</td>
<td>Displays the data source fields in a tabular list format. This list contains a header row. You can sort fields differently by clicking a column header. The List view options include Title, Description, Field, Alias, Format, Segment, Filename, and Reference.</td>
</tr>
<tr>
<td>Structured</td>
<td>Displays the hierarchical structure of the data source files. The Structured view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td><strong>Query Panel Group</strong></td>
<td></td>
</tr>
<tr>
<td>Areas 2x2</td>
<td>Displays data in a two column by two-row grid. When working with the new field container syntax, this option is unavailable.</td>
</tr>
<tr>
<td>Areas 1x4</td>
<td>Displays data in a one column by four-row grid. When working with the new field container syntax, this option is unavailable.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Tree</td>
<td>Displays data in a tree. This is the default.</td>
</tr>
</tbody>
</table>

**Output Window Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrange</td>
<td>Opens a drop-down menu where you can choose how to display multiple output windows. The options are Cascade, Tile Horizontally, and Tile Vertically.</td>
</tr>
<tr>
<td>Output Location</td>
<td>Opens a drop-down menu where you can choose how to direct new output. The options are Single tab (default), New Tab, Single Window, and New Window.</td>
</tr>
<tr>
<td>Switch Output</td>
<td>Opens a drop-down menu for choosing to view any active output window.</td>
</tr>
</tbody>
</table>

**Report Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Report</td>
<td>Lists any active report or chart to which you can switch.</td>
</tr>
</tbody>
</table>

**Field Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Group</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Filter</td>
<td></td>
</tr>
<tr>
<td>Exclude</td>
<td>Removes, but does not delete, the filter from the report or chart.</td>
</tr>
<tr>
<td>Include</td>
<td>Restores a filter that was previously excluded from a report or chart.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>Prompt</td>
<td>Opens the Create a filtering condition dialog box for creating an auto prompting parameter that you can select when you run a report. The Create a filtering condition dialog box is used to create both filters and auto prompting parameters. The following prompt options are available when Parameter is selected from the Type dropdown menu:</td>
</tr>
<tr>
<td></td>
<td>- <strong>Simple.</strong> This is used for prompts using Text Input. This is the default value.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Static.</strong> This is used for prompts using Selection. This option allows you to select multiple values at run-time.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Dynamic.</strong> This is used for prompts using Data Values. This option allows you to select multiple values at run-time.</td>
</tr>
<tr>
<td></td>
<td>- <strong>Optional.</strong> This is used for prompts using Single or Multiselect parameters.</td>
</tr>
<tr>
<td>Sort Group</td>
<td></td>
</tr>
<tr>
<td>Up</td>
<td>Sorts the selected field in ascending order.</td>
</tr>
<tr>
<td>Down</td>
<td>Sorts the selected field in descending order.</td>
</tr>
<tr>
<td>Rank</td>
<td>Inserts a rank column immediately to the left of the report if a Sort By field is selected. It also adds a rank column to the left of the Sort By field if a Measure field is selected. Ranking a Measure field results in two copies of the field, the original Measure field, and the Sort By field that is created during ranking.</td>
</tr>
<tr>
<td>Group</td>
<td>Opens the Create a Group dialog box where you can create a group to combine values together.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Limit</td>
<td>Opens a drop-down menu that allows you to specify the number of unique values to display for a sort group that has been added.</td>
</tr>
<tr>
<td><strong>Break Group</strong></td>
<td></td>
</tr>
<tr>
<td>Page Break</td>
<td>Starts a new page when the primary sort field changes. Clicking the drop-down icon enables you to select <em>Reset Page Numbers</em>, which allows you to reset page numbers on a page break to start at 1.</td>
</tr>
<tr>
<td>Line Break</td>
<td>Inserts a line in the report output when the primary sort field changes.</td>
</tr>
<tr>
<td>Subtotal</td>
<td>Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric fields when the primary sort field changes.</td>
</tr>
<tr>
<td>Sub Header</td>
<td>Opens a dialog box where you can type text to add a subheading just below the column titles in the report output when the primary sort field changes.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>Opens a dialog box where you can type text to add a subfooting at the end of the data on each page of the report output when the primary sort field changes.</td>
</tr>
<tr>
<td><strong>Style Group</strong></td>
<td></td>
</tr>
<tr>
<td>Note: The options in this group are only available for reports in Document mode.</td>
<td></td>
</tr>
<tr>
<td>Font</td>
<td>Opens the Font list, which you can use to change the font.</td>
</tr>
<tr>
<td>Font Size</td>
<td>Opens the Font Size list, which you can use to change the numeric value for the font size.</td>
</tr>
<tr>
<td>Font Color</td>
<td>Opens the Color dialog box, where you can select the font color.</td>
</tr>
<tr>
<td>Style Reset</td>
<td>Resets all settings to the default settings from the template.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Bold</strong></td>
<td>Applies bold font formatting to the selected text.</td>
</tr>
<tr>
<td><strong>Italic</strong></td>
<td>Applies italic font formatting to the selected text.</td>
</tr>
<tr>
<td><strong>Underline</strong></td>
<td>Underlines the selected text.</td>
</tr>
<tr>
<td><strong>Justify Left</strong></td>
<td>Aligns the text to the left of the visual.</td>
</tr>
<tr>
<td><strong>Justify Center</strong></td>
<td>Aligns the text to the center of the visual.</td>
</tr>
<tr>
<td><strong>Justify Right</strong></td>
<td>Aligns the text to the right of the visual.</td>
</tr>
<tr>
<td><strong>Background Color</strong></td>
<td>Opens the Color dialog box, where you can select the background color for the visual.</td>
</tr>
<tr>
<td><strong>Data Style</strong></td>
<td>Styles only the data for the selected data source field.</td>
</tr>
<tr>
<td><strong>Title Style</strong></td>
<td>Styles only the column title for the selected data source field.</td>
</tr>
<tr>
<td><strong>Data + Title</strong></td>
<td>Styles both the data and the column title for the selected data source field.</td>
</tr>
</tbody>
</table>

### Format Group

**Note:** The options in this group are only available for reports in Document mode.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Change currency options</strong></td>
<td>Changes the currency options for the selected field.</td>
</tr>
<tr>
<td><strong>Percent</strong></td>
<td>Specifies the value of the field as a percentage.</td>
</tr>
<tr>
<td><strong>Comma</strong></td>
<td>Specifies the use of commas for the selected field.</td>
</tr>
<tr>
<td><strong>Increase Decimal Places</strong></td>
<td>Increases the number of decimal places that display for the selected field.</td>
</tr>
<tr>
<td><strong>Decrease Decimal Places</strong></td>
<td>Decreases the number of decimal places that display for the selected field.</td>
</tr>
</tbody>
</table>

### Display Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hide Field</strong></td>
<td>Allows you to hide a selected field.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Hide Missing</td>
<td>Allows you to hide fields that have no value.</td>
</tr>
<tr>
<td>Aggregation</td>
<td>Opens a drop-down menu of the following options: None (default), Sum, Average, Count, Count Distinct, Percent of Count, First Value, Last Value, Maximum, Minimum, Total, Percent, Row Percent, Median, Average Square.</td>
</tr>
<tr>
<td>Traffic Lights</td>
<td>Opens the Traffic Light Condition dialog box. From this dialog box, you can add new conditional styling by applying traffic light (and other) colors to a selected field in the output when the field meets specified criteria, modify existing conditional styling, and enable conditional drill-down.</td>
</tr>
<tr>
<td>Within</td>
<td>Allows you to use specific aggregation tasks at different report levels. You can use the Within phrase to manipulate display field values as they are aggregated within a sort group rather than a report column.</td>
</tr>
<tr>
<td>Data Bars</td>
<td>Adds a data visualization column to the right of a selected numeric field. The column displays values in each row using horizontal bars that extend from left to right in varying lengths, depending on the corresponding data values.</td>
</tr>
<tr>
<td>Column(s)</td>
<td>Allows you to indicate the number of columns in which you wish to display multiple graphs. The value can be between 1 and 512. The default is 1. This option is also available from the Query Design pane shortcut menu for a Multi-graph component.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Drill Down</td>
<td>Opens the Drill Down dialog box, where you can configure a hyperlink or a drill-down procedure for the selected field. Clicking that field in the report output, at run time, redirects you to the URL you specified or executes the indicated procedure. This option is disabled in Document mode.</td>
</tr>
</tbody>
</table>

**Series Tab**

In Document mode, the Series tab is enabled for chart components.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Group</strong></td>
<td></td>
</tr>
<tr>
<td>Series drop-down list</td>
<td>Lists the available series in the current chart.</td>
</tr>
<tr>
<td><strong>Style Group</strong></td>
<td></td>
</tr>
<tr>
<td>Style</td>
<td>Opens the Format Series dialog box, where you can edit the styling options for the selected series. You can also open this dialog box by right-clicking a series, and then clicking More Style Options.</td>
</tr>
<tr>
<td><strong>Properties Group</strong></td>
<td></td>
</tr>
<tr>
<td>Data Labels</td>
<td>Adds data labels to the chart. The drop-down menu contains the following data position options for selecting where to display data values as labels on a chart: Above (default), On top edge, Below top edge, Center, and Base. If you are working with a Pie chart, the options are: On Slice, Outside Slice, and Outside with feeler lines. Clicking More Data Label Options opens the Format Labels dialog box, where you can further edit your data labels.</td>
</tr>
<tr>
<td>Trendline</td>
<td>Opens a drop-down menu that provides options for adding a trendline to a chart.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>Equation</td>
<td>Displays the associated mathematical equation for a trendline on a chart.</td>
</tr>
</tbody>
</table>

**Line Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Smooth Line</td>
<td>Draws the chart using smooth lines. The smooth line option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Connect Lines</td>
<td>Controls the display of connecting lines between markers on a line or scatter chart. By default, lines are connected on a line chart and disconnected on a scatter chart.</td>
</tr>
<tr>
<td>Marker</td>
<td>Opens a drop-down menu from which you can select options to change the display of the default data and legend markers on line and scatter chart types. For more information, see <em>How to Change the Appearance of a Marker</em> on page 183. The marker option is not available in InfoAssist Basic.</td>
</tr>
</tbody>
</table>

**Pie group**

*Note:* The following options are only enabled when you are working with a pie chart.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand</td>
<td>Expands pie slices.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides pie slices.</td>
</tr>
</tbody>
</table>

**Ribbon Commands for Visualizations**

When creating and customizing visualizations in Visualizations mode, you can use the following ribbons and commands to customize visualization functionality.

**Home Tab**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clipboard Group</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Paste</td>
<td>Enables you to paste a text, report, or chart object that you have copied to or placed on the clipboard.</td>
</tr>
<tr>
<td>Cut</td>
<td>Enables you to cut a text, report, or chart object from your document, placing it on the clipboard.</td>
</tr>
<tr>
<td>Copy</td>
<td>Enables you to copy a text, report, or chart object to the clipboard.</td>
</tr>
<tr>
<td>Duplicate</td>
<td>Enables you to duplicate a text, report, or chart object in your document, placing it on the clipboard.</td>
</tr>
</tbody>
</table>

**Data Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculation</td>
<td>Opens a menu from which you can choose to create Define or Compute fields.</td>
</tr>
<tr>
<td>Join</td>
<td>Opens the Join dialog box, where you can create a new join, edit or delete existing joins, and add data sources to a join. You can also create blends, which allow you to combine data from local or system resources into your current data source.</td>
</tr>
</tbody>
</table>

**Visual Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert</td>
<td>Inserts a new visual. The left side of the Insert button inserts the default visual, which is a stacked bar chart. Click the down arrow next to the Insert button to specify a visual type, such as a chart, grid, or text.</td>
</tr>
<tr>
<td>Change</td>
<td>Opens the Select a Visual menu, from which you can select the type of chart, map, or grid that you want to add to your visualization.</td>
</tr>
</tbody>
</table>
### Command Description

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Swap</td>
<td>Changes the vertical or horizontal orientation of data in a visual. When you add one or more fields to the canvas, Swap is enabled. When you have data fields in the vertical and horizontal field containers, clicking Swap switches the axis of these data fields to display on the opposite axis. When working with matrix charts, the rows and columns are similarly switched when you click Swap. Swap is available for bar, line, area, scatter, bubble, and matrix marker charts. It is also available for grids. <strong>Note:</strong>&lt;br&gt;☑ Swap is disabled when the canvas is empty.&lt;br&gt;☑ Swap is unavailable for maps.</td>
</tr>
</tbody>
</table>

| Clear   | Clears the current visual. You can use the split button to select the option to clear a component, or the entire visualization, which clears all visuals on the canvas. If you have created a filter, you can also clear it. The Clear button is disabled until you begin developing a visual on the canvas. |

### Storyboard Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td>Takes a snapshot of the current visual or visualization, adding it to the storyboard.</td>
</tr>
<tr>
<td>Show</td>
<td>Opens your storyboard as a PowerPoint presentation, where you can choose to view or save your storyboard. All storyboards display in Microsoft PowerPoint format.</td>
</tr>
</tbody>
</table>

### Format Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Group</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Theme</td>
<td>Opens the Templates dialog box, where you can select a theme to style your grid. You can use the default style sheet by clicking the <em>Use Default Stylesheet</em> button. You can also select a styling theme for your grid or an application theme to style all visualizations created.</td>
</tr>
<tr>
<td>Header &amp; Footer</td>
<td>Opens the Header &amp; Footer dialog box, from which you can add and style headings and footings.</td>
</tr>
<tr>
<td>Column Totals</td>
<td>Adds a grand total row to the bottom of the grid object to sum numeric data in each column.</td>
</tr>
<tr>
<td>Row Totals</td>
<td>This option is not supported in Visualization mode.</td>
</tr>
</tbody>
</table>

**Features Group**

**Note:** These options do not display for grids or maps, with the exception of Frame & Background.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reference</td>
<td>Opens the reference menu, where you can access the Add Reference Line to Y-Axis and Add Reference Line to X-Axis options. Selecting one of these options opens the Reference Line dialog box, where you can set the following: the X-axis or Y-axis value, the text that you want to appear, and the position of the reference line on a chart.</td>
</tr>
<tr>
<td>Grid</td>
<td>Opens the grid menu, where you can access the Horizontal or Vertical Gridlines options. Both selections allow you to enable or disable Major and Minor Gridlines. Clicking <em>More Grid Lines Options</em> opens the Format Grid Lines dialog box.</td>
</tr>
<tr>
<td>Frame &amp; Background</td>
<td>Opens the Frame &amp; Background dialog box, where you can edit the background style and frames for charts. This dialog box contains different options depending on the chart type that you have selected.</td>
</tr>
</tbody>
</table>

**Labels Group**
### Axes
- Opens the Axes menu, where you can enable and rotate horizontal and vertical axis labels, as well as stagger horizontal axis labels. You can also edit the axis labels by clicking *More Vertical Axis Options* or *More Horizontal Axis Options*. This option does not display for grids or maps.

### Legend
- Opens the Legend menu, where you can select the Show Legend option to display the legend on the chart. You can also clear your selection to hide the legend. In addition, you can change the default legend position and orientation. This option displays for maps but does not display for grids.

**Interactive Group**

*Note:* These options do not display for grids or maps.

**Interactive Options**
- Opens the Interactive Options dialog box, which enables you to specify animation and mouse over effects in your chart.

### View Tab

#### Show/Hide Group

**Resources**
- Minimizes the Resources panel, expanding the size of the canvas to occupy the area where the Resources panel typically appears. When you click the Resources button again, the Resources panel displays and the chart, map, or grid adjusts accordingly.

#### Data Panel Group
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logical</td>
<td>Displays the data source fields by type. This is the default view. The Logical view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td>List</td>
<td>Displays the data source fields in a tabular list format. This list contains a header row. You can sort fields differently by clicking a column header. The List view options include Title, Description, Field, Alias, Format, Segment, Filename, and Reference.</td>
</tr>
<tr>
<td>Structured</td>
<td>Displays the hierarchical structure of the data source files. The Structured view options include Title, Description, Field, and Alias.</td>
</tr>
</tbody>
</table>

### Report Group

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch Report</td>
<td>Lists any active report or chart to which you can switch.</td>
</tr>
</tbody>
</table>

### Field Tab

#### Filter Group

**Note:** Options on the Field tab are contingent on the visual type that you select.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box for creating filters. Filters enable you to select only the data that you want and to exclude unwanted data.</td>
</tr>
<tr>
<td>Exclude</td>
<td>Select an existing filter in the Filter pane and choose Exclude to remove, but not delete, the filter from the visual.</td>
</tr>
<tr>
<td>Include</td>
<td>Select an existing filter in the Filter pane and choose Include to restore the filter, which was previously excluded from the visual.</td>
</tr>
</tbody>
</table>
## Ribbon Commands for Visualizations

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Up</strong></td>
<td>Displays the data source fields by type. This is the default view. The Logical view options include Title, Description, Field, and Alias.</td>
</tr>
<tr>
<td><strong>Down</strong></td>
<td>Displays the data source fields in a tabular list format. This list contains a header row. You can sort fields differently by clicking a column header. The List view options include Title, Description, Field, Alias, Format, Segment, Filename, and Reference.</td>
</tr>
<tr>
<td><strong>Group</strong></td>
<td>Opens the Create a Group dialog box where you can create a group to combine values together. For grids, this option is activated when you select a dimension.</td>
</tr>
</tbody>
</table>

**Display Group**

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hide Field</strong></td>
<td>Hides a selected field.</td>
</tr>
<tr>
<td><strong>Aggregation</strong></td>
<td>Specifies an aggregation for a specific field. Commonly used options include: Sum, Average, Count, Minimum, and Maximum.</td>
</tr>
<tr>
<td><strong>Traffic Lights</strong></td>
<td>Specifies conditional styling to the selected field.</td>
</tr>
</tbody>
</table>

## Series Tab

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Select Group</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Note:</strong> This group is not available for grids. For maps, this group is disabled.</td>
<td></td>
</tr>
<tr>
<td><strong>Series drop-down list</strong></td>
<td>Lists the available series in the current visualization.</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Style</td>
<td>Opens the Format Series dialog box, where you can edit the styling options for the selected series. You can also open this dialog box by right-clicking a series, and then clicking <em>More Style Options</em>.</td>
</tr>
<tr>
<td><strong>Properties Group</strong></td>
<td></td>
</tr>
<tr>
<td>Data Labels</td>
<td>Adds data labels to the chart. The drop-down menu contains the following data position options for selecting where to display data values as labels on a chart: Above (default), On top edge, Below top edge, Center, and Base. If you are working with a Pie chart, the options are: On Slice, Outside Slice, and Outside with feeler lines.</td>
</tr>
<tr>
<td>Type</td>
<td>Opens a drop-down menu with the following options for selecting different chart types: None (default), Bar, Line, and Area.</td>
</tr>
<tr>
<td>Trendline</td>
<td>Opens a drop-down menu that provides options for adding a trendline to a chart.</td>
</tr>
<tr>
<td><strong>Line Group</strong></td>
<td></td>
</tr>
<tr>
<td>Smooth Line</td>
<td>Draws the chart using smooth lines.</td>
</tr>
<tr>
<td></td>
<td>The smooth line option is not available in InfoAssist Basic.</td>
</tr>
<tr>
<td>Connect Lines</td>
<td>Controls the display of connecting lines between markers on a line or scatter chart. By default, lines are connected on a line chart and disconnected on a scatter chart.</td>
</tr>
<tr>
<td>Marker</td>
<td>Opens a drop-down menu from which you can select options to change the display of the default data and legend markers on line and scatter chart types. For more information, see <em>How to Change the Appearance of a Marker</em> on page 183.</td>
</tr>
<tr>
<td></td>
<td>The marker option is not available in InfoAssist Basic.</td>
</tr>
</tbody>
</table>
### Pie Group

**Note:** The following options are only enabled when you are working with a pie chart.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Expand</td>
<td>Expands pie slices.</td>
</tr>
<tr>
<td>Hide</td>
<td>Hides pie slices.</td>
</tr>
</tbody>
</table>
Understanding Warning Messages in InfoAssist

This topic describes InfoAssist warning messages.

In this appendix:

- InfoAssist Warning Messages
- Unsupported Syntax and Objects

## InfoAssist Warning Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Are you sure you want to switch data source? Doing so will delete your current report.</td>
<td>This warning message displays when a report is first saved in a different format and one or more additional reports are created and saved, and the user clicks Switch on the Data tab and selects a different report from the shortcut menu.</td>
<td>Deletes the current report.</td>
<td>Preserves the current report.</td>
</tr>
</tbody>
</table>
### InfoAssist Warning Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Are you sure you want to add a data source? Doing so will delete your current report.</td>
<td>This warning message displays when a report is first saved in a different format and an additional report is created and saved, and Add on the Data tab is selected.</td>
<td>Deletes the current report.</td>
<td>Preserves the current report.</td>
</tr>
<tr>
<td>Output to Printer syntax found. This feature is not supported. Your report will be converted to PDF output.</td>
<td>This warning message displays when opening a procedure created in HTML Graph Assistant when certain criteria are met.</td>
<td>Converts the report to PDF format.</td>
<td>Aborts the process of opening the procedure.</td>
</tr>
<tr>
<td>Unsupported Graph Applet syntax found. Your report will be converted to use server-side graphics.</td>
<td>Graph Applet functionality is no longer supported. This warning message displays when opening a procedure that contains Graph Applet syntax.</td>
<td>Converts your report to use server-side graphics.</td>
<td>Aborts the process of opening the procedure.</td>
</tr>
<tr>
<td>Message</td>
<td>Description</td>
<td>OK</td>
<td>Cancel</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Unsupported OLD graph engine syntax found. Your report will be converted to use NEW graph engine syntax.</td>
<td>OLD graph engine functionality is no longer supported. This warning message displays when opening existing procedures with OLD graph engine syntax, informing the user that unsupported syntax was detected and that the procedure will be converted to use NEW graph engine syntax.</td>
<td>Converts the procedure from the OLD graph engine to the NEW graph engine.</td>
<td>No changes are made to the original procedure and it is closed.</td>
</tr>
<tr>
<td>Unsupported chart type syntax found. Your report will be converted to use the default chart type.</td>
<td>This warning message displays when opening an existing procedure, and certain criteria have been met.</td>
<td>Converts the report to use the default chart type.</td>
<td>Cancels the conversion of the report to the default chart type.</td>
</tr>
</tbody>
</table>

B. Understanding Warning Messages in InfoAssist

InfoAssist User’s Manual 619
Unsupported Syntax and Objects

This section describes the syntax and objects that are not supported.

- **SUB-TOTAL syntax is not supported.** If you try to open an existing procedure in InfoAssist from a legacy tool that contains SUB-TOTAL syntax, an unsupported syntax warning message displays. If you choose to continue, InfoAssist will convert the syntax to SUBTOTAL and add the converted syntax to all higher level sort breaks.

- **SUMMARIZE syntax is not supported.** If you try to open an existing procedure in InfoAssist from a legacy tool that contains SUMMARIZE syntax, an unsupported syntax warning message displays. If you choose to continue, InfoAssist will convert the syntax to RECOMPUTE.

- **HTML FULL, FIXED, and PAGED syntax is not supported.** If you try to open an existing procedure in InfoAssist from a legacy tool that contains any of these three options, an unsupported syntax warning message displays. If you choose to continue, InfoAssist will convert the procedure to regular HTML output.

---

### Unsupported Syntax and Objects

<table>
<thead>
<tr>
<th>Message</th>
<th>Description</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Selection in this request is not allowed with your configuration. Your report will be converted to default output.</td>
<td>This warning message displays when the user selection option is not available on restore, or when you are restoring a user selection option when it is disabled at global preference.</td>
<td>Converts the report to use the default output type.</td>
<td>No changes are made to the original procedure and it is closed.</td>
</tr>
<tr>
<td>File Was Modified Outside of InfoAssist. Continue?</td>
<td>This warning message displays when there is any modification done to an report in the text editor.</td>
<td>Proceeds to open the modified procedure in InfoAssist.</td>
<td>Closes the warning message and returns to the WebFOCUS start page.</td>
</tr>
</tbody>
</table>
COLUMN-TOTAL syntax is not supported. If you try to open an existing procedure in InfoAssist from a legacy tool that contains this syntax, an unsupported syntax warning message displays. If you choose to continue, InfoAssist will convert it to use RECOMPUTE syntax.

Line objects in a compound document imported from a legacy tool are not supported. If you try to open an existing procedure that includes line objects, an unsupported syntax warning message displays. If you choose to continue, InfoAssist will remove these line objects.
<table>
<thead>
<tr>
<th><strong>Glossary</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>3D Effect</strong></td>
</tr>
<tr>
<td><strong>Accessibility</strong></td>
</tr>
<tr>
<td><strong>Accordion</strong></td>
</tr>
<tr>
<td><strong>accordion report</strong></td>
</tr>
<tr>
<td><strong>In-Document Analytics chart</strong></td>
</tr>
<tr>
<td><strong>In-Document Analytics dashboard</strong></td>
</tr>
<tr>
<td><strong>In-Document Analytics dashboard prompts</strong></td>
</tr>
<tr>
<td><strong>PDF Analytic Document</strong></td>
</tr>
<tr>
<td><strong>HTML Analytic Document</strong></td>
</tr>
<tr>
<td>---------------------------</td>
</tr>
<tr>
<td><strong>Analytic Document Options</strong></td>
</tr>
<tr>
<td><strong>Aggregation</strong></td>
</tr>
<tr>
<td><strong>aggregation value</strong></td>
</tr>
<tr>
<td><strong>Annotate</strong></td>
</tr>
<tr>
<td><strong>annotation</strong></td>
</tr>
<tr>
<td><strong>application button</strong></td>
</tr>
<tr>
<td><strong>axis</strong></td>
</tr>
<tr>
<td><strong>axis labels</strong></td>
</tr>
<tr>
<td><strong>axis title</strong></td>
</tr>
<tr>
<td><strong>background</strong></td>
</tr>
<tr>
<td><strong>canvas</strong></td>
</tr>
<tr>
<td><strong>cascade</strong></td>
</tr>
<tr>
<td><strong>cascade controls</strong></td>
</tr>
<tr>
<td><strong>cell padding</strong></td>
</tr>
<tr>
<td><strong>color bands</strong></td>
</tr>
<tr>
<td><strong>color mode</strong></td>
</tr>
<tr>
<td>Term</td>
</tr>
<tr>
<td>----------------------</td>
</tr>
<tr>
<td>data bars</td>
</tr>
<tr>
<td>data labels</td>
</tr>
<tr>
<td>Data tab</td>
</tr>
<tr>
<td>Demographic Layers</td>
</tr>
<tr>
<td>dimension filtering</td>
</tr>
<tr>
<td>document theme</td>
</tr>
<tr>
<td>Environment and Styling</td>
</tr>
<tr>
<td>feeler line</td>
</tr>
</tbody>
</table>
Field tab

A tab on the ribbon that appears when the user selects a data source field in the Query pane or the canvas. The options available in the Field tab are specific to the data type that is selected. The options available for numeric fields are different from the options available for non-numeric and date fields. The Field tab provides access to the Filter, Sort, Break, Style, Format, Display, and Links groups.

Filter pane

A component of the Resources panel that is located under the Data pane. You can drag fields from the Data pane to the Filter pane to filter your report. You can also manage filters in the Filter pane.

Format Axis dialog box

A dialog box of options for formatting for both vertical and horizontal axes.

Format Gauge dialog box

A dialog box of options for formatting a gauge chart. Such options include setting and styling a title for the gauge chart, setting tick marks, and color bands, as well as advanced settings, such as setting the gauge start and stop angle.

Format Grid Lines dialog box

A dialog box of options to format horizontal and vertical gridlines, color bands, and frames on a chart.

Format Labels dialog box

A dialog box that contains options for editing data labels.

Format Series dialog box

A dialog box that contains options to format the fill and border of each series on a chart.
<p>| <strong>Format tab</strong> | A tab on the ribbon that contains different options for selecting output formats and other reporting features, depending on whether you are creating a report. For reports, the Format tab provides access to the Destination, Navigation, and Feature groups. |
| <strong>frame</strong> | The area of a chart that contains all of the basic chart elements, such as the plot points, gridlines, legend, and chart title. The frame appears as a rectangle. |
| <strong>Frame &amp; Background</strong> | A customized charting feature. Through the Frame &amp; Background dialog box, the user can set frame and background options specific to the chart type selected. |
| <strong>Freeze</strong> | A custom report output format that allows the user to view output with column titles that freeze (remain in view) when the user scrolls through pages of the report output. |
| <strong>gauges</strong> | A customized charting feature. Through the Gauge dialog box the user can set options specific to a gauge chart. |
| <strong>grid</strong> | A customized charting feature that allows the user to set options for horizontal and vertical gridlines. |
| <strong>gridlines</strong> | Lines that run horizontally and vertically to enhance the readability of a chart. Gridlines can be major or minor. |
| <strong>Home tab</strong> | A tab on the ribbon that contains the most commonly-used commands and options from the Format, Design, Filter, and Report groups. |</p>
<table>
<thead>
<tr>
<th><strong>InfoMini</strong></th>
<th>An application built from an InfoAssist report that contains a subset of InfoAssist functionality at run time.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Insert tab</strong></td>
<td>A tab on the ribbon that contains options to add reports, charts, existing reports, text, images, and In-Document Analytics form control (for HTML Analytic Document, and PDF Analytic Document outputs only) to a canvas in Document mode.</td>
</tr>
<tr>
<td><strong>Interface theme</strong></td>
<td>A theme selected by the user to style all menus and dialog boxes.</td>
</tr>
<tr>
<td><strong>Layout tab</strong></td>
<td>A tab on the ribbon that provides access to page display and layout options from the Page setup, Size &amp; Arrange, and Report groups.</td>
</tr>
<tr>
<td><strong>legend</strong></td>
<td>A chart element that displays each series that appears on a chart.</td>
</tr>
<tr>
<td><strong>Lightweight Mapping</strong></td>
<td>The Lightweight Mapping functionality offers the ability to view data that is bound to a geo-location. Using a powerful HTML5 map viewer, you can view data using a variety of popular formats, such as bubble markers and heat filled polygons (also known as choropleths). The HTML5 map viewer contains zoom, pan, and scale controls. You can use this functionality to visualize patterns, trends, and relationships related to the location information in data.</td>
</tr>
<tr>
<td><strong>limit</strong></td>
<td>A report custom feature in which the number of unique variables in a column is limited.</td>
</tr>
<tr>
<td><strong>markers</strong></td>
<td>Visual elements found on line charts that represent data points on a chart.</td>
</tr>
<tr>
<td><strong>Navigation taskbar</strong></td>
<td>A component of the InfoAssist Application window that displays groups and icons that provides different views and quick access to all active reports and report access.</td>
</tr>
<tr>
<td>------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Page Breaks</strong></td>
<td>A custom report Pages on Demand feature in which a new page is started in the output when the primary sort field changes.</td>
</tr>
<tr>
<td><strong>Pages On Demand</strong></td>
<td>A custom report output format that allows the user to view output, one page at a time, and to use a menu bar at the bottom of the report output, from which the user can view a specific page.</td>
</tr>
<tr>
<td><strong>Pop-up Title</strong></td>
<td>A report custom feature in which pop-up titles are added to a report and appear when the mouse pointer hovers over a column title.</td>
</tr>
<tr>
<td><strong>quadrant lines</strong></td>
<td>Horizontal and vertical lines that cross to divide a chart into four sections.</td>
</tr>
<tr>
<td><strong>Query pane</strong></td>
<td>The Query pane is located at the bottom of the Resources panel. It contains the field containers that hold the data fields that you select.</td>
</tr>
<tr>
<td><strong>Quick Access Toolbar</strong></td>
<td>A toolbar on the InfoAssist Application window that displays frequently used commands, such as New, Open, save, Undo, Redo, View code, Run, and Preview.</td>
</tr>
<tr>
<td><strong>Rank</strong></td>
<td>A report custom feature in which a ranking column is inserted for By and Measure fields in a report.</td>
</tr>
<tr>
<td><strong>Recompute</strong></td>
<td>A report custom feature in which the result of a Compute command is recalculated.</td>
</tr>
<tr>
<td><strong>Reference</strong></td>
<td>A customized charting feature that allows the user to add a reference line to the Y-axis and a reference line to the X-axis.</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Reference Layers</strong></td>
<td>Display a layer of boundaries and locations that range from a continental scale to country, state, and even local neighborhood.</td>
</tr>
<tr>
<td><strong>reference line</strong></td>
<td>A line designed to draw attention to specific data locations on a chart. A maximum of three horizontal (X axis) and three vertical (Y axis) reference lines can be added to a chart.</td>
</tr>
<tr>
<td><strong>Repeat Sort Values</strong></td>
<td>A report custom feature in which all repeated sort values appear instead of blanks after the first instance of a new sort value appears in the report.</td>
</tr>
<tr>
<td><strong>Resources panel</strong></td>
<td>A panel that is comprised of the Data pane, the Filter pane, and the Query pane.</td>
</tr>
<tr>
<td><strong>ribbon</strong></td>
<td>A component of the InfoAssist Application window that displays commands needed to create reports, charts, documents, and dashboards.</td>
</tr>
<tr>
<td><strong>ring label</strong></td>
<td>Descriptive name for a concentric ring found on a ring chart.</td>
</tr>
<tr>
<td><strong>Rotate</strong></td>
<td>A customized charting feature that allows the user to toggle between a vertical or horizontal display of a chart.</td>
</tr>
<tr>
<td><strong>Row Totals</strong></td>
<td>A report custom feature in which a grand total column is inserted to the right side of the report to sum numeric data in each row.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>series</td>
<td>A group of data points that are plotted on a chart</td>
</tr>
<tr>
<td>Series tab</td>
<td>A tab on the ribbon that only appears when the user is working with charts. It provides access to chart options through the Select, Properties, Line, Pie, and Display groups.</td>
</tr>
<tr>
<td>slicers</td>
<td>Dynamic filters that you can use with reports, charts, documents, and dashboards.</td>
</tr>
<tr>
<td>Slicers tab</td>
<td>A tab on the ribbon that provides the ability to create and edit slicers.</td>
</tr>
<tr>
<td>Stack Measures</td>
<td>An option to stack all measure fields on a report.</td>
</tr>
<tr>
<td>splash screen</td>
<td>A screen of available Getting Started and Help options that opens when a user clicks New on the InfoAssist application main menu.</td>
</tr>
<tr>
<td>Status bar</td>
<td>A component of the InfoAssist Application window that contains an output button that the user clicks to see the selected format and an output target button that the user clicks to view the selected option for displaying new output windows or tabs.</td>
</tr>
<tr>
<td>Sub Footer</td>
<td>A report custom feature, in which a subfooting is added at the end of the data on each page of the report output when the primary sort field changes.</td>
</tr>
<tr>
<td>Sub Header</td>
<td>A report custom feature in which a subheading added just below the column titles in the report output when the primary sort field changes.</td>
</tr>
<tr>
<td><strong>Subtotal</strong></td>
<td>A report custom feature in which a subtotal is inserted in the output for all numeric fields when the primary sort field changes.</td>
</tr>
<tr>
<td><strong>switch output</strong></td>
<td>An output view option in which a drop-down menu opens, where the user can select any active report to view the output.</td>
</tr>
<tr>
<td><strong>Table of Contents</strong></td>
<td>A custom report output format that allows the user to view output for individual values of the first sort (By) field, one value at a time.</td>
</tr>
<tr>
<td><strong>tile horizontally</strong></td>
<td>An output view option in which multiple output windows are tiled horizontally, one above another, across the canvas.</td>
</tr>
<tr>
<td><strong>tile vertically</strong></td>
<td>An output view option in which multiple output windows are tiled vertically, side by side, across the canvas.</td>
</tr>
<tr>
<td><strong>Title Popup</strong></td>
<td>A specialized reporting feature in which a pop-up title appears when the mouse pointer hovers over a column title in the report output.</td>
</tr>
<tr>
<td><strong>traffic light conditional styling</strong></td>
<td>Color styling applied to data for a selected measure field. By default a report displays the values that satisfy the first condition in green, and the values that satisfy the second condition in red.</td>
</tr>
<tr>
<td><strong>trendline</strong></td>
<td>A line drawn between any two points on a data series that shows the direction that the values of the data series are going in.</td>
</tr>
<tr>
<td><strong>View</strong></td>
<td>Area of the InfoAssist Options window that provides settings for establishing the design view in which the user will work, the type of data that the user will use when previewing output, the limit that needs to be set on record input, how data and query panels will look, and the output target that will be used.</td>
</tr>
<tr>
<td><strong>View tab</strong></td>
<td>A tab on the ribbon that provides access to report design viewing options in the Design, Show/Hide, Data Panel, Query Panel, Output Window, and Reports groups.</td>
</tr>
<tr>
<td><strong>Within</strong></td>
<td>Functionality that allows you to use specific aggregation tasks at different report levels. You can use the Within phrase to manipulate display field values as they are aggregated within a sort group rather than a report column.</td>
</tr>
</tbody>
</table>
SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR ANY OTHER PURPOSE.

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT, OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE "LICENSE" FILE(S) OF THE SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE SAME.

This document is subject to U.S. and international copyright laws and treaties. No part of this document may be reproduced in any form without the written authorization of TIBCO Software Inc.

TIBCO, the TIBCO logo, the TIBCO O logo, FOCUS, iWay, Omni-Gen, Omni-HealthData, and WebFOCUS are either registered trademarks or trademarks of TIBCO Software Inc. in the United States and/or other countries.

Java and all Java based trademarks and logos are trademarks or registered trademarks of Oracle Corporation and/or its affiliates.

All other product and company names and marks mentioned in this document are the property of their respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system platforms for a specific software version are released at the same time. See the readme file for the availability of this software version on a specific operating system platform.

THIS DOCUMENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT.

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS. CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN THIS DOCUMENT AT ANY TIME.
Index

3D chart types 153
3D charts 153
3D depth
    removing from a bar chart 246

A

accessing Document mode
    from document button 256
    opening an existing item 254
accordion reports 117
active cache 474
    enabling 474
    enabling by component 474
    rows retrieved 474
adding to reports 92
aggregation options in reports 109
aggregation values 186
    dimension 186
Analytic Document Options dialog box 484
    Colors tab 487
    General tab 485
    Menu Options tab 486
annotations
    displaying 251
application button 22
application main menu 23
application window 22
area chart types 149
area charts 148, 283
Auto Drill 345
Auto Linking 349
axis labels
    custom format characters 217, 322
    deleting 222
    formatting 215, 223, 320, 327
    hiding 325
    horizontal axis labels 215, 320
    rotating 222, 326
    secondary axis labels 215, 320
    staggering 222, 325
    vertical axis labels 215, 320
axis titles
    adding 223, 329
axis
    manually setting 223, 328
    setting advanced properties 224, 329
    shortcut menu 220
    using properties 222, 325

B

bar chart types 144
bar charts 142, 278
basemaps
    custom 416
Binning 163
blend 441
blending data 441
bubble charts 152, 291
bubble maps 381

C

cache 481
canvas 22, 73
cell padding in reports 99
change 273
chart frame and background
    formatting 225
chart
    adding a page heading and a page footing 244
    controlling the rendering of a page heading and page footing 245
    frame and background 225
    pyramid 155
    rotating 247
    Sort By Total Value 69, 247
charts
    3D 153
    area 148
    bar 142
    bubble 152
    chart formatting tools 170
    chart outputs 162
    combination 156
    creating a basic chart 159
    creating a combination chart 161
    creating a dual-axis chart 161
    creating a multi-axis chart 162
    creating an advanced chart 159
    displaying annotations 251
    dynamic reference lines 250
    funnel 155
    gauge 155
    gauge thermometer 155
    horizontal bar charts 144
    horizontal box plot 155
    library of advanced charts 158
    line charts 146
    Live Preview 170
    multi-axis 151
    pareto 155
    pie 144
    polar 152
    removing 3D depth 246
    selecting 142
    shortcut menu 171
    special 155
    spectral map 156
    static reference lines 248
    stock 154
    vertical bar charts 143
    vertical box plot 155
    visualizing data with 120
    XY plot 151
    Grids 156
charts
  HTML5 156
choropleth maps 381
circular gauges 295
color bands
  setting 212
Color dialog box 371
color mode
  by group 190
  By Group setting 179
  by series 190
  By Series setting 179
color-banded rows of data in reports 95
column totals in reports 108
combination charts 156
COMPUTE fields 427
create visuals 271
creating a new procedure 16
creating visualizations 271

data 441
data labels
  associated dialog boxes 190
  changing the position 199
  custom format characters 192
  formatting 190
  shortcut menu 198
  showing 199
  using properties 198
Data pane 47
  adding fields to a report 49
Data Panel group 48
Data Source group 426
Data tab
  Data Source group 426
  Display group 425
  Filter group 443
DEFINE fields 427
Detail (DEFINE) dialog box 429
Document mode
  accessing 253
documents
  accessing Document mode 253
  aligning components 263
  building 256
  building a new 254
  building in Document mode 253
  cascading prompts 506
  changing the filter condition 505
  creating from a single report 259
  deleting a component 268
  editing component 261
  editing text 266
  inserting a chart 258
  inserting a report 257
  inserting an existing report 259
  inserting an existing report into a document
    with the Insert tab 259
  inserting an image 260
documents
  inserting reports from multiple data sources 256
  inserting text 260
  inserting text and images 260
  inserting two reports from two different data sources 257
  moving a component 263
  resizing a component 261
  setting target reports 498
  styling and customizing a chart 266
  styling and customizing a report 265

dynamic reference lines 250

E
  Edit Slicers dialog box 547
  Edit Title dialog box 175
  Esri 383
  Esri HTML5 Viewer
    geographic roles, custom 406
  Excel (csv) 81
  Excel output for reports 81
  Export Data 315

F
  field formats
    numeric 102
    percent sign 104
    currency 101
  field images 46
  Field tab
    Filter group 443
  Filter group 443
  Filter pane 47
  filtering with slicers 542
  FOCUS format index files 467
  Format Axis dialog box 215, 320
    Advanced tab 218, 220, 323, 324
    General tab 219, 324
    Labels tab 217, 219, 322, 324
    Scale tab 216, 321
    Title tab 217, 219, 322, 324
  Format Gauge dialog box 235
    Advanced tab 238
    Axis Scale & Labels tab 236
    Bands tab 237
    General Options tab
    Tick Marks tab 237
  Format Grid Lines dialog box 206
    Color Bands tab 207
    Frames tab 208
    Major Grid Lines tab 206
    Minor Grid Lines tab 207
    Quadrant Lines tab
Format Labels dialog box 191
   Advanced tab 193
   Funnel Labels tab 196
   General Options tab 191
   Pie Labels tab 194
   Pie Title tab 195
Format Legend dialog box 200
   Legend Options tab 200
Format Series dialog box 172
   Border tab 174
   Fill tab 173
Format tab 38
Frame & Background dialog box 225
   Advanced tab for 3D charts 231
   Background tab 231
   Frame Edge tab for 2D charts and 2D charts with 3D effects 227
   Frame Edge tab for pie charts 229
   Frame tab for 2D charts and 2D charts with 3D effect
   Frame tab for pie charts 228
   shortcut menu 232
   Wall and Floor tabs 230
frame and background
   using properties 233
freezing column titles in reports 114
funnel charts 155

G

gauge chart
   shortcut menu 239

gauge charts 155
   Format Gauge dialog box 235
gauge thermometer 155
gauge
   using properties 239
geographic roles
   custom 406
gridlines 205
   deleting 213
   displaying horizontal minor 209
   displaying vertical major 210
   displaying vertical minor 210
   formatting 205
   major 205
   minor 205
   setting the color, weight, and style 210
   shortcut menu 208
   using properties 209

H

handles 335
headings and footings 92
   styling in a report 94
Help 22, 28
Home tab 36
   Report group 372
horizontal box plot charts 155
horizontal major gridlines displaying 209
HTML5 455

I
in-document analytics 475
InfoAssist Basic 17
   accessing 19
InfoAssist interface
   application button 22
   application window 22
   canvas 22
   Help 22
   main components 22
   navigating 21
   Navigation taskbar 23
   Quick Access Toolbar 22
   Resources panel 22
   ribbon 22
   status bar 23
InfoAssist Options dialog box 27
InfoAssist
   introducing 15
   accessing 16
   accessing from App Studio 17
InfoMini
   accessing 19
insert 301
Insert tab 37
inserting a chart 258
Insight 120
   adding filters 134
   changing summary operators 128
   charts 123
   filtering 130
   Options toolbar 135
   Phone mode 140
   removing filters 135
interactive dashboards 498
interactive report 315

J
Join dialog box 440

L
Layout tab
   Page Setup group 379
legend
   shortcut menu 202
legends
   formatting 200
   hiding 203
   positioning 204
   specifying border color 204
   using properties 203
Lightweight Mapping 158
limiting column variables in reports 107
line chart types 147
line charts 146, 281
  applying a smooth effect 182
Line Style dialog box 198
Logical view 49

M
major gridlines 205
maps
  bubble 381
  choropleth 381
marker
  changing the appearance of 183, 332
markers
  connecting or hiding a series line 182
mathematical equations 182
matrix charts 297
matrix marker charts 293
maximize visualization 305
minimize visualization 305
minor gridlines 205
Multi Drill 357
multi-axis charts 151
multi-page dashboard
  creating 471
multi-page document
  creating 469
multi-page documents 469
multi-page
  dashboards 469
Multi-Y 319
Multi-Y Axis 318
multipage documents and dashboards
  Page menu 472

N
Navigation taskbar 23, 77

O
options for editing 521
Options menu 521
Options window 28
Output window 75
  cascade 76
  output format options 77
  output target options 76
  output view options 76
  switch output 77
  tile horizontally 76
  tile vertically 76

P
page and line breaks in reports 107
page footing
  adding to a chart 244
page heading
  adding to a chart 244
page headings and page footings
  formatting 244
Page Options dialog box 473
Page Setup group 379
Index

paging 489
Paper-clipping 307
pareto charts 155
pie chart types 145
pie charts 144, 285
pie slices
  expanding 184
  hiding 184
polar charts 152
pop-up titles in reports 108
Procedure Settings 82
pyramid charts 155

Q
Query pane 75
  right-click options 64
Quick Access Toolbar 22, 31

R
ranking fields in reports 106
recalculating compute results in a report 111
Reference Line dialog box 249
reference lines
  COMPUTE field 250
  dynamic 250
  static 248
repeated sort values in reports 110
Report group 372
report paging 489
Report Style dialog box 370

reports
  accordion reports 117
  aggregation options for measure data 109
  cell padding 99
  color-banded rows of data 95
  column totals 108
  custom features 104
  customized output 111
  Excel output 81
  freezing column titles 114
  headings and footings 92
  limiting column variables 107
  Live Preview 170
  OLAP reports 116
  page and line breaks 107
  pop-up titles 108
  ranking fields 106
  recalculating compute results 111
  repeated sort values 110
  report-level styling 90
  row totals 108
  stacked measures 118
  Style group 91
  styling 79, 90
  styling column titles 91
  styling data 91
  styling headings and footings 94
  styling rows with alternate colors 95
  subheadings and subfootings 108
  subtotals 107

644
reports
  table of contents 112
  traffic light conditional styling by constant 96
  traffic light conditional styling by field 97
  visualization bars 109
Resources panel 22, 44
  field images 46
  using Query pane in 54
ribbon 22
ring pie charts 287
row totals in reports 108

S
scatter charts 152, 289
secondary axes options
  Format Secondary Axis dialog box 220
series
  changing the title 189
  changing the type 181
  color mode 190
  deleting 190
  dialog boxes 172
  filtering values in 185
  formatting 172
  formatting the fill and border 180
hiding fields 185
shortcut menu 177
sorting fields 185
using properties 180
Show data 315
  314
Size and Position dialog box 262, 263
Slicers tab 39
slicers
  Edit Slicers dialog box 547
  filtering with 542
  using 539
slope lines 181
special charts 155
spectral map charts 156
stacked measures in reports 118
static reference lines 248
status bar 23, 78
stock chart types 155
stock charts 154
storyboard 337
  creating 337
Style dialog box 197
subheadings and subfootings in reports 108
subquery filter 468
subtotals in reports 107
Summary Field (COMPUTE) dialog box 429

T
text
  adding 302
  inserting 301
Thumbnails 87
ticks
  setting 211
Traffic Light Condition dialog box 175
traffic light conditional styling by constant in reports 96
traffic light conditional styling by field in reports 97
traffic light conditions
  applying with drill-down to numeric measure field (by constant) 187
  applying with drill-down to numeric measure field (by field) 188
treemap charts 294
trendlines
  adding 181

U
user preferences
  changing 28
  environment and styling 30
  format 29
  layout 29
  view 29
User Selection 456

V
vertical box plots charts 155
View tab
  Data Panel group 48
visualization bars in reports 109
visualizations 271, 299, 302
  animating 338
  creating 271, 302
  inserting 301
  Multi Drill 317
  placement of 335
  renaming 306
visuals
  area charts 283
  bar charts 278
  bubble charts 291
  bubble maps 381
  changing 273
  choropleth maps 381
  circular gauges 295
  gauges 295
  grids 277
  horizontal bar charts 280
  inserting 301
  line charts 281
  maps 381
  matrix marker charts 293
  move 337
  pie charts 285
  place 336
  ring pie charts 287
  scatter charts 289
  selecting 273
  stacked area charts 283
  stacked bar charts 278
visuals
  treemaps 294
  vertical bar charts 279

W

Within 369

X

XY plot chart types 152
XY plot charts 151